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Welcome

Avenza welcomes you to map-making in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of map-making by allowing spatial data
files to be used to create maps inside a vector graphics program. MAPublisher allows all cartographic tasks to be
performed where they should be done; in a powerful graphics environment.

This manual assumes that the user is familiar with Adobe Illustrator and has at least a basic understanding of
geographic information systems (GIS) terminology and concepts. Please refer to the Adobe Illustrator user guide for
more information on using Adobe Illustrator.

The User Guide explains the installation process and the many features of MAPublisher. All MAPublisher panels,
functions and tools are thoroughly detailed together with the related concepts necessary to build map and perform
fundamental cartographic and GIS tasks. Please refer to the document Avenza Projections Guide.pdf for more
information on the projections supported in MAPublisher.

As a complement to these guides, the MAPublisher software installer includes tutorial documents (MAPublisher 8
Tutorial Guide.pdf, MAPublisher 8 Quick Start Guide.pdf and MAPublisher 8 MAP LabelPro Tutorial Guide) and associated
GIS datasets. We encourage all users to go through these guides to gain additional experience with MAPublisher
tools and functions.

MAPublisher and Adobe Illustrator together constitute an integrated cartographic design software system with
state-of-the-art graphics tools and geographic functions.
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Introduction

MAPublisher 8.7 is the newest version of a powerful suite of plug-ins for Adobe lllustrator CS4 and CS5 that bridges
the gap between geographic information systems (GIS) and high-end graphic design software in order to facilitate
the map creation process. MAPublisher offers additional panels, functions, tools and functions to the powerful
Adobe lllustrator design environment that enable GIS data files to be used as a base for cartographic production
destined for print or Web contents.

Working from a traditional Adobe lllustrator document, users create and edit their data organized through layers
(either new or imported with MAPublisher). Users benefit from the Adobe lllustrator graphic tools as well as
additional custom MAPublisher functions and panels to create, edit and query the map data.

MAPublisher Simple and Advanced Import functions allow the import of major GIS and CAD formats (ArcGIS, Maplnfo,
AutoCAD, MicroStation, KLM and more) into Adobe lllustrator, while retaining their native geometry (Point, Line,
Text, Area), layer structure, geographic location and attribute data.

The cartographic workspace is managed through MAP Views that control the geospatial parameters: coordinate
system, map anchor, map scale and rotation. Layers organized under the same MAP View share the same
geographic frame of reference. A layer must reside within a MAP View to be managed by MAPublisher functions
and keep its spatial and attribute information; however layers not related to a MAP View may still be used for
presentation purposes (such as title, scale and legend). An Adobe Illustrator document may contain more than one
MAP View. For example, a map with an inset map at a larger scale to represent a zoomed-in area of interest.

The MAP Attributes panel allows for creating, editing and querying attribute information. For example, for a line layer
containing street data, each line segment may be linked to a table with information relative to the street name
and street category. Using the MAP Attributes panel, this information can be viewed, queried, edited or additional
columns of data may be appended.

MAP Themes make use of the attribute data to apply Adobe lllustrator graphic styles, symbols or character styles to
map features based on an object’s attribute values. Choose from Stylesheet, Charts, and Dot Density themes.

MAPublisher also offers many functions and tools to manage GIS data from within Adobe lllustrator:

« Import major GIS and CAD formats (MAPublisher Simple and Advanced Import, Spatial Database)

« Plot a symbol by typing in its world coordinates (MAP Point Plotter)

- Draw objects with geographic dimensions (MAP Area Tools)

- Trim the geographic extents of the map (MAP Vector Crop)

- Join lines or points that share a same attribute value, simplify lines, create a buffer area around a line (Buffer
Art, Flip Lines, Join Areas, Join Lines, Join Points, Line Plotter, Simplify Lines)

- Automatically label features based on attribute data (MAP LabelPro, Label Features and MAP Tagger Tool)

- Select features based on attributes (MAP Selections)

- Import and export geographically referenced images (Register Image)

- Create grids and indexes (Grids and Graticules)

- Create scale bars and north arrows (Scale Bar, Create North Arrow)

- Export to Geospatial PDF (Export Geospatial PDF)

« Export a map to Flash with populated Web tags (MAP Web Author)

« Export layers to major GIS and CAD formats (MAP Views)

+ And much more...
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MAPublisher Features

MAP Web Author

Export Adobe lllustrator documents with GIS data to interactive Flash maps, complete with callout bubbles,
rollovers, layer control, pan and zoom controls, and with all the underlying GIS attributes intact. Export Flash maps
without any additional coding or software requirements and embed them to any Web page. Further customization
using advanced CSS and MAP Web Authort Javascript APl is available for advanced users.

MAPublisher Spatial Database import

Import spatial data from Esri Personal Geodatabase (.mdb), File Geodatabase (.gdf), and ArcSDE servers. This
function requires Esri software and a valid license installed on the computer and consequently it is only available on
Windows operating systems. Supported feature types are Point, Polyline, Polygon, Circular Arc, Eliptical Arc, Bezier
Curve, Annotations (text). The MAPublisher Spatial Database import allows for SQL queries and spatial filters.

MAPublisher LabelPro™

MAPublisher LabelPro™ revolutionizes the way users can label map data, including using symbols as labels and label
conflict resolution with a high degree of customizable rule-based labeling options. The MAP LabelPro engine uses
your map data attributes for labeling with styles, rules and controls configured through an intuitive, easy-to-use
Graphical User Interface. This function is available as an optional add-on to MAPublisher 8.1 and higher.

Geospatial PDF Import and Export

Ability to import geospatial PDF documents quickly and easily using MAPublisher. This import method can
automatically assign the content in a geospatial PDF to appropriate MAP Layers and a MAP View. Export map
data to a geospatially enabled PDF. In this process, all objects and associated MAP Attributes information (when
available) are ported to PDF, while also maintaining the map coordinate system. When a geospatial PDF is opened
with Adobe Acrobat Reader 9, one can find locations, measure distances, add location markers as well as copy
coordinates to the clipboard. Additionally, objects can be selected and queried and their MAP Attributes can be
viewed in the Adobe Acrobat Model Tree.

MAP Themes

The former MAP Stylesheets has been completely revamped. Like the name implies, MAP Themes creates dot
density maps, charts and uses stylesheets to create choropleth maps. Use various classification methods to easily
create data classes. In addition, create highly customizable MAP Theme Legends.

MAPublisher Panels

MAPublisher panels seamlessly integrate into the user interface and can be resized, moved, and docked just like
native Adobe lllustrator panels.

MAPublisher Toolbar

The MAPublisher Toolbar allows you to easily launch all the main MAPublisher tools with a single click.

MAP Vector Crop Tool

Crop map documents by exact locations (including MAP Locations) and dimensions. Easily remove unwanted data
while preserving attributes and styles. Perfect for creating inset maps. Crop To Shape tool can use any shape to crop.
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MAP Point Plotter Panel

MAP Point Plotter places points (e.g. locations of towns or cities) based on user input locations onto any projected
map in projected units or lat/long format (decimal degrees, or Degrees Minutes Seconds). MAP Point Plotter also
offers the option to instantly plot centroids for line or area features.

Area Plotter

The Area Plotter tool creates new rectangle or ellipse polygons on MAP Area layers by using page or world
coordinates, and by location type (using either a bounding box or by a single coordinate position). Use it to create
precise area shapes based on coordinate locations.

Import and Export Data

Import data from mapping applications such as ArcGIS, MaplInfo, MicroStation, Google Earth and other sources
with all attributes and georeferencing intact. Make vector and database edits, data edits, additions and save your
changes to a variety of GIS data formats. Newly supported formats are KMZ, GML and S-57 (import only).

MAP Views

The MAP Views panel controls the Adobe lllustrator layers organization into geographically referenced entities. It
offers many ancillary tools: export to GIS format, layer lock and display control, Switch to MAP View, exchange MAP
Objects between Adobe lllustrator documents.

Several geographical references can be maintained per document (e.g. main map and inset maps), stored as MAP
Views. Each MAP View scale, transformation, position on the artboard is configured through the MAP View Editor —
with many option for display, zoom, rescale, rotation, and so on.

MAP Attributes

The attribute table holds map attribute information for line, area and point data. Add and remove columns, edit
schemas, join tables, calculate and apply expressions to customize map attributes. MAP Attributes are the base
to many other MAPublisher tools (such as line functions, MAP Themes, and MAP Web Author). They can also be
exported to text file for further usage.

MAP Themes

MAPublisher quickly and easily styles map features using Stylesheets, Charts and Dot Density themes. Specify
rules and expressions to apply preset or custom symbols, graphic styles and character styles to artwork based on
exisiting map attributes.

MAP Measurement Tool

The MAP Measurement Tool measures straight distances (between two points), path distances (multiple points),
azimuths, and the perimeter and area of closed paths — in page or map unit (real world distances). Furthermore,
the measuring path can be converted to a line or area in the currently selected layer.
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MAP Selections

Build, edit and apply multiple selection criteria based on the attributes and properties contained in MAP Layers
using MAP Selections. Selection criteria are created in an expression builder and can be applied to any MAP layer,
and can be saved so they can be edited or applied later.

Geometry Operations

Join areas, lines or points and flip lines while keeping attributes intact. Use Simplify Line to reduce the number of
vertices in a point (with preview and information on the number of filtered points). Create lines based on a series
of point locations. Use Buffer Art to create buffer areas around line, area or point features. Join Areas can dissolve
multiple areas into a larger area and still retain attributes.

Labeling

Create labels for map objects using values from the MAP Attributes panel. MAPublisher provides two methods of
adding labels to your map: Label Features labels specified layers automatically; and MAP Tagger Tool labels features
individually through user selection.

Register Image

Register images accurately to your vector data. MAPublisher determines the parameters of the raster image and the
coordinate system of a selected MAP Layer in the registration process. A MAP Layer feature type called Image allows
georeferenced images to be placed accurately. In addition, Simple and Advanced Import now supports image
formats which simplifies the process of importing them into an Adobe Illustrator document.

MAP Elements

Easily add customizable map elements such as scale bars, north arrows and map legends. Choose from preset
designs or edit an existing one.

Merge Layers

The new Merge Layers tool combines at least two MAP Layers of the same feature type into a new MAP layer based
on its attribute values. The art from the source layers can either be copied or completely moved to the new layer
(including its attributes).

Split Layer

The Split Layer function splits a layer into new layers based on an expression or by unique attribute value. The
qualifying features can either be copied or moved to a new layer, while maintaining all their attribute data.

MAPublisher Log

The new MAPublisher Log records information about which MAPublisher tools were used and when they were
used. View detailed information about successful operations, warnings and errors.
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MAPublisher License Management

The new MAPublisher License Management system helps users manage their licensing in a more streamlined and
user-friendly manner. Users can now evaluate the product, register, retrieve their licenses and checkout a floating
license, all in a single dialog box. Additionally, MAPublisher panels are now marked with a lock icon when the
software is not licensed.

MAPublisher Preferences

The MAPublisher Preferences allow users to fully customize their MAPublisher experience. Control everything
from the way layers are sorted to the font used to display attribute data or style of the MAP Selections panel. This
includes several previously hidden options that used to be the domain of advanced users.

Web Feature Service and Web Map Service

Two new import features: Web Feature Service (WFS) and Web Map Service (WMS). Access these features through
Simple or Advanced Import. WFS accesses web servers that deliver vector content in GML format. WMS access web
servers that deliver raster content in a variety of formats.

Create Halo

The new Create Halo tool produces halo graphic styles and applies halos to features on MAP layers. Halos can be
independently created as a graphic style without having them applied or they can be directly applied to a MAP
layer without having to create a graphic style.

Scale and Rotate By Attribute

The new Scale & Rotate By Attribute tool provides options to scale and rotate art objects using specified values or
the target MAP layer's attributes.

Document Operations

Text Utilities performs many text actions such as correcting upside down text, separating multiline text into single
line and cropping text path to text length. These actions can be applied to either all text layers or specific text on a
layer. Right-to-Left Text is used to apply proper formatting to right-to-left languages such as Arabic and Hebrew.

MAP Locations

The MAP Locations are used as annotation to identify map world or map page locations. These locations can then
be used in other MAPublisher functions when specifying map or page anchors and in tools such as Specify Anchors,
Area Plotter, Line Plotter and Point Plotter.

MAPublisher FME Auto

With the add-on MAPublisher FME Auto license comes the ability to import FME FFS files. Use FME Desktop tools to
translate GIS data to work with MAPublisher for a true automated workflow.
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What’s New in MAPublisher 8.7

Grids & Graticules

The Grids & Graticules tool received major enhancements. It's now even easier to create index grids, graticules, and
measured grids. Many controls are available to fine tune grid lines, borders, center style labeling, tick marks, and
more. Grids can be created for reference purposes or to follow designated lines such as latitude and longitude, and
can also be labelled for indexing. Multiple grids can be created and layered to form a grid collection for a highly
customized look. Save grid settings to configuration files and share them with others who can load them.
Georeferencer

The new Georeferencer tool provides the ability to give spatial properties to a non-referenced map by establishing
a relationship between page locations in the document (using MAP Page Locations) and world locations.
Georeference data to establish the correct position in a map by using geographical coordinates from an online map
service, another document, or manual entry, to match MAPublisher page locations.

Buffer Area

The new ability to buffer areas using the Buffer Art tool.

Label Features

Redesigned the Label Features dialog box for easier label management.

Text Utilities

New utility called Merge text provides the ability to merge multiple lines of text into a single text object.

And many more enhancements...

Improved user interface changes and bug fixes.
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NATIDNALL . PARK

Getting
Started

Before using MAPublisher please read this section to ensure
that you have a suitable hardware environment, are familiar
with the installation and activation procedures, and have
adequately prepared your system and workspace to make
maps with Adobe Illustrator and MAPublisher 8..

Topics covered in this section:
System Requirements

Installation Instructions
MAPublisher Compatibility Notes
MAPublisher License Management
The MAPublisher Tools

The MAPublisher Toolbar
MAPublisher Preferences
Preparing the Workspace
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System Requirements

Before installing MAPublisher, please ensure that these minimum system requirements are met (recommended
requirements are mentioned as necessary):

WINDOWS

«  Adobe lllustrator CS4 / CS5 / CS5.1

« 2 GHz or faster Intel Pentium 4 processor (Intel Core 2 Duo or better recommended)
«  Windows XP /Vista / 7 (compatible with 64-bit versions)

« 2 GB of RAM minimum (4 GB of RAM or higher recommended)

« 500 MB of available hard-disk space

MACOS X

«  Adobe lllustrator CS4 / CS5 / CS5.1

«  Intel processor (Intel Core 2 Duo or better recommended)

+ MacOS X 10.6 or higher

+ 2 GB of RAM minimum (4 GB of RAM or higher recommended)
« 500 MB of available hard-disk space

Notes: Not all foreign language versions of Adobe Illustrator may be supported. Please contact support@avenza.com
for more information.

Installing MAPublisher on a system that does not meet the minimum requirements may produce unexpected
results or errors. These issues may not be supported by Avenza Technical Support.
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Installation Instructions

MAPublisher is licensed for use on a single computer and, once activated, will be node-locked and will only function
on that computer. Therefore, before proceeding with installation and activation, please ensure that MAPublisher is
installed on the appropriate computer.

Different versions of MAPublisher can be installed on the same computer if different versions of Adobe Illustrator
are present. For example, MAPublisher 7.6 for Adobe lllustrator CS2 and MAPublisher 8.7 for Adobe Illustrator CS5.1.

It is not recommended to do so, but different point releases of MAPublisher 8.x can be installed on the same
machine. For example, MAPublisher 8.4 for Adobe Illustrator CS4 and MAPublisher 8.7 for Adobe lllustrator CS5.1.
It is recommended to uninstall older versions of MAPublisher before installing the newest release. During the
uninstall process, an option will be given to backup custom coordinates systems and MAPublisher LabelPro rules.

For users intending to use MAPublisher LabelPro, a system restart is recommended after installing MAPublisher. This
ensures that included fonts are installed correctly.

WINDOWS

«  Make sure that a compatible version of Adobe lllustrator is installed on the computer. If Adobe
Illustrator is running, exit the program.

«  DVDversion: Insert the MAPublisher 8.7 DVD. If Autorun is disabled on the system, navigate to the
MAPublisher 8.7 directory on the DVD, and double-click the Setup.exe file.

«  Electronicversion: Double-click the mp87wi-e.zip file to open the WinZip self extractor. When the files are
unzipped, proceed to the MAPublisher directory and double-click the Setup.exe file.

«  Proceed through the installation screens as instructed. Options are given to install documentation and
tutorial data. If these components are selected, the files can be subsequently be found here: Start > All
Programs > Avenza > MAPublisher 8 > MAPublisher Tutorials.

«  Launch Adobe lllustrator. Proceed to the section about Registration and Licensing.

MACOS X

«  Make sure that a compatible version of Adobe Illustrator is installed on the computer. If Adobe
Illustrator is running, exit the program.

«  DVDversion: Insert the MAPublisher 8.7 DVD. Navigate to the MAPublisher 8.7 directory on the DVD, and
double-click the Install MAPublisher 8.7 icon.

«  Electronicversion: Unstuff the mp87mi-e.dmg file if this operation has not been completed automatically.
Then proceed to the MAPublisher 8.7 folder and double-click the Install MAPublisher 8.7 icon.

+  Proceed through the installation screens as instructed. Note that documentation and tutorial data will
also be installed. After installation, these files can be found in the Applications\Avenza\MAPublisher 8\
MAPublisher Tutorials . An Alias to this folder will be created at the end of the installation process which
will be placed on the desktop.

«  Launch Adobe Illustrator. Proceed to the section about Registration and Licensing..
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MAPublisher Compatibility Notes

MAPublisher 8.7 is compatible with Adobe lllustrator CS4, CS5 and CS5.1. Please read the following important
compatibility information with respect to working with legacy MAPublisher and Adobe Illustrator documents.

BACKWARDS COMPATIBILITY

All MAPublisher documents are not backwards compatible with previous versions of MAPublisher.

Saving the Adobe lllustrator document to an older version (e.g. saving a CS5 document as CS4) may have
unexpected results, such as loss of data attributes. It is recommended to save a copy of the file in the current Adobe
lllustrator version before attempting to save to a legacy version.

MAPUBLISHER 5 (OR EARLIER) DOCUMENTS

Point Data

MAPublisher introduced new standards on dealing with point data in MAPublisher 6. Pre-MAPublisher 6 documents
will have font based points converted to symbols on opening of the document.

MAPUBLISHER 6 (OR EARLIER) DOCUMENTS

Grids and Graticules
Grids and Graticules were redesigned in MAPublisher 7. Please note that grids created in previous versions of
MAPublisher (6.x and earlier) will need to be recreated with the new tool if the generation of an index is required.

Legend to Stylesheet Conversion

Legend functionality (Assign Legend Info, Draw Legend etc) was ported into MAP Stylesheets in MAPublisher 7.
Legend information held in legacy MAPublisher documents (6.x and earlier) will be converted into stylesheets on
document open. Subsequently Graphic Styles (for line and area legends), Character Styles (for text legends) and
Symbols (for point legends) will automatically be generated and added to the respective Adobe Illustrator panels.

To qualify for legend conversion, legend art in legacy documents must contain the following properties:
- Beofavalid art type: i.e. polygon, path, symbol or text
«  Have alegend expression assigned (via Assign Legend Info or Auto Assign Legend Info)
+  Have a target MAP Layer

During the conversion process you will be asked to set additional conversion preferences:

- Determine if target MAP Layers should be immediately assigned to the applicable stylesheet. Checking
this option will immediately apply the new stylesheets to map art on target layers, whereas unchecking
this option means the new stylesheets will not be applied on document open, allowing you to manually
drag target layers into the applicable stylesheet later. Note auto assignment conversions are slower.

«  Determine if you wish to merge similar converted stylesheets (i.e. stylesheets with a matching feature
type and original map layer) into a single stylesheet. Note this option will be disabled if it is not
applicable.

Tables

Table information held on table layers (i.e. MPTables layers) will be removed on document open. Therefore ensure
that all tables have been joined to the vector art prior to opening the document in MAPublisher 8.
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ALL MAPUBLISHER DOCUMENTS IN ADOBE ILLUSTRATOR 10 (OR EARLIER) FORMAT

Legacy Text Conversion

Adobe introduced new methods for dealing with text art in Adobe lllustrator CS. Therefore files containing
MAPublisher text objects must be converted using Adobe Illustrator and MAPublisher text conversion utilities.

If the Adobe lllustrator legacy text conversion message appears when opening a legacy document, click OK. This
will allow MAPublisher to use its own conversion utility to update text items while maintain the text attributes. If
you click Update, the document will be opened, however all attributes associated with this text will be lost.

At the MAPublisher Legacy Text Conversion dialog box, choose one of the following:

All text art

MAPublisher text art only

Nothing

To convert both MAPublisher text and regular Adobe
Illustrator text to the new Adobe lllustrator text format

To convert only MAPublisher text to the new Adobe
lllustrator text format

To open the file but lose attribute information
associated with MAPublisher text elements

MAPublisher Legacy Conversion

Legacy Text Conversion

MAPublisher has detected that this document contains legacy Tlustrator text art.
Tlustrator will not recognize such text as true text artuntil that art is converted,
and MAPublisher will not display attributes for legacy text art.

If you decide not to convert the text at this time and instead opt to convert it
manually at a later time, be aware that Hlustrator's legacy text conversion process
does NOT preserve attributes for converted text art.

Update
@ Al textart
“) MaPublisher text art only

) Nothing

The MAPublisher document conversion process generated the following
Layer Message

COMPATIBILITY WITH THIRD-PARTY PLUG-INS

ScaleBar_text
Land Use
Layerl

Converted & piece(s) of legacy text art.
Converted 7 piece(s) of legacy text art.
Converted 1 piece(s) of legacy text art.
MPTables Dropped 1 MAP tables.

ScaleBar_area 5 attributes converted on 5 piece(s) of art
Parcel Data_area 11 attributes converted on 1006 piece(s) of art
Land Use_area 8 attributes converted on 80 piece(s) of art
Boundary_area 5 attributes converted on 1 piece(s) of art

All efforts have been made to develop MAPublisher in accordance with the Adobe Illustrator SDK and third-party
development schema. However, Avenza cannot verify and validate compliance and compatibility with other
third-party plug-ins that may be installed on your system and cannot guarantee that MAPublisher will perform as
expected in such configurations. If you believe that a third-party plug-in is conflicting with MAPublisher, please

contact support@avenza.com.
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MAPublisher License Management

MAPublisher will not function until it is activated. MAPublisher is available in both single-user and floating license
configurations. Floating licenses are designed to allow an organization to deploy a specific number of licenses
that can be used and shared on any number of computers over a network. If you have purchased a floating license
please refer to the floating license installation guide provided with your purchase. The instructions in this user
guide are for the activation of single-user licenses of MAPublisher only.

IMPORTANT: Some peripheral components might interfere with the activation process. Before activating
MAPublisher, users must temporarily unplug or disable: mobile phone, blue tooth, wireless or GPS systems.
Laptop users with a docking station must activate MAPublisher in the undocked state.

After installing MAPublisher, launch Adobe lllustrator. The Welcome to MAPublisher dialog box will appear. When
an Internet connection is enabled and the latest license is valid, MAPublisher will automatically activate from
information provided by Avenza license servers.

This screen also provides several licensing options: Evaluate, Register, Retrieve and Floating.

Note: To continue to use Adobe lllustrator without MAPublisher, cancel this dialog box and activate MAPublisher
license later by navigating to the Help menu in Adobe Illustrator and then to MAPublisher Licensing > License
Management. MAPublisher panels are marked with a lock icon when the software is not licensed.

Welcome to MAPublisher

87

BelllITiStrato s

forFAdol

; Machine ID- When moving or
When Map Quality Matters’ activating a license through
the Internet or by e-mail, the
computer's Machine ID here
can be found here.

SYSTIME INE
———
License Management
%) S hegi . p—
(Gevduote]  [DRegstw]  [LReweve|  [roang] Giaciee) (Bres) (o) (@imas)
License status: Licensed from server Feature Version Type  Status License Key
7). hedut foating licenses automaticaly 4 MAPublisher 87 Floating Licensed from server Floating
b MAPublisher LabelPro 1.0 Floating Unlicensed
[T Don't show again MAPublisher FIME Aute 1.0 Floating Unlicensed
MAPublisher welcome dialog box
Automatically checkout license Machine ID: 0022222¢1111
Use roaming license
Duration of borrow: 1day(s)
The borrowin ns w ct from the server,

MAPublisher License Management
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ACTIVATE AN EVALUATION VERSION OF MAPUBLISHER

1. Afterinstallation of MAPublisher, click the Evaluate button of the MAPublisher Welcome Screen or MAPublisher License
Management dialog box. Complete the form and click Evaluate.

2. When you are ready to purchase the software you can open the MAPublisher License Management dialog box
from Adobe lllustrator Help menu at MAPublisher Licensing > License Management, click Register button and
follow the instructions in the next paragraph.

Note: A MAPublisher evaluation is fully functional. There are no limitations except that an evaluation license is only
valid for 14 days from the day of activation.

REGISTER A PURCHASED COPY OF MAPUBLISHER

1. Toregister a purchased copy of MAPublisher, click the Register button in either the MAPublisher Welcome Screen
or MAPublisher License Management dialog box. Enter the license key that was provided when the product was
purchased. Complete the form and click Register.

Note: The license key for MAPublisher 8.x starts with "MP80-"

RETRIEVE YOUR MAPUBLISHER LICENSE

To retrieve an activated MAPublisher license, click the Retrieve button in either the License Management dialog box
or Welcome Screen. The license file will be downloaded from the Avenza Systems licensing server.

CHECKOUT A FLOATING LICENSE

If you have purchased a floating license, please refer to the floating license installation guide provided with your
purchase. Once the server license is fully operational, follow these instructions to checkout a license from the client
machine (the computer running the actual MAPublisher application).

1. Afterinstallation of MAPublisher, click the Floating button of the MAPublisher Welcome Screen or MAPublisher
License Management dialog box.
2. Enter the name or IP address of the server where the license manager resides.

3. Click the Checkout button to retrieve the one of the licenses from the server.

Notes: If you wish to use Adobe Illustrator without MAPublisher, then click the Checkin button from the MAPublisher
License Management dialog box (at Help > MAPublisher Licensing > License Management). This releases the
license, so other users can use it.

The link to the server is set once. The next time Adobe Illustrator is started, just click the Checkout button on

the MAPublisher Welcome Screen or License Management dialog box.
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MAPUBLISHER LABELPRO LICENSING

MAPublisher LabelPro is an optional add-on to MAPublisher (8.1 and higher). Purchased MAPublisher LabelPro
licenses are added to the main MAPublisher license. During the registration process described earlier in this chapter,
all valid licenses will be imported. When purchasing a new MAPublisher LabelPro license on top of an existing
MAPublisher license, the existing license key will be tagged to support MAPublisher LabelPro and the new license
must be retrieved (see instructions earlier).

To evaluate MAPublisher LabelPro, open the MAPublisher License Management dialog box from the Adobe lllustrator
menu (Help > MAPublisher Licensing > MAPublisher License Management). Click the MAPublisher LabelPro branch and

then click the Evaluate button as previously explained.

Click the Log button to see more system information about the license status.

License Management

Feature Version Type  Status License Key
og
4 MAPublisher 8.7 Floating Licensed from server Fleating
MAPublisher LabelPro 1.0 Floating Licensed from server Fleating
MAPublisher FME Aute 1.0 Floating Unlicensed

The evaluation version of MAPublisher LabelPro scrambles the text of placed labels but preserves the case, spacing
and punctuation. The results give a sense of how actual labels would be placed based on the rule settings. See
chapter 17 for more details on MAP LabelPro functionality and usage.

Note: MAPublisher and MAPublisher LabelPro can only be both floating licenses or both local licenses (fixed or
evaluation). A user on a floating license wishing to evaluate MAPublisher LabelPro will have their main
MAPublisher and MAPublisher LabelPro licenses switched to a local evaluation license. At the end of the
evaluation period, the settings for floating license can be reset as described above.

MAPUBLISHER FME AUTO LICENSING

MAPublisher FME Auto is an optional add-on to MAPublisher (8.6 and higher). It is used in conjunction with

FME software to import data (see chapter 3). Purchased MAPublisher FME Auto licenses are added to the main
MAPublisher license. During the registration process described earlier in this chapter, all valid licenses will be
imported. When purchasing a new MAPublisher FME Auto license on top of an existing MAPublisher license, the
existing license key will be tagged to support MAPublisher FME Auto and the new license must be retrieved (see
instructions earlier).

To evaluate MAPublisher FME Auto, open the MAPublisher License Management dialog box from the Adobe
lllustrator menu (Help > MAPublisher Licensing > MAPublisher License Management). Click the MAPublisher FME Auto
branch and then click the Evaluate button.
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MOVE A LICENSE

To move a previously activated license to a new computer, use the following steps:

1. Uninstall MAPublisher from the current computer.
2. Install MAPublisher on the new computer.

3. Obtain the machine ID for the new computer (as found in the MAPublisher License Management dialog box
started from the Adobe lllustrator Help menu at MAPublisher Licensing > License Management.)

4. Complete the on-line form at http://www.avenza.com/support/rehost-license. For offline users, call tech support.

LICENSE TROUBLESHOOTING

If you cannot register or retrieve an evaluation or purchased license from within MAPublisher (e.g. firewall
limitations), visit the Avenza Systems website (www.avenza.com/activation) and provide the Machine ID displayed in
the License Management dialog box. A zipped license file attachment will be sent to the registered e-mail address
on record. Unzip this attachment and save the .lic file to the appropriate folder:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista / 7: C:\ProgramData\Avenza\MAPublisher 8
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In

To quickly access the MAPublisher license file directory, right-click a row in the License Management dialog box and
click Browse to license folder. Copy or move MAPublisher license files directly into this location.

License Management

L) Evaluate ] I -/ Register ] [ 1l Retrieve ] [ﬁj Floating ] ﬁ_] Checkin license
Feature Version Type Status 5| e -Log
4 MAPublisher 8.7 Floating Licensed from ser > Register product...
MAPublisher LabelPre 1.0 Floating Licensed from ser
i N n ) Bvaluate...
MAPublisher FME Auto 1.0 Fleating Unlicensed
I Retrieve licenses
'l Browse to license folder...

m Checkin Automatically checkout license Machine ID:  0022222¢1111

Use roaming license

Duration of borr

The bomawing peri

1dayl(s)
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MAPublisher Tools

MAPublisher tools can be found in a number of locations in Adobe Illustrator.

MAPublisher Import Map Data can be MAPublisher Preferences can be
found in the File menu found in the Edit menu.
[ £dt  Obiect Type Seect EMect View Window Help fie [ Cject Type Select [Mect View Window Help
Mew... CirdsH Unge Clear ez
New from Template_ kst il s i
Open. sy I Chik
Open Recent Files 3 Coy Cha
Rrewein i Bridge... AleCirle 0 Paite Tl
Import Map Dats (1 Sinplen Paite in Front CuieF
I Pastain Back R
Share My Scretn. L it Paste in Place. Shift-Crke
et Paste cn A1l Arboands AleSheCiried
Chose QW
Save Ctles Find snd Replace._
Save As.. Shifte Qe §. Find MNest
Save a Copy.. Al Carde 5 Check Speling... il
Save s Template— Bt Custom Dictioniey.
Srve for Wb & Devices... e Shifte Cirde § Detine Pattem
Save Selected Shces.. B8t Celons .
Revert n:
it Driginas
Place_ Trampesency Fomenes Presets..
Save for Microtoht Office.. Tracing Presete..
Export__ Prirt Presets
Adcbe PO Presets...
gk g S Presets._
Document Setup.. e Cirl~P Pespective Geid Preiets..
Document Color Mode v Color Sestingr... Shet-CuieK
File Info... Ale Shifts Crrfe] Aasign Prefile..
Priet. CeleP MR lithas Pralarencer..
B CueQ :mmm'snm. t+Sht-Cir+ K
rederenes .

MAPublisher tools can be found in the Object > MAPublisher menu.

Fle st (DB Type Select  EMect View  Window Heip | B [E -

Import MAP Cbjects...
Heguster [mage...
¥ MAP Lo<ations...
MaPublisher Log...

Area Plotter...
Georeference Duta...
Impent Places...
Line Plester...

Buffer Art...
Crop To Shape..
Fiip Lines...
Sain Areas...
Joun Lines....
Join Paints...

= Simplify Lines...
Vector Crop...

Merge Layers...
Split Ly,
Create Halo...

Dath Offset .
Scale 8 Ratate By Atsibaite..

Live Paint
Live Trace
Test Wrap

é’

Create Knockeuts...
Lakiel Features...
MAP LabelPro...
Pight-Te-Left Tet..,
Tet Lilities...

Anboards
Graph

Create North Arrow...
Grds & Graticules...

Seale Bar
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The MAPublisher panels can be found in the Window > MAPublisher menu.
G ES Omer Type oo Ee vee DM |

Ansage .
Weaskapace v

[T

A eF
anstae eIl
Color Guude eFy

- ey
Grnphic Styien e
e el

Mad stz o AR ook

¢ P e Chl P AP Thamen
AP Wit
ntrein Cireras VAP Sart Plcmar
VG ety LAAP Selectee

§
§
|
i
i
z

Syt She i FLL VAP e Sunar

Varbles
B Liseari .

Gumphic St Lbearies .
Smttzh Ly .

Seven MAPublisher tools can be found in the main Adobe lllustrator Tools panel.

7>
A

Click and hold tool icon to open context
menu to choose the related tool.

< |

b

g
©)

5

MAP Area Tool (box) MAP Area Tool (ellipse)

L

)
©

e

MAP Vector MAP Vector Ellipse Crop Tool
Rectangle Crop Tool

PEDRY /S
O

MAP Measurement Tool

CHC IS =

&

MAP Contour Tagger

=
=
]
=
a
8
]
g
e

9
[y

5

%

MAP Location Tool

CEE FAdFROLDH

O]

o
4
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MAPublisher Toolbar

Window > MAPublisher > MAP Toolbar

The MAPublisher Toolbar provides easy access to launch the MAPublisher tools and panels. The toolbar is divided
into eight sections: MAPublisher Import/Export, MAP Properties, Data Creation, Geoprocessing, Data Organization, Cartographic Tools,
Text and Labels and Map Layout.

| CEEESY RCEDT

MAPublisher MAP i Data Geoprocessing . Data  :Cartographic | TextandLabels : Map Layout
Import/Export H Properties  :  Creation : : Organization Tools :

D OYIE TS rEeee TL CoBS 0TS T By k|

The MAPublisher Toolbar can be saved in a workspace (Adobe lllustrator main menu Window > Workspace).

MAPUBLISHER IMPORT/EXPORT

Simplelmport4 = = T3, ﬂ-—z— MAP Web Author
Advanced Import; I— Export Geospatial PDF

Copy MAP Objects From Register Image

MAP PROPERTIES

MAPViews4 Al @ L] —=—MapublisherLog
' i

MAP Attributes | MAP Locations
MAP Info
DATA CREATION
Area P|0tter4l o] o '1, E: "=l Georeference Data
?
|

Line Plotter MAP Point Plotter
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GEOPROCESSING

£

JomAreas4J = - g"" &) é«:-g) 4:&-—=—Fliplines

?

L
Join Lmes Buffer Art
Join Points Crop To Shape
Simplify Lines Vector Crop
DATA ORGANIZATION

MAP Selectlons—'- 'Qr ﬁ ﬁ — Split Layers
Merge Layers
CARTOGRAPHICTOOLS
MAP Theme54 T = @ ;ﬁ == Dash Offset
Create Halo ! l Scale & Rotate By Attribute
TEXT AND LABELS

MAPLabeIProﬂ@. E}, a4l . &5 |

Right-to-Left Text

Label Features Create Knockouts
Text Utilities
MAP LAYOUT
Grids and Graticules 4@ Al b rN i Create North Arrow
Make Index Scale Bar

Chapter 1: Getting Started
MAPublisher Toolbar

27



MAPublisher Preferences
Edit > MAPublisher Preferences (Windows)
Hlustrator > MAPublisher Preferences (Mac)

MAPublisher Preferences are options that allow users to customize MAPublisher panels and editors, including those
for layer ordering, font for attribute data display and panel style. Settings are available for the following categories:

. Expression Builder + MAP Measurement

. FME Auto «  MAP Selections (panel)

«  General + MAPThemes (panel and editor)

. Import Map Data +  MAP Views (panel and editor)

«  MAP Attributes (panel) «  Online Maps

« MAP Crop Tool «  Spatial Database (Basic Esri ArcSDE Server Editor,
+  MAP Info Panel Esri Geodatabase Editor and General Spatial

«  MAP LabelPro Database Editor). Windows only.

+  MAP Locations (panel)

MAPublisher Preferences

fou Expression Builder General —
= FME fate —
0 General

L Impert Map Dats
[ MAP Artributes

B ooy ot Property sheet specific to selected
P s Labano preference category appears here.
B MAP Measurerent

T MAF Selecti

T MAP Themes

@ MaF Views

& Onbine Maps
Spatial Database

MAPublisher Preferences are saved in an Adobe lllustrator preference file called AlPrefs (Windows) or Adobe
Illustrator Prefs (Mac), which is launched each time Adobe lllustrator is started. Therefore, MAPublisher Preferences
are not file dependent. The Adobe Illustrator preference file is located in following directory:

Windows XP: C:\Documents and Settings\[user profile]\Application Data\Adobe\Adobe lllustrator CSX Settings\AlPrefs
Windows Vista / 7: C:\Users/[user]\AppData\Roaming\Adobe\Adobe lllustrator CSX Settings\AlPrefs
Mac OS X: Users/[username]/Library/Preferences/Adobe lllustrator CSX Settings/Adobe lllustrator Prefs

OPEN MAPUBLISHER PREFERENCES

MAPublisher Preferences can be opened from the Adobe Illustrator main menu, Edit > MAPublisher Preferences
(Windows) or lllustrator > MAPublisher Preferences (Mac), from the panel options menu of the following MAPublisher
panels: MAP Attributes, MAP Selections, MAP Themes and MAP Views, and by double-clicking the tools buttons: MAP
Location and MAP Measurement.

When opened through the Adobe lllustrator menu, MAPublisher Preferences opens up with no category selected.
When started from a specific MAPublisher panel options menu, MAPublisher Preferences open on the current panel
property sheet. All preferences shown here are the default settings.
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MAPUBLISHER PREFERENCES SETTINGS

Clicking one of the MAPublisher category or sub-categories on the left hand list displays
property sheet displayed on the right.

Expression Builder Preferences

the corresponding

The Expression Builder property sheet shows the settings relative to the Expression Builder dialog box used with
the MAP Attributes, MAP Themes and MAP Selections panels (see chapter 5 for more information).

MAPUBlisher Praferences

unique values - Set the

—
= FME fute

Lk General

[0 it bap Dats
@ MAP Atributes

A Lol 4

Maximum recent expressions: - Set the maximum number
recent expressions displayed in the Expression Library
(Expression Components > Description).

General Preferences
The General property sheet is used to change the layer ordering rule for all MAPublisher

maximum number of unique
values visible in the Expression
Builder (Expression Components >
Description).

The default value is 1000, users with

high performance computers can
increase this number.

panels. By default, layers

are sorted alphabetically only. The other option is to first group layers by data type first (Legend, Text, Point, Line

and Area) and subsequently in alphabetical order for each group.

MAPublisher Preferences

| f Expression Builder
= FME Aute
0 General
[ Import Map Dats
[ MAP Artributes
8 MAP Crep Tosl
Bl MAP Info Panel

Locale - This option affects how
| | MAPublisher formats numbers (e.g.
| use comma or point as a decimal
separator). Use the operating system
local settings or specify a different
language and country.

and

£l

For lobelng

B MaP LabalPro

' MAP Locations

S MAP Measuresmend
T MAP Selections.

L MAP Themes

@ MAP Views

7] Bk noites For Layers created by MAPubsher operations
| Medum

Preview quality - Adjust the

preview quality within various
MAPublisher dialog boxes

Sertg style:

Frmven qualty:

Add notes for layers created by MAPublisher
operations - Enable to automatically create
layer notes for MAPublisher operations

Log notification level - What is recorded by
the log. By default, Warnings & critical
messages is chosen. If needed, choose
No notification or Critical messages only.

Format for labeling op
display purposes based on locale
Change number labels based on
country (e.g. 400.00 in USA compared
t0 400,00 in Norway)

Sorting Style - Set to Name, then type
for an alphabetical sorting. Set to
Type, then name to first sort the layers
per data type (Legend, Text, Point,
Line or Area)

| intain point si weight/
text size when rescaling Scale
changes (made in the MAP View
Editor) that affect stroke, point

| and text sizes.

Pinned map units - The selected
| map units are listed first in
the unit drop-down lists of

MAPubishes Preferences
‘ f Expeession Builder General > Transformation o |
= FME fate |
4 & Genaral | Marnitan pont e when rescaing £ Carcal "
& Trondomation | 91 paantain stoke weght when rescaing
o Units ] Muintains beat s whn escalng.
(5 Impert Map Dats
[ M&P Aetributes
MAPubiishes Preferences
| f Expression Builder General > Units o
= FME Aute —_—
iy Frred ma units: /20 Fest = Cancel
- G";"'Mf i 1/10 US Survey Feat
Rt ArcMinate
o (R | AreSecond
& Import Map Dats Beroit's Chain
M MaP fiibutes Benoit's Link
&l MAP Crop Tocl Bt wicith 125 Meter
W MaP infe Panel Bim width 165 U5 Survey Foot
T MAP Labelbro Bin width 25 Meger
B MAP Locations Ban wickth 3125 Meter
S MAP Messurement Bin wickh 330 US Survey Foot
T MaP Selections =
0 MR Themes M reORnT Mag urits: $ie
@ MAP View Page it (Puvels ) =

MAPublisher (e.g. in Scale Bar
or Buffer Lines dialog boxes)

Max recent map units - Maximum
number of map units
memorized by MAPublisher

Max recent map units - Maximum
number of map units
memorized by MAPublisher
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Import Map Data Preferences

The Import Map Data preference category allows users to sort the order of the attributes columns upon import.
By default, attributes are imported in the same order as in the source GIS data file and the MAPublisher #Property
attributes are created in front of the imported attributes (see chapter 5 for additional information).

MAPGbisher Preferences

f Expression Builder

= FME Ao

enetal
Impert Map Dats
[ MaP Attributes
& MaP Crap Tenl
EH MaP Info Panel
T MAP Libelro

# MAP Locations

o MAP Meawurement

Attribute sort on import - Set to Do not
Sort to maintain the attributes order
of the source GIS file. Set to Order
attributes alphabetically to apply this

W MAD Selectung

T MAP Themes

@ MAP Views

& Dnline Maps
Spatial Datsbaie

Show extensions in Format drop-down list
By default, the Format drop-down

list in the Simple and Advanced
Import dialog boxes shows the

format extensions (e.g. 'shp'). Clear
this check box not to display format

extensions.

Show extents iR Advanded [mport table
] mpert Geompatal POFs.

Import Geospatial PDFs

Check this option Import table - Check this
enable the ability to  option to display the
import geospatial data extents (lower left
PDF documents. and upper right corners

coordinates)

Import Map Data > Web Services

Show extents in Advanced

Show full file name in Advanced
Import table - The Advanced

I_ new ordering.
Path corners - Set to Miter, Round or
Bevel join

—— Path endings - Set to Butt, Round or
Projecting cap

Property disposition on import - Set to
Move properties to start or Move
properties to end

Import table shows the list of

to display the full path.

selected files for import. By
default, only the file name is
displayed. Check this option

Append feature type as suffix on imported
layer names - By default, the feature

type is appended to the layer name
(e.g."_area' or '_point'). Clear this
check box to prevent this behaviour.
Ensure imported layer names are unique
By default, MAPublisher appends
anumber 1, 2 etc... to an imported
layer name if the layer name already
exists. Clear this check box to
prevent this behaviour.

MAPGbisher Preferences

WMS default output directory

fm Expression Builder et Hap Dals = Web Services = The default output directory
T ol it Braraoty: (o for files ger}erated l?y the
{3 tmpert Map Data WS defut ouat drestony: Web Mapping Service
@ Wieb Senices import feature
[T MAP Auributes
ﬂ e e WFS default output directory
T MAP LabelPro The default output directory
! MAP Locstions for files generated by the
¥ v Web Feature Service import
T MAP Themes. feature
MAP Attributes Preferences
MAP Attributes Preferences
MAPubliher Preferences R 3 li datato d path
f= Expression Builder HAF Attributes. = sub-cnmpnngnts- Enable this option
= ”:'—‘Tﬂ Teokats stk deks o compound Bolh mb-cosccnts e before editing the attribute schema
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{4 Impent Map Data
[ MAP Atributes
(6l MaP Crop Tonl
Bl Map ke Panel
TF MAP Libelro

Defmit siring size: 35

Dt chacimal eount: §fz

Default decimal count - Specify the default
number of decimals applied when
creating a new attribute of type [R] Real

Chapter 1: Getting Started

MAPublisher Preferences

Default string size - Specify the default
string size applied when creating a

new attribute of type [§] String

so that the attributes do not get
broken when releasing a compound
path (see chapter 5)



MAP Attributes > Panel

MAPGbisher Preferences

I
F= Expression Builder AR Altributes = Pamel
= FME Auto

i Tabie forit: W Uise default fort

143 Impent Map Data MG el g 3

+ [T MAP Atiributes Table forit e Default |

Table font - Set the text font for
headers and attribute values

Table font size - Set the text font size

T Pandt

(8] MAP Crop Teol ] S
[l MAP Info Parel ] Shom dinplary
T MAP LibePro Shany reccedset nvgdten

* MAP Locations

Show recordset navigation — Enable this
option to show navigation buttons in
the MAP Attributes panel. Use them
to scroll through attribute records.

MAP Crop Tool Preferences

Show display names in column headers
Enable this option to show the
display name of a column header
instead of the actual column name

Show icons in column headers - Enable
this option to display the data type in
front of the attribute column name
(|E| Boolean, m Integer, R Real, and
String)

The MAP Crop Tool preference category contains point text and path text crop type and crop method settings.

MAPubikher Preferences

Fieset Do net shom aopn oreferences

P Eapreviion Rusider | HAP Crop Tool
= FME fute Point Text: Foints:
3 General
-4 Vestaeize sorize
[ Impcrt Map Duta i i
[ MAP Attributes o cr da
= MAP Crap Tesl @ orgnof st chrssts  Anacy for beser copping baundaries:

MAP Info Panel "
B MAP LibeiFro [ u
:‘ MAP Locations Pth Tat: AR T
S MAP Messurement

Vectorine ord
' MP Selections o
T MAP Themes P pa oty
@ MAP Views @ Crop text based on:
- ?P'melz?kp; @ Orign of first character
sbase
Text bounds
Crop path
| S — et

Point Text - Choose how
point text is handled
when intersected by a
crop boundary

Points - Choose how points are
handled when intersected by
a crop boundary

Path Text - Choose how

point text is handled

when intersected by a

crop boundary

Cropping Boundary - Adjust
accuracy for vectorizing a
bezier path when intersected
by a crop boundary

Note: For Spatial Database spatial filter (crop on import option), there will be no point vectorizing and text will be

cropped based on whether its bounding box touches the crop area.

MAP Info Panel

The MAP Info panel preference category contains general settings (see chapter 4).

MAPGbisher Preferences

f= Expression Builder AP Info Panel
FMIE Gt —
General | Lathong deplay format:
(3 impert Map Data Display precsion: ofk
[ Map anributes
(&l MAP Crop Teol

B AP ko Parst]
T AR Labeliire

¥ MAP Locations
% MAP Messurement
T MAP Selestions

T MaP Themes

Lat/Long display format- Set the latitude
and longitude display format:

« Decimal degrees

« Delimited Degrees Minutes Seconds
« Degrees.Minutes

« Degrees.MinutesSeconds

« Packed DMS with decimal point

« Packed DMS

Display precision - Set the number of
decimals shown on the MAP Info panel
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MAP LabelPro Preferences

The MAP LabelPro preference category contains general settings to save the path access to saved rules, styles and
symbol folders (see chapter 17 for more information on MAP LabelPro).

Base rule folder — Directory path to the

MAPublisher Preferences

fm Expression Builder MAF Labatira [
:_ ::_:::s Bace rue folder:  C:Peoge an \ " ' “cancel
(58 trmpert Map Data Dase styie foder: C:rogre "
A]
E ::: :::pb:::l CEWrogr A BLabeProiSymbols|,
I MaF info Panel . bgnare nvskle ek e———— [gnore invisible artwork — Enable
? :“’;: t:“‘:;s 7] Merge mutine tea this option to ignore individual
. MAP Massurimant invisible artwork. If this option
F MAP Selectiong is disabled, individual invisible
b it artwork will be taken into account
@ Oniine Maps as labelling source and obstacle.
Spatial Datobase
Merge multiline text - Merges
multiple lines of text into a
single line
Ry e e,

rule folder. Click the browse button
| E]to open a folder browser and
change the path.

.—;— Base style folder - Directory path to the

style folder. Click the browse button
E]to open a folder browser and
change the path.

—— Symbol folder - Directory path to the
symbol folder. Click the browse
button [] to open a folder browser
and change the path.

Note: The default directories for the rule, style and symbol folders:

«  Default rules and styles folders—respectively Rules and Styles subfolders in the directory:
Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\..

Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\..

Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/..

«  Default symbol folder:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Symbols
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Symbols
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/Symbols

MAP Locations Preferences

The MAP Locations preference to control MAP Location labels, lat/long format and precision.

MAP Locations Preferences
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MAPublisher Preferences

MAP Location label policy - Control how

7= Expression Bulkder MAP Locations el | the labels appear or disappear
A TME Aty 1AP Locabin label poky: [ Ehaw when ool curser & nearty. ) (==
1 n 1
3 Import Map Data Aust-show lebel provimity: o |
[0 MAP Arbutes T |
| (& MaP Crop Tool

M MaP Info Pare
T MAP Labeli'ra

F! MAP Locations
S MAP Messurement
T MAP Selections

T Mak Themes

Label proximity - Control how close
the mouse cursor has to be before a
label appears

MAP Locations > Clipboard MAP Locations > Editor
MAP Locations > Clipboard MAP Locations > Editor
Alternate coordinate: [Geodetic base -]

Lat/Long display format: [Decmal degrees (D+L.d*])

Latflong format: [Decimal degrees (D +.d%]) -

Precision: 6%
Precision: 6l
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MAP Measurement Preferences

The MAP Measurement category contains display settings for the MAP Measurement Tool (see chapter 7 for details).

MAPGbisher Preferences

Units - Choose to use the current

fm Expression Builder
= FMEfne

L General

{43 Impent Map Data
[0 MAP Atibutes
[l MaP Crop Toal
Bl Map ke Panel
T MAP Libelro

# MAP Locations
S MAP Messurement
T MAP Selectuons
T MAP Themes

@ MAP Views

@ Online Maps

HAF Measurement.
Livts:

Calnubaton methed:
Dy recsiens:

Lire ok

New e cokur:

613

e layer's units or select a specific unit in
= the drop-down list
Cancel

G Method - Choose to calculate

distance based on datum (geodesic)

or map projection (Cartesian)

L

— Display precision - Set the number

S anmtn

Porutrer argie deecton: | Counter clacknne

Show azimuths - Display forward
and reverse azimuth when using
the MAP Measurement tool

MAP Selections Preferences

Positive angle direction - Set the
positive angle direction as either
counter-clockwise or clockwise

of decimals shown on the MAP
Measurement annotations

Line colour - Set the color of the
digitized measurement path

New line colour - Set the color of
the current segment (between
last digitized point and current
mouse position)

The MAP Selections preference category does not contain general settings but has a sub-category for the MAP
Selections panel (see chapter 11 for a full description of the MAP Selections panel).

MAPGbisher Preferences

f Expression Builder
= FME St
i General
{3 Impert Map Data
[ M2P Airributes
& MaP Crap Tenl
N MaR Info Panel
T MAP Labelra
' MAP Locations
S MAP Messurement
* T MAP Sebections
™ Paned
T MAP Themes

HAF Selections. > Panel

7] Shew selectern on bvs ey

MAP Themes Preferences

Show selections on two lines - Enable

this option to display the selection
filter name and its expression on two
separate lines.

The MAP Themes preference category has a main property sheet and also contains a sub-categories for the MAP
Themes panel (see chapter 9 for a full description of the MAP Themes editor and panel).

MAPGbisher Preferences

features to use in Rule Generator

f Expression Builder
= FME St
i General
{3 Impert Map Data
[ M2P Airributes
& MaP Crap Tenl
N MaR Info Panel
T MAP Labelra
' MAP Locations
S MAP Messurement
* T MAP Sebections
T Pandd
T MAP Themes
@ MAP Views

MAF Themes.

Mandmum features o use i Rule Generator:

Manemm data cagses:

20000 [+

1

1000 |3

This option specifies the maximum
number of unique values that can be
generated by the Rule Generator.

=)

Cancel

data classes

This option specifies the maximum
number of data classes when that
can be used with the Rule Generator.
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MAP Themes > Panel

MAPublisher Preferences MAP Themes sort style — By default,
F Expression Builder AP Themes > Panel = the General sorting style is applied
= EME e T — e . (option Use General preference). Set to
- (Wes Soneral | concel :

o8 Gaarsl Name, then type for an alphabetical

15 Impost Map Data Sort st g naural s3g companison N

[T M2P Atsributes sorting. Set to Type, then name to first

(8 M&P Crop Toal sort the layers per data type (Legend,

Bl MAP Info Panel Text, Point, Line or Area).

T MAP Labeira

# Mmap Locations

§ MAR Messurerment Sort list using natural string comparison —

T MAP Selections i i

i S Enal?le this option to use the natural

T Panel sorting for layer and MAP Themes

@ MAD Views names using numbers (e.g. 1,2,10

& Online Maps instead of 1, 10, 2)

MAP Views Preferences

The MAP Views preference category does not contain general settings but has sub-categories for the MAP Views
editor and panel (see chapter 4 for a full description of the MAP Views editor and panel).

MAP Views > Editor

MAPubdisher Preferences

f Expression Builder
= FME St
i General
{3 Impert Map Data
[T MAP Aitributes
(@ MaP Crap Teol
Bl Map ke Panel
T MAP Libelro
' MAP Locations
S MAP Messurement
W MAD Salections
I MAP Themes
“ @ MAPViews
=1 Eamor
T Panel
@ Online Maps

MAP Views > Panel

AP Views = Editor

Startcentered on: [Curent rtbomd.

Shem Lastucde Longitie ondenng ooton

Start d on - By default, the
current artboard is centered in the
preview area of the MAP Views dialog
box. Change the option to have it
centered on the current MAP View.

MAPubdisher Preferences

Show Lat/Long ordering option

Enable this option to show the
Latitude/Longitude ordering
drop-down menu in the MAP Views
dialog box. This effectively swaps the
order of how latitude and longitude
values are shown.

f= Expression Builder
= FME st

b Geneal
143 Impent Map Data
[ MAP Attributes
(&l MAP Crop Teol
B MaP ok Paned
W MAP Labetbro
# MaP Locations
W MAP Messurement
*F Map Selections
L MAP Themes
+ @ MAP Views
) Edtor
T Panet
& Dnline Maps
Spatial Dutabisse

HAP Virars > Panel

Sort st irsing natural s¥ing compuarisen

| Shem rote ndcators.
| Show tooltips whik dragging

Sort list using natural string comparison
Enable this option to use the natural
sorting for layer and MAP View
names using numbers (e.g. 1,2,10
instead of 1, 10, 2).

Show note indicators - When enabled,
it displays the note icons next to the
layer name in the MAP View panel
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Show tool tips while dragging - When
dragging a layer from one MAP
View to another, a tool tip displays
information on the destination MAP
View. Clear this check box to prevent
tool tips to be displayed.



Spatial Database Preferences

For Windows only. The MAPublisher Spatial Database preference category does not contain general settings but has
three sub-categories: Basic Esri ArcSDE Server Editor, Esri Geodatabase Editor and General Spatial Database Editor (see
chapter 3 for a full description of the MAPublisher Spatial Database).

Spatial Database > Basic Esri ArcSDE Server Editor

MAPGbisher Preferences

F Expression Builder
= FME St
i General
{3 Impert Map Data
[ MaP Attributes
& MaP Crap Tenl
N MaR Info Panel
T MAP Labelra
' MAP Locations
S MAP Messurement
T MAP Sebections
T MaP Themes
@ MAP Views
@ Onlne Maps
+ |4 Spatial Datsbase
B Batic Eeri ArcSDE Server Editor
£ Esri Geodutabase Edites
ET Gerserad Spatial Database Edies

o Crog

Sertrematenly orvect i | Averaa AICE

—— ArcGIS Bin Directory - Specify the
location where the ArcGIS Bin
directory is installed. Click the Browse
button to open a folder browser and
change the path.

Spatial Database > Esri Geodatabase Editor

ically connect to — Check this
option to automatically connect to a
specific server connection, selected
in the drop-down list

MAPGbisher Preferences

Use alias as layer name — Enable this

f= Expression Builder

[ Impert Map Data
[0 MaP Anibutes
(&l MAP Crop Teol
M MaP info Panel
T AR Labeliire
¥ MaP Locations
W MAP Measurement
T MAP Selections
T MaP Themes
B MAP Views.
@ Online Mags
- Spetial Database
1 Basic Esn ArcSOE Server Editor
BT Esei Geodatabase Editor
1 Gerverad Spatial Database Editcy

7] Lise akan as laver name

Use abdvmiated

option to use feature class' alias
name rather than its true name

Layer s
Displny cobect deampinfuiotype deseriptios:
£177 Load subtvpes o5 seoarste avers
Sert foatiee datasets diphabeticaly when seiecting for import
Sort fenture classes siphubeticaly when selecing for import.
Sort antriutes sohabetoaly when selecang for mport
Automaticaly corect ;| Averas AOL Comecon v

(mtead

| Hhumbier of ponts 1o use 1o speaty 8 spatsl Miter boundng bax:

Load subtypes as separate layers —— Sort attributes alphabetically when selecting for

Enable this option to use
create new layers per subtype

Sort feature datasets alphabetically —
when selecting forimport - Enable
this option to sort feature
datasets alphabetically in the
import dialog boxes

import — Check this option to sort attributes
alphabetically in the import dialog boxes

+— Sort feature dlasses alphabetically when
selecting forimport - Enable this option
to sort feature classes alphabetically
in the import dialog boxes

'— Automatically connect to — Check this
option to automatically connect to a
specific server connection, selected
in the drop-down list

Number of points to use to specify a spatial
bounding box - Choose either two opposite
corner points or four sequential points.

Use d table name for layer name
ArcSDE geodatabases' tables

are identified as databaseName.
userName.tableName. The
abbreviated version uses only the
table name as layer name.

If this option is used in combination
with the "use alias" option, the alias is
applied first.

— Display coded domain/subtype description
Option to import attributes with
coded values from subtypes and
attribute domains as follow:

« Instead: replace the codes by their
description (text)

« Never: import actual values—codes

« In Addition: create two attribute
columns, one with coded values
and one with descriptions
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Spatial Database > General Spatial Database Editor

MAPublisher Preferences

Jo Expression Builder
= EME e

| & General
{4 Impart Map Data

{ [ MaP Atrributes

| & MaP Crap Tenl
Bl MR ke Panel
T MAP Labetra
# MAP Locations
W MAP Measurement

Heamber of SQL queries to remember: s

husmber of defaut AAISEES B remember: L5

=)

W MAD Selectung
T MAP Themes
© MAP Views
& Dnline Maps
a Spatual Databae
Basic sl ArcSOE Server Editor
= Eari Geodatabase Editor
7 Gemersd Spatal Database Ednee

Online Maps Preferences

MAPublisher Preferences

o Expeession Builder Umbne Haps
= FME Sute
b General
(5 Impet Map Dats Cnine Mags it fie
[T MAP Astributes
| 8 MaP Crop Tool
Bl MAP Info Panel
B MaP LabalPro
* MAP Locations
S MAP Measuresmend
T MAP Selections.
L MAP Themes
@ MAP Views
@ Online Maps.
Spatial Database

FME Auto Preferences

COrline maps are used in Georeferencer and in MAP Locaions.

=]

Cancel

ancel |

The MAPublisher FME Auto preference category can be viewed in Chapter 3.

RESET MAPUBLISHER PREFERENCES TO DEFAULT SETTINGS

Number of SQL queries to remember
Select the number of queries
memorized in the Recent category

Number of default datasets to remember
Select the number of default datasets
saved in memory for later use

Online Map HTML file

Choose a new HTML file to specify a
different online map service. Leaving
this blank will use the default online
map service.

Customization of the HTML file is
required. Please contact Avenza
Support for more information.

MAPublisher Preferences can be reset directly from the MAPublisher Preferences dialog box. A right click on a
category will display the choice to reset the preference setting of this category or the entire MAPublisher Preferences.

“%,  Reset 'MAP Views' and sub-preferences

“%  Reset all preferences

MAPublisher Preferences will also be reset if the Adobe Illustrator preferences are reset or deleted. Adobe often
recommends this to solve some problems with the application. Adobe lllustrator preferences are reset by doing one

of

36

the following:

. Press and hold Alt+Control+Shift (Windows) or Option+Command-+Shift (Mac) as Adobe lllustrator is starting.

The current settings are deleted.

. Remove or rename the AlPrefs file (Windows) or Adobe lllustrator Prefs file (Mac). New preferences files

are created the next time Adobe lllustrator is restarted.
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MAPublisher Log

Object > MAPublisher > MAPublisher Log or MAP Toolbar L]

o
MAPublisher Log [ Zloomto/Clear Selection/Add To Selection/
J Remove From Selection - Controls to
B
Message When Layer
£ & Writing out transfermed features to artboard 34 seconds ago
2 Writing out transformed features to artboard 34 seconds ago
L& Writing out transformed features to artboard 34 seconds ago
L& Writing out transformed features to artboard 34 seconds ago
Messages - Used MAPublisher tools + [ Advanced Import 40 seconds ago
are logged here. Expand items to @ Medify MAF View Hotels' 1 minute 2go Export Export - Export the list to a text file
view details about each tool. [ simplelmport 1 minute 2go
>[5 SimpleImport 1 minute age
4 [ simpleImport 1 minute ago
% Reading data from 'C:\Users\Public\Documents\A... 1 minute ago
L Creating lllustrator artwork 1 minute ago
L7 Reading data from 'C:\Users\Public\Documents\A.. 1 minute ago
¢ Creating lllustrator artwork 1 minute ago
Show i i ing/critical show: (@) [
messages - Toggle the filtersto ||

show different message types

FUNCTIONALITY

The MAPublisher Log records information about which MAPublisher tools are used and when they were used.

USING MAPUBLISHER LOG

To view the MAPublisher Log dialog box, click the [LJ] button on the MAPublisher Toolbar or click Object > MAPublisher
> MAPublisher Log.

When a MAPublisher tool is used, information such as the tool used, inputs, outputs, warnings and errors are
recorded into the log. The log also displays when tools were executed and which layers were involved. However,
not all MAPublisher tools are logged (such as MAP LabelPro, MAP Tagger, Label Features, Scale Bar, MAP Locations,
MAP Selections, and MAP Web Author).

Use the Show toggles to filter information, warning and critical messages.

Click the Export button to export the entire log to a text file.

A maximum of 10,000 messages can be logged. Click the Clear button to remove all messages from the log. This is
permanent and cannot be undone.
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Preparing the Workspace

Before using MAPublisher, you must first set up your Adobe lllustrator document. It is at this point that you define
your page size and units, set your print orientation and generally prepare your Adobe lllustrator workspace.

Establish the desired page size and orientation before importing map data as MAPublisher will establish
georeferencing based on the current page. However editing page dimensions after import will maintain correct
georeferencing based on the new page dimensions.

Note: If no document is open, MAPublisher Simple and Advanced Import initiate the New Document dialog box.

SETTING UP A DOCUMENT

1. Create a new Adobe lllustrator document by selecting File > New, or Select File > Document Setup if you already
have a blank document open - The Adobe lllustrator Document Setup dialog box appears.

2. Select the size to use for your page. Letter (8.5”x 11”) is the default size*. You may wish to change the
orientation to landscape for some files. For example, a map of Chile may be best displayed in portrait but a
map of Indonesia may be best displayed in landscape.

Select your desired page units. The default unit type is Points.

4. Ensure the page origin is at 0,0. To do this, select View > Show Rulers. Double-click the top left corner of the
rulers where the vertical and horizontal rulers intersect.

For more information and details regarding these operations please refer to your Adobe lllustrator User Guide.

*In step 2 the default page size of 8.5” x 11" is for North American versions of Adobe lllustrator. Other language versions
of Adobe lllustrator may have different default page sizes. Consult your Adobe lllustrator User Guide for more information.

Notes: Note that the maximum length and width dimension for an Adobe Illustrator document is 227.54 inches.

Adobe lllustrator CS5 introduces a new function to Duplicate Artboard. This new function should be used
with caution because it also duplicates art and moves it on the page, but the duplicated art reference is the
same geographic frame as the original art (they are contained in the same layer). Therefore the geographic
position of the duplicated art will not be correct.
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Map Data File
Formats

MAPublisher imports and exports many of the leading GIS
industry file formats.

Import Formats

Adobe Geospatial PDF (*.pdf)

AutoCAD Drawing/Exchange (*.dxf, *.dwg)
Delimited Text Data (*.txt, *.csv, *.tsv)

Digital Line Graph (*.dlg, *.opt)

Esri ArcInfo Generate (*.gen)

Esri Interchange File (*.e00)

Esri Shapefile (*.shp)

Esri ArcMap Document (*.mxd)

FME Feature Store (*.ffs)

Geography Markup Language (*.gml)

GPS Exchange Format (*.gpx)

Image (multiple formats)

Google Earth (*.kml, *.kmz)

Maplnfo Interchange Format (*.mif)
Maplnfo Table (*.tab)

Microsoft Excel (*.xIs)

MicroStation Design (*.dgn)

International Hydographic Office S-57 (*.000)
Spatial Data Transfer Standard (SDTS) (*.ddf)
TIGER/Line (*.rt1, *.ow1)

Web Feature Service

Web Map Service

Basic Esri ArcSDE Server

Basic Personal Geodatabase Reader (*.mdb)
Esri ArcSDE Geodatabase

Esri File Geodatabase (*.gdb)

Esri Personal Geodatabase (*.mdb)

Export Formats

Adobe Geospatial PDF (*.pdf)
AutoCAD Drawing/Exchange (*.dwg, *.dxf)
Delimited Text Data (*.txt, *.csv, *.tsv)
Esri Interchange File (*.e00)

Esri ArcInfo Generate (*.gen)

Esri Shapefile (*.shp)

Geography Markup Language (*.gml)
Google Earth (*.kml, *.kmz)

Maplinfo Interchange (*.mif)

Maplnfo Table (*.tab)

Microsoft Excel (*.xIs)

MicroStation Design (*.dgn)

Chapter 2: Map Data File Formats
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Import and Export Supported Data Formats

This section provides an overview of the supported formats. For an in-depth analysis of further considerations when
using these formats during Import, please see appendix AT.

DATA FORMAT DESCRIPTIONS

Adobe Geospatial Portable Document Format (*.pdf)

Import and Export

The geospatial PDF is considered an Adobe Acrobat Portable Document Format (following the PDF 1.7 specification)
that contains information that is required to georeference location data. It is an open specification developed and
maintained by Adobe Systems. See detailed specifications in Section 8.3 at http.//www.adobe.com/devnet/acrobat/
pdfs/PDF32000_2008.pdf.

AutoCAD Drawing (*.dwg) and Drawing Exchange (*.dxf)

Import and Export

These file types are most commonly created by Autodesk AutoCAD product, though other computer-aided design
(CAD) programs such as Bentley MicroStation capable of creating them. Two formats are used by AutoCAD: DXF
(drawing exchange format) files and ASCIl representations of the binary DWG (drawing) files. Logically, both files are
identical and MAPublisher treats both file types in the same manner. AutoCAD files consist of drawing settings and
configurations, as well as a series of entities, or graphic elements, organized into layers. MAPublisher provides broad
support for many AutoCAD entity types and options. Prior to import, set the colour mode of the Adobe Illustrator
document to the same scheme used in the colour table of the CAD file (RGB or CMYK) to ensure colours are
imported correctly. Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point,
then line, then area layers. Annotation objects are converted to a point containing attribute information including
the text value to be labeled and its angle. Certain symbols may import as "exploded" objects in MAPublisher.

Delimited Text Data (*.txt, *.csv, *.tsv)

Import and Export

MAPublisher also supports the import of Delimited Text Data held in a variety of tabular file formats, as long as the
data contains coordinate values. File types supported are Text (.txt), Tab Separated (.tsv) and Comma Separated
(.csv) files. Import Settings dialog box: In order to import point data with MAPublisher the parameters must be set
by clicking the Settings’ button. This operation is required to choose the columns of the selected attribute file that
will be used to derive the X and Y coordinates of the data, and ensure correct georeferencing. These and further
settings are discussed in chapter 6 and in the Delimited Text Data Settings section in appendix A1.

Digital Line Graph (*.dlg, *.opt)

Import only

The USGS (United States Geological Survey) DLG file structure is designed to accommodate categories of spatial
data represented on a conventional line map. Node (point), line, and area data types are accepted. The attribute
coding scheme is designed to accommodate basic cartographic data categories such as hypsography, hydrography,
or political and cultural features, as well as additional thematic data categories.
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Esri Arcinfo Generate (*.gen)

Import and Export

Arcinfo Generate files are created by Esri Arcinfo product, and have a simple ASCII from x-y to x-y format. Due to its
simplicity you can also use a text editor such as Notepad to create text files and save them with a *.gen extension,
which can then be imported with MAPublisher.

Esri Interchange File (*.e00)

Import and Export

Esri Interchange File files are created by Esri ArcInfo product. A single EQO file describes a complete Arcinfo
coverage. The file itself is actually an archive of several smaller files, or sub files, which will have fixed names and
follow a predefined data format. MAPublisher will reproduce these sub files as distinct Adobe Illustrator layers on
import. Therefore importing a single e00 import can result in the generation of point, area, line and text layers.

Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point, then line, then area layers.

Esri Shapefile (*.shp)

Import and Export

Shapefiles are most commonly created by Esri ArcGIS or ArcView. Shapefiles store both geometry and attributes for
features, and a single shapefile will consist of at least three physical files: the .shp portion contains the geometric
data, the .dbf contains attributes for the geometric data, and the .shx contains the index information. There is often
a .prj file, which stores coordinate system information and is automatically read by MAPublisher on import. If a
shapefile folder does not contain a .prj file, a coordinate system should be specified in MAPublisher. The important
things to remember when importing shapefiles are that the .shp file must be the one that is selected through

the MAPublisher import filter and that all its component files must be in the same folder. You may also find that

a shapefile directory includes two extra files, a .sbn and a .sbx, which hold the spatial index for the geometric

data. These two files will not exist unless the shapefile was created with an Esri product, and are not necessary for
successful import with MAPublisher.

Esri ArcMap Document (*.mxd)

Import

ArcMap Documents (.mxd files) contain information describing the map, page layout, layers associated with it,
and any objects inserted into the map. The MAPublisher Simple and Advanced Import are used to import ArcMap
Documents. Due to certain limitations, only the coordinate system, layer order and map data are retained when
importing an ArcMap Document. Any styles, such as strokes, fills and patterns are not preserved. In addition, to
import ArcMap documents, at least ArcGIS 9.x must be installed.

FME Feature Store (*.ffs)

Import

FFS stands for FME Feature Store. This format is a memory dump of FME features; so it supports the complete FME
data model and can hold anything that FME features carry. This makes the format attractive as a holding spot for
data that should persist between FME runs.

MAPublisher-FME Auto is a plugin for MAPublisher. It is already installed with MAPublisher and requires activation
through MAPublisher Licensing. See chapter 3 for more information about FFS import and MAPublisher-FME Auto.
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Geography Markup Language (*.gml, *.xml)

Import and Export

The Geography Markup Language (GML) was designed as a geographic interface language for the Geo-Web. It is
currently in draft as an ISO standard (ISO 19136). The goal of the format is to provide users with a set of abstract
base objects that can be built into working real world dataset. It uses an XML base to store geometry and feature
information that can easily be transported across the Internet.

The GML Simple Feature Profile was created by the Open Geospatial Consortium (OGC) as a restricted but useful
subset of the GML specification. It provides a reduced geometry and metadata profile that can be shared across
many GIS tasks. This simple feature model can be used as a base to generate local application profiles for a specific
work area. Since the GML models base abstract classes, these application profiles (schemas) are required for
accessing and processing any GML datasets. GML data has a *.gml extension, and requires a attributes schema file
*xsd. Some GML files may have their .xsd file referenced to a URL path, we recommend to copy the xsd files locally,
to avoid error messages upon import when no internet connection is available.

Users have two options to store their .gml and .xsd files: they can be both located in a same directory or the xsd files
can be kept in the MAPublisher GML Schema directory found here:

Windows XP, Vista and 7: C:\Program Files\Avenza\MAPublisher 8\Data Source Files\GMLSchema
Mac OS X: /Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/Data Source Files/GMLSchema

The second option is the most practical if all the GML files are using a same schema (only one instance of the XSD
file needs to be saved). Installed with MAPublisher are three default XSD files:
«  xmlxsd, generic GML attribute schema.
+  nen3610.xsd and top10nl.xsd, models standardized in the Netherlands (maintained by the Dutch
topographic office Kadaster).

GML files with a missing XSD file or with an invalid attribute schema will cause a GML validation error upon import
(see chapter 3). Users have the option to find the appropriate XSD file and copy it to the GML Schema directory or
to the GML file directory. This option will assign a type string to all attributes. See chapter 3 Importing Map Data for
more details on these settings.

MAPublisher supports the import of simple features (points, lines, polygons, donuts, and aggregates) in GML 2.0
and later versions. MAPublisher supports export to GML 3.1.1.

Google Earth (*.kml, *.kmz)

Import and Export

Keyhole Markup Language (KML), is an XML-based language for managing the display of three-dimensional
geospatial data in the programs Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies
a set of features for display. Each feature always has a longitude and a latitude and can have other data, such as tilt,
heading, and altitude. KML shares some of the same structural grammar as GML. KML files are very often distributed
as KMZ files, which are zipped KML files with a .kmz extension. MAPublisher imports and exports both file type
based on the KML version 2.2 specifications.
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GPS Exchange Format (*.gpx)

Import only
GPS Exchange Format (GPX for short) is a light-weight XML-based data format designed for the interchange of GPS
data. MAPublisher supports GPX schema version 1.1.

Image (*.png, *.jpeg, *.jpg, *.jpe, *.tif, *.tiff *, *.gif, *.jp2, *.jpf, *.jpx, *.j2k, *.j2¢, *.jpc, *.psd, *.pdd, *.bmp)
Import only

Referenced raster files of the above mentioned formats can be imported and placed directly into a MAPublisher
MAP View from the Simple and Advanced Import tools. These images have the option to be linked or embedded
into Adobe lllustrator upon import. Images cannot be reprojected by MAPublisher in Adobe Illustrator. Use
Geographic Imager or another third-party software to properly reproject geospatial images.

International Hydrographic Office S-57 (*.000, *.030)

Import only

S-57 is referring to the IHO (International Hydrographic Office) Special Publication number 57 related to the IHO
transfer standard for Digital Hydrographic Data . Maintained by the IHO, S-57 format is intended for the exchange of
digital hydrographic data between national hydrographic offices and for its distribution to manufacturers, mariners
and other data users. It is used for the supply of ENC cells (Electronic Navigational Charts) to ECDIS (Electronic Chart
Display and Information System). The objects spatial geometry can be of Point, Line or Area geometry, while object
descriptions are categorized in object classes, organized in specific attributes schemas. To make full use of this
format, refer to the online object catalog available on www.s-57.com.

MAPublisher imports non-encrypted S-57 data into MAP layers named per S-57 object acronym, of type Area, Line
or Points. All S-57 Attributes are converted into MAP Attributes.

An Adobe lllustrator template is supplied to automatically style the map after import. The template contains a series
of MAPublisher stylesheets linking S-57 imported features to nautical symbols and graphic styles (libraries provided
by Avenza). This representation is non-exhaustive and meant to assist users with limited knowledge of the S-57
format to interpret the data contents more easily. The S-57 template and the symbols and graphic styles libraries
can be found in the MAPublisher Helpful Styles & Symbols folder (see Appendix 4).

Maplnfo Interchange Format (*.mif)

Import and Export

Files of this type are most commonly created by the Maplinfo product, though other products, including
MAPublisher, are also capable of generating files in this format. These files exist in pairs where each file has the same
name but ends in either a .mif or .mid file extension. The .mif portion contains the vector geometric data, and the
.mid contains the associated attributes. Both files are required in order to successfully import a file of this format to
Adobe lllustrator using MAPublisher. The important things to remember when importing Maplinfo files are that the
.mif file must be the one that is selected through the MAPublisher import filter and that both files must be in the
same folder. MAPublisher will automatically locate and deal with the .mid file.
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Mapinfo Table (*.tab)

Import and Export
The TAB format is a simple, non-topological format for storing the geometric location and attribute information
of geographic features, and is an integral part of the Mapinfo product. The TAB format defines the geometry and
attributes of geographically-referenced features in several files with specific file extensions that are stored in the
same folder on disk. They are:

.tab: main file, table structure in ASCII format.

.map: the file that stores the feature geometry.

.id: the file that stores the index of the feature geometry.

.dat: the dBASE file that stores the attribute information of features.

.nd: table field indexes (if necessary)
The geometry of each feature is stored as a shape that comprises a set of vector coordinates. The attributes for each
feature are stored as a record in a dBASE table (.dat) associated with the Shapefile (.(map). There is one record in the
dBASE table for each feature in the map file. Raster TAB files cannot be imported in MAPublisher.

To ensure successful import, select the .tab component in the MAPublisher importers.

Microsoft Excel (*.xls)

Import and Export

Import geographic point data from an Excel spreadsheet (version 2007 and earlier only; *xIsx is not supported)
that contains latitude and longitude entries for each row. In order to import point data, click the Settings button in
the Import dialog box to choose which columns will be used to as the X and Y coordinates of the data, and ensure
correct georeferencing. Further settings including other types of are discussed in Appendix A1.

MicroStation Design (*.dgn)

Import and Export

MicroStation Design files (.dgn) are the native files created by Bentley Systems Inc. (and formerly Intergraph)
MicroStation product. Design Files consist of a header, followed by a series of elements. The header contains global
information including the transformation equation from design units to user coordinates, as well as the dimension
of the elements in the file. Each element contains standard display information, such as its colour, level, class, and
style, as well as a number of attributes specific to its element type. During the import process, MAPublisher will
produce one layer for each Level that exists in the MicroStation Design File. Annotation objects are converted to a
point containing attribute information including the text value to be labeled and its angle.

MAPublisher supports the import of MicroStation J (version 7 and 8) files, however attached raster file will not
be imported (ignored). Prior to import, the colour mode of the Adobe Illustrator document should be the same
scheme used in the colour table of the original file to ensure that the colours are interpreted correctly.

The hierarchy of layers in multi-feature imports is by feature type in the following order: text layers, then point
layers, then line layers, then area layers. Raster files attached to DGN files are ignored during the import process.
Files are exported from MAPublisher as MicroStation J files. Upon export, users may select a DGN seed file. All
information in the seed file gets carried over to the output file, such as level (layer) definitions, units, colors, line
styles definitions, etc. If an exported layer name matches a level name in the seed file, the data of that layer is
appended to the existing level, if not, a new level is created.
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Spatial Data Transfer Standard (SDTS) (*catd.ddf)

Import only

Digital cartographic products of the USGS are available in the Spatial Data Transfer Standard format, and are
generally distributed over the Internet as a means of promoting the standard. For SDTS import, select the catd file
(xxxxcatd.ddf), which is the index file that contains a description of the other files in the SDTS transfer. Individual
DDF files cannot be imported. Generally all SDTS downloads will contain the CATD file.

TIGER/Line (*.rt1, *.rt*, *.bw1)

Import only

TIGER is an abbreviation of Topologically Integrated Geographic Encoding and Reference System, and was developed
by the U.S. Census Bureau. TIGER/Line files are a digital database of geographic features, such as roads, railroads,
rivers, lakes, political boundaries, census statistical boundaries, etc., that cover the entire United States. The
database contains information about these features such as their location in latitude and longitude, the name, the
type of feature, address ranges for most streets, the geographic relationship to other features, and other related
information. TIGER/Line files are the public product created from the Census Bureau TIGER database of geographic
formation. TIGER was developed in order to support the mapping and related geographic activities required by the
census and sample survey programs. More information on the TIGER/Line file format and data product can be found
on the US Census web page at: http://www.census.gov/geo/www/tiger/

MAPublisher considers the .rt1 or .bw1 file as the TIGER dataset. Even though each county will consist of a series
of files with a common base name, there may be a number of different extensions. Remember to select the .rt1 or
.bw1 file when importing TIGER data.

Web Feature Service

Import only

Web Feature Service is an interface standard designed by the Open Geospatial Consortium (OGC) for GIS vector
data transactions across the Web. The MAPublisher WFS import connects to servers that use versions 1.0.0 and 1.1.0
of the OGC standard. WFS servers provide GML files, which are read using the MAPublisher GML importer. The GML
importer supports the GML simple features 2.0+ profile.

As the WFS importer is read-only, WFS-T is not supported. See Web Feature Service in Chapter 3 "Importing Map
Data" for information on WFS parameters.

Web Map Service

Import only

Web Map Service is an interface standard designed by the Open Geospatial Consortium (OGC) for GIS raster data
transactions through http protocol. The MAPublisher WMS import connects to servers that use version 1.1.1 of the
OGC standard. WMS data formats include .png, .jpg, .tif, and GeoTIFF. See Web Map Service in Chapter 3 "Importing
Map Data" for information on WFS parameters.
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Basic Esri ArcSDE Server’

Import only

ArcSDE geodatabases are multi-user Esri spatial databases, that allow users to store, use, and manage their GIS

data in one of the following commercial database management systems (DBMS): IBM DB2, IBM Informix, Microsoft
SQL Server, or Oracle. They are available in three levels of flexibility: desktop, workgroup and enterprise. The Basic
Esri ArcSDE Server import option allows users who have a free Esri desktop application called ArcReader to import
feature classes from ArcSDE geodatabases, but with some limitations on the selection functions — see chapter 3 for
more information on spatial databases.

1 Basic Esri ArcSDE Servers are not supported on Mac due to limitations of the related Esri libraries.

Basic Personal Database Reader (*.mdb) (Mac supported)

Import only

The basic personal geodatabase reader can import basic feature class geometries and attributes on systems that
do not have an Esri license. This makes it possible, for the first time, to open .mdb on Mac systems. The basic reader
provides limited import capabilites supporting geometries and attributes not annotations or subtypes. Spatial
Filters can be specified and SQL queries are supported on PC only.

Esri ArcSDE Geodatabase’

Import only

ArcSDE geodatabases are multi-user Esri spatial databases, that allow users to store, use, and manage their GIS
data in one of the following commercial database management systems (DBMS): IBM DB2, IBM Informix, Microsoft
SQL Server, or Oracle. They are available in three levels of flexibility: desktop, workgroup and enterprise. The Esri
ArcSDE geodatabase import option allows users who have ArcGIS software and a valid license to import all ArcSDE
geodatabase types with advanced options for the selection — see chapter 3 for more information on spatial
databases.

1 Esri ArcSDE geodatabases are not supported on Mac due to limitations of the related Esri libraries.

Esri File Geodatabase’ (*.gdb)

Import only

A File geodatabase is a native Esri single-user spatial database. It is a collection of various types of GIS datasets held
in a file system folder. This is the recommended native data format for ArcGIS. Importing this format requires ArcGIS
software and a valid license — see chapter 3 for more information on spatial databases.

1 Esri File geodatabases are not supported on Mac due to limitations of the related Esri libraries.

Esri Personal Geodatabase (*.mdb)

Import only

A Personal geodatabase is a native Esri single-user spatial database. This is the original data format for ArcGIS
geodatabases stored and managed in Microsoft Access data files. Importing this format requires ArcGIS software
and a valid license — see chapter 3 for more information on spatial databases.

1 Esri Personal geodatabases are not supported on Mac due to limitations of the related Esri libraries.
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OTHER SUPPORTED FILES

MAPublisher also supports Adobe lllustrator (*.ai) files created by Cartographica, a third-party GIS software.
Cartographica users who wish to use files in MAPublisher must check the Indude data in export option during export.

lllustrator Export Options
[ | Label all line segments
(O] Polygon labels appear inside
O Polygon labels appear astride

™ Include data in export

MAPublisher reads Adobe lllustrator files exported by Cartographica and extracts the geospatial information to
convert it into layers and MAP Views—including projection, map scale and page position. However, there may be
limitations when working with these files and it is recommended that they be saved as Adobe Illustrator CS4/CS5
files (this is required before exporting to geospatial PDF).

DATA CONSIDERATIONS

When obtaining GIS data for use with MAPublisher, whether from an online source, commercial vendor,
government office or from a source within your organization, there are a number of important considerations to
keep in mind.

First and foremost, obtain data in one of the formats supported by the MAPublisher. In cases where the file format
native to a particular mapping application is not supported by MAPublisher, you can often request the data
provider to export a file in one of the supported formats.

When obtaining data you should acquire as much metadata about the files as possible. MAPublisher deals with
data in the following manner: Unprojected data will be imported by MAPublisher with latitude and longitude map
anchors, which will therefore range from (x) -180 to 180, (y) -90 to 90.

If you receive projected data you should be aware of the following. MAPublisher will import projected data
with a true scale and appropriate map anchors. Unlike unprojected data, these map anchors will not be in lat/
long, but rather in a coordinate system appropriate for the particular projection. For most file formats the name
of the projection, datum, and units will be recognized by MAPublisher. However if the program cannot find this
information in the data, and you wish to subsequently reproject your data, you will be required to specify the
coordinate system.

In addition, MAPublisher is a two dimensional mapping program. If you attempt to import 3D data with
MAPublisher it will be converted to two dimensional artwork by the importers. Data provided in a generic latitude
and longitude (unprojected) coordinate system will usually be recognized as a WGS 84 (World Geodetic System
1984 - EPSG = 4326) coordinate system by the MAPublisher importers.
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Importing
Map Data

The Import functions are the starting point for most users
wanting to work with GIS map data in Adobe lllustrator. These
functions are used to import GIS data, set the initial map scale
and define your cartographic workspace to start making maps.

The topics covered in this section:

Simple Import

Advanced Import

Web Feature/Map Service

Spatial Databases

Geospatial PDF Import

MAPublisher FME Auto and FME FFS Import

See chapter 2 for detailed descriptions of formats that
MAPublisher can import.
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Format - Select the data type you
wish to import. This drop-down list
shows the names of all MAPublisher
supported data types.

Dataset - Displays the directory

Simple Import

File > Import Map Data > Simple and MAP Toolbar E

Simple Import

[ [ Settings-Opens a Settings dialog box

—L—<Format: [&n Shapefile [*.shp]

path and filename for the currently
selected file(s). You can also
manually type in the dataset
location here.

Source Coordinate System - Provides

Dataset:  APublisher 8VTutorial Guide & Data\Tutorial Data'\canada. shp Browse... Cancel

if the file format requires the input
of extra parameters, such as for the
import of DGN, DXF, DWG, E00, GML,

Encoding: [Unlmda, 8-bit (UTF-8)

=

KML, MIF/MID, Tab and Delimited

»

a description of the coordinate
system and units detected in the
data source. If the coordinate system
of the selected file(s) is known, but

it was not automatically detected

by the program, click here. This will
open the Specify Source Coordinate
System dialog box (below).

RELATED TOOLS

Source Coordinate System:

NAD27 @ @ From File... [o
[ sameas: | @ canada -
?

Text Data (see facing page).

Browse - Opens a Data Source
browser to enable the selection of

files for import.

Encoding - Assign a codec if the

attribute information held in the

Same as - Check this option in
order to assign a coordinate
system that matches that of an

Clear - Clear the
existing source

View Coordinate System
Information - View more
information about the

existing MAP View. Enabled when current coordinate system

another MAP View is present.

Specify Source Coordinate System
Accessed by clicking the source coordinate system link.

coordinate system.

selected dataset uses a double byte
character set.

From File - Choose a coordinate
system from another file

) ity Sosrce Coordnate System
fr— -
Custom Doty C'ProgramDetsiverss MAPUDISher Blantomayytems wm
Folder =||@ & Depleysame [ Bansati *
. ok byt £\ NSIDC [ASE-Gd Global MSIOC [ASE-Grd Globd Usgaer
Coordinate Systems - Choose a ———=  aes Nobinssn Nobiason woih
category appropriate to the o i ——— —
data to be imported. To view s Van e inten i Giiten wisse
. Eurepe £ WG5S B/ NSIDC EASE-Gead Global WGE BA / NSIDC EASE-Gridl Global
all of the coordinate systems cample Sysseme-NET FER LS & WG58/ POC Marcatar WG B4/ PEC Lrcater Wb
* | % i North Amencs. B weise WO WS
select *All*. F.or alistof the G & 4/ Worid Lquickstast Cybndnesl WIS B4 / Worid Lqudstant Cybrdnesl e
last 10 coordinate systems ctner S— WGSBA / Wodd M eton wassi |
Cudeted {Dey o) 1 kel | WGSBS
used, select *Recent*. b i B i hciighd e
uin £ Wkek T, sl Mk Gonpm Wikl Tripa, sl Mpsidin Gopemich. WS84
Ward &\ Woeld Iuadbetant Cybndrical (Spherel  Wossd Equidessnt Cybndricsl (Sphers) Unsgact =
Search - Specify a text string = .
to search the database +l 8 i @ 3
for coordinate systems.
Results are displayed in the s
*Search* category. Lo ree  flame

)

Coordinate System -This
area shows information about the
coordinate systems. (i.e. Name,
Type, Envelope, EPSG Code). To
choose a known source coordinate
system select it from this list.

Search - Click this button and your
search results will be populated

Dataset Coordinate Systems
Automatically opens if multiple datasets have been selected and they do not have a matching coordinate system.

Dataset Coordinate Systems

Dataset - List of all the datasets

‘fou cannot select multiple datasets with different coordinate
systems. Below you will find a list of your selected datasets and

their associated coordinate system.

selected for import

Coordinate System - List the coordinate

Dataset Coordinate System

canada.shp MAD27
ukpolyshp WG5 84

system of each individual dataset
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Matching MAP View

Automatically opens if there is already a coordinate system in your document which matches the incoming data.

Matching MAP View Found

-

Add to - Add the incoming data file to a
matching MAP View

Fit to page based on new MAP View - Create a
new MAP View for the imported data.

Existing data and incoming data will be
treated separately in terms of page scaling

and position

Yfour data matches one or more MAP Views found in the
document. Please select a destination MAP View.

Destination MAP View:

Cancel

MAP View list - Select the matching coordinate
system that you wish to align the incoming
data to.

© Addto: [ @ worldeast

1

[F] Resize MAP View to fit

() Fit to page based on new MAP View

Resize MAP View to fit - Check this box to scale the
matching data so that both the selected layer and
the incoming data fit inside the page extents.

IMPORT SETTINGS

AutoCAD Drawing/Exchange Settings

Settings

Read Hatches - Check this box to read —e [#] Read hatches
the hatch pattern on import

Group Entities - Group entities by layer Group Entities:
name or geometry By layer
By geometry

White Lines and Fills - Set the option: —e white Lines and Fills:
« Importas is:import the data
true to the original colour
settings contained in the file.
Change white lines and fills

Impartasis

Change white lines and fills to black
*) Create black background

to black: import black lines
instead of the files native
white lines.

Create black background:
incorporate a layer containing
a black background, to mimic
the AutoCAD environment.

Geography Markup Language Settings

Latitude/Longitude or X/Y Columns
These two drop-down lists hold
the names of all the numeric
columns in the selected file.
Select the columns containing
the coordinate information.

Use first line as a header - Check this
box if the first line of the text file
contains column headings.

Specify Schema - Specify the data

schema type for attributes in the
delimited text data set

Delimited Text Data Settings

Coordinate Format - Select the coordinate format of the data to be
imported (e.g. Decimal Degrees, Packed DMS... see chapter 6).

Settings

e Coordinate Format:
[Decimal degrees D +L.d7)

-

Format:

Decimal degrees, with optional direction indicator,
Examples:
7.5444W, 549777 | 79,44

Notation: items in [] are optional, " means zero or more digits and '+ means
one or more digits. Direction can be indicated with ', 'N', or W'

Coordinate Columns:

ngitude: (Longitude: 123, 127416

=)
=)

titude: [ Latitude: 48,289093

|

#[7] Use first line as a header (detected)

Specify Schema:
o 3
b

Web Feature Service Settings

Settings i

X-Y Coordinate Ordering —e x-v Coordinate trdering: = XY Coordi dering ¥ - =

Change the order of @ Reverse ¥ ¥ coneeh for geedese ceerdnates fdefouit hehainus) Change the order of @ Default behaviour Revesse Xt coords for peoderic conrdnate sytema

XandY coordinates. Reverse Xt coordnates [ conae X and Y coordinates. for WES 1.0, do not reverse for WFS 1L0.0  caxel
This may help Do rast reverae K ¥ conmiintes This may help Reverse X coordnaltes

when an external
program exports X-Y
coordinates in reverse.

it

s

Caoy your Fequently ured XS0 fies to GMLSChema folder
MaFublshar rngtallabon o svosd having B lsan Bham usth pour GM

n

program exports X-Y
coordinates in reverse.

when an external D PV Y Clordnas
Hink:

Copr rour Fequently ured O fes o GMESchema fistler in MaPudisher
= e oM fes
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Esri Interchange File Settings

Maplinfo TAB and MIF Settings

Settings

Settings

Ignore TIC Layer - Enable

to suppress creating of
_tic_point layer. Disable to
create a layer holding the

Pen and Brush Patterns
Enable this box to
view the pen and

[7] Import pens and brush patterns as visible attributes

Cancel

brush pattern values

in the imported

registration control points.

'
'
'
'
'
'
!
'
[7] 1gnore TIC layer - '
'
'
'
'
'
'
'
'
'

attribute table.

Basic Esri ArcSDE Server, Esri ArcSDE Geodatabase,
Esri File Geodatabase and Esri Personal Geodatabase

Settings

Prepend feature dataset name to layer name
Select this option to prepend feature
dataset names to layer names.

Unicode database - Unless specific issues
importing converted geodatabases,
keep this option as default.

[T] Prepend feature dataset name to layer name
lle @ Unicode database
Cancel

() Use locale to decode:

Locale:

If no value is entered, the locale of the current
machine will be used.

Use locale to decode - This option might be
required if the geodatabase was created by
converting a file in a format not supporting
unicode (e.g. Esri shapefile) and if it contains
non-ASCll characters.

Locale - Specify the locale name (e.g. en-US),
leave it as 0 to use the locale of the current
machine.

Note:  These are advanced settings. Contact Avenza Technical Support (support@avenza.com) for assistance.
Google Earth Settings MicroStation Design Settings
Setings Complex Chains - Component Settings
— of a complex chain returned
Allow random colour mode 31 Ahow saedom ok mode. o as its own feature. Otherwise —— - [] Drop complex chains

Enable this option to
generate random colour
settings for the data

Expand network links
Enable this option to
use of network linked
KML files

Automatically apply Symbols
when possible

Enable to use Symbols
from Google Earth

¥| Expand network inks
| Impaort KML properties as visbie attrbutes e—
7] ustomaticaly spply Symbels when possitie

Import KML properties as visible attributes - Enable
this option to import KML-specific attributes
into the MAP Attributes panel as visible
entities. When this option is disabled, these
KML attributes are imported but are hidden
in the MAP Attributes panel

The KML attributes are Description and
Address which are displayed in the MAP
Attributes panel as km/Description (object

description) and kmlAddress (object address).

Image Settings

Settings

Image placement
Embed the image
into the document
or Link to it. Please
see note about

Image placement: @ Embed (0 Link
Embedding TIFF image that contains transparency
may cause referending and exportissues. Choose
“Flatten Layers to a Single Image™ when the TIFF
Tmport Options appear.

transparency.
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all elements of the complex
chain will be merged into a
single linear feature.

e[| Create groups for like text

o] Ignare tags on import

Create groups for like text

Text in the same graphic
group or the same text node
will be grouped in lllustrator

Ignore tags on import - Ignores
any tags on import so that it
does not affect spatial extent.

Group Elements - Choose how —
to group the elements. If
elements are grouped by
level, it may result in a large
number of output files.

(e Coordinate Units:

Coordinate Units - Specifies how —
feature coordinates will be
interpreted and converted.

Group
@ By level

@ By geometry

© Master

) UOR

White Lines and Fills:

) Importasis

@ Change white lines and fils to black
() Create black background

L4

White Lines and Fills - Set the option:

« Import as is: import the data true to the original
colour settings contained in the file.

« Change white lines and fills to black: import black
lines instead of the files native white lines.

« Create black background:. incorporate a layer
containing a black background, to mimic the
Microstation environment.



SIMPLE IMPORT FUNCTIONALITY

The Simple Import function provides a fast, uncomplicated method of importing map data into Adobe Illustrator. Its
purpose is to import a single piece of map data or several files sharing the same format and coordinate system.

PREREQUISITES

Use Simple Import either before or after an Adobe lllustrator document is created. If no document is open, Simple
Import will initiate the New Document dialog box.

MAPublisher will interpret the artboard dimensions during the import process, and calculate a map scale for the
document accordingly. If the document size is changed in the Adobe Illustrator document settings, the scale will
have to be recalculated using the MAP View Editor (see chapter 4 for more information). Remember, a map of the
world would fit well into a page with a landscape orientation, whereas a map of South America would fit best into a
page with a Portrait orientation.

Some import options are specified in the MAPublisher Preferences Import MAP Data category, such as attribute order, layer
naming convention or display of extents in the import dialogs. For a full description, please refer to chapter 1 on
MAPublisher Preferences.

USING SIMPLE IMPORT

The MAPublisher Simple Import function is accessed from the Adobe lllustrator menu File > Import Map Data >
Simple Import or from the MAPublisher toolbar button E .

Overview

The dialog box itself is split into two sections. The upper section provides options to choose a file format, select
the dataset to import, and choose any additional settings that may be required. The lower section displays the
coordinate system of the selected file (if available) and provides an option to specify one manually.

Adding Files

First specify the format of the file to be imported. Set the Format drop-down list as <Auto detect format> or to a
specific format. With the <Auto detect format> option, all supported GIS files will be displayed in the browser.
Choosing the required format directly is recommended to ease navigation.

Once a format has been selected, click the Browse button to select the file(s) to be imported and then click Open.
Alternatively type in the full path of the file(s) in the Dataset text box. Only files in a same format and sharing the
same coordinate system can be imported at once with the MAPublisher Simple Import dialog box.

Notes: The import of multiple Delimited Text files is not supported.
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Source Coordinate System

Once the Dataset text box has been populated with a valid path, MAPublisher will read the file(s) to determine if a
valid coordinate system can be found and will display it in the Source Coordinate System section.

If the program returns the message [No Coordinate System Specified] for the coordinate system, click the hyperlink
to specify it. In the Specify Source Coordinate System dialog box, coordinate systems are separated into categories
(geodetic or projected) to ease the process of choosing a coordinate system: under the Coordinate System category
*All* will list all the coordinate systems in the database. For an overview of Geodetic and Projected systems and
Datums see appendix A2.To view the parameters of a certain coordinate system, click the Info button.

Character Encoding

Extended and international character sets are supported as attributes on import. To assign a character codec
suitable for your selected dataset, choose the appropriate value from the list box.

Format Specific Settings

Certain file formats offer additional configuration parameters which can be accessed by clicking the Settings
button. These file formats are listed in the Import Settings section above. After selecting a file, if the format accepts
additional settings, the Settings button will be enabled.

*Additional Settings are mandatory only for importing Delimited Text Data.

Delimited Text Data Settings

MAPublisher also allows for the import of delimited text files as point data provided they contain coordinate values.
MAPublisher supports the following delimiters between data values: comma, return, end-of-line and tab.

To import delimited text data, first specify the Format: Projected Units, Decimal Degrees, Delimited Degrees Minutes
Seconds, Degrees.Minutes, Degrees.MinutesSeconds, Packed DMS with decimals and Packed DMS (see chapter 6, for
more details). In the Coordinate Columns, specify the fields in the source file that contains the coordinate information.
The caption of the fields display Longitude and Latitude or X and Y, depending on the selected format. If the first line
of the text file contains column headings, check the Use first line as a header option (MIAPublisher generally detects it
automatically). If the file does not appear to contain column headers, MAPublisher will assign the default headers
Column1, Column2 to the attribute columns on import. Assign data schema types to attribute columns in the Select
Schema frame.

Importing Data

Once the files are selected and settings specified, click OK to start the import process. If the Adobe Illustrator
document contains a MAP View with a coordinate system matching the incoming data, the Matching MAP View dialog
box will open with the following options:

«  Addto: choose the MAP View from the drop-down list in which to add the incoming data. Check the option Resize
MAP View to fit to scale all the data (existing and incoming) to fit on the artboard. If this option is not checked, the
imported data may fall outside the page extents

«  Fitto page based on new MAP View: the incoming data will be treated separately from the matching data, as if it was
the firstimport. The incoming data will overlap with the existing data, use the MAP View Editor to scale and
move the data on the page (see chapter 4 on MAP Views).
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RESULTS

The data is imported as individual Adobe Illustrator layers with appropriate feature type matching the original
source data type. Layers are named based on the file name or on the layer name in the source file. By default,

the appropriate feature type extension is appended (e.g. name_area), and a layer name is already present in the
document, it appends a number (e.g. name_area 1) — but this may be disabled in the MAPublisher Preferences,
Import MAP Data property sheet. The layers are automatically placed as sub-features of a MAP View (existing or new)
that contains the geospatial, scaling and positioning information.

Notes: When importing data exceeding the allowable 32,000 points per path in Adobe lllustrator, MAPublisher
automatically simplifies the imported object and shows a warning message.

The simplification algorithm compares points in a line or polygon in groups of three. When the shortest
segment is found, the center point is removed, and the total segment distances are recalculated. This
removal process continues until the maximum allowable number of points is reached.
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File List - This is a table ——
where all files selected for
import are listed

Destination MAP View

New based on - Imports all
of the files to one of the
coordinate systems in the
File List

Use existing - Allows users —
to import all of the files in

Advanced Import

File > Import Map Data > Advanced and MAP Toolbar ﬁ]

Coordinate System - coordinate

Advanced Imgort

system of the data source

Data Source - Map file(s) to be
imported (full path or just

file name depending on
MAPublisher Preferences - see
chapter 1).

Destination MAP View:

® @ New based on:

a coordinate system that
already exists in a MAP View
in the document

Autoscale - If multiple files are
present in the File List, and
New Based On or Use Existing
is selected, check this box to
ensure the imported artwork
fits inside the page extents

RELATED TOOLS

Advanced Import - Add

TT® (0) Use existing: @ Boundary
] Auto scale
(y) Create new: Editor...

!
Coordinate System  DataSource  Featurese——7M
— |T|WGSS4 world.mif 220
2 Robinson worldeast.shp 164
3 NADZ7 usa.tab 51
Add... ] [ Remaove ] [ Edit... }=

Coordinate system: WGS 84

Page anchors: {0 px, 722 px)

Visual scale: 1: 185627600, 165401
Map anchors: {-180,0000, -20,0000)
Map unit: Degree

Map angle: 0

Features - Number of objects to
be imported

(ifenabled in Import MAP Data
MAPublisher Preferences).
Extents - Displays the lower
left (LL) and upper right

(UR) coordinates (XY) of the
dataset extents.

Add - Allows the selection of
files for import by opening the
Advanced Import Data
Source function (see below).

Remove - Removes selected
files from the list

Edit - Allows editing of the

Create new - Allows users to import all
of the files in a new coordinate system.
Click the Editor button to open the MAP

View Editor (see chapter 4).

Accessed via the Add or Edit button in Advanced Import.

Format - Select the data type you
wish to import. This drop-down list
shows the names of all MAPublisher
supported data types.

Dataset - Displays the directory
path and filename for the currently
selected file(s). You can also
manually type in the dataset
location here.

Source Coordinate System - Provides

a description of the coordinate
system and units detected in the
data source. If the coordinate system
of the selected file(s) is known, but

it was not automatically detected

by the program, click here. This will
open the Specify Source Coordinate
System dialog box (below).

Import Settings

1

Details - Displays details of currently
selected file: coordinate system, page
anchors, visual scale, map anchors,
map unit, and map angle.

Add

Format: | Esri Shapefile [*.shp]

l
- ] Settings...

Dataset: ner 8\Tutorial Guide & Data'Tutorial Data\southchinasea. shp Browse... Cancel

Encoding: [Ummde, 8-bit (UTF-8)

b

»

Source Coordinate System:
WGS 84
D Same as: @ torontopaints

1

From File... s

l

Same as - Check this option in
order to assign a coordinate
system that matches that of an
existing MAP View. Enabled when
another MAP View is present.

Clear - Clear the
existing source

View Coordinate System
Information - View more
information about the
current coordinate system

See the Simple Import various Import Settings dialog boxes and options.
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coordinate system.

selected file by re-opening
the Simple Import Data
Source function (see below)

Settings - Opens a Settings dialog box
if the file format requires the input
of extra parameters, such as for the
import of DGN, DXF, DWG, E00, GML,
KML, MIF/MID, Tab and Delimited
Text Data (see facing page).

Browse - Opens a Data Source
browser to enable the selection of
files for import.

Encoding - Assign a codec if the
attribute information held in the
selected dataset uses a double byte
character set.

From File - Choose a coordinate
system from another file



ADVANCED IMPORT FUNCTIONALITY

Advanced Import provides an alternative method of importing map data into Adobe lllustrator. This function can
import files in multiple formats and coordinate systems. All files flagged for import are displayed in the dialog
box with information relative to their coordinate system. All imported files are reprojected to match a selected
coordinate system.

Note: Advanced Import is recommended when importing data that will require a coordinate system
transformation that implies redrawing and path divisions (e.g. world data reprojected from European to
North American aspect). Applying a coordinate system transformation during Advanced Import allows
MAPublisher to split paths during transformation, which is not possible at a later stage. Divided paths are
grouped as compound paths.

PREREQUISITES

Use Advanced Import either before or after an Adobe Illustrator document is created. If no document is open,
Advanced Import will initiate the New Document dialog box. Please refer to the Simple Import Prerequisites section
in this chapter.

USING ADVANCED IMPORT

Access MAPublisher Advanced Import from the Adobe lllustrator menu File > Import MAP Data > Advanced Import or
by clicking the MAPublisher Toolbar button [5] .

Dialog Box Overview

The top part of the Advanced Import dialog box provides a list of the selected files, their coordinate system
information and the number of features they contain. The bottom part of the dialog box refers to the Destination
MAP View settings.

The Add and Edit buttons open a dialog box similar to the Simple Import dialog box. Please refer to the previous

section for information on the Character Encoding, Format Specific Settings and Delimited Text Data Settings.

Note: The dialog box displays the file name or the full path of the selected files depending on the settings specified
in the MAPublisher Preferences for Import MAP Data (see chapter 1). Users can also choose to display the
geographical extents of the file.

Adding Files

Click the Add button to select one or more files that share the same format and coordinate system. The Add dialog
box is similar to the Simple Import dialog box, please refer to previous section for more information. Browse for
data, then click OK to add the files to the Advanced Import list.

To import more files in a different format or coordinate system, use the Add dialog box again, as often as necessary.
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Advanced Import File List

All selected datasets are listed in the Advanced Import dialog box. Listed features include the filename, the specified
coordinate system and the number of features contained in the dataset.

Click a row in the file list to select a dataset. Then, click Remove to remove the dataset or click Edit to change the
import parameters. The Edit dialog box provides the same options as the Add dialog box where users can modify
the access path, settings or source coordinate system.

Note: Itis not possible to import multiple files with a mix of unknown and known coordinate systems. Therefore
the unknown coordinate systems will need to be specified before import.

Destination MAP view

Although the Advanced Import allows users to import files with multiple source coordinate systems, they have to
be imported into a single coordinate system. This information is stored in the Destination MAP View section (for more
information on MAP Views, please refer to chapter 4).

Users have three options to select the coordinate system of the Destination MAP View.

« New based on option: choose the coordinate system of one of the files selected for import.
«  Use existing option: if the Adobe lllustrator document already contains map data, choose the MAP View with the
desired coordinate system from the list of existing MAP Views in the document

With these two options, check the option Resize MAP View to fit to scale all the data (existing and incoming) to fit on
the artboard. If this option is not checked, the imported data may fall outside the page extents

«  (Create new option: specify the parameter for a new MAP View. Click the Editor button to open the MAP View Editor.
In the Destination Source Coordinate system section, click the Specify button to select a coordinate system from a
large list of existing system or to create a custom one. The MAP View Editor is explained in depth in chapter 4, in
brief it allows for the edition of the scale, the position of the data on the page and rotation.

RESULTS

Once the files have been selected for import and properly set up, click OK to start the import process.

The data is imported as individual Adobe Illustrator layers with appropriate feature type matching the original
source data type. Layers are named based on the file name or on the layer name in the source file. By default,

the appropriate feature type extension is appended (e.g. name_area), and a layer name is already present in the
document, it appends a number (e.g. name_area 1) — but this may be disabled in the MAPublisher Preferences,
Import MAP Data property sheet. The layers are automatically placed as sub-features of a MAP View (existing or new)
that contains the geospatial, scaling and positioning information.
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Web Feature/Map Service

Simple or Advanced Import (Format drop-down list)

WEB FEATURE SERVICE

Import vector data using the Web Feature Service (WFS). It accesses web servers that deliver vector content in GML
format. To access WFS settings, choose Web Feature Service in the Format drop-down list of the Simple or Advanced
Import dialog box and click the Settings button.

To manage servers used in the WFS, click Browse. The Browse Web Feature Service dialog box maintains a list of
loaded map services. To add a new service click the Add button, then add the service URL and version number. This
list can also be populated with a number of services aggregated by Avenza. To do so, click the Load Services From
Avenza button. To remove a service, select one, then click the Remove button.

Brovise Web Feature Service
Neme Connestion URL Version
Saved Services ——e| NSDI Framework hittp://frameworkuds.usgs.gov/fr .cgi?DATASTORE=Fra... 1.0.0
WFS title and map service USGS NSDI Geonames WFS. B usgs.g 2 110
abstract CubeWerx WFS hitp://demo.cubewerc.com/demofcubeserv/cubeserv.cgitdatastore=Fo... 1.00
Intergraph DC Metro hittp://regis.intergraph.com/wfs/demetro/ request.asp
Add/Remove WES Uo:u:N o cﬁp:;jwwwb ‘wealher‘g::vff:;;ecast;/xr;l/tof";_ ;El;;‘\ces/ndfdowiservenphp 1;3
) nited Nations Data pi//webservices ionicsoft.com/unData 0
Add a WFS by entering a unnamed itps//www bsc-soc.org/cgi-bin/bsc_ows.aspiversion=L0.0&ampiservic.. 100 Load Services from Avenza
name for the service and world data hitp://webservices ionicsoft.com/worldDatafwfs/WORLD?SERVICE=WFS ~ 1.0.0 Loads an updated list of
the connection URL. WMS Web Featu?e Services
import supports only — =[G Web Feature Services
version 1.1.1. .

In the Select Features dialog box, choose map features in the layer tree to import them. The layer abstract at the
bottom of the dialog box displays a descriptive field about the selected layer and its bounding box coordinates.
Click the Specify Spatial Filter to specify four exact coordinates to limit the area being imported. See Import Personal
and File Geodatabases for more information. Optionally, check the Save file to directory option and browse to a
location to save it locally (not required to use the feature).

Select Features
Title Tte:Intrgraph WFS
The title of the current WFS —_
A CensusTracts
[ CongressionalDistricts
Layer Tree 1! Counties
Structured list of available Hespitals
layers. May or may not show I Interstates
geometry (Area, Point, Layer) I MetroLines
type depending on server I.']; :‘Et"’sm'u"‘
X aces
settings P! Schools
Specify Spatial Filter
Define a bounding box
Save file to directory [7] save file to directory: Browse. .. to limit imported
Check this and browse to a features
location to save the selected
map features. SRS: EPSG:4325 ol
Layer Abstract Bounding Box: (-79.487651,36.989592) (-75.043342,39.722997) \E \
A descriptive field including <
layer metadata
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WEB MAP SERVICE

Import raster data with the Web Map Service (WMS). It accesses web servers that deliver raster content in a variety
of formats. There are no format specific settings associated with this importer. To access WMS, choose Web Feature
Service in the Format drop-down list in the Simple or Advanced dialog box.

To manage web servers used in the WMS, click Browse. The Browse Web Map Service dialog box maintains a list of
loaded services. This list can be populated with a number of services aggregated by Avenza. To add a new service
click the Add button, then add the service URL. MAPublisher WMS importer only supports WMS version 1.1.1.

Browse Weh Map Senvier
. Hamr Connection UL vemon =] ]
Saved Services - - r
. L e WASAPL hittp:/fwrms jpLnsa.gov/wims.cgi 111 E [
WMS title and map service Aiss of Canads P/ atlas. ge ca/cgi-iryatl nERSION: 111 111 -
abstract & P & ! & jas |
unrssmed p 2 icg < gmap 111
urinamed 1 B Lnrvede/ ot 11 = Load Services from Avenza -
b i v i
Add/Remove WMS - i & ‘I;\(I)asinan uspdaFed Iflst of
Add a WMS by entering a —| Avena| eA ap >ervices from
name for the service and the an Avenza server.
connection URL.
Format
Select Web Map Layer Available output formats
Server Info Info: Title: CubeSERV WMS. Farmat: [Gff - oK Style - Choose from
WMS title and map service Layers: Stle: rendering styles available
4 CubeWerx »| [cubewerx -] for the selected layer
4 Foundation
4 Boundories Coordinate System:
Barrier Line Features wes 84 Epse:4326) =) Coordinate System
Boundaries C Text L i
. Layer Tree oundories boverage 3 Additional Server Parameters: ChOOSE fl'om aVaIlabIe
Structured list of layers Coastlines Spatial Reference Systems
available in the current WMS ge"t“fg"““
ceans/Seas
s K e — Additional Server Parameters
Political Boundaries Nurber OFxPixds: |52 = Additional parameters as
Political Boundary Point Features outlined in WMS abstract
> Data Quality Number of Y Pixels: 246
> Digital Terrain Set Badk .
- h - Toggle backgroun
Image Placement: @ Embed ) Link transparency on import
Expand/Collapse Layer ltems —o P y P
Expand or collapse items in Description: [ =iy e Number of X Pixels
the layer tree Abstract: VRF Narrative Table for "Administrative Areas™ B Input number of X pixels to
[} . . )
Description ——e <P>Orly international admistrative areas have been captured, The isting LlEETEECE change outputimage size.
i = PR N
An abStraCt Of the layer that country names for the "na2” attribute is incomplete and contains errors in - World file (1) = Image s TESIZed proportlonally.
may include metadata : . -
Y - Show Preview Specify Spatial Filter - Import
definitions N
data based on a specified
(-180.00,83.63) 360.00 deg — N N
geographic bounding box.
Preview !
Toggle thumbnail preview 173,63 deg Set output directory for
of WMS image. Spatial image - Check to enable
extents displayed around it. 1 and browse to a location
(180.00,-90,00) to save the image.
Optionally, check Write
reference file to include a
Image Placement reference file with the
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Choose to have the image embedded
or linked in the document.
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Spatial Databases

A geodatabase is a native Esri ArcGIS data format for storing geographic data. It is a collection of geographic
datasets of various types and managed in either a file folder structure or a relational database, such as:

- Feature classes of points, lines, polygons and annotation for discrete features
- Feature datasets (group of feature classes)

«  Descriptive attributes stored in tables
«  Raster datasets and raster catalogs for imagery

MAPublisher can import several types of Esri geodatabases:

File User Size RDBMS Esri Licensing MAPublisher
extension  access limit Technology (create)* Import access
Microsoft Access Arcinfo
Personal geodatabase .mdb Single 2GB ’ ArcEditor Folder browser
(Jet Engine) )
ArcView
Arcinfo
File geodatabase .gdb Single 1T8B No RDBMS - uses ArcEditor Folder browser
local file structure X
ArcView
ArcSDE Desktop Multiple SQL Server ArcGIS Engine ArcSDE server
geodatabase ) (limited) 4GB Express Arcinfo connection
(called Personal in 9.2) P ArcEditor
ArcSDE Workgroup Multiple SQL Server ArcGlIS Server ArcSDE server
- L 4GB -
geodatabase (limited) Express Workgroup connection
DB2
ArcSDE Enterprise Multiple Depends Informix ArcGlIS Server ArcSDE server
eodatabase ) (unlimited) on the Oracle Enterprise connection
9 server PostgreSQL P
SQL server

*For all geodatabases, an ArcEngine license is the minimum requirement for direct read of vector and raster data.

MAPublisher has the capacity to import all types of geodatabases (categorized as Personal, File and ArcSDE
geodatabases). The connection to an ArcSDE server requires server access, user account and versioning information
to be provided by the database administrator. These parameters are exactly the same required to establish a

connection using Esri ArcCatalog — with a small exception for SQL Server Express connections, explained later on

in this chapter.

Once imported into Adobe lllustrator, data does not maintain a link with the original database and database
functions are not valid (topology, table/feature class relationships, subtypes and attributes domains rules). However,
MAPublisher can make use of the geodatabases spatial and non-spatial relationships, subtypes and attribute
domains information during the import process (to populate layer names and attributes).

The following sections include how to:

Import Personal and File Geodatabases
Import Using Basic Personal Geodatabase Reader (Mac supported)
Import Esri ArcSDE Geodatabases
Import from Basic Esri ArcSDE server
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SOFTWARE REQUIREMENTS

The MAPublisher Basic Personal Geodatabase Reader does require any ArcGlIS licenses for Mac and Windows.
However, this means that some import functions are limited in use (explained further in this chapter).

To be able to fully import Esri geodatabases or to fully access an ArcSDE server using MAPublisher Simple and
Advanced Import, a valid Esri software must be installed and licensed—at minimum, ArcGIS Engine Runtime. More
commonly, higher licenses that may be used are ArcView, ArcEditor and ArcInfo.

Direct access to feature classes on an ArcSDE Server only requires ArcReader, available for free. However, File and
Personal geodatabases cannot be read using ArcReader. With this license configuration, access to files with a Basic
Esri ArcSDE Server connection is limited compared to a Esri ArcSDE Geodatabase connections (explained further in
this chapter). MAPublisher supports all ArcSDE server connections and SQL queries supported by Esri.

If ArcReader is not installed on the default installation directory, it might be necessary to edit the binary
location in the MAPublisher Preferences, Basic Esri ArcSDE Server Editor (see chapter 1).

MAPublisher supports geodatabases from versions ArcGIS 9.2 and higher. However, there are some
limitations to the direct connections from 9.2 clients to the ArcSDE 9.3 geodatabases. Please refer to Esri
documentation on software requirements (service packs) and limitations.

To access geodatabases created by ArcGIS 10 in MAPublisher, an installation of ArcGIS 10 is required. Having
a valid installation allows for backwards compatibility with geodatabases created by ArcGIS 9.2 and higher.

SUPPORTED FEATURES

Data Types

The following is a list of supported and unsupported geodatabase geometry types for import in MAPublisher:

Supported Unsupported

* Upon import, MAPublisher Point Raster
converts an arc to a line Polyline Grids
where a series of vertices Polygon MultiPatch
will maintain the geometry. Circular Arc* Dimensions
Elliptical Arc*

Bezier Curve
Annotations

Note: To import a geometry type that requires the use of a Representation in ArcGIS (such as Bezier curves), the
Behavior when Representation Geometry is Edited must be set to Change the geometry of the supporting
feature—option specified when creating a new Representation in ArcGIS.

62 | Chapter 3: Importing Map Data
Spatial Databases



Aliases

ArcGlIS users can give the feature classes an alias that acts as an alternate name. Unlike feature class names, aliases

can contain spaces, punctuations, and start with a number. In ArcMap, feature classes are referred to with their alias
name. In ArcCatalog, feature classes are represented by their true names.

Specify to use aliases for layer names in the MAPublisher Preferences for Spatial Database > Esri Geodatabase Editor:

MAPublisher Preferences

o Expression Builder
= FME Auto
> L General
> [ Import Map Data
4 MAP Attributes
[# MaP Crop Tl
[l MAP Info Panel
T MAP LabelPro
» % MAP Locations
@ MAP Measurement
> 5 MAP Selections
> T MAP Themes
@ MAP Views
(@ Online Maps
4 [ Spatial Database
[ Basic Esri ArcSDE Server Editor
7] Esri Geodatabase Editor
[] General Spatial Database Editor

Reset ‘Do not show again’ preferences

Spatial Database > Esri Geodatabase Editor

Use alias as layer name

[ Use abbreviated table name for layer name

Display coded domain/subtype description: Instead v]

[7] Load subtypes as separate layers

[] Sort feature datasets alphabetically when selecting for import
[] Sort feature dasses alphabetically when selecting for import
[ sort attributes alphabetically when selecting for import

[ Automatically connect to: | Avenza ArcSDE Connection

Number of points to use to specify a spatial fiter bounding bax: Twa (opposite comers) -

!

Note: Aliases for attribute field names are imported as Display Name and true field names as Name of MAP

Attributes columns.

Subtypes and Attribute domains

Subtypes are particular attribute fields made to create groups of records in a feature class that share the same types

of properties. The attribute fields designated as subtype fields contain numerical coded values and have a data type

of short or long integer. Each coded value is associated with a description (textual). In the MAPublisher Preferences
for Spatial Database > Esri Geodatabase Editor, users may choose to load subtypes as separate layers.

Attribute domains are used to constrain the values allowed in any particular attribute of a feature class (or subtypes).

There are two types of attribute domain:

«  Arange domain limits the value of a numerical attribute in between minimum and maximum values —
range domains are not relevant to MAPublisher.
« A coded value domain specifies a valid set of coded values for an attribute (of any type — text, numeric

or date). Both coded values and their meaningful description are stored in the database.

In the MAPublisher Preferences for Spatial Database > Esri Geodatabase Editor, users can set the option to import

attributes with coded values from subtypes and attribute domains as follow:

«  Instead: replace the codes by their description (text)
«  Never:import the actual values (code)

«  InAddition: create two attribute columns, one containing the coded values and one containing the

corresponding descriptions.
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Spatial Filters

During the import process, users can enter two opposite corner coordinate points in any coordinates system unit to
limit the geographic area for the data being imported (see next section).

Note: When importing a feature class that has no art it is considered to have invalid extents and a spatial filter
cannot be created.

SQL Queries

During the import process, users can use SQL queries on feature classes and tables to limit the objects and
attributes to be imported.

Multiple feature classes can be imported using multiple SQL statements as long as all classes share the same source
coordinate system. SQL queries can also be used to import a feature class and the attribute information from a
related non-spatial table. To apply SQL queries on multiple feature classes with different source coordinate systems,
use Advanced Import and add the feature classes in several Add sessions (see chapter 3 for more information on the
Advanced Import).

MAPublisher uses Esri libraries to run SQL queries. Please refer to Esri documentation for more information on
supported SQL expressions and syntax — it may vary depending on the geodatabase and database server type.

Non-Spatial Relationships

MAPublisher supports non-spatial relationships between feature classes and tables during the import process using
SQL queries. Here are some examples:

Query Result

Import and inner join a feature class to a related table (only

»  SELECT * FROM Feature_Class,Table WHERE FeatureClass.ld=Table.ld . . )
features with entries in the related table are imported)

» SELECT * FROM Feature_Class,Table WHERE FeatureClassId=Tableld | Import and inner join a feature class to a related table and

AND Table.Attribute='"ABC' app|y a query
» SELECT * FROM Feature_Class WHERE FeatureClass.Id IN (SELECT Import a feature class without joining to a related table, but
Table.ld FROM Table WHERE Table.Attribute='"ABC') use a table value to make aquery

Note: SQL syntax may vary depending on the database server type.

Once vector data is imported into Adobe lllustrator, the database relationships rules do not apply anymore. It is
however possible to use the MAP Attributes panel Join Table function to join geodatabase tables with MAPublisher
vector data. For more information, please refer to chapter 5.

Note: When the non-spatial table information is imported together with the feature class using a SQL query, only
the vector features that have a record in the related table are imported. Import first the feature class and use
Join Table in a second step: all vector features are imported and the related table information is added where
a record match is found. This second option might be recommended if the database is not well known.
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IMPORT PERSONAL AND FILE GEODATABASES

Simple Import or Advanced Import > Add

Simple Import
Format - Select Esi File Geodatabase Format: [Esri Personal Geodatabase [*mdb] o] [settngs.. | [ ok ]
or Esri Personal Geodatabase. —
Dataset: - 8{Tutorial Guide & DatalTutorial DataNorthernOntario.mdb | Browse... Careet Browse - Opens a Select dataset
<Auto detect format> can only be browser. File Geodatabases have
used for Personal Geodatabases. Encoding: [Umde. &-hit (UTF-3) N ]

the extension *.gdb and Personal
Geodatabases have *.mdb.
Source Coordinate System:

NADB3(1986]

[F] Same as: | @ torontopaints

FUNCTIONALITY

Esri Personal and File geodatabase feature classes can be imported using Simple Import or Advanced Import. The
file selection is done in two steps: 1) select the database (*.mdb file for Personal geodatabase, a *.gdb folder for File
geodatabase); 2) select feature classes directly or through an SQL query. Optionally, define a spatial filter to limit the
geographic extents of the data being imported.

When feature datasets are present in the database, MAPublisher uses them to group feature classes per parent
feature dataset to ease the selection process, but feature datasets are not imported as such. The feature dataset
name may be prefixed to the name of the data layer created during import (using an import setting).

For each format, multiple feature classes sharing the same source coordinate system may be selected at once in
the Simple Import or Advanced Import > Add dialog box. To import feature classes that do not have matching
spatial reference, use Advanced Import and add the feature classes in several Add sessions (see chapter 3 for more
information on Advanced Import functionality).

The feature classes (objects and attributes) are imported on separated MAP layers. The layer naming convention is
set in the MAPublisher Preferences for Spatial Databases > Esri Geodatabase Editor.

USING IMPORT ESRI PERSONAL AND FILE GEODATABASES

In the Simple Import or Advanced Import > Add dialog box, set the Format drop-down list to Esri Personal Geodatabase
or Esri File Geodatabase. Using <Auto detect format> only works with Personal geodatabases (File geodatabases
cannot be detected because they are directories). The Settings are described in chapter 3. Click the Browse button
and select a file with the extension *.mdb (Personal geodatabase) or a directory with the extension *.gdb (File
geodatabase)— only one geodatabase can be accessed at a time. Click Open to open the Select Feature Classes dialog
box where specific feature classes can be imported.
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Select Feature Classes

In the Select Feature Classes dialog box, import one or more feature classes or build SQL queries to select subsets of
feature classes. Click the names of the feature classes to select them for import—selected classes are highlighted. To
deselect a class, click the selected name again.

Select Feature Classes

Select Feature Classes - Click one or more @ Select Feature Classes:
feature classes to import, only classes

; port, only ¢ @ 2 Grodeti
sharing the same original coordinate ) )

- P! digital_elevation_model_point
system (spatial reference) can be Bl control_point
imported together [Al obscured_area
[ breakline
4 Landform

P! spot_elevation_point

iLl elevation_contour_line
4 Administrative

Al county_boundary

A county_tiles

[A delivery_boundary

Specify Spatial Filter- Click this button to

open the Specify Spatial Filter dialog box pecify Spatial Filter...
SQL Query - Click this option to access 7 SQL Query:

the Create SQL Select Query dialog box

Create SQL Select Query...

Specify Spatial Filter

A spatial filter consists of a rectangle that defines the extents of imported data. Use extents of an existing MAP
Layer from the drop-down list or enter new coordinates values manually. When setting points manually, enter
two opposite corner coordinates that represent the actual extent of the data. When MAP Locations exist on the
document, it is possible to use them to specify corner coordinates. If required, click the Input Coordinate System
link to use an alternate coordinate system for the inputs.

Relationship - Specify features to be included (not available for Basic Spatial Databases):
« Intersects: includes features that intersects the spatial extent
« Contains: includes only features that are entirely contained within the spatial extent
« CroptoFilter: includes only features that are cropped to the spatial extent

Specify Spatial Filter

Use extents of layer - Choose an existing Relationship: @ Intersects () Contains () Crop toFilter
MAP Layer and click Update to use its By
spatial extents as the spatial filter fherbten
. X e () Use extents of layer: Hotel t
Set points manually - Enter two opposite o Emtdims |l

corners of the spatial filter boundaries —re @ Set paints manually

Input Coordinate System - Coordinate Input Coordinate System: WGS 84
system specified for entering the filter <
coordinates (if different from source) orer:
Long:  144.965333 d .
Corner - Specify X and Y e =3 MAP Locations - Choose
coordinates to use as a corner o e i predefined MAP
of the spatial filter Opposite Comner: LocatAlons or Artboard
locations (corners)
« long: 144.965333 deg
Opposite Corner - Specify X and Y
o lat:  -37.813527 deg

coordinates to use as the opposite
corner of the spatial filter

The Relationship type affects how the spatial filter boundary interacts with the imported features :
« Intersects: import objects that intersect the extents of the spatial filter
- Contains: import objects fully contained within the extents of the spatial filter
«  Crop toFilter: includes only features that are cropped to the spatial extent
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Create SQL Select Query

An SQL statement can be built to limit the number of objects and attributes imported from a single feature class.
The SELECT clause should always contain one and one only "Shape" object (actual spatial feature). When possible,
use the operator button to add formatted query statements (including spaces), to limit the typing errors.
For example:
« Infeature class "FC_Point", import all points and the "Valve" attribute (other attributes are not imported).
» SELECT FC_Point.Shape, FC_Point.Valve_ID FROM FC_Point
« Infeature class "FC_Line", import lines (vector only) that have the attribute "Id" equals to 1, 2, 3 or 4.
» SELECT FC_Line.Shape FROM FC_Line WHERE FC_Line.ld IN (1,2,3,4)

Use the Validate button in the Create SQL Select Query dialog box to verify the query syntax prior to import.

Multiple feature classes can be imported using multiple SQL statements separated by a semi-colon (;) as long as all
classes share the same source coordinate system. SQL queries can also be used to import a feature class and the
attribute information from a related non-spatial table (see previous section). To perform SQL queries on multiple
feature classes with different source coordinate systems, use the Advanced Import and add the feature classes in
several Add sessions (see chapter 3 for more information on the Advanced Import).

Recently used SQL queries are saved and accessed by clicking the Recent button. The number of recent queries
saved is set in the MAPublisher Preferences on Spatial Database > General Spatial Database Editor (see chapter 1).

Create SQL Select Query 0

r p - Click an operator button to
3 )
; + add the corresponding formatted text
[saEcT] (m] (=] =) Bk (including spaces) to the query
SQL Query Editor - Type in an SELECT spot_elevation_point. SHAPE FROM spot_elevation_point WHERE cancel
SQL query. The SQL syntax spot_elevation_point.0BJECTID N (1,2,3,4)

Recent - Opens a list of recent SQL

must be compliant with statements (see also MAPublisher

the DBMS server in use.

! s Preferences on Spatial Database > General
One and one only §hap§ @ Spatial Database Editor - chapter 1)
field must be specified in @ ) lick i th
the SELECT clause. idaf Validate - Click to verify the query syntax
Select Feature Class or Attribute name:
Selection - Select a feature > Geodetic )=
class name or attribute 4 Landform ) El
and double-click or click # [Pl spot_elevation_point
Add to Query to add it 2 SHAPE S @}: Add to Query - Select a feature class name
to the SQL Query Editor [T OBJECTID (Object identifier) or attribute and click this button to add
" " [I] SUBTYPEID (SubType identifier) the item the SQL statement
above. At_tndb_ute a(;le_:\s spteleid i
names are indicated in - - — Select recent SQL query
pa renthesis. :fhan creating a guery, it is necessary to spedify a single "SHAPE™ field in the select
ause.
To spedfy multiple SQL queries, separate them using a semicolon(;). SELECT elevation_centour_line.SHAPE FROM elevation_contour_line oK
. - SELECT obscured_area. SHAPE FROM obscured_area WHERE obscure
Specify Spatial Filter - Opens —- - -
th: Spgriz | Filter dialogpbox pecfy Spaial Fiter. SELECT spot_elevation_paint SHAPE FROM spot_elevation_point Wi

(see previous page)

Delete - Click to delete—-

recent SQL queries
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IMPORT USING BASIC PERSONAL GEODATABASE READER
Simple Import or Advanced Import > Add

Simple Import
Format - Select Basic Personal Geodatabase ——e Format:  [Basic Personal Geodatabase Reader [*.mdb] =] [ setings...
This works in both Windows and Mac [e——
. X Dataset: - 8\Tutorial Guide & DataVTutorial DataVorthernOntario.mdb | Browse... Browse - Opens a Select dataset
without an ArcGlIS license. ! i \N [ P

browser. Only Personal Geodatabases

Encoding: [Unicode, 8-bit (UTF-8) - A h
[ ] with *.mdb extension can be chosen.

Source Coordinate System:

MADA3{1986)

[F] sameas: | @ torontopoints

FUNCTIONALITY

Esri Personal geodatabase feature classes can be imported using Simple Import or Advanced Import. The main
difference between this format and the Esri Personal Geodatabase format is that the Basic is available to users
without an ArcGlIS license and works on both Mac and Windows.

The Basic Personal Geodatabase Reader can only read the feature classes as tables (and referred to as tables). The file
selection is done in two steps: 1) select the database (*.mdb only); 2) select tables directly or through an SQL query.
Optionally, define a spatial filter to limit the geographic extents of the data being imported.

Some limited functions are worth noting. The Basic Personal Geodatabase Reader doesn't support feature datasets,
doesn't support relationship (intersect/contains) in spatial filters, and doesn't support domain or subtypes. Other

than the listed differences, the Basic Personal Geodatabase Reader functions similarly to importing an Esri Personal

Geodatabase (see previous section, Import Personal and File Geodatabases).

USING BASIC PERSONAL GEODATABASE READER

In the Simple Import or the Advanced Import > Add dialog box, in the Format drop-down list, choose Basic Personal
Geodatabase Reader. Click the Browse button and select a file with the extension *.mdb (Personal geodatabase)—only
one geodatabase can be accessed at a time. Click Open to open the Select Feature Classes dialog box where specific
feature classes can be imported.

Select Tables

Feature classes are referred to as tables using the Basic Personal Geodatabase Reader. In the Select Tables dialog box,
directly import one or more tables or build SQL queries to select attributes of tables. To directly select tables, click the
names of the table to import—selected tables are highlighted. To deselect a table, click the selected name again.

Note: Text layers in a geodatabase are seen as areas in the Select Tables dialog box, but are imported as text.

Specify Spatial Filter and Create SQL Select Query

The Specify Spatial Filter and Create SQL Query for Basic Personal Geodatabase Reader functions similarly to importing an
Esri Personal Geodatabase (see previous section, Import Personal and File Geodatabases).
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IMPORT ESRI ARCSDE GEODATABASES

Simple Import or Advanced Import > Add

Simple Import
Format - Select Esri ArcSDE Geodatabase. —— Fermat:  [Esri ArcSDE Geodatabase v [ settngs... | [ ox |
< > .
Auto detect format> cannot be used (o r— — — Browse - Opens Browse ArcSDE

Encoding: [Unicode, 8-bit (UTF-8) - Geodatabase dialog box

Source Coordinate System:

NAD33 / UTM zone 12N

D Same as: @ torontopoints

FUNCTIONALITY

Esri ArcSDE geodatabase feature classes can be imported using Simple Import or Advanced Import. Importing
ArcSDE geodatabases requires users to create a connection to the database server containing the database. Once a
connection is established, feature class selection is done in the same manner as Personal and File geodatabases—
by direct selection or SQL query (see previous section) and using spatial filters.

The connection parameters to an ArcSDE server are saved with the application. The dataset selections (called MAP
Datasets) are also saved. The maximum number of default MAP Datasets saved is set in the MAPublisher Preferences
for Spatial Database > General Spatial Database Editor. MAP Datasets saved with a specific name (other than the
default one given) are always saved.

Like the other geodatabase formats, multiple feature classes sharing the same source coordinate system may be
selected all at once. To import feature classes that do not have matching spatial reference, use Advanced Import
and add the feature classes in several Add sessions (see chapter 3 for more information on the Advanced Import).

The feature classes (objects and attributes) are imported on separated MAP layers. ArcSDE geodatabase tables
are identified as databaseName.userName.tableName. An abbreviated version using only the table name as layer
name can be applied as a preference. This option and other layer naming conventions are set in the MAPublisher
Preferences for Spatial Databases > Esri geodatabase Editor (see chapter 1 and previous section).

When feature datasets are present in the database, MAPublisher uses them to group feature classes per parent
feature dataset to ease the selection process, but feature datasets as whole cannot be individually imported—only
its individual feature classes can. An import setting allows the feature dataset name to be prepended to the name
of the data layer created during import.
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USING IMPORT ESRI ARCSDE GEODATABASES

In the Simple Import or the Advanced Import > Add dialog box, set the Format drop-down list to Esri ArcSDE
Geodatabase. <Auto detect format> does not detect Esri ArcSDE geodatabases. Click the Browse button to open the

Browse ArcSDE Geodatabase dialog box.

The Browse ArcSDE Geodatabase dialog box has options to create, edit and delete connection parameters to ArcSDE

servers. It also stores recently used and saved MAP Datasets.

Brownse ASDE Geudatabase

Select Connection o MAP Datasst:

4 Connections

Connections - List of connections already
created within MAPublisher

Dhracle_torves
5L _Dxpress_Connection
ArcSDE 92 Conmection.

Recent/saved MAP Datasets - List of recently ———f——e frcent/srd MAF Datasets

used and saved MAP Datasets |

Edit
« If a connection is selected, it opens
the Edit ArcSDE Geodatabase

Connection dialog box

« If a MAP Dataset is selected, it opens
the Edit ArcSDE Geodatabase MAP
Dataset dialog box

Create new - Opens the Create new ArcSDE _—.ormrh- Edt.,
Geodatabase Connection dialog box.

Copy - Copy the selected ArcSDE connection

n-:k'-r_ s—————— Delete - Delete the selected ArcSDE

connection or MAP Dataset

Esri ArcSDE Geodatabase Connection

In MAPublisher, apply the same connection parameters as in an Esri application (such as ArcCatalog):

X . . Edit ArcSDE Geodatabase Connection
Connection Settings - Specify the

connection settings: Connection Name,
Server, Service and Database Name as

Connection Name: ArcSDE 33 Connection

o .  Server: db93. server. name
specified in the database Connection & g
Properties in Esri ArcCatalog : Service: 5151
DEIDE3

Database Mame:
See next page for specific details for SQL e
Server Express connection (Desktop and

@) Database Authentication
Workgroup Geodatabases) )

L User Name:  user
Database Authentication - Enter user

name and password provided by the
database administrator

Password:  sess

[T Check if you want MAPublisher to remember your password,

Operating System Authentication — e
The server connection uses
Windows authentication. The user

| Operating System Authentication

Connection Details - Specify the transactional or historical
version to be accessed. The interface lists the existing
versions for the database.

Information to be provided by the database administrator.

A=

Connection Details

Please specify the details of this connection.

(@) This connection refers to a transactional version

Version Name Version Description

sde.DEFAULT Instance default version,

Transactional Version: sde.DEFAULT

Test Connection

Specify...

must be logged into Windows
with a login name that is also
valid on the database server.

() This connection refers to a historical version

Connect using a historical marker.

DEFALLT

Test Connection - Test the connection
parameters prior to accessing datasets
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Important Note for SQL Server Express Users

There is an exception for connections to SQL Server Express servers — ArcSDE Desktop (called Personal in ArcGIS
9.2) and Workgroup geodatabases. In ArcCatalog, users set a "Database Servers" connection where only the server
name followed by \sqlexpress is required to establish a connection. In MAPublisher, there is no specific interface for
SQL Server Express connections, the same interface as for the other types of ArcSDE geodatabases must be used
with specific settings:

Server | Name of the server followed by _ SQLEXPRESS

Service | The server name must be preceeded by sde:sqlserver and
followed by \sglexpress (e.g. sde:sqlserver:ServerName\sqlexpress)

Database name | The name of the database must be known

Operating System | Must use this to authenticate SQL Server Express databases
Authentication

Select MAP Datasets

To make a new selection of feature classes from an ArcSDE geodatabase, click a connection name on the Connections
tree of the Browse ArcSDE Geodatabase dialog box and click OK. This opens the Select Feature Classes dialog box. This
dialog box for ArcSDE geodatabases is very similar to the Select Feature Classes dialog box of Personal and File
geodatabases described in the previous section: users can directly select one or more feature classes (provided that
they share the same spatial reference) or build an SQL query to select a subset of some feature classes and apply
spatial filters. The difference with ArcSDE geodatabases is that the feature class selection is saved as a MAP Dataset.
Type in a MAP Dataset name for the selection at the top of the dialog box.

Select Feature Classes

MAF Dataset: Texas MAP Dataset 1 MAP Dataset - Type a name for the selected
Feature dasses - Click one or more @) Select Feature Classes: dataset (by direct selection or SQL
. - C | M . " N
feature classes to import - only classes query). This name will be displayed in
4 sdesde.Texas » the Recent/saved MAP Dataset list of the

sharing the same original coordinate
system (spatial reference) can be
imported together

P! sde.sdeAirports 2 Browse ArcSDE Geodatabase dialog box.
[ sde.sde Builtup_areas 2
sdesde Capitals 2 The number of default recent MAP

sdle.sde. Cities 75k to 900k 2 Datasets saved is set in the MAPublisher
sde sdeCities_greater 900k 2 Preferences for Spatial Database > General

sdesde.Cities_unknownpop_2 SpariaIDatabase Editor.
sde.sde.Cities_up_to_75k_2 .

|L] sde.sde.Contour_lines_2
Specify Spatial Filter- Click to open the P sde.sde.Cultural_landmarks_2
Specify Spatial Filter dialog box. See & sde.sde.Glacier 2

Import Personal and File Geodatabases. [Al sde.sde.Great_lakes_1

T sde.sdle. Gridl

[

ClCEC IR

Specify Spatial Filter...
SQL Query - Click to access the Create SQL —T*- S Query:
Select Query dialog box. See

Import Personal and File Geodatabases. Create S0L Select Query...
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Click a MAP Dataset in the Recent/saved MAP Datasets tree of the Browse ArcSDE Geodatabase dialog box. The MAP Dataset
name and connection can be changed in the Edit Ar¢SDE Geodatabase MAP Dataset dialog box.

MAP Dataset - Edit the name of th

Edit ArcSDE Geodatabase MAP Dataset

MAP Dataset: Texas MAP Dataset

MAP Dataset. It will be displayed in
the Recent/Saved MAP Dataset list
of the Browse ArcSDE Geodatabase
dialog box.

Connection - Set the name of the
connection to use to access a dataset

SQL Query - SQL query used to select the
data features (when used) :

te Connection: | Avenza ArcSDE Cannection

z Cancel

Feature Classes: | (] sde.sde.Builtup_areas 2

P sdesde.Airports 2
P sdesde.Capitals 2

P =de.sde.Cities_T5k_to 900k 2
A sdesdeGreat_lakes 1

[l sde.sde.Major_routes 2

L] sde.sdeMinor_routes 2

Il sde.sde.Physiography_2

[L] sde.sdeRailroad _track_2

P sde.sde.Railway_stations_2

m

Spatial Filter - Spatial filter used to limit
the import extents (when used)

e o in
SQL Query: None
Spatial fiter:  None

Feature Classes - List of
selected feature classes

The maximum number of recent MAP Datasets saved with the default name is set in the MAPublisher Preferences
for Spatial Database > General Spatial Database Editor (user named datasets are saved until deleted).

Settings

Spatial database parameters can by clicking the Settings button in the Simple Import or Advanced Import > Add
dialog box. These settings are described in chapter 3. Optionally, prefix the feature dataset names to the layer name

created on import.

Access it by going to MAPublisher Preferences > Spatial Database > Esri Geodatabase Editor:

MAPublisher Preferences

i Expression Builder

Spatial Database > Esri Geodatabase Editor

= FMEAute
> 4 General
>[5 Import Map Data
> [E MAP Attributes
[ MAP Crop Tool
[ MAP Info Panel
¥ MAP LabelPro
» ¥ MAP Locations
& MAP Measurement
> T MAP Selections
> T MAP Themes
> @ MAP Views
@ Online Maps
4 () Spatial Database
[ Basic Esri ArcSDE Server Editor
] Esti Geodatabase Editor
[ General Spatial Database Editor

Reset Do not show again’ preferences

Use alias as layer name
7] Use abbreviated tzble name for layer name

Display coded domain/subtype description: [mnstead

[ Load subtypes as separate layers

] Sort feature datasets alphabetically nhen selecting for import
[7] Sort festure dasses alphabetically when selecting for import
[7] Sort attributes alphabetically when selecting for import

[ Automatically connect to: | Avenza ArcsDE Cennection

Number of points to use to specify = spatial fiter bounding box: [Two (opposite comers)
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Use iated table name for layer name
ArcSDE Geodatabases' tables

are identified as databaseName.
userName.tableName. The
abbreviated version uses only the
table name as layer name.

If this option is used in combination
with the "use alias" option, the alias is
applied first.



IMPORT FROM BASIC ESRI ARCSDE SERVER

Simple Import or Advanced Import > Add

Simple Import

Format - Choose Basic Esri ArcSDE Server Format: [Basm Esri ArcSDE Server

<Auto detect format> cannot be used.

Dataset: | Canada Dataset

Encoding: [Ummde, 8-bit (UTF-8)

Source Coordinate System:

[No Coordinate System Specified]

Same as: | @ torontopoints

1
=] [ settings... oK
Browse... *H—canre—1 Browse - Opens the Browse Basic Esri
-] ArcSDE Server dialog box
0

FUNCTIONALITY

Users who do not have an ArcGlIS license can install ArcReader, a free Esri desktop application (www.esri.com). Only
ArcSDE geodatabases can be read, File and Personal geodatabases are not supported using this format. In addition,

file access with a Basic Esri ArcSDE Server connection is limited compared to a Esri ArcSDE Geodatabase connection:

«  Aliases, sub-types and attribute domains are not supported — only true names and actual values

(codes) are imported.

«  Feature datasets are not recognized. Feature classes are all listed on the same level, they are not

grouped by feature dataset.
. Feature classes are referred to as "tables"

. Operating System Authentication is not supported.

USING IMPORT BASIC ESRI ARCSDE SERVER

In the Simple Import or the Advanced Import > Add dialog box, set the Format drop-down list to Basic Esri Ar¢SDE
Server. <Auto detect format> does not detect Esri ArcSDE geodatabases. Click the Browse button to open the Browse

Basic ArcSDE Geodatabase dialog box.

The Browse ArcSDE Geodatabase dialog box has options to create, edit and delete connection parameters to ArcSDE

servers. It also stores recently used and saved MAP Datasets.

Browse Basic ESRI ArcSDE Server

Connections - List of connections already Select Connection or MAP Dataset:

created within MAPublisher———e 4 Connections
Basic ArcSDE server

Recent/saved MAP Datasets - List of recently
used and saved MAP Datasets

Recent/saved MAP Datasets

Create new - Opens the Create new Basic:

{reanens] [ et [ comne ] [_ose=

- If a connection is selected, it opens
the Edit Basic Esri ArcSDE Server
Connection dialog box

- If a MAP Dataset is selected, it opens
the Edit Basic Esri ArcSDE Server MAP
Dataset dialog box

Copy - Copy the selected ArcSDE connection

ArcSDE Server Connection dialog box.

¢ Delete - Delete the selected ArcSDE
connection or MAP Dataset
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Basic Esri ArcSDE Server Connection

In MAPublisher, apply the same connection parameters as in an Esri application (such as ArcCatalog):

Connection Settings

Connection Name, Server, Service and
Database Name as specified in the database
Connection Properties in ArcCatalog

See next page for specific details for SQL
Server Express connection (Desktop and
Workgroup Geodatabases)

Create New Basic ESRI ArcSDE Server Connection

: Connection Name: New_Connection

i Server: Server_name
: Service: Service_name

: Database Name:  Database_name

Wersion: Version

¢ User Name: user

User Name / Password - Specify
authentication information provided by
the database administrator

Note:

Version - Enter the transaction

{ Password: e

[ Check if you want MAPublisher to remember your password.

version information provided by
the database administrator.

Unlike ArcSDE Geodatabases, the
ArcSDE server interface does not list
the versions existing in the database.

Test Connection

Test Connection - Tests the connection
parameters prior to accessing datasets.

If ArcReader is not installed in the default installation directory, it may be necessary to edit the binary

location in the MAPublisher Preferences > Basic Esri ArcSDE Server Editor (see chapter 1).

Important Note For SQL Server Express Users

Some specific settings are required for SQL Server Express connections. See Esri ArcSDE geodatabase connection.

Select Tables

Feature classes are referred to as tables using the Basic Esri ArcSDE Server. In the Select Tables dialog box, directly
import one or more tables or build SQL queries to select attributes of tables. To directly select tables, click the names
of the table to import—selected tables are highlighted. To deselect a table, click the selected name again.

Note:

Select Tables - Click one or more tables to —
import. Only tables sharing the same
original coordinate system (spatial
reference) can be imported together.

Specify Spatial Filter- Click to open the
Specify Spatial Filter dialog box. See
Import Personal and File Geodatabases.

Select Tables

MAP Dataset: Texas MAP Dataset

@ Select Tables:

P sdesde.airports_2

§E sde.sde.builtup_areas_2

o~

sde.sde.capitals_2
sde.sde.cities 75k_te 900k 2
sde.sde.cities_greater 900k_2
sde.sde.cities_unknownpop_2
sde.cde.cities_up_to_75k_2
Il sde.sde.contour_lines_2

P/ sdesde.cultural_landmarks_2
[A sde.sde.glacier 2

[A sdesde.great_lakes_L

D sde.sde.gridl 2

11 sde.sde.arid1 5

a=Bia- e~ e

SQL Query - Click to access the Create SQL — |
Select Query dialog box. See
Import Personal and File Geodatabases.

te ©)

Specify Spatial Filter...
SQL Query:

Create SQL Select Query...
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Text layers in a geodatabase are seen as areas in the Select Tables dialog box, but are imported as text.

MAP Dataset - Type a name for the selected
dataset (by direct selection or SQL

query). This name will be displayed in the
Recent/saved MAP Dataset list of the Browse
Basic ArcSDE Geodatabase dialog box.

The number of default recent MAP Datasets
saved is set in the MAPublisher Preferences
for Spatial Database > General Spatial
Database Editor.



Geospatial PDF Import

FUNCTIONALITY

The Geospatial PDF Import is an easy way to import a geospatial PDF into Adobe lllustrator using MAPublisher. Its
purpose is to import the map data and organize them into MAP Layers in a MAP View.

PREREQUISITES

MAPublisher supports geospatial PDF documents generated from MAPublisher and Geographic Imager. It also
supports third-party georeferenced PDF documents (e.g. ArcGIS and TerraGo).

USING GEOSPATIAL PDF IMPORT

Import a geospatial PDF from the File > Open menu. Browse for a geospatial PDF document and click Open. The
Select PDF Import Method dialog box will open.

Select PDF Import Method

The Select PDF Import Method contains two options for import: Advanced and Simple.

Select PDF Import Method

@ Import and split into layers (Advanced PDF Import):

The PDF will be imported and MAPublisher will separate art to its
respective layer, maintaining attributes and referendng. If you
experience any issues with layer order please use the simple method.

() Import to a single layer (Simple PDF Import):
The PDF will be imported to a single layer maintaining referending,

however attributes will be lost. Use this method if you are experiencing
incorrect layer order using the advanced method.

The Advanced PDF Import method is used to separate art to its respective layer. This method maintains attributes
and referencing. It will open the Layer Assignment dialog box so that layers in the PDF can be assigned a
MAPublisher feature type and a MAP View. In most cases, it is recommended to use Advanced PDF Import.

The Simple PDF Import method should be used if any layer order issues are caused by the Advanced import. This
method imports features to a single MAP View and Adobe lllustrator layer. This method maintains referencing,
however all attribute information will be lost.
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Layer Assignment

When Advanced PDF Import is used, it will open the Layer Assignment dialog box. It is used to assign the data
structure found in a geospatial PDF to the appropriate Feature Type and a MAP View. It contains three columns:
Layer, Feature Type and MAP View. In the Feature Type column, the <Auto-detect> option automatically chooses
the appropriate feature type (Area, Point, Line, Image, Text or Legend) to assign each layer. Alternatively, click a
Feature Type cell to assign a layer to the appropriate feature type (or to None for no feature type). Layers can be
assigned to the AllLayers MAP View or to a Non-MAP Layer. To assign nothing, click the Cancel button.

Layer Assignment )
Layer Feature Type MAP View oK
|, <Auto-detect> @ AllLayers
«# torontostreetsjoined_line 4 <Auto-detect> @ AllLayers
« torentopoints_point , <Auto-detect> @ AllLayers
 grid | <Auto-detect> @ AllLayers
« Tmage \ <Auto-detect> @ Alllayers
«” non map layer ,, <Auto-detect> @ AllLayers
o MPtext \ <Auto-detect> @ AllLayers
«” Marrow i, <Auto-detect> @ AllLayers
o scalebar |, <Auto-detect> @ AllLayers
< | n »

Note: During import, MAPublisher is unable to assign layers to a MAP View when a geospatial PDF does not have
any layer structure to begin with.

NOTES ABOUT GEOSPATIAL PDF IMPORT

Adobe lllustrator does not import layers set to invisible in a PDF document. This situation may happen if layers in
MAPublisher are set to invisible and then exported to PDF. To prevent this from happening, ensure that all layers are
made visible before export to PDF.

In certain cases, point objects may be imported as areas. Depending on how the authoring program created the
PDF will determine how MAPublisher imports point objects. A possible workaround to this is to recreate point
objects or create centroids using the existing areas in MAPublisher. Alternatively, try a different authoring program
to export to PDF.

In certain cases, text objects are imported but every word is broken into independent characters. Resolving this
issue is dependent on how the authoring program creates the PDF.

There are several TerraGo PDF export settings to be aware of. The Layer Menus export option provides a way to
organize a layer listing in a PDF document but has no affect on layer structure. MAPublisher does not use this
option during import. Also, the initial visibility for all layers you wish to import must be set to visible. MAPublisher is
unable to import layers set to invisible by the TerraGo PDF exporter.
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MAPublisher FME Auto and FME FFS Import

FUNCTIONALITY

MAPublisher has two main functions that support FME Desktop:

1. In FME Workbench and FME Universal Viewer, the Adobe lllustrator - Avenza MAPublisher writer provides
export options to convert GIS data into an Adobe lllustrator document, complete with a MAP View and MAP
layers (see next page).

2. In MAPublisher, FME Auto gives the ability to import FME Feature Store (*.ffs) files.

The combination of MAPublisher FME Auto and the Adobe Illustrator - Avenza MAPublisher writer in FME Desktop
creates a full featured GIS processing and design environment. Use Adobe Illustrator templates with FME Auto

to create an automated workflow from FME Desktop to MAPublisher seamlessly. Use the MAP Theme styesheet
Auto-Assign option to automatically have your custom styles applied as data is imported into Adobe Illustrator.
Templates and MAPublisher MAP Themes and styles can be prepared in advance.

PREREQUISITES

MAPublisher FME Auto is a separate license that must be activated in MAPublisher License Management dialog box
before use (see Chapter 1).

MAPublisher FFS import is available through Simple and Advanced Import when FME 32-bit is installed (on
Windows 32-bit or 64-bit).

The Adobe lllustrator - Avenza MAPublisher writer plugin for FME can be used with both 32 and 64-bit FME,
however the FME Auto component in MAPublisher requires either a 32-bit version of FME or the 32-bit FME
redistributable (which can be downloaded from Avenza website) to be installed.

IMPORTING FME FFS FILES

This is similar to importing other formats (See Simple Import and Advanced Import). In Simple or Advanced Import,
choose FME Feature Store [*.ffs] from the Format drop-down list. Click Browse to select the file(s) to be imported and
then click Open.

Simple Import

Format: [FME Feature Store [*.ffs] v] l Settings... ] [ Ok J

Dotset: n|QATesDatsFomatsHE\Geomety Geamesy_ves

Encading: [Unicode, 8-bit (UTF-8) -]

Source Coordinate System:

Same as:

FFS files can have password protection. To import an FFS file protected by a password, click the Settings button and
enter the password. A warning dialog box will appear if the password is incorrect and a notification that says Unable
to read datasource displays in the import dialog box.
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USING MAPUBLISHER FME AUTO IN FME WORKBENCH AND FME UNIVERSAL VIEWER

FME Workbench is a visual workflow editor used for developing data transformation tools. It is commonly used for
translations between various GIS data types. FME Universal Viewer is a utility that allows you to view data in any
FME-supported format. The Adobe lllustrator - Avenza MAPublisher writer provides export options to convert GIS
data into a new Adobe lllustrator document, complete with a MAP View and MAP layers.

To access the MAPublisher writer in the FME Workbench main window, go to Writers > Add Writer. To access the
MAPublisher writer in FME Universal Viewer, click File > Save Data As. In the Add Writer dialog box, browse for the
Adobe lllustrator - Avenza MAPublisher format.

Format - Browse the Writer Gallery to
select the Adobe lllustrator - Avenza
MAPublisher writer

Dataset - Browse for the intermediate
file (*.ffs) to be translated

Parameters - Specify the destination Adobe
Illustrator file and advanced settings
for MAPublisher FME Auto. Detailed
information about the parameters below.

Workflow Options

©® static Schema

(©) Dynamic Schema

Help:

FME Workbench FME Universal Viewer
%] Add Writer m.‘ &5 Select Destination Format and Dataset @Q
Wiriter Writer
Format:  Adobe Tlustrator - Avenza MAPublisher - B Format:  Adobe Ilustrator - Avenza MAPublisher ¥
Dataset: \Formats\FME\Geometry\Geometry_Area.ffs @ Dataset: \formats\geometry. ffs [;E
—e Coord. System: 5ame as source w E Coord. System: Same as source w

Click the Parameters button to access the Adobe Illustrator - Avenza MAPublisher Parameters dialog box:

5] Adobe lllustrator - Avenza MAPublisher Parameters

T[]

Adobe Tustrator Parameters

Initial Al File/Template:

Adobe lllustrator P

Specify initial Adobe Illustrator file

or template to import GIS data to,
the destination Adobe lllustrator file
(where it is saved to) and how the
document behaves (leave open, save,
or save and close)

Other P

Destination AT File:

[

Document Disposition: |Leave open

Existing Document MAP View

Fit to Page After Adding Data

Existing Document MAP View - Use these
options to fit data to the page and

If Matching MAP View Found: |Create new MAP View

Other Parameters

Strip Format Attributes

Additional options to strip format
attributes, wait for results (stops

on errors), quit Adobe lllustrator if
launched using FME, and choose a FFS
file compression level.
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Adobe Illustrator - Avenza MAPublisher Parameters

Initial Al File/Template

Translate data from FME to Adobe Illustrator by using existing Adobe lllustrator file (*.ai) or Adobe lllustrator
Template file (*.ait). If no file is set for this option, a prompt will appear to create a new document when the import
process starts in Adobe Illustrator.

Destination Al file and Document disposition
After GIS data is successfully imported into Adobe Illustrator, there are several options to handle the document
using the Document disposition drop-down options:

«  Leave open: After the import process is complete, the Adobe Illustrator document will be kept open

«  Save: After the import process is complete, the Adobe Illustrator document will be saved, but will
remain open.

«  Saveand close: After the import process is complete, the document will be saved and then closed.

To save a document using a specified name, enter it into the Destination Al file box and set the document
disposition to Save or Save and Close. Alternatively, you can specify only the Initial Al File, in which case it will be
overwritten in the process. When no Destination Al file name is set and the Initial Al file is either a new document or
a template, a prompt at the end of the automation process to specify a file name will appear.

Existing Document MAP View

Fit to Page After Adding Data
Enable this option to scale the data (existing and incoming) to fit to the extent of the art board.

When an existing Adobe lllustrator file contains a MAP View with the same coordinate system as the data being
imported with MAPublisher FME Auto, the If Matching Existing MAP View Found option contains several options to
handle the imported datasets:

«  (Create New MAP View: The datasets will be imported to a new MAP View.

«  Promptthe User: A prompt will appear during the automation whether or not the GIS data should be
imported to an existing MAP View. With this option, user can specify which MAP View to use. This
option is useful when there are multiple MAP Views with the same coordinate system available in the
specified Adobe lllustrator file.

-« All data to first matching MAP View: If the specified Adobe Illustrator file has multiple MAP Views with the
same coordinate system, GIS data via FME Automation will be brought to the first MAP View with the
same coordinate system as the one with the GIS dataset being imported.
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Other Parameters

Strip Format Attributes

When GIS data is converted to FME Feature Store (FFS) format, the FFS file may contain extra attributes to preserve
information of the original data format such as dimension, geometry type, and feature type information. Enable
this option to prevent these attributes from being imported into the Adobe Illustrator document.

Note that FFS retains all the attribute data from its initial sources, which may include source format-specific
attributes, source user attributes, etc. While disabling this option minimizes the amount of data imported, enabling
it may result in better rendering of the original dataset features and allow you to perform stylization in MAPublisher
based on the original source attributes.

Wait For Result from MAPublisher

By default, after sending a request to MAPublisher to perform an import operation, FME does not wait for the
application to complete it and immediately proceeds to the next item. When this option is enabled, the format
writer will wait for MAPublisher to finish its work and report the results to the FME log, rather than having it
displayed in MAPublisher.

Quit Launched Illustrator If Unused

MAPublisher FME Auto starts Adobe Illustrator if it is not running. Enable this option to quit Adobe Illustrator after
the import process if it was launched by FME and it has no other pending requests. If Adobe Illustrator is already
running when MAPublisher FME Auto begins, this option will be ignored. Please also note that all the writers in the
workspace should have this option enabled for Al to Adobe Illustrator to quit. Please also note that depending on
timing Adobe Illustrator may quit and launch multiple times if this option is set, since it makes the decision about
quitting only based on the requests that have arrived so far.

Character Encoding
By default, the current system locale is used to decode language-specific data for attribute definitions and values.
This option is the way to specify what encoding should be used to interpret the attribute data in MAPublisher.

FFS File Compression Level
This option is inherited from FME FFS writer option and has three settings: None, Medium, and High. A lower
compression level will result in faster operation while a higher compression level will result in smaller file sizes.

FME Workbench Navigator
All the parameters for the Adobe lllustrator - Avenza MAPublisher writer are available in the FME Workbench
Navigator. Use this panel to adjust parameters before importing GIS data to Adobe lllustrator.

The Adobe lllustrator - Avenza MAPublisher Parameters dialog box is only accessible once. After it is closed, it
cannot be accessed again. All the parameters in that dialog box are available in the Navigator panel.
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MAPublisher Preference Settings for FME Auto

FME Auto preference settings are available in MAPublisher Preferences (Chapter 1).

Run this version of lllustrator when using FME Auto

auigator -x  Enable this option to set a specific version of Adobe lllustrator to be used as
4 £5| Geometry_rea [MAPUBLISHER] - . . . .
@ Coordinate System: <not set> 7| the default when multiple versions of Adobe lllustrator (which are compatible

4-£35 Parameters . . .
£5} Destination FME Feature Store (FFS) Fie: \idashMPIQA with MAPublisher 8.6) are installed.

-3 Initial AL Fle/Template: <not set> L

455 Destination AI File: C:\Users\mlaw\Desktop\canada.ai |~

~£53 Document Disposition: Leave open . . . .

£ 17 Metching MAPYen Found: Create new MAPVew If this preference is not enabled in any of the Adobe lllustrator versions

~53 Fit to Page After Adding Data: Yes

%Wa.tfmsmn to ~installed, the most recent version will be launched when MAPublisher FME
- Strip Format Attributes: Yes . .
i2 st o Auto starts. For example, if a machine has Adobe lllustrator CS4 and CS5
~£83 FFS File Compression Level: None . . . . .
%Tmesdmsmmm installed with MAPublisher 8.6, the CS5 version will be launched.
> Advance:

Feature Types
i —— » | When Adobe lllustrator is already running before MAPublisher FME Auto starts,
it will be used for MAPublisher FME Auto regardless of the option selected in

MAPublisher Preferences.

Seconds before timeout

o Bpresdon Buiider FHE Auto This option specifies the number of seconds FME Desktop
= e I7] Run s versio of lustrator hen Lsing Y A, will try for when attempting to open Adobe lllustrator. If
: Immlpuzn Seconds before tmeouts  60s 2 FME Desktop can not open Adobe lllustrator, a message
& MAP Crop Tool will appear in the FME Log.

il MAP Info Panel
& MAP LabelPro
# MAP Locations

KNOWN LIMITATIONS

«  Raster Image import with MAPublisher FME Auto is not supported
«  RasterImage in FFS format cannot be imported to MAPublisher
«  Multipoint geometry cannot be imported.
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MAP Layers and
MAP Views

The MAP Views panel is the hub from which many additional
MAPublisher features may be accessed. It organizes MAP
layers into based on distinct coordinate systems known as
MAP Views. Use this panel to specify coordinate systems

for MAP Views, peform coordinate transformations, adjust
scale, change data alignment and placement, and export to
industry standard GIS formats.

When importing data, an Adobe lllustrator layer is created for
each feature type, and is by default appended with a _point,
_line, _area, or _text suffix in the Adobe Illustrator Layers
panel. Certain file types generate multiple layers, such as
DGN or DXEF, but are similarly split up by feature type. A single
import of such files produces a single MAP View as an import
can only take place into a single coordinate system. Custom
MAP Views may be created in order to georeference existing
Adobe lllustrator artwork.

The following pages deal with the creation and management
of MAP Views, specifying and projecting a coordinate system,
editing scale and data placement on the page, merging Adobe
lllustrator layers, and exporting to GIS formats.

Topics covered in this section:

MAP Views Panel

MAP View Editor

Export MAP Layers and MAP Views
MAP Info Panel

Copy MAP Objects From
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MAP Views Panel

Window> MAPublisher > MAP Views and MAP Toolbar |E

MAP Views - Each contains —e [ _,— Layer Note - Click this button to
distinct configurations of Cye— add a layer note. A note with no
geospatial parameters + symbol contains a note.
MAP Layers - An alphabetical ) Switch MAP View - Click this button to
list of the layers that comprise 0‘ SMv‘xLCCig\:vetsoelae::)f:elfﬁirr;fzA(/)I:i
each MAP View, symbolized b -
yfeatu,e typ!— | < data moves the selected layer to
H D the [Non-MAP layers] section and
o removes the georeferencing and
Lock button - Click box to lock 5 attributes in the process.
or unlock a MAP Layer (lock :
check box is mirrored in the : P airport_paint [}
Adobe lllustrator Layers panel) _. a ! = O Add MAP Layer - Creates a new MAP
Non-MAP layers - Lists the Adobe ————{—= /| Hon-map lzyers] layer (in both the MAP Views panel
lllustrator layers that are not part of ] Layert 3 and the Adobe Illustrator Layers
a specified MAP View, and do not - p_anel). Opens the Add MAP Layer
contain georeferenced information 3 MAP Views B <@ ~0 = dialog box.
| [ +

Export MAP View i+ / MAP Layer ==
Export the selected MAP View or
MAP Layer to various GIS formats

Zoom to "Land_Area_image"

Lock "Land_Arez_image"
Unlock "Land_Area_image"
Hidle *Land_Area_image”

Show 'Land_Area_image"

Delete selection button - Delete the
currently selected MAP Layer or
MAP View

«—— Layer Operations - Zoom, toggle lock,
and toggle visibility of MAP Views

and MAP layers.

Lock all layers except "Land_Area_image”
Unlock alllayers except "Land_Area_image”
Hide all layers except "Land_Area_image”

Show all layers except "Land_Area_image"

MAP Views Panel Options Menu

New MAP View...

Mew MAP View For Photoshop Paths...

Duplicate "Chicagoland”
Edit “Chicagoland"...

Delete Selection
Add MAP Layer...

Specify Anchors..
Export Coordinate System to File..

Export "Chicagoland"...
Layer Name Search & Replace...
Sort Art on Layer...

Edit Layer Note...

Load Custom Coordinate Systems...
Edit Custom Coordinate Systems...

Document Summary...

Specify Altemate Coordinate System...

Copy MAP Objects From...

Preferences...
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New MAP View - Create a new MAP View and specify its name and coordinate information.

New MAP View For Photoshop Paths- Specify a new MAP View based on paths exported from Geographic Imager/Adobe Photoshop.
Duplicate Selection - Create a duplicate of the currently selected MAP View.

Edit Selection - Open the MAP View Editor to edit the name and coordinate system of the currently selected MAP View.

Delete Selection - Delete the currently selected MAP View or MAP Layer provided it does not contain any Adobe Illustrator layers.
Add MAP Layer - Create a new MAP Layer through Add MAP Layer dialog box.

Specify Anchors - Manually establish the tie-in point between Map and Page Anchors (should only be used for new MAP Views or
for the correction of georeferencing errors).

Export Coordinate System to File - Exports the selected MAP View coordinate system to a WKT definition (*.wkt) (see Appendix A2).
Export Selection - Enable the export of the selected MAP View or MAP Layer to various GIS formats.

Layer Name Search & Replace - Search for text within layer names and specify an alternative. Useful for multi-layer imports.

Sort Art on Layer - Sort art in ascending or descending order based on attribute.

Edit Layer Note - Add or edit the selected layer's note.

Load Custom Coordinate Systems - Load external coordinate systems in XML format (see Appendix A2).
Document Summary - View a summary of all features and other art on both MAP layers and non-MAP layers.

Specify Alternate Coordinate System - Choose a coordinate system that appears as an alternate option on many MAPublisher tools.
Edit Custom Coordinate Systems - Open the custom coordinate system editor to create new coordinate systems and edit the
parameters of existing ones in the data source (see Appendix A2).

Copy MAP Objects From - Copy MAP Views, MAP layers, MAP Themes (including Stylesheets), and MAP Selection Filters from other
open documents.

Preferences - Opens MAPublisher Preferences on the MAP Views Panel property sheet (see chapter 1).
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RELATED TOOLS
-

Layer name - Type the name of the new
layer (it will appear in both MAP Views
and Adobe lllustrator Layers panels)

Feature Type -Select the type of feature
of the new layer. This drop-down list

presents a choice of Area, Line, Point,
Image, Text or Legend layer types

Feature Type -Select the type of feature
that exists on the layer being dragged.
This drop-down list presents a choice of
Area, Line, Point, Image, Text or Legend
layer types.

Add MAP Layer

Add MAP Layer

Layer name: Layer 1

[@Area

r® Feature type:

7

Advanced:

Base Attribute Schema on - Check this option to
copy the attribute schema from the existing
MAP Layer selected in the drop-down list

[] Base attribute schema on:
‘Check this option to inherit the attribute structure from the specified layer

P usdties_point

Plot Centroids, Label Features, MAP Tagger
Tool and MAP LabelPro tools make use of this
option, see specific chapters.

Undefined Layer

Automatically opens when switching a Non-MAP layer to a sp

ecified MAP View.

Undefined Layer - Layer 1

5

[lEIAraa

ature type:

) |

OK

Advanced:

[] Base attribute schema on:

Base Attribute Schema on - Check this option to
copy the attribute schema from the existing
MAP Layer selected in the drop-down list

Plot Centroids, Label Features, MAP Tagger
Tool and MAP LabelPro tools make use of this
option, see specific chapters.

Select custom coordinate system Choose
this option and then click the Select
button to specify the coordinate
system of the named MAP View via the
Select Coordinate System dialog box
(see Appendix 2). Once selected, the
coordinate system will be displayed
below it.

P| usdities_paint

Chedk this option 1o inhertt the atribite stucture from the spacied layer.

Apply toall - When multiple layers
are switched at once to a specified
MAP View, check this box to apply

Apply to all

the same feature type to all

Missing Coordinate System

Automatically opens when dragging a MAP Layer to an alternate MAP View, and
either the source or destination MAP View has an unspecified coordinate system.

Missing Coordinate System

-

The 'MAFP View 1' MAP View does not contain any coordinate system information.

Please specify the coordinate system of this MAP View.
() Specify coordinate system: Select...

Coordinate system:

Same as - Choose this option in
order to assign a coordinate
system to the named MAP View
that matches that of an existing

@ Same as: [ @ Vancouver Downtown

MAP View. The coordinate

Coordinate system: NADS3 / UTM zone 10M

system of the selected MAP
View will be displayed below.

Layer Name Search & Replace

Layer Name Search & Replace

Input Coordinate system - Specify the
coordinate system in which the

Find what: _area

anchor position is entered. Use

Specify Anchors
Should only be accessed when creating a new MAP View
or correcting inaccurate georeferencing information.
Caution: editing anchors can damage the accuracy of the data.

the current MAP View's coordinate

Replace with:  palygon

Specify Anchors

system or specify a different one
(by default, the geodetic system —

Cancel

Find what -
variable c
current la:

Replace with - Type in the
variable you wish to change
the layer names to

which you wish to search

base of the projection or WGS84, in

. latitude-longitude format).
Type in the

ontained in the

yer names on Page Anchor - The location of the —

Page Anchors in the units of the
current document. Click the MAP
Location button to choose a Page
MAP Location as a page anchor.

Map Anchor - The location of the Map
Anchors in the units of the selected —
coordinate system. Click the MAP
Location button to choose a World

- Input Coordinate System:

le Page Anchor:

e Map Anchor:

@ Use MAP View's coordinate system

) Use: NAD33(1986)

" X: 0.000000

+ Y. 0.000000

Make sure you have set rulers to Global Rulers when
reading the page location with any Ilustrator tools.

You can find the option at View > Rulers > Change to Global Rulers

oF X 488417.398416
o Y

5457455.696055

MAP Location as a page anchor.
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OVERVIEW

The MAP Views panel displays a list of all the Adobe lllustrator layers in the current document and all MAP Views—
defined configurations for geospatial parameters (coordinate system, anchors, map scale and rotation). Every
MAP Layer is shown in this panel as belonging to a particular MAP View. Adobe lllustrator layers that do not have
georeferencing information (e.g. non-map objects such as diagrams and supplemental art) are placed in the
[Non-MAP layers] category.

Categories are symbolized in the following manner:
MAP View Contains layers with georeferenced and attribute information.

/ [Non-MAP layers] ~ Contains layers with no georeferenced or attribute information.

Each layer that belongs to a MAP View is symbolized in MAPublisher panels and dialog boxes with an icon
identifying its feature type:

Area layer (e.g. county boundaries, urban areas, country outlines etc.)
Line layer (e.g. rivers, roads, railways etc.)
P Point layer (e.g. town and city symbols, railway stations etc.)

Text layer (e.g. text labels)
'@ Legend layer  (for MAPublisher Legend items: North Arrows, Scale Bars, Grids)
I Imagelayer  (for referenced images)

Note: Layers are sorted alphabetically or by data type, as specified in the MAP Views category in the MAPublisher
Preferences (see chapter 1).

FUNCTIONALITY

MAP Views are designed to give easy access to settings for specifying and transforming coordinate systems, for
editing scale and data placement on the page and for exporting to GIS formats. The MAP Views panel allows
toggling Adobe lllustrator layers accessibility, georeferencing existing Adobe lllustrator artwork, changing multiple
layer names and projecting data on the fly.

USING THE MAP VIEWS PANEL

Creating New MAP Views

To create a new MAP View, click New MAP View in the panel options menu. This opens the MAP View Editor (discussed in
MAP View Editor section). Specify a coordinate system and enter values for scale, rotation, and page anchors. After
creating a new MAP View, the Specify Anchors item from the MAP Views panel options menu must be used to define
the tie-in point between Map Anchors and Page Anchors.

Note: Creating a new MAP View is only recommended when registering a non-referenced Adobe lllustrator
document. To transform an existing MAP View to a new coordinate system and scale (e.g. to create an inset
map), use the duplicate MAP View function and transform or rescale the copied MAP View.
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Duplicate And Delete MAP Views

MAP Views can be duplicated. For example, to create inset maps make a duplicate and drag MAP Layers into the
new MAP View. Then use the MAP View Editor to edit the placement, scale or coordinate system of the duplicate.
Note that MAP Layers can only be duplicated in the Adobe lllustrator Layers panel.

Delete a MAP View or MAP Layer using the Delete button at the base of the panel or through the MAP Views panel
options menu. When deleting a MAP View, any MAP layers (and sublayers) within it are also deleted.

Create New MAP Layers

Create new MAP Layers to hold geospatial data or to generate artwork using MAPublisher tools (plot points, labels,
legends, grids, scale bars and north arrows). Click the Add MAP Layer button s to create a new Adobe Illustrator
layer which simultaneously places it into a selected MAP View. Specify the appropriate Layer name and Feature type for
the new layer. Below are examples of the types of MAPublisher tools that require a specific MAP Layer type:

Area layer Join Areas, Line Plotter (see chapter 8)
Line layer Buffer Art, Join Lines, Line Plotter (see chapter 8)

MAP Point Plotter (see chapter 6)
Join Points (see chapter 8)

v B =

Point layer
Label Features, MAP Tagger (see chapter 10)
MAPublisher LabelPro (see chapter 17)

Grids and Graticules (see chapter 13)
Scale Bars, North Arrows (see chapter 14)

H

Text layer

Legend layer

=]

Image layer Import Image, Register Image (see chapter 3 and 12)

Note: The Advanced option Base attribute schema on will copy the attribute schema from an existing MAP Layer (see
chapter 5 for details). This option is required to enable the copying of attributes from source to destination
layers in the MAPublisher labelling tools and Plot Centroids function. See respective chapters.

Reproject MAP Layers using the MAP Views Panel

The MAP Views panel can be used to move Adobe Illustrator layers from one MAP View to another; projecting
vector* data-on-the fly. Alternatively, drag-and-drop layers or use the Switch MAP View button .+, .
* Raster imagery cannot be reprojected with MAPublisher.

Alternatively, use the drag-and-drop method. For example, to reproject a layer that has a UTM projection into a
Lat/Long projection, click it and drag it from the MAP View with the UTM projection and drop it into the MAP View
with the Lat/Long projection. MAPublisher will automatically reproject and scale artwork on the layer to match the
destination MAP View. The Missing Coordinate System dialog box appears when neither the origin nor destination
MAP View contains a defined coordinate system. Two options are available in this dialog box:

1. Specify custom coordinate system: specify projection using the Source Coordinate System function.
2. Sameas: specify coordinate system based on an existing MAP View in the document.
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Note: Many transformations will inherently cause the loss of precision by the very nature of complex mathematical
calculations that must be performed. Additionally there are differences in precision between MAPublisher
and Adobe lllustrator. MAPublisher calculations are in 64-bit for accuracy, but the results are stored in
Adobe lllustrator as 32-bit. As a result, please be aware that some precision may be lost if layers are dragged
repeatedly from one coordinate system to another. When determining a coordinate system to use via the
drag method, we strongly recommend Edit > Undo to revert back until the appropriate system is found.

Assign Georeferencing Information to Adobe lllustrator Layers

Existing Adobe lllustrator layers that do not contain georeferencing or attribute information also appear in this
panel under the default MAP View entitled [Non-MAP layers]. Such layers can be moved into a specified MAP View with
a matching geospatial configuration (coordinate system, scale, position on the page, etc.).

Note: Moving a non-MAP layer to a MAP View does not imply any transformation (the artwork is not redrawn).
Ensure that the art on the non-MAP layer is positioned and scaled properly on the page with regard to the
MAP View definition.

Moving a non-MAP layer into a specified MAP View prompts the Define Layer dialog box. Use it to specify the feature
type of the moved layer. Multiple layers may be selected and moved together to a specified MAP View. Use the Apply
toall option to assign the same feature type to all layers being moved. The Base attribute schema on option copies the
attribute schema from an existing MAP Layer (see chapter 5 for details).

Specify Anchors

The Specify Anchors function should only be accessed when referencing a new MAP View (for example in the
process of georeferencing an Adobe lllustrator file, see appendix A1) or to correct an inaccurate referencing.

When the Use Current MAP View's coordinate system option is chosen, Map Anchor coordinate values are entered in the
map units of the coordinate system of the MAP View. Map Anchor coordinates must be known from information
written on the map (e.g. graticule crossings) or from external sources (metadata, survey points or other). MAP World
Locations can be used as Map Anchors.

When the Use: [coordinate system] option is chosen, the current coordinate system link is enabled. Click it to open

the Select Coordinate System dialog box. The coordinates values entered will be in the unit (Point Style) of the chosen
coordinate system. When the selected or default coordinate system is projected, X and Y coordinates are entered in
the unit (Point Style) of the coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate
system is Geodetic, Lat and Long coordinates are entered in degrees.

Note: When the current MAP View coordinate system is a projected system, the default system specified in
Use: [coordinate system] is set to the geodetic system base for the projection. For example, if the MAP View
system is US State Plane NAD83 / Colorado North (ftUS), the default alternative system is set to NAD83 (to
enter the latitude/longitude coordinates in degrees).

The Page Anchor is entered in the current unit of the document. This unit can be changed through the Adobe
lllustrator menu File > Document Setup. Positions of points on the document in page coordinates are determined
using the Adobe lllustrator Info panel (menu Window > Info). MAP Page Locations can be used as page anchors.

Note: For CS5 users, Page Anchor values must be relative to Global Rulers. To use Global Rulers, choose View >
Rulers > Change to Global Rulers.
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Layer Name Search & Replace

To quickly change the names of multiple Adobe Illustrator layers, use the Layer Name Search & Replace function
located in the MAP Views panel options menu. For example, MicroStation Design or CAD imports can contain

a large number of similarly named layers and doing a name search and replace is more efficient than manually
changing each of them..

Zoom to MAP Layer or to MAP View

To zoom to a MAP Layer, select one and click the Layers Operations button |sg %/ at the bottom of the MAP Views
panel. Click the Zoom to "[Layer]" in the context menu. When a MAP View is selected, this option becomes Zoom to all
layers in "[MAP View]". This is particularly useful for documents containing a large number of layers.

Layers Operations

The Layer Operations button |sg 5| will perform a variety of layer operations. If a MAP Layer is selected, use the
context menu to Lock, Unlock, Hide or Show "[Layer]" or to Lock, Unlock, Hide or Show all layers except "[Layer]". If a MAP View is
selected, the same options become for all layers in "[MAP View]" or all layers except layers in "[MAP View]".

MAP Layer Note

MAP Layer Notes contain general information about the layer, such as how it was created or on its source data. MAP
Layers that have layer notes attached to them are indicated with the icon |:'| . MAP Layers with no layer notes are

marked with | .

Layer notes can be automatically added when the layers are created through MAPublisher functions (e.g. MAP Data
Import, Plot Centroids, Web Feature/Map Service, etc.). To do so, enable the MAPublisher General Preferences option
Add notes for layers created by MAPublisher operations — see chapter 1 for details. The automatic notes show the function
and parameters used to create it. For example a note of a layer created by import indicates information such as the
path of the source data, format and date.

To add or edit a layer note, choose the MAP Views panel options menu Edit Layer Note. In the Add/Edit Layer Note
dialog box, type new text or edit the existing information. Click the Clear button to clear all information.

Edit Layer Note
Created by: Import 0K
Dataset: C:\Users\PublicDocuments|AvenzaMAPUblisher 8\Quick Start Guide & Data\Quick
Start Data\Vector Files\Projected Data\Roads. tab
Format: MapInfo TAB
Encoding: UTF-8
Coordinate system: NADS3 / UTM zone 10N

Feature count: 194
Created on: 20/04/2010 9:22:11 AM

Last updated on: 20/04/2010 9:22:11 AM
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Export MAP Views and MAP Layers

The MAP Views panel offers the option to export a single MAP View e ora single MAP Layer a5 toa
multitude of GIS formats. This function is explained later in this chapter.

New MAP View For Photoshop Paths

The New MAP View For Photoshop Paths function creates a new MAP View using a reference file and associated
Adobe lllustrator file exported from Geographic Imager for Adobe Photoshop.

Adobe Photoshop offers a function to create vector paths and export them to Adobe Illustrator. Adobe Photoshop
uses Geographic Imager to maintain the spatial reference and outputs it as an .rsf reference file. To import the paths
into Adobe Illustrator using MAPublisher, use the New MAP View For Photoshop Paths from the MAP View panel options
menu to create a new MAP View based on the .rsf file. After doing this, the Adobe lllustrator layers can simply be
dragged from [Non MAP Layers] to the newly created MAP View to finalize the georeferencing. The vector data can
now be used in a current MAPublisher project, edited, transformed or exported to any external GIS format.

New MAP View For Photoshop Paths

Reference file: OK
Move non-MAP Layers into MAP View as:
Destination Artboard: |Artboard 1 -

Tip: use the artboard tool to display artboard numbers

New MAP View For Photoshop Paths allows the creation of a MAP View using a reference file and assodated
Tlustrator file created in Photoshop and Geographic Imager.

+ In Photoshop, create a vector path.

»Export this with referencing from Photoshop as an Tlustrator file. With the Geographic Imager plug-n
you can also export the associated .rsfreference file,

*When the newly created Ilustrator file is opened with MAPublisher the reference file can be used to create
a MAP View using this tool.

Remove MAPublisher Information

At the end of a project cycle, it may be useful to permanently remove all georeferencing and attribute information
in the current document. This can be accomplished by switching all MAP Layer(s) to the [Non-MAP layers] category
in the MAP Views panel via drag and drop or clicking the Switch Map View button =i, and the Remove MAP data option.

Note: This function should only be used as required and as a final step. Be sure to save a copy of the document
before performing this operation as this will erase all attribute data.
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Preview Pane - Displays the data

MAP View Editor

MAP Views panel > Edit MAP View / New MAP View,
Advanced Import > Create New > Editor

Edit "Lower 48 States”

Map Anchor
X: -178.2176000400
Y: 18.9247953100

extents of the MAP View:
White rectangle - Artboard extents

Page Anchor
X: 36.364258 px

Colour rectangle - Data extents of the —1

current MAP View

Crosshair - Location of the current
Map and Page Anchors

Configure Margins - Adjust the
artboard margins

Show/Hide Preview Details - Display or
hide the Map and Page Anchors
and artboard margins

Name - Name of the MAP View

Scale - Edit the MAP View scale
relative to the page. Click Auto-
scale to fit the data extents to the
artboard or the margins.

Angle - Rotation angle of the MAP
View. Click to reset to zero;
click | 1] to orient the MAP View
north up.

Perform Coordinate System Transformation
Enable this option to transform the
data to a new coordinate system.
Click the coordinate system link

to open the Specify Destination
Coordinate System dialog box.

: 791, 500000 px

Page Alignment

- ‘ Auto Scale v| LLX: 35.864502
2| degrees =

Name: Lower 48 States

Scale: 1: £5099621.822375

Angle: 0.00

Source Coordinate System:

NAD27

[] Perform Coordinate System Transformation:

Destination: [No Coordinate System Specified]

—

same as: | @ torontostrestsjoined

Datum shift:

LLY: 792.000000

— Zoom buttons - Zoom in/out

Center current MAP View extents on
screen - Fit preview to the extents

Center active artboard on screen - Fit

preview to the artboard extents

Scaling - Maintain point size, stroke
width and font size when scaling

Pan Preview Mode - Pan around the
preview pane

— Move MAP View Mode - Move the

position of the current MAP View

Previews and Configure Previews
Select and configure how the
previews are shown

Page Alignment - Affects the position

of the Page Anchor:

« LLXand LLY- Position of the
lower left corner of the data in
document units

S OO0
- Doo
= om0
—L
&) | FromFile... I

Same as - Check this option
to transform to a coordinate
system used by another
MAP View in the document

From File - Load a destination
coordinate system from an
external file

FUNCTIONALITY

Specify - Open the Specify
Destination Coordinate
system dialog box to select
a coordinate system

Datum Shift - Displays
the datum shift for the
transformation

« Alignment Control - Click a position
on the grid to control the
alignment of the data extent
relative to the page (e.g. center

__middle, upperright...)

Source Coordinate System - Displays

the current coordinate system

assigned to the MAP View. Click
the link to open the Specify Source

Coordinate System dialog box to

select a new source coordinate

system. To be used only if the

* Info - View the parameters of a

selected coordinate system

Clear - Remove all references
to a coordinate system

From File - Load a source
coordinate system from an
external file

source coordinate system is
undefined or is not matching

the data.

To apply a new coordinate system to
a MAP View, use Perform Coordinate
System Transformation.

The MAP View Editor displays and controls the geospatial parameters of the MAP View (coordinate systems and
scale on the artboard), the position of the data extents on the page (alignment and rotation) and provides a way to
change the MAP View name. A preview pane shows and allows users to move the current MAP View relative to the
artboard and to the other MAP Views in the document.

The MAP View Editor is also where coordinate system transformations are performed. Transformations affect the
data geometry on the page as map art is redrawn to match the new coordinate system properties.
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USING THE MAP VIEW EDITOR

The MAP View Editor can be accessed as part of the Advanced Import dialog box or from the MAP Views panel:
«  Advanced Import: click the Create new option in the Destination MAP View section, and then click the Editor
button to open the MAP View Editor.
«  MAP Views panel: select a MAP View, and then select Edit under the Options arrow in the upper right
corner of the panel. Alternatively, double-click the MAP View name in the MAP Views panel.

Preview Pane and Configure Previews

By default, the Preview Pane displays the data extents with a green rectangle and the MAP View orientation with an
arrow pointing north. To move the data on the page, click inside the green rectangle and drag the data to a more
suitable position relative to the page. Use the Zoom In, Zoom Out and Center buttons to set the magnification of the
preview. To move the page within the Preview Pane, click outside the MAP View extent and drag to move the page.

The Previews drop-down list changes the preview to Coloured boxes (previews up to ten MAP views, each with
different colours as specified in the Configure Previews settings), Thumbnails (preview a reduced image of the
document contents, including all MAP views) and Thumbnails & Boxes (shows both thumbnails and coloured boxes
of up to 10 MAP views in the document).

Note: Due to Adobe lllustrator rasterization limitations, thumbnails cannot be created for very large MAP Views.

To configure the previews, click the Configure Previews button []. To adjust the colour of the current MAP View
preview, click the colour chip and choose a colour in the colour picker dialog box. Layer visibility can be individually
toggled under the Visible column. Use the Show All or Hide All buttons to toggle the visibility of the entire list. To
toggle only the layers of a particular MAP View, right-click the MAP View to access a context menu that has the
options to Show All or Hide All. Adjust thumbnail quality using the drop-down list at the bottom of the dialog box.
Quality settings include: Low, Medium, High, and Very High.

Configure Preview I Current MAP View preview colour
4 Click to change the colour
Current MAP View preview colour: . oK

Name
MAP View 4 @ [ USAMAP View
0 Legend
0 Scale Bar
[T State Names
Pl uscities_point
L] usroads_line
A USImage
2 @ [ World
P! Capitals
Al World_area
0 Graticule
[A waterbackground
a @ [ hawaii
A hawaii_area copy
A hawaii_area
4 |/ Non-MAP Layers
¥ Layerl

il quality Thumbnail quality:

Cancel

Show Al

MAP Layers
Hide All

Toggle Visibility (layer's thumbnails)

Toggle Visibility (MAP View's coloured box)

0 ODOOO00O0O00RRREEE §

Note: The Auto-Scale function will apply to the extent of the visible layers only.
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MAP View Name

The current name of the MAP View is listed in the Name box, which can be edited. MAP Views are ordered
alphabetically in the MAP Views panel, so changing a MAP View name may change its position in the panel.

Scale

The scale of the current MAP View is shown in the Scale box. For MAP Views in a projected coordinate system, the
scale value is a real world scale (exact ratio linear distance on the page over distance on the ground). For MAP Views
in a geodetic coordinate system (i.e. Lat/Long format in angular unit), the scale value is approximated using the
common formula 1°= 111.353m (metres per degree at the equator). This is not an accurate number because the
formula is only valid at the equator, but it is more intuitive for cartographic considerations.

The scale can be edited by typing in a precise value or by using the Up and Down arrows to increase or decrease the
scale by 10% of the starting value. The Auto-scale button applies the scale to fit the visible data in the preview to the
artboard or margins and centers the map on the page (see Preview Pane). Click the Auto-scale drop-down arrow to
use either the artboard or margins as the scale extent.

Rotation

A rotation figure can be applied or edited by specifying an angle in the entry field, or by using the arrow buttons.
Notice that changes to rotation will be automatically previewed in the Preview Pane with the green rectangle and
arrow depicting the new orientation of the data. Click |# ] button to reset the angle to 0. Click [In] button to orient
the MAP View True North up (True North is calculated at the center of the data extents).

Page Alignment

During the import process, MAPublisher sets the page and map anchors so that the lower left corner of the
artboard coincides with the lower left corner of the map extents. Note that Adobe lllustrator CS4 and CS5 use
different locations for the page origin, with (0,0) being located in the lower left corner in CS4 and (0,0) located in the
upper left corner in CS5. Use the Page Alignment settings to precisely move the data on the page. In the LLX/LLY boxes,
edit the position of the lower left corner of the data extents in document units. Alternatively, the alignment control
provides pre-set positions of the map extents relative to the page (center-middle, lower-left, upper-right, etc.). Click
one of the alignment control grid locations to align the MAP View.

Notes: Editing the lower left corner position does not affect data integrity. It simply means that the data is shifted on
the page but the corresponding real world coordinates remain unchanged.

The Page Anchor does not always coincide with the lower left corner of the map extent. When manually
registering an Adobe document, users can also enter a specific position using the MAP Views panel options
menu Specify Anchors (see first section of this chapter).
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Set Source Coordinate System

In most cases, the MAP View source coordinate system is initially assigned during the import process if the imported
data file contains such information (see chapter 3). To view the properties of the source coordinate system, click the
info button.

If no coordinate system is recognized during the import, the resulting MAP View source coordinate system is set
to [No Coordinate System Specified]. In order to scale, rotate or transform the MAP View, a coordinate system must
be specified. To do so, click the coordinate system link to open the Specify Source Coordinate System dialog box (explained
below). Alternatively, use From File to set the source coordinate system using an external file (e.g. .wkt, .map, .prj, or
.tab).

Note: If you are referencing a non-georeferenced Adobe Illustrator file, it is not enough to specify the source
coordinate system to reference your map, you'll also need to specify appropriate map and page anchors. See
Georeferencing an Adobe lllustrator file in appendix A1 General Tips.

In some rare cases, the source coordinate system may have been wrongly assigned during the import process
(due to a wrong manual selection or file issue). In this case, users may want to specify another coordinate system.
This should be done with caution as data integrity may be lost if the current coordinate system is mistakenly
overwritten. Changing the source coordinate system does not affect the data geometry on the page. To specify a
new coordinate system for a MAP View, use Perform Coordinate System Transformation.

Coordinate System Transformation

To transform a MAP View to another coordinate system using the MAP View Editor, click the Perform Coordinate System
Transformation check box (the MAP View must contain data and a source coordinate system for this option to be
available). Users have three options to select the destination coordinate system:

«  Select a coordinate system from the MAPublisher database: click the coordinate system link in the Perform
Coordinate System Transformation frame to open the Specify Destination Coordinate System dialog box.

«  Select a coordinate system used by another MAP View in the document: click the Same as check box and
select the appropriate MAP View in the drop-down list. This does not affect the page position.

«  Select a coordinate system from another file: click From File to set the destination coordinate system
using an external file (e.g. .wkt, .map, .prj, or .tab).

The Preview Pane displays the new data extents for the transformed MAP View, however the thumbnails view is not
available until the transformation is finalized by clicking the OK button in the MAP View Editor.

Some coordinate system transformations require a datum shift. When this is the case, MAPublisher selects the most
appropriate datum transformation. This can be edited by clicking the Specify button in the datum shifts frame and
selecting another datum transformation (see appendix A2 and Avenza Projections Guide.pdf for more information).

Note: Coordinate system transformations can also be performed in the MAP Views panel. Simply drag a MAP layer
from one MAP View to another MAP View of a different coordinate system.
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Specify Coordinate System

The Specify Source/Destination Coordinate System dialog boxes allow users to select, copy and edit coordinate systems and
associated parameters from the MAPublisher coordinate systems (Geodetic Data Source). The MAPublisher Geodetic
Datasource is explained in depth in Appendix A2.

Coordinate systems are divided in two categories: Geodetic and Projected. For convenience, they are sorted in sub-
folders by continent > country > sub-division (e.g. state or county). The *All* category lists all systems with no sorting;
the *Recent* category lists the last 10 systems recently selected; the *Search* category lists the result of a coordinate
system search. The MAPublisher coordinate systems may also contain custom systems.

New MAP Views

After clicking the New MAP View button, the MAP View Editor opens for users to set the name, coordinate system and
page scaling of the new MAP View. After a new MAP View is created, the Specify Anchors option from the MAP Views
panel must be used to define the tie-in point between Map Anchor and Page Anchor. Map Anchor coordinates can
be entered in any chosen coordinate system (for example, latitude and longitude in degree for projected map). This
functionality is explained in detail in Georeferencing an Adobe lllustrator file in appendix A1 General Tips.

Long/Lat Order (optional)

Enable the Show Latitude/Longitude ordering option in the MAPublisher Preferences for MAP Views > Editor (see chapter 1)
to see an additional item in the Lat/Lon Order drop-down list:

LatfLong Order: ’Longitude, latitude v]

The latitude/longitude order—Longitude, latitude or Latitude, longitude—applies to the following tools or panels:
MAP Info, MAP Point Plotter and Line Plotter.

Scaling

When the map scale changes, the point size, stroke and text font are maintained by default. To alter how scaling
affects these options, click the Scaling button in the MAP View Editor dialog box. In the Scaling dialog box, uncheck
the preferred options.

Scaling

Maintain point size when scaling
Maintain stroke width when scaling
Cancel

Maintsin text font size when scaling
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Multiple Artboards

Adobe lllustrator CS4 introduced the concept of multiple artboards (up to 100). MAPublisher uses this new feature
in the MAP View Editor.

When a document contains multiple artboards, the MAP View Editor dialog box has an additional option to select
the Active Artboard. When choosing the Active Artboard, the Preview Pane displays the number of each artboard. The
current active artboard is shown in white, while the others are greyed out. The Page Alignment and Scale calculations
are based on the Active Artboard dimensions.

To move the data extent (green box in the Preview Pane) from one artboard to another, change the Active Artboard
number to the artboard where the data is to be moved, then click the Auto-scale button or one of the Page
Alignment grid positions.

Edit "Lower US States”

;

Canel
Artboards - Preview of all artboards —
present on the canvas

Active Arthoard - White background —7

#o HoE P

Other Arthoards - Greyed out —

[ Acteartboars: 1y = [ Freviews:

Active Artboard- Select the number
of the artboard to be set as Active

Note: Adobe lllustrator CS4 and CS5 allows users to move artboards. However, this action does not preserve the
georeferencing (same effect as moving art on the active artboard). Instead of moving the artboard, users
must do the following:

«  Create a new artboard at the desired position on the canvas
«  Open the MAP View Editor and move the MAP View from the initial artboard to the new one
«  Delete the initial artboard
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Export MAP Layers and MAP Views

MAP Views panel > Export and buttons @ & (MAP View) w5 (MAP Layer)

Export "Lower 48"

— Settings - Opens a Settings dialog box for

Format - Select the export format for

the selected layer or MAP View Format:

[EsR1 shapefie

)
v || settings... oK

Dataset - Displays the directory path for Dataset:

Ci/Users/Desktop

Browse... Cancel

the export of the currently selected

Character encoding: lSystEm

the input of extra parameters (see below)

Character Encoding - Assign a codec if the

)

layer or MAP View

EXPORT SETTINGS

General Settings

Keep format extension - Check Settings

Export visible attributes

this option to export layers
with their feature extension
(_area, _line, _point, or _text)
which may have been
appended to layer names

[7] Keep format extension

only - Check this
option to export
only the attributes

Include header
Add the column
headers at the

= | "
Export visible attributes only ot

that are currently

visible in the MAP first line of the

exported text file

during import

AutoCAD Settings

Attributes panel

GML Settings

attribute information held in the selected
layer or MAP View uses a double byte
character set

Delimited XY Text Data /
Microsoft Excel

Settings

[] Keep format extension
Export wisible attributes only
Indude header

KML/KMZ Settings

Settings

[] Keep format extension @
Cancel

Release:

T R12 ) R2000
@ R13 ) R2004
T R14 @ R2007

hd
I

Semngs
Kee format extension

41 Export viskle atibuites orly
[ ¥.-¥ Coardimate Grdering:

& Reverse X coords for gesdetic coondnates (default behavowr]
| feverse X1 cosrdeates

Do ot reverse X4 soordnates

@ Feature Collection Options:
@ e sempie festures profie

Wit 10 plsn GML feature collections (can be resd by Global Mapper)

Settings

[7] Do not export atiributes (Google Maps compatible)

[7] Keep format extension

Export visble attributes only

[7] Use attributes’ Display Mame instead of Name
Create placemark icons from symbols

Wirite default symbol names as placemark names

I
Release - Specify the AutoCAD version
number to export to

Feature Collection Options - Select output GML schema
X-Y Coordinate Ordering - Set the X-Y coordinate ordering

for GML files. This may help in third-party software.

MIF/MID Settings

Settings

[”] Keep format extension

MicroStation Settings

EO0O Settings

Settings

Settings

[ Keep format extension
Allow area fils

Export visible attributes only

[7] suppress Pen and Brush lines

—t e [ Suppress Point symbols

(-t Delimiter:
@ Comma (default)
() Semicolon

5 Tab

b

Delimiter - Set the field delimiters to either
comma, semicolon or tab

— Suppress Point symbols - Check this option
to remove point symbols in the output
Maplnfo MID/MIF files

Suppress Pen and Brush lines - Check this option
to remove all pen and brush styles in the
output MaplInfo MID/MIF files

Export visible attributes only
Keep format extension

—e Coordinate Units: -re E00 Compression Levek
@ Master @) Mone
) UoR | Partial
) Full
e Seed File:

[ e | ¢

Seed File - If required, select a seed file to be applied
to the exported dgn file . Click Clear to remove the
seed file selection.

L Coordinate Units - Specifies how feature coordinates
will be interpreted and converted (Master, Sub or
Units of Resolution).

L— Allow area fills - Controls whether or not fill linkages

will be written out for ellipses, shapes, and solids.
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FUNCTIONALITY

MAPublisher supports the export of single MAP Layers or whole MAP Views to various GIS and table formats,
maintaining all georeferencing and attribute information. The following export formats are supported:

AutoCAD Drawing/Interchange (*.dwg, *.dxf) Microsoft Excel (*.xls)

Delimited Text Data (*.csv, *.tsv, *.txt) GML (Simple Features 3.1.1) (*.gml, *.xsd)
Esri Arcinfo Generate (*.gen) KML/KMZ (*.kml, *.kmz)

Esri Interchange File (*.e00) Maplinfo MIF/MID (*.mif, *.mid)

Esri Shapefile (*.shp) Maplinfo TAB (*.tab)

Image (*.tif with reference file, see chapter 12) Microstation Design (*.dgn)

Notes: Exporting a MAP View to CAD or MicroStation format will assemble all hosted layers into a single file.
Exporting a MAP View to Flash map or Geospatial PDF is explained in chapter 15 and 16, respectively.

Only Point MAP Layers can be exported to Excel and delimited text data formats.

PREREQUISITES

The Export function exports a single selected Adobe Illustrator layer contained in a MAP View or all layers contained
in a selected MAP View. Both imported and user created MAP Views that contain MAP Layers are suitable for export
to GIS formats.

USING MAP EXPORT

Export a MAP View

To export all the MAP layers within a single MAP View, select the MAP View to be exported in the MAP Views panel,
then click the Export MAP View button CSE Alternatively, click Export "[MAP View name]" in the panel options menu.

Export a MAP Layer

To export a single layer, select the MAP Layer to be exported in the MAP Views panel, then click Export MAP Layer
button g £ . Alternatively, click Export "[MAP View name]" in the panel options menu. In the Export layer dialog box,
choose the required export Format. Click the Settings button for additional options.

Note: Only a single MAP View or a single layer can be exported at one time.

Keep Format Extension

The name of the MAP Layer or MAP View selected for export is the default name of the exported file. However
the feature type text (i.e. _area, _line, _point, or _text) appended to Adobe Illustrator layers by MAPublisher in the
Import process, are removed during the export process, unless the Keep format extension option is checked.
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Export Visible Attributes

Enable this option to export only the attributes that are currently visible in the MAP Attributes panel. If this option is
not checked, all attribute columns (including MAPublisher #Property attributes) are exported.

Format Specific Settings

Depending on the selected export format, additional specific settings may be available. This is the case for the
following formats: AutoCAD, Delimited XY Text Data, MicroStation, MID/MIF, EOO and KML/KMZ. See the Export
Settings above. When exporting to KML/KMZ, specify the format extension (*.kml or *.kmz) in the Select Export File
dialog box (Save As Type drop-down list).

Note: KML/KMZ format only supports WGS84 geodetic coordinate system. Export to KML/KMZ will automatically
transform the vector data from the MAP View's coordinate system to this system as part of the export process.

Choose a Destination Folder

Most of the export formats require the selection of a destination folder only. For export to Esri or Maplnfo formats,
click the Browse button to specify a destination folder. Click the OK button to export your MAP Layer.

When exporting to AutoCAD format, it is required to specify a name for the exported file, and select the file extension
(*.dxf or *.dwg) to be used. For MicroStation formats, it is required to specify a name for the exported file. To export
to either of these formats, click the Browse button to name the export file, and then choose the file format from the
Format drop-down list.

ADDITIONAL NOTES

Valid Area Direction (Area Layer Exports)

When exporting area layers to GIS formats, polygon outlines must have a positive Area value, whereas holes
contained inside compound paths (or complex shapes) must have a negative Area value. If some polygons in the
#Area property column of the MAP Attribute table contradict these guidelines, use the following tools to convert
the MAPublisher area calculation from a negative to a positive value or vice versa:

«  FlipLines tool (chapter 8) to convert multiple areas.

«  Create a Selection Filter (chapter 11) to select all elements that have an #Area of less than zero (to select
negative values) or greater than zero (to select positive values). Then use the Flip Lines tool.

«  Edit the #AreaDirection property value (chapter 5) to convert areas one by one: select the area to edit
and then choose the alternate value for #AreaDirection in the MAP Attributes panel.

Text Exports

It is not possible to export values in the #Text property column. An alternative is to create a new string attribute
column and assign it an expression of #Text. See Edit Schema in chapter 5 on MAP Attributes.

Texts on a path are exported as point text with an angle (main direction of the original path).
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MAP Info Panel

Window > MAPublisher > MAP Info or MAP Toolbar > MAP Info | |

Displays the parameters of the currently selected layer.

WX/WY - The X and Y coordinates of the

. B H MAP INFO
cursor in current map units

Longitude: -110.173011 Latitude: 161.825047
Geodetic Longitude/Latitude - The longitude Gaodstic - Longituds: Szame as zbove itk B rmoasinn Scale - Map scale of the current layer
and latitude based on the geodetic Scale 13 65,099,621.822375 Angle: 0.00° Angle - Angle of rotation
datum of the coordinate system Map X: -178.21760 PageX: 336476 px ol
WGS84 Longitude/Latitude - The longitude » Map Y: 1852480 Page Y: 791.555570 px : Page X/Y - Page anchors

X : Coordinate System: NADZ7 :

and latitude based on t.he World : - ¢ MapX/Y - Map anchors
Geodetic System Lo B H

Coordinate System - Coordinate system of
the current layer (if specified)

Units - Units of the coordinate system :
(if specified)

FUNCTIONALITY

The MAPublisher MAP Info panel displays the coordinates of the mouse cursor on the selected map layer, in current
Map Units and in Degrees. Geodetic latitude and longitude values are in reference to the geodetic datum set in the
coordinate system definition. The WGS84 latitude and longitude values are in reference to the World Geodetic
System. Ungeoreferenced layers display its coordinates in Page Units. The panel also displays the Map and Page Anchors,
the Scale, Angle of rotation and the Coordinate System and Units of the MAP Layer.

USING THE MAP INFO PANEL

To use the MAP Info panel, click the (<] button in Adobe lllustrator Tools panel, in the MAP Toolbar or open the panel
through Window > MAPublisher > MAP Info. The map coordinates update in the panel with every change of the
location of the mouse cursor.

The map units correspond to the units of the currently selected layer. If the selected layer is a MAP Layer, the units
are taken from the MAP View's source coordinate system. If the selected layer in a Non MAP Layer, the units of the
Adobe lllustrator documents are used (see File > Document Setup).

To show Geodetic, WGS84 or MGRS (Military MAP INFO ” = v | Show Geodetic Base
. . Longitude: -79.251733 Latitude: 43.718571
Grlq Reference System) values, click the~ panel el e Lottudie: Some oe 2bonre Show WS84
options menu and choose the appropriate Scale 11 74,730.131342 Angle: -30.00° Show MGRS
H H H Map X: -79.41153 Page X: 54.738328 px
display. The pgnel will update to display the s enion paae s a9mcatet e T
chosen coordinate values. Coordinate System: WGS 54
Units: Degres

Notes: The map coordinates update even when other tools are selected.

When the cursor is placed outside of the MAP View extent of the selected layer, positions' values are
indicated as Unavailable.
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Copy MAP Objects From

MAP Views panel > Copy MAP Objects From or MAP Toolbar @

3

Copy MAP Objects From

Check the MAP Objects to copy:
Document - Available open Object
map document a Exercise2-12.ai
4 @ MAP Views
MAP Views - List of available @ Chicagoland
MAP Views to import 4 T MAP Themes

Census Median Age
G0 Male vs Female
Metra System Stylesheet

. ) Pink - Census Median Age
MAP Selections - List of available Population Density

MAP Selections to import *# Population Distribution

4 5F MAP Selections
] Manual School Selection
(@ Select Schools in West Town
Fe Select West Town Community

Source Toggle - Click
checkbox to select
MAP Objects in source
document for copy to
the active document

MAP Themes - List of available
MAP Themes to import

OOEEOODO0OO0ORE

Copy MAP layers belonging to copied MAP Views

FUNCTIONALITY

The Copy MAP Objects From feature copies MAP objects from an open document to another open document,
including all MAP Views and the layers that are within them, MAP Themes, and MAP Selections. This can be a useful
tool when merging parts of several documents into a single document. For example, it might be useful to import a
commonly used inset map.

PREREQUISITES

At least two Adobe lllustrator documents must be open to use Copy MAP Objects From. The active document does
not need to contain any MAP View, but the second document must contain at least one MAP View.

Note: Copy MAP Objects From imports all the layers contained in the selected MAP View. To choose specific MAP
layers to import, in the source document, make a duplicate of the MAP View and copy or move only selected
layers to it. Then proceed to import the duplicate MAP View.

USING COPY MAP OBJECTS FROM

Click the Copy MAP Objects From button @ on the MAPublisher Toolbar or click Copy MAP Objects From in the MAP Views
panel options menu.

The Copy MAP Objects From dialog box shows all other documents currently open, along with all the MAP Views,
MAP Themes and MAP Selections they contain. Click the toggles to select at least one MAP object to be copied from

the source document and click OK to copy it to the active document.

Note: Copy MAP Objects From can also be accessed in the MAP Themes and MAP Selections panel options menus.
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MAP
Attributes

MAPublisher can import GIS files into Adobe lllustrator while
maintaining both geographic referencing and attribute
information. This makes it very easy to produce high quality
maps.

Attribute information can be used in many powerful
MAPublisher functions such as MAPublisher labeling engines,
MAP Themes, MAP Selections and MAP Web Author.

This section explains the principles of attribute information
and how they are manipulated within MAPublisher.

Topics covered in this section are:
Attributes Foreword

MAP Attributes Panel

Edit Schema

Expression Builder

Find & Replace Attributes
Apply Expression

Join Table

Export Attributes
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Attributes Foreword

ATTRIBUTE INFORMATION

The attribute table that forms part of a GIS map file is one of the most important parts of the data set. It is in the
attribute table that we find important information such as street names for lines, zoning or zip code numbers for
areas and elevations for points to go along with our line, area or point vector data. Along with line, area and point
vector data imported as explained in the previous sections, MAPublisher also imports the attribute data table
associated with any vector map file that it supports.

MAP LAYERS

All MAP Layers contain attribute information (except Legend MAP Layers). Each MAP Layer is symbolized in
MAPublisher panels and dialog boxes with an icon depicting its feature type:

[Al Arealayer  (e.g. county boundaries, urban areas, country outlines)
Line layer (e.g. rivers, roads, railways)

P Pointlayer  (e.g. town and city symbols, railway stations)

Text layer (e.g. city labels)

Image layer (e.g. background terrain shading, orthoimagery)

MAPUBLISHER #PROPERTY ATTRIBUTES

In addition to the attribute values that were imported into a work session, Area, Line, Point, Text and Image MAP
Layers are also assigned a number of additional MAPublisher attribute columns. These property columns (prefixed
with a #) are designed to indicate the physical properties of map art on the Adobe lllustrator canvas. Art can be
modified directly from the attribute table by making edits to values in these columns. The following property
columns are attached to valid map layers in this version of MAPublisher:

Area layers
#LayerName
#ID

#Name
#AreaDirection
#VertexCount
#Style
#StrokeWeight
#Perimeter
#PathClosed
#ArtScale
#Area
#Opacity

The name of the containing layer. This property cannot be set.

The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
The name of the polygon. Editing this property will change the name in the Layers panel.
The direction as clockwise or counter-clockwise. Editing it will reverse the direction.

The number of points in the art. This property cannot be set.

The Graphic Style in use. Editing this property will apply the selected style to the art.

The stroke weight of the path. Editing this property will alter the stroke weight of the art.
The perimeter of the area in world units. This property cannot be set.

Describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
The scaling of the line stroke. Editing this value will scale the stroke weight.

The area of the path in world units. This property cannot be set.

The opatcity level of the polygon. Editing this property will change the opacity of the art.
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Line layers
#LayerName
#ID

#Name
#VertexCount
#Style
#StrokeWeight
#PathClosed
#Length
#ArtScale
#Opacity

P Point layers
#LayerName
#PageX

#PageY

#ID

#Name
#HorizontalScale
#VerticalScale
#Rotation
#Style

#MapX

#MapY
#Opacity

Text layers

#LayerName
#PageX

#PageY

#ID

#FontSize
#FontFamily
#Name

#Text
#TextLength
#Rotation
#Style

#MapX
#MapY
#HorizontalScale
#VerticalScale
#Opacity

The name of the containing layer. This property cannot be set.

The internal unique ID to refer to Adobe lllustrator artwork within the document. Read-only.

The name of the polygon. Editing this property will change the name in the Layers panel.

The number of points in the art. This property cannot be set.

The Graphic Style in use. Editing this property will apply the selected style to the art.

The stroke weight of the path. Editing this property will alter the stroke weight of the art.
Describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
The length of the path in world units. This property cannot be set.

The scaling of the line stroke. Editing this value will scale the stroke weight.

The opacity level of the polygon. Editing this property will change the opacity of the art.

The name of the containing layer. This property cannot be set.

The x-coordinate in the document units of the current point.

The y-coordinate in the document units of the current point.

The internal unique ID to refer to Adobe lllustrator artwork within the document. Read-only.
The name of the point. Editing this property will change the name in the Layers panel.

The horizontal scaling of a point object. Editing this value will scale the symbol in the X axis.
The vertical scaling of a point object. Editing this value will scale the symbol in the Y axis.
The rotation in degrees of the art around its anchor point. Editing this value will rotate art.
The Symbol in use. Editing this property will apply the selected symbol to the art.

The x-coordinate in the world units of the current point.

The y-coordinate in the world units of the current point.

The opacity level of the polygon. Editing this property will change the opacity of the art.

The name of the containing layer. This property cannot be set.

The x-coordinate in the document units of the current point text. For text-on-a-path or text-in-a-
path, this will be the x-coordinate of the first vertex on the associated path.

The y-coordinate in the document units of the current point. For text-on-a-path or text-in-a-path, this
will be the y-coordinate of the first vertex on the associated path.

The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.

The font size used by the text.

The font family used by the text.

The name of the text field. Editing this property will change the name in the Layers panel.

The contents of the text. Editing this will affect text on the page. Multiline text is allowed.

The number of characters in the contents of the text art. This property cannot be set.

The rotation in degrees of the art around its anchor point. Editing this value will rotate art.

The Character Style in use. Editing this property will apply the selected style to the art.

The x-coordinate in the world units of the current point.

The y-coordinate in the world units of the current point.

The horizontal scaling of a point object. Editing this value will scale the text in the X axis.

The vertical scaling of a point object. Editing this value will scale the text in the Y axis.

The opatcity level of the polygon. Editing this property will change the opacity of the art.
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Image layers

#LayerName The name of the containing layer. This property cannot be set.

#ID The internal unique ID to refer to Adobe lllustrator artwork within the document. Read-only.
#Name The name of the text field. Editing this property will change the name in the Layers panel.
#PixelWidth The number of pixels across the width of the image.

#PixelHeight The number of pixels across the height of the image.

#Opacity The opacity level of the image. Editing this property will change the opacity of the image.
#lLowerLeftX The lower left X coordinate of the image. Read-only.

#lLowerLeftY The lower left Y coordinate of the image. Read-only.

#UpperLeftX The upper left X coordinate of the image. Read-only.

#UpperLeftY The upper left Y coordinate of the image. Read-only.

#UpperRightX The upper right X coordinate of the image. Read-only.
#UpperRightY The upper right Y coordinate of the image. Read-only.
#LowerRightX The lower right X coordinate of the image. Read-only.
#LowerRightY The lower right Y coordinate of the image. Read-only.

Warning: The #ID property is not persistent. This means that if a document is saved and re-opened, the #ID value
might change. The value will usually not change over the life of a document session, but there are Adobe
Illustrator operations that can cause the value to change.

IMPORTANT ADOBE ILLUSTRATOR COMPATIBILITY NOTES

Several Adobe lllustrator functions may cause the link between artwork objects and their attributes to be broken,
resulting in possible data loss. These functions are:

Compound path (Make) +  Blob brush (Adobe lllustrator CS4)
Pathfinder «  Shape-builder tool (Adobe lllustrator CS5)
Live Paint «  EraserTool

Gradient mesh - KnifeTool

By default, releasing a compound path also breaks the link between released paths and the attributes. To avoid
this behaviour, users may enable the option Replicate attribute data to compound path sub-components in the MAPublisher
Preferences for MAP Attributes. This option must be enabled before the attribute schema is created or updated for
the attribute data to be copied to the compound path components. To fully enable this option, follow the simple
steps below:

1. Enable Replicate attribute data to compound path sub-components.
2. Change the visibility status of one attribute column to force the attribute schema to update itself.
3. Release the compound path.

Note: This option has an impact on performance, so it should only be enabled if necessary.

If required, users should first duplicate their working layer in the Adobe lllustrator Layers panel before using these
functions. The original layer can be kept for labeling (see chapter 10 and 18) or for information purposes.
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Layer Selection - If data is —
selected on a number of
layers, select the map layer
containing the attributes to
be viewed with this list

e Layer: [ [A] Lower43_area (49 areas selected)

MAP ATTRIBUTES

MAP Attributes Panel

Window > MAPublisher > MAP Attributes and MAP Toolbar

Pin Current Selection - Attributes remain
active even after art is deselected

Click header to sort column
values alpha/numerically

Attributes and Properties
Attribute and property
values on the selected layer
are displayed here

Recordset Navigation - Navigate:
through table records using

[Sl#Style  [BI#PathClosed [RIAREA STATg_NAME [SISUB_REGION  [MIPOPULATION =
Aidsl 51,715.786 Alabama E5Cen 4,447,100 ‘El
Aids2 113,712,679 Arizona Mountain 5,130,632
Aids1 52,913.232 Arkansas WS Cen 2,673,400

[ Aidsd 157,776.310 California Pacific 33,871,648
Aids2 104,101.231 Coelorado Meuntain 4,301,261
Aids2 4,976.566 Connecticut N Eng 3,405,565
Aidsl 2,054.586 Delaware S At 783,600
Aids2 66.063 District of Colu... 572059

i |

e 49 areas selected

these controls and indicatorJ—

Selected objects - Number
of objects selected on the
current layer

Context menus

Right-click (Windows) or Ctrl-click (Mac) to display the menus:

In column header:
Resize oll to fit content
Resize "ARFA’ to fit content

e

-

Hide Colwmn.
New Column
Foit "ARFA"...
DOelate ‘AREA

Show/Hide Columns "

OE

Resize [column] to fit content
Resize only the selected
columns

—— Resize all to fit content

Resize the width of all columns

to fit the longest value

FUNCTIONALITY

Highlight Feature - Click the feature — |

attribute to highlight that feature
on your map

Panel options menu:

New Column

In arow:
e - Edit "SUB_REGION"...
1% ZoomTo Festure Hide Column - To hide the Delete "SUB_REGION®
o currently selected column 7 I
i Mew Cotumn. e————— New Column - Adds a new legizzrmid]
W Edit'AREA".. column to the attribute table Edit Schema
= Delete ARER | _ Find & Replace...
Shaw/Hide Calumns & Show All Apply Expression.

Shaw All Except Properties Join Table.

Hidhe 211 Add Caleulated Data,

Export Attributes...
L]

sharne Preferences..

#hreaDirection
FerterCount
tyle
=HtrokeWeight

EPerimeter

sEEEEEEB

Edit Schema - Edit the properties of
all columns of the current attribute
table: column names, visibility,
type and width, assign expressions
to columns

Find & Replace - Click to find and
replace attributes in the current
attribute table

—— Apply Expression - To assign attribute

values or graphical properties to
selected art via the input of an
expression

JoinTable - Click to join an external data
table to the current attribute table

Zoom to Feature - Click the Feature
number or right click the attribute
and select Zoom to Feature

Show/Hide Columns - Enable or
disable column names to show or
hide columns. Or choose to show
all columns, or hide all columns.

Edit Column - Edit the properties
of the selected column

Delete Column - Delete the
currently selected column
Auto-Zoom - When enabled, the
map document will zoom to the
selected attribute automatically
Lock Zoom Level - When enabled,
locks the zoom level

Add Calculated Data - Add or

edit an attribute column with
calculated data

Export attributes - Export all
selected attribute information
to a delimited text file

Preferences - Opens the MAP
Attributes panel preferences
(see chapter 1)

The MAP Attributes panel displays the map attribute and property attribute records for a map layer, which are
linked to the graphic elements of the map, and makes them available for editing. This panel is also the hub from
which you can edit column schemas, toggle visibility, add or delete columns, join tables, find and replace attributes,
and apply expressions to selected art. Only the visible attributes of selected map features will be displayed in the

dialog box.

USING THE MAP ATTRIBUTES PANEL

Viewing Attributes

Selected features are sorted by layer. The Layer drop-down list shows all the layers that currently have features
selected, as well as the number of selected map objects for each layer (also reported at the base of the panel). The
attribute values displayed in columns in the MAP Attributes panel can be sorted in ascending or descending order
by clicking the column header. The widths of the columns may be changed by clicking the column separator and
manually dragging it to resize as desired. Use the recordset navigation controls to scroll through table entries.
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The type of attribute is indicated by an icon preceding the column name:
[E| Boolean: column contains True or False values
[Il Integer: column contains only whole numbers (limited to 10 digits)
Jil Real: column contains numbers carrying decimal values
String: column can contain attributes that are both alpha and numeric

Edit Attributes

The MAP Attributes panel is a table that displays all the attributes of selected art. All attribute values may be
edited except for certain MAPublisher Property attributes (see earlier in this chapter). To change the value of a cell,
double-click it and enter the new value. Keep in mind that entered values must correspond with the column type
(i.e. only enter numbers into a column of type Real or Integer). The edits will be immediately reflected in the map
documents database records. Existing attribute records may also be edited or modified by performing a find and
replace operation on them.

Column Visibility

Click the Show/Hide Columns button (or right-click [Windows] or Ctrl+click [Mac] on a column in the dialog box) to edit
the column visibility, either toggling visibility for individual columns or for all columns. It is also possible to edit the
visibility of attribute columns with the Edit Schema tool.

This function will also Show All, Show All Except Properties (show only attributes that are non-property attributes,
consequently hiding any visible property attributes) or Hide All.

Zoom to Feature and Auto-Zoom

To zoom into a specific feature in the attribute table, select a single attribute and click the Zoom to Feature button. This
will automatically fit this feature to the screen and highlight it—useful for closer examination or to simply locate it
on the map. To highlight a specific feature on the page maintaining the current zoom level, click another attribute
of that feature.

To automatically zoom to a selected feature, enable Auto-Zoom in the panel options menu. As long as it is enabled,
the zoom will change every time a different feature is selected. Use Lock Zoom Level to maintain the same zoom level
for all features selected afterwards.

Property Attributes

The attribute table can also be configured to display property attributes for datasets. These attributes describe the
current assignment of graphical properties such as the stroke weight, style, rotation and scale. Some of these fields
can be edited and provide the ability to modify a map object's graphical properties directly within the context of
the MAP Attributes panel.

Pin Attributes

Click the Pin button to keep selected attributes active even after the artwork is unselected. This may be helpful
during attribute editing when accidentally unselecting artwork may occur. To unpin attributes, click the Pin button
again. When attributes are pinned, attribute values can be manually edited but the functions at the bottom of the
panel are disabled except for Zoom to Feature (Show/Hide columns, Edit Schema, Find and Replace, Apply Expression,
Join Table and Add Calculated). The Export Attributes function is also disabled.
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Edit Schema

MAP Attributes panel > Edit Schema / Edit Column / New Column

Edit Schema
1 Name - Edit the name of the
(4] [m | Name: STATE_NAME selected column
. £ —
Up/Down - Click to move the — ] g Rzam; . Display Name; STATE NAVE m Display Name - Ediit the column

selected column up or down reaLirechon i
the column st Afchts order M #VerterCount = Sig ) display name

X C [§] #Style

in the attribute table. || size: 25 = Type - Choose column type:

#StrokeWeight
#Perimeter
B #PathClosed

Column list - Attribute and
(#) property columns on the N Size / Decimals - Adjust the length
current layer are listed here. ﬂi’ts‘“‘e Visible of String type or number
. rea I .
Select a column here to edit - of decimals of Real type

a I bt AREA [ rRead-only
its properties on the right. STATE_MNAME [7] Derive value from expression:

STATE_FIPS .
B :

IS SUB_REGION ¥pression & @

[S] STATE ABBR S

Add - Click to add a new Visibility - Choose to show or

column to the column list hide the selected column

Integer, Real, String or Boolean
Defauit Value:

Default Value - Assign the
same value to all items in the
selected column, if required

Read-only - Check this option
to ensure that values in this
column can not be edited

Remove - Click to delete —'  perive value from expression - Check this option to assign
the selected column an expression to the selected column. Either enter
the expression directly into the entry field, or click the
Browse button to access the Expression Builder dialog box.

In MAPublisher, the term schema is used to define the structure of the MAP Attributes table.

FUNCTIONALITY

The Edit Schema function provides settings to edit and manage the attribute structure of datasets, create, edit and
delete columns, set visibility preferences and assign expressions. Any changes made to the schema will instantly be
reflected in the MAP Attributes panel.

USING EDIT SCHEMA |

Select map artwork containing attributes to populate the MAP Attributes panel. Click the Edit Schema button or
menu item in the MAP Attributes panel options menu to open the Edit Schema dialog box.

Note: Edit Schema can also be accessed via the Edit Column context menu. Within the MAP Attributes panel, select
the column to be edited, right-click the column heading or cell and click Edit [column name]. Edit Schema opens
with the same column immediately selected in the column list.

Edit Schema lists all of the columns which currently exist in the MAP Layer attribute structure, including MAPublisher
Property attributes (see previous section). By default, imported or created attributes will be visible, whereas property
columns will not be shown by default. Please note some #Property column structures cannot be edited (read-only).

Edit Column Format

Each column has a name and display name. The name is used in the expression builder and for export. The display
name is used when exporting to geospatial PDF (see chapter 16) and is shown by default in the column name in the
MAP Attributes panel (see MAPublisher Preferences in chapter 1).

Punctuation characters are not supported in column names in order to avoid potential conflicts when exporting to
external formats. The following illegal characters are replaced with an underscore '_" upon data import or join table:
space - ~ 1 @ #$ %N r&*(C))Y-+={FYLTI;::""\N,<._.>/7
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To rename a column enter new text directly into the Name field. All expressions referring to this attribute name are
updated instantaneously.

Note: Some external file formats have limits on the number of characters allowed for field names. Therefore, during
the export from MAPublisher, some field names may get truncated to comply to the chosen external file
format. For example, Esri shapefiles are limited to 10 characters (confirmed up to ArcGIS 9.3), Esri Interchange
File (.e00) to 16 characters, and Maplnfo to 30 characters.

Once the name is set, specify a data type by making the appropriate selection in the Type list.

To modify the amount of characters or decimals, enter a value into the Size/Decimal text box (the maximum string
size is 28000). A Default Value can be assigned for all new objects placed on the selected layer by entering text
accordingly. Check or uncheck the Visible option to edit a column’s visibility. Check or uncheck the Read-only option
to edit a column’s read/write status.

Check the Derive value from expression option to assign an expression to the selected column. Enter a valid expression
in the Expression field or click the Browse button to enter and edit expressions via the Expression Builder dialog box.
The Expression Validity icon ¥ will report if the expression entered is valid. Otherwise it will report 2 and include
additional warning notes. This function is useful, for example, to populate the column values based on the contents
of other columns and/or mathematical formulas.

Note: Values derived from expressions are dynamically linked to the attributes used in the expression. Therefore,
they are read-only. Use the Apply Expression function to generate values that can be modified.

The following are some examples of basic expressions that can be assigned to columns in Edit Schema:

Basic expression Result

“Ontario” (applied to column = NAME) All items are assigned the value “Ontario” in the NAME column.

All area items are assigned the value “MAP Area 01" in the #Style column and

MAP Area 01" (applied to column = #5tyle) are assigned the Graphic Style “MAP Area 01" on the page.

All point items are assigned the value 45 in the #Rotation column and are

45 (applied to column = #Rotation) rotated to 45° on the page

Note: String values are case-sensitive and must be entered between quotation marks (“.").

Add, Delete and Re-Order Columns

Columns display in the MAP Attributes panel according to the display order established in Edit Schema. The display
order of attribute columns in the MAP Attributes panel can be set by reordering the existing column list. Any
column may be moved up or down the list by selecting it and clicking the Up or Down buttons.

To create a new column, click the Add button and input the desired column properties. To delete an existing column,
choose it from the column list and click the Delete button. Click 0K to confirm the edits to the schema. These edits
will be immediately visible in the MAP Attributes panel.
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Expression Builder

Accessed from Edit Schema, Apply Expression, New/Edit MAP Selection,
Edit Chart Theme, Edit Stylesheet Theme, Rule Generator

Expression Builder

Expression Builder

Operator buttons - Click to insert an—-— E]E] B
operator into the expression at the
current cursor position POPULATION / AREA Cancel

Library - Access all expressions for the
| documentincluding recently used,
attribute filters, named expressions

— Save - Save the current expression to a

Expression Validity - Indicates if the named expression.
expression is valid « or invalid @.
If invalid, additional info is reported. Expression Entry - Area to compose
Advanced toggle - Click to show or hide — expressions

the Expression Components section o The expression is valid. Position: 17 Cursor Position - Position of the current

text entry point

columns, constants and functions for
use in the expression. Double-click
items to insert into expression.

Objects - List of attribute and property-l Lo x| Expression Companents

Description - Displays information about
bj L= the selected item in the Objects panel,
o [A Lowerd8_area STATE_NAME - i.e. a description and example of the
[T Constants function or constant, or information

Layer attributes - List of the attribute and

[

[ »

#tn i i
property columns g ﬂ;:e ;;':: 'Z_W regarding the format of the MAP layer
B =i Default Value: along with its attribute values.
Constants - List of constants for use in the — i . . )
o . [*4 Functions When selecting an attribute, click the
expression if required [RI 285 Refresh unigue values o . % N
| Acos link Display unique values* to display
Functions - List of functions for use in the —- [ AsIN ﬁ'r‘?f;';a the attribute values of the selected
expression if required R ATAN Arkansas attribute column.
[B coNTAINS California
cas ~| Colorada a2 *Display unique values only lists up
L to a maximum set in the MAPublisher

Preferences for the Expression builder (see
chapter 1 for more information)

Save Expression
This dialog box appears when the Save button is clicked

Save Named Expression

Mame: Expression Name -
Cancel

FUNCTIONALITY

The MAPublisher Edit Expression tool is used for the entry and editing of expressions. It is used in a number of
locations such as creating new attribute values and properties, making selections or apply styles. Expressions are
built using a combination of names, operators and functions.

Edit Expression provides functionality for a number of tools:

Edit Schema: To create or edit an expression for the generation of values in an attribute or column.
(MAP Attributes panel > Edit Schema > Derive value from expression)

Apply Expression: To apply an expression to an attribute or property column for selected art only.
(MAP Attributes panel > Apply Expression)

New/Edit MAP Selection (chapter 11): To create or edit expression criteria for use in selecting map data.
(MAP Selections panel > New/Edit MAP Selection)

Edit Stylesheet Theme (chapter 9): To create or edit an expression for use in styling map data.

(MAP Themes panel > Edit [Stylesheet Theme name] > Advanced Expression mode
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ENTER EXPRESSIONS

Expressions can be built by typing or by clicking the operator buttons and items in the Objects list (attribute name
and values, constants and functions). These items are colour coded for easy identification: attribute names in
purple, string values in orange, operators and numerical values in grey, constants in green and functions in black.
Click any of the operator buttons or double-click an item from the Objects list to insert it into the expression.

It is recommended to use the interface rather than the keyboard to build expressions, to guarantee functions are
formatted correctly (e.g. with brackets and appropriate case) and for attribute values of type strings, quotations
marks are added automatically. Note that expressions are case-sensitive. For string comparison, all strings values
can be converted to a same case using the appropriate function (LOWER(“string”) or UPPER(“string”)).

Validity

The validity of the expression will be displayed below the Expression Entry text area and will be updated as the
expression is built. The Expression Validity icon ¥ will report if the expression entered is valid. Otherwise it will report
& and include additional warning notes.

Operator Buttons

Click to insert an operator at the current cursor position. Available operators are as follows:

( Open clause operator < Logical less than comparator

) Close clause operator >  Logical greater than comparator

AND Logical AND operator +  Mathematical addition operator

OR  Logical OR operator - Mathematical subtraction operator

= Logical equal to comparator | Mathematical division operator

I= Logical not equal to comparator *  Mathematical multiplication operator
& Text concatenate operator
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Expression Components

Items in the Objects list are divided
into three function categories:
math, string and miscellaneous.
Information on a selected item is
displayed in the Description panel.
Double-click to insert an object at
the current cursor position.

<MAP Layer>*
List of attribute columns’

List of #property columns

Constants

[Bl #false Boolean false value

Bl #true Boolean true value

#pi mnumerical value (3.141592)

* Layer may vary depending on tool.
For Edit Schema, Apply Expression
and New/Edit MAP Selections, the
current layer is displayed. In Edit
Stylesheet Theme, all layers hosted by
the stylesheet are displayed.

1 Unique values contained in each
attribute column can be viewed in the
Description panel.

Notes: String values are case-sensitive
and must be entered in double

quotes (“.").

For functions using indexes for
text position (MID, SEARCH and
SPLIT), the first index number
is 0.

Function

Bl ABS

[ ACOS

[’ ASIN

Bl ATAN

B CONTAINS
Cos
DEGREES
ENDSWITH
FIXED
FROM_HEX
IF

IF_CASE
LEFT
LENGTH
LIKE

LOG

LN

MAX
MAX_COLNAME
MIN
MIN_COLNAME
LOWER

MID
NUMBER
POW
PROPER
RADIANS
RAND
REGEX
RIGHT
ROUND
ROUNDDOWN
ROUNDUP
SEARCH

[’ SIN

SPLIT

B SQRT

[B STARTSWITH
SUBSTITUTE
SUBSTITUTE_RX
[E TAN
TO_HEX
TRIM
UPPER

™

PR R Ao vEEREEDRE

S

HEHEE®H

Description

Absolute value of a number

Inverse of the cosine of an angle

Arcsine of an angle

Arctangent of an angle

True if source string contains search string

Cosine of an angle

Converts values from radians to degrees

Returns true the source string ends with the suffix string
Numbers as string values

Returns the decimal value of the hexadecimal string
Conditional statement

Conditional statement based on multiple cases

Extracts the first N characters of a string

Returns the number of characters in a string

Searches the source string using wild cards

Gets the logarithm of the value (base 10 log)

Gets the natural logarithm (base e log, e = 2.718281828)
Returns biggest attribute value

Returns name of attribute which has biggest value
Returns smallest attribute value

Returns name of attribute which has smallest value
Converts string to lower case

Extracts N characters of a string from a specified location
String values as numbers

Base to the power of an exponent

Strings converted to capital case

Converts values from degrees to radians

Generates a random value between zero (min) and value (max)
Searches the source string using a reqular expression
Extracts the last N characters of a string

Rounds to specified decimals of precision

Rounds down to specified decimals of precision

Rounds up to specified decimals of precision

Returns the position of a character in a string

The sine of an angle

Splits a string and extracts the indexed part of it

Square root of a value

Returns true if the source string starts with the prefix string
Replaces a set of characters by another in a string
Replaces a regular expression by characters in a string
Tangent of an angle

Returns hex string version of value

Removes all spaces in a text (except single ones between words)
Converts string to upper case
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Examples of Basic Expressions

APPLY EXPRESSION

Expression

Result

“Ontario” (applied to column = NAME)

All items are assigned the value “Ontario” in the NAME column.

“MAP Area 01" (applied to column = #Style)

All area items are assigned the value “MAP Area 01" in the #Style column
and are assigned the Graphic Style “MAP Area 01" on the page.

45 (applied to column = #Rotation)

All point items are assigned the value 45 in the #Rotation column and are
rotated to 45° on the page.

MAP SELECTIONS

Expression

Result

NAME = “Ontario”

All items with the value “Ontario” in the NAME column are selected.

POPULATION < 1000000

All items with values less than one million in the POPULATION column are
selected.

NAME = “Ontario” OR NAME = “Alberta”

All items with the value “Ontario” OR “Alberta” in the NAME column are
selected.

NAME = “Ontario” AND POPULATION < 1000000

Only the items containing the value “Ontario” in the NAME column AND
values less than one million in the POPULATION column are selected.

MAP THEME STYLESHEET

Expression

Result

NAME = “Ontario”

All items with the value “Ontario” in the NAME column are assigned the
selected style.

POPULATION < 1000000

All items with values less than one million in the POPULATION column are
assigned the selected style.

NAME = “Ontario” OR NAME = “Alberta”

All items with the value “Ontario” OR “Alberta” in the NAME column are
assigned the selected style.

NAME = “Ontario” AND POPULATION < 1000000

Only items containing the value “Ontario” in the NAME column AND
values less than one million in the POPULATION column are assigned the
selected style.
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EDIT SCHEMA

Expression

Result

LOWER(NAME) (applied to column = name)

All items in column name are assigned the value of the column NAME in
lower case (e.g. “ontario” for “Ontario”)

PROPER(hame) (applied to column = Proper_name)

All items in Proper_name are assigned the value of the column name in
proper case (or capital case) (e.g. “Ontario” for “ontario”)

TRIMJOINING_COLUMN)

All items are trimmed with all spaces except single ones between words
(e.g." Route 66 "becomes "Route 66"). This is particularly useful prior
to using the Join Table function because extra spaces at the beginning,
end or in between words will cause the join to fail.

Examples of Complex Expressions
MAP SELECTIONS or MAP THEME STYLESHEET

Expression

Result

LIKE (NAME, “*New*"")

All items with the string of letters "New" in the NAME column are selected
(e.g. “New Brunswick” and “Province of Newfoundland”)

STARTSWITH (NAME, “0”)

All items that starts with the letter “0” (“Ontario”) are selected.

EDIT SCHEMA

Expression

Result

ROUND((POPULATION/ AREA),3)
(applied to column=density)

All items are calculated as “population divided by area’; rounded to three
decimals.

IF_CASE("'null"*, VALUE>0,"positive",VALUE<O,
"'negative")

A default status of "null" is assigned unless the value is strictly greater than
or less than zero.

SUBSTITUTE_RX(ROAD_NAME,"\D",""")

All non digit characters (\D is the regular expression for non-digit char-
acter) are replaced by nothing (two double-quotes indicate that the new
string is blank), therefore only numerical values are kept. For example, if
the ROAD_NAME equals "Route 66", the result is "66" This can be useful to
prepare an attribute table prior to labeling roads with road number rather
than road names.

SPLIT(GEOLOGIC_UNIT,"(**,0)

All items containing one or more open parenthesis are split in several text
blocks (as many as there are open parenthesis, plus one), and returns

the first block found (index 0). For example, if GEOLOGIC_UNIT equals
"Qmw(Qc)’, the result is "Qmw".

SUBSTITUTE(SPLIT(GEOLOGIC_
UNIT,"(",1),")","™")

Removes all closing parenthesis (i.e substitute all closing parenthesis
with nothing) in the result of the same SPLIT as above, that returns the
second text block found (index 1). For example, if GEOLOGIC_UNIT equals
"Qmw(Qc)’, the result is "Qc": first the SPLIT function returns "QC)" and
then ")"is removed with a SUBSTITUTE.

More examples of each individual function can be found in the Expression Builder dialog box. Expand the Expression
Components, choose a function or constant on the Objects list and the Description tab is updated with explanations

and examples.
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EXPRESSION LIBRARY

Expressions already entered in the MAP Attributes panel, MAP Themes stylesheets (see chapter 9) or MAP Selections
panel (see chapter 11) can be reused by selecting them from the Expression Library.

Expressions are sorted in three categories: Recent, Named Expressions or Attribute Filter. One or more entries can be
selected per category. Click the Insert button to add the selection to the Expression Builder—multiple selections are
concatenated with the AND statement.

Note: It is not possible to insert multiple expressions from different categories at once.

Recent Expressions

Expressions in the Recent tab of the Expression Library are expressions saved in memory for the time of the Adobe
lllustrator session (they are reset if the document is closed). They correspond to expressions recently typed

in the Expression Builder from the MAP Attributes panel or MAP Themes stylesheets but were not saved as a
Named Expression.

To delete a recent expression, select it in the Expression Library dialog box and click the Delete button.

Expression Library
Select one or more expressions: e Insert - Adds the selection
(2) Recent | [E NamedExpressions | £ Attribute Filter ‘ to the expression builder.
Cose P Multiple selections are
Recent Expressi STATE_ABBR &" "8 SUB_REGION concatenated with the AND
List of expressions recently statement.
used in MAP Attributes or
MAP Theme Stylesheets Close - Closes the dialog
during the current session. without adding expressions
Select one or more entries
in the list.
Delete - Delete the selected {-—e Delete
expression (enabled

for Recent and Named
Expressions only)

Note: In the MAP Attributes panel, expressions are saved in the recent list only when the Edit Schema dialog
box is closed.
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Named Expressions

Expressions entered in the Expression Builder can be saved as a Named Expression by clicking the Save button. Unlike
the Recent expressions, named expressions are saved within the Adobe lllustrator document. They are listed in
the Named Expressions tab of the Expression Library. To delete a named expression, select it in the Expression Library

dialog box and click the Delete button.

Named Expressions - Lists
all the expressions saved
through the Save Named

Expressions dialog box.

Select one or more
entries in the list.

Attribute Filter Expressions

Expression Library

Select one or more expressions: =
() Recent | [ NamedExpressions | fin Atribute Fiter | [:]
Close
Name Expression

Pepulation Den... POPULATION/ AREA

The Attribute Filter tab of the library lists the expressions in use in the MAP Selections of type Attribute Filter. See details
on the MAP Selections panel in chapter 11. Attribute Filter expressions cannot be deleted from the Expression

Library (only the MAP Selections panel).

Attribute Filter Expressions
Lists the Attribute Filter
expression saved in the
MAP Selections Panel
(see chapter 11).

Select one or more
entries in the list.

Expression Library

Select one or mare expressions: F—
L) Recent | Mamed Expressions | fi4  Attribute Filter L
Name Expressicn
Toll TOLL_RD= "¥"
Interstate ADMMN_CLASS= "Interstate”
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Find & Replace Attributes

MAP Attributes panel > Find & Replace

Find and Replace )
Find/ Replace - Choose to Find variables, or to Find
and Replace variables simultaneously I Replace Find Next - Move to th tval tching th
ind Next - Move to the next value matching the
Find what - Enter a variable on which to perform a Find what:  Florida - Find Next Find what variable
search in the current attribute table. Note this list .
N . . s r® Replace with: FL - )
will also contain previous criteria. Replace Replace - Replace the selected value with the
Replace In Replace with variable
Replace with - Enter a variable on which to replace () Al Attributes @ |_ Replace All- Repl " hing th
found items. Note this list will also contain T i ,EP ace All - EP ace all occurrences matching the
previous criteria @ Just Find what variable
Find / Replace All Attributes / Just in Column - Perform Case sensitive E:sseeszr;s'cl::e};irl'ﬁf; E/Zfzkrei/(i’r?ar:alfevv?lli“fen;c?;i:ng e
the Find or Find & Replace on all attributes in the [ Match whole word only e— Match whole word only - If checked. onl d
current layer or only in a specified column atch whole word ony - IT checked, only words
4 Y P matching the Find what variable will be found

(words containing the variable will be ignored)

FUNCTIONALITY

The Find & Replace tool provides settings to search and/or replace attribute values and properties contained in the
MAP Attributes panel. Note that only values in visible columns can be found and/or replaced.

USING FIND & REPLACE @

Click the Find & Replace button at the bottom of the MAP Attributes panel or choose it from the panel options menu.

Find Only

Click the Find tab and enter the search criteria directly into the Find what entry field (previous criteria can be selected
from the list). A search may be performed on all attributes by default, or only on specific columns contained within
the MAP Attributes panel by enabling the Just option and choosing a column from the list. Criteria may be further
refined by enabling the Case sensitive and Match whole word only options.

Click the Find Next button to perform the search. Search results can be seen in the MAP Attributes panel; the column
header and row number containing the first matching record will be displayed in bold text. At this point, a search
for individual records can be done again by clicking the Find Next button.

Find & Replace

To replace records selected through the Find operation click the Replace tab. Find & Replace criteria can be typed
directly into the Find what and Replace with entry fields (previous criteria can be selected from the lists). A find and
replace may be performed on all attributes by default, or only on specific columns contained within the MAP
Attributes panel by enabling the Just option and choosing a column from the list. Criteria may be further refined by
enabling the Case sensitive and Match whole word only options.

There are two methods to replace values. The first method requires approving each replacement manually by
clicking the Replace button so that each instance of the attribute located via the search parameters is successively
replaced in the map attribute table. The second method allows for the replacement of all found records
simultaneously, accomplished by clicking the Replace All button.
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MAP Attributes panel > Apply Expression
Apply to - Select the attribute -
pclz)}{umn on which to apply Apply Expression Expression Builder - Opens the Expression

the expression. Attribute and Builder dialog box
MAPublisher Property columns can Apply to: [ [T] POPULATION_DENSITY - l O ’, Expression Library - Opens the Expression

be assigned expressions. Library dialog box

Expression:  popUL ATION [ AREA 7
Expression - Enter the —,_ [g Cancel

expression into the text box or
click the Expression Builder or
Expression Library button

" The expression is valid. Expression Validity - Indicates if the
expression is valid ¥ or invalid®.
If invalid, additional info is reported.

FUNCTIONALITY

Use the Apply Expression function to assign new values or edit attribute properties. For example, it can be used
to compute attribute values based on the values in other columns, to assign a style by editing the #Style property
attribute, or to rotate symbols by assigning a fixed value to the #Rotation property attribute. Read-only attributes
cannot be edited with Apply Expression.

Note that property attributes are dynamic. Changes made to them in the map attribute table are reflected
immediately in the graphical properties and on-screen display of the data to which they are linked. Expressions can
be generated and applied to data based on the values found in an existing attribute column, providing a one-step
process to transform a vast number of different objects in a single operation.

Note: Unlike the Derive Value From Expression option in Edit Schema, values computed through Apply Expression are not
tied to the original attributes constructing the expression and can be edited later on. Only currently selected
artwork is affected by the changes.

APPLY EXPRESSIONS

Ensure the data required for the application of the expression is selected and appears in the MAP Attributes panel.
Click the Apply Expression button or choose it from the panel options menu.

First specify a column from the Apply to list to specify which attribute column the expression will be applied to. The
columns listed here are representative of the attribute structure unique to the data layer currently displayed in the
attribute table as well as the standard MAPublisher property attributes.

To assign an expression to a column, enter a valid expression in the Expression text box. Alternatively, click the
Expression Builder button to open the Expression Builder dialog box. To access other expressions saved in the map
document, click the Expression Library button to open the Expression Library dialog box.

The Expression Validity icon will report ¥ if the expression entered is valid. Otherwise it will report © andinclude
additional warning notes.
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Join Table

MAP Attributes panel > Join Table

Join Table
Data Type - Choose Files (all Operating Source:
Systems) or Geodatabase formats
(Windows only) e Data type: [F\Ies {ASCII, Excel, 5dts, Dbf) - ]
Data Set Name - Click the Browse button ——e Dataset name: Data/Tutorial Data/Demographics. xs
to select the data table to be joined
Worksheet: Sheetl Name/Worksheet - Specify the worksheet
. to use when a Microsoft Excel file is
Source Matching Column - Select a column ——-e Matching column: [ STATE_NAME - ] selected
from the source table to match to a o i
column in the destination layer First line contains column names
First line contains column names J Specify Schema...
For Delimited Text and Excel type Character Encoding - Assign a codec if
tables, check this box to derive column Character encoding: |Unicode, 8-bit (UTF-5) the attribute information held in the
names from the first row selected dataset uses a double byte
Specify Schema - Adjust the schema type — o character set
for each column BPEITIIITS
Target layer: AK A Target Layer - Select the layer containing
Case sensitive when matching - Values from — | | Matching column: [ SEAE-hAUE e ;:;ngvii?f:tﬂ\beus‘sJ ?ct:!lfaabtizm ove
the two matching columns will be o .
matched based on case sensitivity e Destination Matching (oll{mn - Selecta
Add matching column from source - Add column from the destination layer to
the matching source column into the —I—-—-D Case sensitive when matching match to a column in the Source Table
destination attribute table e[| Add matching column from source
ate existing columns instead of addin Update existing columns instead of adding columns when possible
Update existing columns instead of adding [F] upd: I d of adding col h bl
columns when possible - Update existing

column values instead of adding more

FUNCTIONALITY

Join Table provides the ability to merge external data tables directly into an existing MAP Layer attribute schema in
order to create a single extended attribute table. Four of the most common table formats are supported:

dBase (*.dbf) Delimited Text (*.csv, *.tsv, *.txt)
USGS SDTS (*.ddf) Microsoft Excel (*.xls)

When exporting tables from spreadsheet applications for use with MAPublisher the preferred format to use is
Delimited Text (*.csv).

Note: dBase tables created or edited in Microsoft Excel must have a proper data type assigned to each column
through cell formatting before being saved as dbf. For example, numerical values specified in a cell set with a
format "General" will import as an Integer type by default, therefore loosing all decimal values.

Windows users with licensed Esri software can join tables with feature classes and non-spatial tables of geodatabases
(ArcSDE, File and Personal). For information on Esri software requirements for this option, please refer to chapter 3.

PREREQUISITES

In order to join a table into an existing attribute schema, both MAP Layer and data table must share at least one
common attribute column with matching values. The column must be of a matching type (i.e. String, Real, Integer,
Boolean) in both the Source and the Destination table. If not, the join may not be successful.
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USING JOIN TABLE [1+]

Click the Join Table button or choose Join Table in the MAP Attributes panel options menu.

Source Data (Files)

Click the Browse button to select the data table for import. If a Microsoft Excel file is selected, use the Worksheet
drop-down list to specify the sheet to be used for joining. Select a column in the Matching Column drop-down list. This
is the source attribute column to join on.

In MAPublisher, double-byte characters are supported in attributes on import, allowing such attributes to be used
for labeling and export. To assign a codec suitable for the selected dataset, choose an appropriate entry from the
Character Encoding drop-down list.

If the table contains column names as headers, check the First line contains column names option. If it does not contain
headers, do not check this option and each column will be assigned a default heading name: Column1, Column2, etc.

Source Data (Esri geodatabases)

Windows users with licensed Esri software can join tables with feature classes and non-spatial tables of
geodatabases (ArcSDE, File and Personal are supported but not the multi-OS Basic Personal Geodatabase).

If the Data type drop-down list is set to Esri ArcSDE Geodatabase, click the Browse button to select the ArcSDE server
connection and then select the appropriate feature class or non-spatial table. If the Data type drop-down list is set
to Esri File Geodatabase or Esri Personal Geodatabase, click the Browse button to select a feature class or non-spatial
table. Please refer to chapter 3 for information on ArcSDE server connection and feature class selection.

The attribute selection is the same as for Files source data.

Destination

The Target Layer is specified under the Destination section. Choose an attribute from the Matching Column drop-down
list. This column must match the format and values as the column chosen as the Source Matching Column.

Additional Option

If the Case sensitive when matching option is checked, the column entries from the two matching columns will only be
matched by case. If the Add matching column from source option is checked, the source column is also imported and the
column name is appended with the number 1. The Update existing columns instead of adding columns when possible option
attempts to update attributes instead of appending more columns to the table.

Note: Attribute names can not contain all numbers. If a source column name contains all numbers the column is
joined but the attribute column name is changed to Attributel, Attribute2, etc.
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Calculation - Set the type of calculation:
« Centroid (area and line layers)
« Position (point layers)
« North Angle (point layers)
« Statistics (all layers)

Column X - Select or add the attribute
column to receive the x position value

ColumnY - Select or add the attribute
column to receive the y position value

Options - Apply the calculation to all art
oronly selected art

Add Calculated Data

MAP Attributes panel options > Add Calculated Data
Add Centroid / Position Data

Add Calculated Data

—l——c Calculation: [Centroid

— Status - () icon indicates that a new
column is created, % icon indicates
that an existing column is being
updated

e ColumnX: [B] new_position_x
——* Column ¥: new_position_y
Type: [Page woordinates
Unit:
Options:

@ Apply to al art on layer

() Apply only to selected art

Type - Select the type of coordinates:
« Page coordinates: position in

Adobe document page units

« Projected coordinates: available if
the coordinate system of the MAP
View is projected

« Geodetic coordinates: Longitude/
Latitude position

+ WGS84 coordinates: Longitude/
Latitude position

Not available for text layers

Add Statistics Data

Add Calculated Data

Target - Choose or add 1

the attribute column to —[*CAeation: [Siatates

- oK

receive statistic values s

the operation to be e source:
performed: Distribution,
Deviation, Sum, Mean
or Standard Deviation
Source - Select the ot
attribute column to be
used as source for the

@ Apply toallartonl

IRl rew_stat_col

Operation - Specify — s coeaton

) Apply only to selected art

o Lo

layer

calculations
Add Colour Data
Add Calculated Data
Calculation: [Colours =[x

Colour source - Choose —— Colour source: [strake = ==
the colour source as 4+ Colour model: [cyic -]
the fill or the stroke of - cran - © ndd
the layer or objects H p—— ey
Colour model - Choose yelow v © add
the colour model: biack - @ Add
CMYK or RGB e |

{ Range:

Colour attribute labels —
Specify attribute labels
to the associated CMYK
or RGB colours. Labels
must be unique. Range
values can be from zero
to 1.0 or 100.0

Colours —

Indeterminate Col

Options:
@ Apply to all art or

* Apply only to sek

.
@) Indicate indeterminate colour using:

lours:

@ Reset attribute to default when colour source is indeteriminate

-1.0000

n layer

lected art

Colours that cannot
be determined (such
as gradients) are reset
to default or a specific
value can be specified
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Not available for point layers

'— Unit - Set the unit when Projected
coordinates or Geodetic coordinates is
selected as Type

Add North Angle Data

Add Calculated Data

Target - Choose or add — e Target:

the attribute column
to receive north
angle values

Calculation: [Nerth Angle

Options:

new_north_angle

@ Apply to all art on layer

Apply orly to selected art

This option only available when point data is selected

Add Auto-Number

Target - Choose or add —+
the attribute column to

Add Calculated Data

Caleulation: [Auto-number

- oK

receive ID numbers

Starting ID - the number -
value at which to start

Sort by - Choose an —-+
existing attribute
column to order the
auto-number ID by.
Choose a Sort Order to
determine ascending
or descending order.

+® Target: id v @ Add
gID: 0 <
Sortby: [ [T #Opacity .]

=

Sertorder: [Ascending

Options:
@ Apply to all art on layer

) Apply only to selected art




FUNCTIONALITY

The Add Calculated Data function populates existing or new MAP Attribute columns with values calculated from the art
geometry or from another column of numerical values. The calculation options are:

«  Geographic information: centroid position for lines and areas or position and north angle for points .

«  Perform statistic calculations based on the overall attribute data of a specified column.

Calculated values are not updated automatically when the source column changes. Add Calculated Data must be
run again for updates to be applied.

For single polygons, the centroid can be assimilated to the center of mass of the surface. For single lines, the
centroid is the mid-point of the line. For polygons or lines grouped into a compound path, the centroid of the
largest polygon or line is used.

Note: The centroid of a Bezier polygon (smoothed path) may not be completely accurate because only the anchor
points are used to calculate the centroid's position. If necessary, use the Adobe lllustrator Add Anchor Points
function (Object > Path > Add Anchor Points) before running Add Calculated Data.

Calculated data can be added or updated to all art on a layer or only to the selected art, however statistical
calculations are based on the entire dataset.

PREREQUISITES

Add Calculated Data can populate new or existing attribute columns. Only attributes of type Real can be updated,
so users should make sure that the proper data type is applied to these columns.

For statistics calculations, the source column must be numerical (Integer or Real type). Users may need to use the
Join Table function to import appropriate numerical data beforehand (e.g. election results per county). See Edit
Schema in this chapter.

USING ADD CALCULATED DATA

Make a selection on the MAP layer concerned and click Add Calculated Data from the MAP Attributes panel options menu.

Calculate Centroid or Position

If the selected data is on a Line or Area MAP Layer, choose Centroid from the Calculation drop-down list to calculate
the x and y position of the line or area centroids. If the selected data is on a Point MAP Layer, choose Position from
the Calculation drop-down list to calculate the x and y position of points in a specific coordinate format.

Note: Centroids positions are calculated using the low accuracy method (see chapter 6 on Plot Centroids for details).

In the Column X and ColumnY drop-down lists, users have the option to keep the default new column names
(new_position_x and new_position_y), type names of their choice, or select an existing column. Only existing
columns of data type Real are listed.

The positions coordinate format is set in the Type drop-down list. The options are:
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- Page coordinates: x and y positions relative to the Adobe Illustrator page reference, in page units (as
specified in the Adobe Illustrator document setup).

«  Projected coordinates: x and y positions in the source coordinate system of the MAP View containing the
selected layer (if this system is projected).

+  Geodetic coordinates: longitude and latitude positions — calculated from x and y positions if the source
coordinate systems of the MAP View containing the selected layer is projected.

« WGS84 coordinates: longitude and latitude positions — calculated from x and y positions if the source
coordinate systems of the MAP View containing the selected layer is projected.

The Unit drop-down list shows a selection of linear or angular units if the coordinate type is set to projected or
geodetic respectively.

Finally, set the option to calculate the centroid or position to the selected art only or to all art on the current layer.

Calculate Statistics

To calculate statistics based on a source attribute column, choose Statistics from the Calculation drop-down list.

The following statistical operations are available:

«  Deviation: for each row, difference between the current value and the mean.

«  Distribution: for each row, current value divided by the sum.

«  Mean: sum of all the row values divided by the number of rows in the source column (same for all rows).

«  Standard Deviation: measure of the variability or dispersion of the row values in the source column. A
low standard deviation indicates that row values are very close to the mean, whereas high standard
deviation indicates that row values are spread out. Calculated as the square root of the sum of all
deviations squared, divided by the number of rows in the source column (same for all rows).

«  Sum: addition of all the row values in the source column (same for all rows).

In the Target drop-down list, users have the options to keep the default new column name (new_stat_col), type a
name of their choice, or select an existing column. Only existing columns of data type Real are listed.

Then, select the required function in the Operation drop-down list. Deviation and Distribution calculate a value
specific to each row; Mean, Standard Deviation and Sum create a single value for all rows.

In the Source drop-down list, select the source column from within all numerical attributes of the current layer.
Users have the option to add calculated data to all art on a layer or only to the selected art, however statistical
calculations are based on the entire dataset of the source column

Note: To obtain a distribution in percents, first use Add Calculated Data with the Distribution operation, then use the
Apply Expression function to multiply the column values by 100 (e.g. COLUMN = COLUMN * 100).

Calculate North Angle

To calculate north angles of points on a Point layer, , choose North Angle from the Calculation drop-down list.
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Calculate Colours

To calculate colours of layers or objects, choose Colours from the Calculation drop-down list.

In the Colour source drop-down list, choose from either Fill or Stroke of the current layer or objects. This will be the
source of which MAPublisher retrieves the colour values from.

In the Colour model drop-down list, choose from either CMYK or RGB. This will change the available colour attribute
label boxes below it and set the colour attribute values. When CMYK is chosen, colour values in the attribute table
are populated with Real numbers. For example, a cyan value of 0.2562 is equivalent to 25.62 in the Adobe lllustrator
Color panel. When RGB is chosen, colour values in the attribute table are populated with Integer numbers.

By default, the colour attribute label boxes are populated with the name of the colour. These are the attribute
column heading names and can be edited, however, they must remain unique. An indicator to the right of the box
displays either "Add" or "Update". When calculating new colour attribute values and a new label is entered, the
indicator will display "Add". It is possible to update the values in the attribute table when the colour of the layer or
objects are changed. When using the same attribute labels, the indicator will display "Update". This overwrites the
existing colour values in the attribute table.

Adjust the CMYK colour Range value by representing them as numbers from 0.0 to 1.0 or 0.0 to 100.0.

Indeterminate colours are colours that MAPublisher cannot determine for a layer or object. The colour value will not
be calculated if:

«  objects do not have fill or stroke

«  objects have gradient colour

«  objects have patterns or hatches

+  objects have colors not in CMYK or RGB (e.g. Pantone)

«  colourrs are applied to the layer group (not object level)

In the Indeterminate Colours section, two options are available to deal with these situations. Reset attribute to
default when colour source is indeterminate sets the attribute values to 0 (zero). The Indicate indeterminate colours
using option allows you to specify a specific value. The default is -1.0000.

Calculate Auto-Numbers

To calculate auto-numbers for records in the attribute table, choose Auto-number from the Calculation drop-down list.

Choose or add the attribute column in the Target box. In the Starting ID box, specify a numeric value to begin
numbering from. In the Sort by drop-down list, choose which attribute the ID values should be sorted by. In the Sort
order drop-down list, choose ascending or descending order. For example, if the attribute to sort by is StreetName
and sort order is Descending, an attribute table with three records will look like this:

Layer: | L torantostrestsjoined line (3 Ines selectec) = |

[S)StreetMame  [id
1 QUEENSTW
2 COLLEGEST
3 BEVERLEY ST

3 lines selected FEEEE .
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File name - Click the Browse button to select
the directory and type the file name where
to save the exported attributes.

Scope - Choose to export all the attributes
or only the visible attributes.

Delimiter - Specify the field delimiter. Select
Comma, Semi-Colon, Space or Tab from the
drop-down list.

FUNCTIONALITY

Export Attributes

MAP Attributes panel options > Export Attributes

Export Attributes

-

flename: |[Documents/canada._data. bt

Mote: File will be exported in UTF-8

Options:

cope: () Export all attributes

@ Export visible attributes only

[ Indude column names an first line

Include column names on first line
Click this option to export the
column names on the first line of
the exported text file.

The Export Attributes function exports all selected attribute information from the current MAP Layer to a delimited
text file—comma, semi-colon, space or tab separated.

PREREQUISITES

Attributes will be exported as they are in the MAP Attributes panel. For example, users can change the number of
decimals for attributes of type Real prior to exporting (see Edit Schema in this chapter), to limit the size of the exported
file—or to turn on/off the visibility of some attributes, with Edit Schema or the MAP Attributes panel Show/Hide function.

USING EXPORT ATTRIBUTE

S

Export attributes is accessed from the MAP Attributes panel options menu.

In the Export Attributes dialog box, click the Browse button to navigate to the directory where the exported file will
be saved and type a file name. By default, the exported file will be appended a .txt extension—to export in another
delimited text format, type another file extension (*.csv or *.tsv) in the file name (e.g. world.csv).

Users have the following options to set:
«  Export all attributes or visible attributes only.

«  Set field delimiter in the exported text file to Comma, Semi-Colon, Space or Tab.
«  Export or not the column names on the first line.

The result is a delimited text file. Text attributes (type String) are exported in double quotes ("..") and are separated

by commas in example below.

C)

"#Style","AREA","STATE_NAME","POPULATION","Draw"
"Aids1",121757.343000,"New Mexico",1819048 true
"Aids3",264435.873000,"Texas", 20851820, true
"Aids1",70003.325000,"Oklahoma”, 3450654 true
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MAP Locations
and Data Creation

The ability to accurately place locations on a map is basic
to cartography. This can be achieved with MAP Locations
to place page locations as well as world locations. MAP
Locations are used for reference and can be used in other
MAPublisher tools such Georeferencer, Area Plotter, Line
Plotter, Point Plotter, and Vector Crop.

Create data points to represent features such as cities, retail
shop, and airports, using precise location placement of MAP
Point Plotter. Also use it to plot centroids and create point
symbols at MAP Locations.

Create data areas with Area Plotter with known coordinates.
It is a great tool to make land parcels and shapes that have
been measured on the ground or with a GPS.

Create data lines with Line Plotter using known coordinates.
Plot multiple locations to draw lines point to point. For more
control, include distance and direction for navigation style
line plotting.

Topics covered in this section:
MAP Locations
Georeferencer

MAP Point Plotter

Line Plotter

Area Plotter
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MAP Locations and MAP Locations Tool

Object > MAPublisher > MAP Locations or MAPublisher Toolbar \EI and Tools > MAP Location Tool IEI

MAP Locations )
% MAP Locations oK.
Remove MAP Location
Name X | Longitude ¥ | Latitude  Coordinate System Cancel Click to remove a selected
the Name, X and ' 3 131110075 P Wess Edit MAP Location
Y coordinates, and ! Location o ’ Edit the highlighted
coordinate system ? Location 3 - MAP World Location 86.910506 60350006 WS84 MAP Location in the list
of each placed MAP
Location pin. ? Location 4 -39.375000 -89.515788 WG5S 84
Use Point Layer
. . wg 5
(opz:MAP I".)m:o" to (I|p||:{)alrd [ ['-'_!] @ Create new MAP World
opy single or multiple N . )
MAP Location coordinates Use Show MAP Locations in the View menu to see location pins at all times. | ' Locations with Point layer
to the clipboard g‘e Oslme Maﬁ:;’:ﬁ y
Zoom to MAP Location - Zoom to Add MAP World Location ~ Add MAP Page Location L::: t?oziwusin an cc))rnline
the highlighted MAP Location Click to add a new MAP  Click to add a new MAP Page map service 9

World Location to the list  Location to the list

FUNCTIONALITY
MAP Locations are used as annotations to identify map world or page locations. These can then be used in other

MAPublisher functions when specifying map or page anchors and in tools such as Georeferencer, Specify Anchors,
Area Plotter, Line Plotter, Point Plotter and Vector Crop.

USING MAP LOCATIONS

Plot MAP World Locations (on MAP Layer)

To plot MAP World Locations, the document must have at least . .
. . . . . Add MAP World Location
a geodetic coordinate system. Click the MAP Location Tool in the
Tools toolbar to enable it. The cursor changes to a crosshair Fame: [ |
when the mouse cursor is hovering anywhere in the document e (T i
. . . . () Geodetic base: NAD33(1986)
(including outside of the artboard). Click the artboard at an ot [ropcisdus -

appropriate location to open the Add MAP World Location
dialog box. Indicated are the coordinate system and coordinates
of the clicked location. Optionally, copy the coordinates to the

o % 491,965.202527 m

o Y 5,460,061.694021 m

clipboard. MAP World Location pins are blue.

Plot MAP Page Locations (on Non-MAP Layer)

MAP Page Locations can only be plotted on a Non-MAP layer (not contained Add MAP Page Location

in a MAP View). Click the MAP Location Tool in the Tools toolbar to enable it. The o
cursor changes to a crosshair when the mouse cursor is hovering anywhere
in the document (including outside of the artboard). Click the artboard at an o % m27m7 ox
appropriate location to open the Add MAP Page Location dialog box. Indicated o Y 343666504 o
are the page units of the clicked location. Optionally, copy the page units to the 4

clipboard. MAP Page Location pins are green.

When a MAP View already exists, MAP Page Locations can be added through the MAP Locations dialog box using
the Add MAP Page Location button. Alternatively, add them to a selected Non-MAP layer.
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MAP Locations Dialog Box

Click the MAP Locations button on the MAPublisher Toolbar or double-click the MAP Location Tool. The MAP Locations
dialog box is used to manage both MAP World and MAP Page Locations. It shows the Name, X and Y coordinates
and coordinate system for plotted locations. Manage MAP Locations using the Add MAP World Location, Add MAP Page
Location, Use online map to create MAP World Locations, Edit MAP Location, and Remove buttons.

-
?,m

?@

?ﬁl

26 | NADSZ / UTM seree 10N

. i
450 16 ET1ATD m | 3,459 168 165821 m | MADHS / UTHA zeme 10H

Only highlighted MAP Locations are shown on map. To copy MAP Location coordinates to the clipboard, select a
single or multiple MAP Locations, then click the Copy MAP Location to dliphboard button.

To see MAP Locations at any time (without the MAP Location Tool active), click View > Show/Hide MAP Locations to
toggle its visibility. When set to Hide MAP Locations, the MAP Location pins are only visible when the MAP Locations
Tool is active. Hold Shift to move MAP Locations. Adjust MAP Location label visibility in MAPublisher Preferences.

MAP Locations Used In MAPublisher Tools

MAP Locations can be used in several MAPublisher tools for georeferencing, as reference for corners, locations to
draw lines and locations to plot points. They can also be used in Specify Anchors to identify map and page anchors.

Georeferencer Area Plotter Vector Crop
Fi e T
oo e o i == = == =
 pom i i) )
— = R =
Ve Use i sluton Woldlocten  Quonglue  Visthude (P ® Word cordiotes: & wonenre [@ o
v ® LNy QI WoSH (| A = E..a..k 083 /U e 100 o | (e
- ) TIOAON deg 423663 deg WOSEH i s AR} [T Use: s
- Input format: | Projected units. - M
v ] " =
o
v © o P |
v o s e Locaton type: (Boundingbox ]
. v pace | e e e
v PinShE 1 P E 1 ISy 2y WG58 -
- Uk fonm e .
e A
Y 5,458,520.709688 m
R e i
e
W X 490,154.901555 m
i e .
Line Plotter
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Georeferencer
Object > MAPublisher > Georeferencer or MAPublisher Toolbar IEI

Add world locations from:

Add world locations from an online World Location
map source (i.e. Google Maps) or from Indicates which source the  X|Longitude, Y|Latitude world locations Georeference & Save
another open document. world location is from. World locations added from sources Apply the
| .
Gearelerencer | georeferencing
s solution and create a
N . [ 11 1 { ] {
Reference Locations from: | ) Gooole wace | |, Open documents. | [Bepgafermce AR |* MAP View
The reference location IsVahd Usemsolubion  Page Locstion World Lucation Mlongitide  Vilabude  CoodinsteSystem | [ sae  Jor—Save
table shows connections v v * GomemiCypress @ JLIMTTS deg 42311TT0deg WGSHA —— Save the reference
between MAP Page o locations, but does
. o £ ¥ Fhghland/Suliolk @ TLOION dey 42386439 dey WGSBA
Locations and world ——e not georeference
|0Cati0ns. Three sources Of o o ¥ Sallow 5t # ~TROFERGT cleg 42333047 deg  WGSEL
world locations: manual o 7 # Princetan/Marian (@ TUOETT deq 423TT2AL deq WGSEL Coordi System
entry, online map, or i
Y P v v ¥ Deskshiervok (@ TLOGMI0E deg 423605 deg WGSSA The coordinate
another open document. : system used for each
v Paterson/Sth E. PattersoryDthE.1 -TLOSOTS2deq 4233185 dey WOSEM reference location
Add/Remove Reference Location — i3] [/
Click Add to insert a new Speafy coordnate system:  Hone]
reference location. Click 1

Remove to delete a selected

reference location Specify coordinate system

Specify a known coordinate system
for more accurate results

FUNCTIONALITY

Use the Georeferencer tool to give spatial properties to a non-referenced map by establishing a relationship
between page locations in the document (using MAP Page Locations) and world locations. There are three sources
for world locations: 1. an online map service; 2. entering location coordinates manually; and 3. MAP World Locations
from an open document. After connecting page and world locations, the tool calculates combined error using
different projected coordinate systems. Choose a projected coordinate system based on best fit and create a new
MAP View to contain the spatial information.

PREREQUISITES

«  Must start with a non-georeferenced layer (Non-MAP Layer) with defined MAP Page Locations.

«  Asource of world locations. Sources are: an online map service (Google Maps), world location coordinates
that are manually entered, and MAP World Locations from an open document.

« A minimum of four page/world locations should be used. However, it is recommended to use more
locations for better accuracy.

- Data being georeferenced cannot have a perspective or skew. Incorrect results may occur if they do.

. Using an online map service requires active Internet connection.
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USING GEOREFERENCER

In all situations, it is required to define MAP Page Locations on a non-georeferenced layer before choosing real
world locations to connect them to. Use the MAP Locations tool to plot MAP Page Locations in known locations
so that it is possible to connect them easily to world locations. There are three sources for adding world locations
which connect to MAP Page Locations: 1. an online map service; 2. entering location coordinates manually; and 3.

MAP World Locations from an open document.

Click the Georeferencer button on the MAPublisher Toolbar or go to Object > MAPublisher > Georeferencer.

Use online maps to add world locations

Add world locations from online map services such as Google Maps or Bing Maps. In the Georeferencer dialog box,
click the online map service button to choose world locations for matching MAP Page Locations (if multiple map
services are available, click the drop-down arrow to choose). In the Add World Locations dialog box, choosing a
MAP Page Location from the drop-down list automatically pans and centers it on the artboard. Use the Zoom in and
Zoom out buttons to enlarge or decrease the artboard zoom level. To navigate the online map, pan and zoom with
the mouse (and mouse wheel) or use the navigation control slider. Optionally, enter street or city names into the

Place search bar to find places quickly.

il Wond Locuton - = > Zoom arthoard
Matching MAP Page Location ——— ssiing s rage Locaten: | ¥ serishueiock = 2oom arthom: 3] = Zoom in and Zoom out of
Choose a MAP Page Location o <hange wEey the artboard.
and click the corresponding ~ Seorch [ Mep | Satefite |
position in the online map. R/ .
Click the Zoom In and Zoom N = e, Locatn:fsear:h d citi
Out buttons to adjust the i ® Search for streets and cities
zoom level of the artboard. - & to he.lp you ngrrow down
- %5 specific locations
World Location pl: k T - :_“%
Click the map to pick a world L f
location. This placemark |laas e f
represents the world location s = 3
that connects to the MAP = .
Page Location. e g, <
2 g dare 2013 Gaoy e - Tarmat e

To plot a world location position on the online map, navigate to a location that matches the chosen MAP Page
Location and click it. A placemark designates that a world location has been set. To adjust the world location
position, click and drag the placemark to a new location and release the mouse button. Unassigned MAP Page

Locations are denoted by (UNASSIGNED) in the drop-down list.

The reference locations list gets populated with the matching MAP Page Locations and world locations. The World
Location column shows that MAP Page Locations are matched with an online map world location.

IsValid Useinsolution MAP PageLocation World Location

v ¢ Princeton/Marion (g
g 9 Patterson/SthE. (@

Is Valid 4 ? Highland/Suffolk

. ighland/Suffo
MAP Page Locations are ¢ e
connected to online map 4 ¥ Gorham/Cypress (@
world locations 4 9 BerkshiresYork (gl

X

-71.03667733 deg
-71.05075222 deg
-71.03102122 deg
-71.12477515 deg

-71.09139775 deg

Chapter 6: MAP Locations and Data Creation

¥
4237724449 deg
4233185778 deg
4238683823 deg
4233277881 deg

4236940456 deg

Coordinate System

WGES84
WGs84
WGs84
WG584

WGS84

131

Georeferencer



Use a georeferenced document to add MAP World Locations

The source for world locations is an open Adobe lllustrator document with MAP World Locations already plotted
in it. It is essentially retrieving MAP World Locations from another georeferenced artboard and using them in the
current non-georeferenced artboard. In the Georeference dialog box, click the Open documents button. When

a document is chosen in the drop-down list, the list populates with found MAP World Locations. Click the list to
choose MAP World Locations.

Choose MAP World Locations

Document — e Document: Baston.ai - o
Choose an open document 5
X Elm/H k1
from the drop-down list. 5 miblancoc Cancel
Princeton/Marion 1
The open document should ® Berkshire/York1
have the appropriate ? Highland/Suffolk 1
L]
L]
L]
L]

Map World Locations:

MAP World Locations that
populates the list below it.

Clarendon/Montgomery 1
Swallow 5t 1
Gorham/Cypress 1
Patterson/9th E. 1

MAP World Locations

Choose the appropriate
MAP World Locations to add
to the reference list. Ctrl +
click to pick multiple items. |

The reference locations list gets populated with MAP World Locations. Importing MAP World Locations with the
same name as a MAP Page Location will automatically match them and add to the solution. Choose the matching
MAP Page Locations for each row. The World Location column shows that it is matched using an open document.

Is Valid IsValid Usein solution MAP Page Location World Location X ¥ Coordinate System
Choose appropriate MAP J ] ? Em/Hancock 9 Elm/Hancockl FLIITISTOL deg 4233080092 deg  WGS 34
Page Locations to match ——e
the MAP World Locations

J B 9 Princeton/Marion 1 7103667733 deg 4237724449 deg  WGS84
added from the open 4 B ? Highland/Suff.. ? Highland/Suffolk 1 7103102122 deg 4238683023 deg WG5S 84
[ ] [l

7 Princeton/Ma...

georeferenced document.

Clarendon/Montgomery1  -71.07200806 deg 4234412145 deg WGS84

Manually add X and Y world locations

In the Georeference dialog box, click the Add button to add new reference locations to the list. The MAP Page
Location column automatically populates with available locations. To add X and Y (Longitude and Latitude) world
location coordinates, double-click the X and Y column entries.

Edit Location
Coordinate System
_ oK
Choose an appropri Coordinate System: @) WGS 84 Lo ]
coordinate system to Geodetic base: Unavalable
georeference in Input format: Decimal degrees (D+.d"]) )
Long/Lat (oordln?tes o Long: 7107200806 o
Enter world location —-e
coordinates that connect to o Lat 4234412145 e
MAP Page Locations

The World Location column shows that MAP Page Locations are matched by manually entered world locations.

IsValid Use in solution MAP Page Location  World Location X ¥ Coordinate System
Is Valid 4 ? Clarendon/Montgomery &~ 7107200806 deg 4234412145 deg  WGS 84
When X and Y world —
locations are entered, it 4 7 Swallow St & 7102886204 deg 4233364727 deg  WGS 84
connects to the chosen J 9 Highland/Suffolk &7 7103102122 deg 4238683923 deg  WGS 84
MAP Page Location .
@ | & 000000000 deg  0.00000000 deg  WGS 84
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Georeference and Save

When at least four reference locations are valid, it is ready for georeferencing. The check box in the Use in solution
indicates whether or not the reference location should be included in the georeference calculation. A minimum of
four reference locations are required for georeferencing.

Click Georeference & Save to begin the georeference process. MAPublisher calculates the georeferencing and produces
a list of coordinate systems that best fit the data.

Combined Error

Rank The total error calculated (between
This value represents the rank page and world locations) of X and
of best fit. A value of 1.00 is a Y reference locations. Click Details
better fit than a greater value. to see values of each location used.
Select Coordinate System
Name Rank Combined Error Rotation  * OK
[
Coordinate System Name WGS 72BE / UTM zone 19N 1.00 000012543 deg 1732 deg i
Choose an WG572 / UTM zone 19N 0.00012543 deg 1731 deg
appropriate
coordinate system. — 8l P S A UTEAT) m 000012543 deg 1731 deg Rotation
These are based The amount of
on the calculation NADE3 / UTM zone 19N 00 0.00012543 deg 1731 deg rotation required
of the reference NAD27 / UTM zone 19N 104 000012528 deg 1733 deg to georeference
location points. the data.
NADE3 / Massachusetts Mainland (ftUS) 110 0.00012559 deg 0,047 deg
Error Details.. ] [Ccordinate System Details.. ]

The listed coordinate systems each have a Rank, Combined Error, and Rotation Value. The Rank value represents a
number that indicates the most appropriate coordinate system for the data. A value of 1.00 means the coordinate
system is the best fit based on error values, coordinate system envelope fit, rotation, and other calculated factors.
Rank values should be low but an appropriate match could be greater than 1.00. The Combined Error is the total
error calculated (between MAP Page Locations and world locations) of X and Y reference locations. Click the Details
button to see individual Error X, Error Y, and Combined Error for each reference location used in the calculation. The
Rotation value indicates the amount of rotation required to georeference the data and will vary depending on the
coordinate system. The resulting MAP View will be assigned this rotation.

After a coordinate system is chosen for the georeference, the final step in the process is to create a new MAP View
that will contain the referencing information. Optionally, select layers to move to the new MAP View. These layers
can also be moved to the new MAP View after.

Create MAP View
Name of MAP View:
Name of MAP View —{-e L1 Zone 15N (72 W to 66 W)
Enter a name for the e —
new MAP View 1 7 Roads
Layers to move to new MAP View
Select layers to move to the
new MAP View. These layers
can also be moved after the
georeference.
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GEOREFERENCE WORKFLOW (BRIEF)

1.

Place at least four MAP Page Locations on an unreferenced document in locations that will be matched to
known world locations (or MAP World Locations for an open document source).

Decide which georeferencing source to use to connect MAP Page and world locations (online map, open
document, or manual entry). Choose world locations based on the position of MAP Page Locations. Specify
the georeference coordinate system if it is known.

Ensure a minimum of four reference locations are used in the solution and click Georeference & Save.

In the list of results, view coordinate system details, fitness, combined error, and rotation value. Choose the
most appropriate coordinate system for the map and assign it to a new MAP View.

IMPORTANT GEOREFERENCING NOTES

134

Georeferencing cannot be performed on an unprojected map (i.e. a map in a geodetic coordinate system).
It is recommended to use as many points as possible to achieve the best geocoding results.
Reference points should spaced out as best as possible (e.g. one in each corner of artboard).

Zoom in to the maximum zoom level to get the most accurate location. This is true when plotting both
MAP Page Location and matching world location using an online map service (Google/Bing Maps).

It is recommended to provide meaningful names to MAP Locations for easier identification.
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MAP Point Plotter

Window > MAPublisher > MAP Point Plotter and MAPublisher Toolbar &

Current Layer - Displays the selected layer
name and coordinate system

Input Coordinate System - Specify the
reference coordinate system in which
the point coordinates are entered.
Use the current layer's coordinate
system, or specify a different one

(by default WGS84, lat/long format).
Click the Select button to open the
Select Coordinate System dialog box and
choose any coordinate system.

Coordinates - Enter point coordinates in
MAP units or in a different choice of
coordinate system

Format - Select the input format

for values in degrees (when input
coordinate system is geodetic)

Plot- Click to plot the symbol after
coordinates have been entered

—\_ ‘Current Layer
te P\ Hotels_paint

MAP POINT PLOTTER

MADE3 / UTM zone 10N

Display

Plot Centroids...
Plot MAP Locations...

Scale: 2 100% -

Symbal: . [Ma&Publisher Default Symbal]

le Input Coordinsts Systam:
(@) Use Current Layer's coordinate system

_\—_ Coordinates:

Scale - Change the size of the chosen
symbol if required. The arrow keys will
increase or decrease the scale value by

() Use: WGS 84 Select...

10% increments.

— Symbol Style - Choose a symbol to use.
Click the symbol name to open the list
of symbols to choose from

Select a symbol:

Note: Points can only be plotted on point layers. The plot button will be
disabled if another map layer type is the active layer.

PREREQUISITES

¢ MAP Symbol 15 - oK
<7 MAP Symbol 16 |
3

& MAP Symbol 17
& MAP Symbol 18
5 MAP Symbal 19
[3] MAP Symbol 20
© MAP Symbol 21
& MAP Symbol 22
MAP Symbol 23
MAP Symbol 24
i MAP Symbol 25 -

[T

To plot points using the Point Plotter, a georeferenced MAP View and | P Point layer must be chosen because it uses
the coordinate system to calculate where specified points are plotted.

USING POINT PLOTTER

Enter Coordinates

When the Use Current Layer's coordinate system option is chosen, coordinate values can be entered in the current MAP

units of the coordinate system of the MAP View containing the selected layer.

When the Use: WGS 84 option is chosen, the Select button becomes enabled. Click the Select button to open the Select
Coordinate System dialog box and choose a coordinate system as required.

Chapter 6: MAP Locations and Data Creation 135

MAP Point Plotter



When the selected or default coordinate system is projected, X and Y coordinates are entered in the unit (Point
Style) of the coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate system is
Geodetic, Lat/Long coordinates can be entered in degrees in the following formats:

- Decimal degrees (D+[.d*])

«  Delimited Degrees Minutes Seconds (D+ MM SS[.s*])

. Degrees.Minutes (D+.MM[m*])

. Degrees.MinutesSeconds (D+.MMSS[s*])

«  Packed DMS with decimal point((D)DDMMSS[.s*1)

. Packed DMS ((D)DDMMSS[s*])

Notes: Items in [ ] are optional, * means zero or more digits, + means one or more digits.

Lines of latitude run East-West (the Equator is an example), whereas lines of longitude run North-South (the
Greenwich Meridian is an example). Positive degree values represent north latitudes and east longitudes.
Negative degree values represent south latitudes and west longitudes. Directions can be entered either
with positive/negative values or using the N, S, E or W letters preceding or following the numerical values,
separated or not with a space.

Valid delimiters for Delimited Degrees Minutes Seconds format are:
- space, hyphen (-), colons () or underscore (_), e.g. 43 41 48.98N, 43-41-48.98N, 43:41:48.98N or
43_41_48.98N
- d(degree), single quote (minute), double quote (second), e.g. 43d41'48.98"N

Packed formats require the use of two digits for degrees of latitude (e.g. 1°N must be written 01) and 3 digits
for degrees of longitude (e.g. 1°E must be written 001).

Examples of Latitude/Longitude values

Formats Decimals Delimited Degrees.Minutes | Degrees. Packed DMS with | Packed DMS
Degrees Degrees Minutes MinutesSeconds | decimal point
Seconds
Avenza Office: Lat | 43.6969N 43d41'48.98'N 43.418163N 43.414898N 434148.98N 43414898N
43°41'48.98"N Long | 79.3922w 79d23'32.38"W 79.235396W 79.233238W 0792332.38W 079233238W
79°23'32.38"W
(41 8163N 7923 5306w | LT | 43.6969 43414898 N43.418163 N 43.414898 434148.98 N 43414898
(=48.6969°N | 79.3922°W) Long | -79.3922 W 079 23 32.38 W79.235396 W 79.233238 079233238 W 079233238
lat | N43.6969 N 43-41-48.98 43418163 43.414898 N 434148.98 43414898N
Long | -079.3922 W 79:23:32.38 -079.235396 -079.233238 W 0792332.38 079233238

Warning - Double-quotes (") are supported in MAP Point Plotter, but not in the import of Delimited Text.

Set up the Symbol Selection

The symbols used by Point Plotter are a direct reproduction of those that exist in the Adobe Illustrator Symbols
panel. To open the Adobe lllustrator Symbols panel, click the menu Window > Symbols. To add symbols to the
Symbols panel, create symbols as closed Adobe lllustrator objects and drag them into the panel. Alternatively,
open the Symbols panel, click the panel options menu > Open Symbols Library > MAP Symbols > MAP - Symbols. The
MAP - Symbols.ai file from the Helpful Styles & Symbols folder is installed with MAPublisher (see Appendix 4).
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Choose a Symbol and Scale

After entering coordinate values select an appropriate symbol to use by clicking the symbol name link. Again the
symbols displayed are the symbols that currently exist in the Adobe lllustrator Symbols panel. To scale the symbol
used, edit the Scale entry field. Clicking the Up and Down arrows will increase or decrease the value by 10%.

Note: When a MAP Themes stylesheet is assigned to a Point layer, it will override the map symbol chosen in the
MAP Point Plotter panel.

Plot Points

Click Plot to plot the point in the designated MAP layer. To plot subsequent points, edit the coordinates, and if
required, choose different symbols and click Plot again.

Plot Centroids
MAP View - Select the MAP View Map View: [ @ world - o
containing the layers of interest (Source
Layer and Destination Layer) e s [ B ikl =aea s I
Source Layer - Select the Area or Line o
MAP Layer containing the paths on | PR
which the centroids will be calculated () Existing layer: | P! Capitals
@ New layer: centroid P Options:
Destination Layer - Select either an This layer will inhesit the source layer’s stribute schema, '
existing Pﬁ'"t MAP Laﬁer or;relate.ﬁ Style - Select the symbol to use.
new one where centroid symbols wi Options: Available Adobe lllustrator Symbols
be added are listed
Style: @ MAP Symbol 03 - .
Scale: 100 % 3 Scale - Select the symbol
High accuracy (slower, forces centroid within area boundaries) Use high accuracy - if the selected source
I layer is an Area MAP Layer, check this

option for a high placement accuracy.

Plot Centroids adds point symbols at the center of polygons or lines, while copying the attributes from the source
MAP layer when the New Layer option is selected. This function is useful for cartographic generalization purpose
(e.g. replacing small island area by a symbol), or to simply add a meaningful symbol at the center of areas. For single
lines, the centroid is the mid-point of the line. For polygons or lines grouped into a compound path, the centroid of
the largest polygon or longest line is used.

Note: The centroid of a Bezier polygon (smoothed path) may not be completely accurate because only the anchor
points are used to calculate the centroid's position. If necessary, use the Adobe lllustrator Add Anchor Points
function (Object > Path > Add Anchor Points) before running Plot Centroids on Bezier polygons.

The document must contain a georeferenced MAP View that includes a MAP layer of type Area or Line that contains
art. An existing Point layer may be used as destination layer (Existing Layer option). Desired symbols must be loaded
in the Adobe lllustrator Symbols panel to use them.
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Using Plot Centroids

Plot Centroids is located in the MAP Point Plotter panel options menu.
+  Choose the MAP View that contains the layers whose centroids are to be plotted
«  Choose the Source Layer containing the polygons or lines for which the centroids will be based upon
«  Choose the Destination Layer, an existing Point layer or create a new one, to store the centroids
+  Choose the symbol Style and Scale to apply.

The High accuracy placement option makes more advanced calculations for the centroid positions to force them to
fall within the area boundaries (useful for areas with strange shapes, for example some S shape islands).

Note: When the New Layer option is enabled, the attributes from the source MAP layer are copied to the new
Point layer. However, when using an existing point layer, attributes do not get transferred unless the Point
layer was created with its attribute schema based on the same source MAP Layer (see chapter 4 for more
information on the Base attribute schema on option when creating new MAP layers).

Results

Symbols are added to the specified Point MAP Layer. Depending on the type of polygon or line (single or
compound path), symbols are located on the center of the polygons/lines or at the center of the biggest
polygon/longest line of a group.

Example: result of plotting centroids on a Canadian provincial Area layer.
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PLOT MAP LOCATIONS

Plot MAP Locations

Select MAP Locations to plot: &=
MAP Location A

MAP Location 1
MAP Location 2
MAP Location 3
MAP Location 4 P

MAP Location 5
MAP Location 6

Destination MAPView—L

MAP Locations to plot
Select a single or multiple
MAP Locations to plot.

m

©-0-0-—t-6-6-&-0

Choose which MAP View the

MAP Locations are plotted to ||, Destination Map View: | @ Hotels -
New layer name New layer name: P newlayer
Enter a Point layer n;’me for ] |—Symbol - Choose a symbol to represent
R Symbol: @ [MAPublisher Default Symbol] ” i
the plotted MAP Locations [ > the plotted MAP Locations
Scale: ¢ 100% [= Scale - Use the slider or enter a symbol

Include latitude and longitude as Include latitude and longitude as attributes scale for MAP Locations
attributes - Enable to include
coordinates in the attribute table

Plot MAP Locations adds point symbols at positions of MAP Locations. This is useful for reference purposes or to simply

add a symbol at MAP Locations.

The document must contain a georeferenced MAP View that includes a MAP layer of type Area or Line that contains
art. An existing Point layer may be used as destination layer (Existing Layer option). Desired symbols must be loaded

in the Adobe lllustrator Symbols panel to use them.

Using Plot MAP Locations

Click the MAP Point Plotter panel options menu and choose Plot MAP Locations.
«  Select the MAP Locations to plot in the list
+  Choose a Destination MAP View to store the Point layer
- Specify a new Point layer name for which the MAP Locations will be plotted
«  Select the Symbol and Scale to apply.

Results

Points are plotted where MAP Locations are positioned. The MAP Locations are maintained.
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Target layer - Indicates the
currently selected layer (can
be area or line layer) and its
coordinate system

Input Coordinate system - Specify
the coordinate system in which
the starting point coordinate is
entered. Use the current layer's

coordinate system, or specify

a different one (by default,

the geodetic system base of
the projection, in latitude-
longitude format). Click the
Select button to open the Select
Coordinate System dialog box and
choose any coordinate system.

Format - Select the input —

format for values in degrees
(when input coordinate
system is geodetic)

Starting Point - Enter the ——

coordinates of the first point
of the line or click the MAP
Locations button to choose a
location for the Starting Point.
Valid coordinates are marked
with a green check mark,
invalid ones with a red x.

Additional Line Points - Choose
Course & Distance to enter

a series of heading and
distance values
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Line Plotter

Line Plotter

Object > MAPublisher > Line Plotter* or MAP Toolbar |ﬁ|

Line Plotter (Point By Point)

Line Plotter ——
rTargetlayer: | [ Streets ~|  Additional Line Points:

Coordinate system: WGS 84

Input Coordinate System:
@ Use target layer's coordinate system

© use: WS84

rmat: [Decmal degrees (D+L.d%)

Starting Point:
« long: -79.411536

—o
o lat 43.672093

Options:
[7] Close path (requires at least three points)

deg
deg

[a] Long lat

Cancel

Additional Line Points - Choose
Point By Point to enter the
consecutive vertices of the line
by their coordinates

E2]E -79.370270 43572003
2 -79.370270 43640205
3 79.411536 43640205

3 additional point(s)

Close Path - Check this option to
automatically close the path
(recommended when using the
Line Plotter on Area layers)

Line vertices - Enter here the
point coordinates of each
line vertex

Remove - Select a row and click [@] to remove it.

— Add and Add Point from MAP Locations - Click 2] to

add a new row. Click |#] to add a new point
from a list of MAP Locations.

Line Plotter (Course & Distance)

Line Plotter

Target layer: [ L Rivers

Coordinate system: WGS 84

Input Coordinate System:

@ Use target layer's coordinate system
) Use: WGS84

Format: [Dedmal degrees D+.d"])

Method:

MNarth type: |True north

v] Additional Line Points: [Course & Distance oK

Cancel

Urits: Meter -
Direction: | ‘@) Clockwise: -

Import list of h
Click to choose a text file (.txt)

that contains headings and
distances to import
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[a] Heading Distance
Starting Point:

B2l 35.0000° 5250000 m
' long: -79.411536
Ol PrE— 2 128.0000° 4170000 m
. 3 8.0000° 1780000 m
[7] Close path (requires at least three points)

3 additional point(s)
t

ding/Distance - Enter here a
series of heading and distance
to define the consecutive
vertices of the line

Method - Choose the distance

method:

« Cartesian: distance in the
map projection

« Geodesic: shortest distance
along the Earth's curvature

« Rhumb Line: distance along
the Earth curvature at
constant heading

North Type - In the Cartesian
method, choose one of the
north options which headings
are measured from:

« Grid North: north along the
map projection (straight up
on the map)

« True North: actual north
direction (as given by a
north arrow)

Unit - Select the linear unit for
distances

Direction - Choose Clockwise
or Counter-clockwise for the
direction of the heading value



FUNCTIONALITY

The MAPublisher Line Plotter creates a new path to a Line or |A| Area layer. Enter line vertices using two options:

. Point by Point: enter a starting point and consecutive point coordinates.

«  Course & Distance: enter a starting point and a series of headings (angles) and real-world distances. Each
consecutive vertex is defined at an angle and distance from the previous point. Additional options are
available for angle and distance definitions (see hereafter).

The created path is made of straight segments connecting the points.

PREREQUISITES

As required, first create a new MAP Layer of type Line or Area, or use one of the existing MAP layers of the
appropriate type.

USING LINE PLOTTER

Select a Line or Area layer in the MAP Views panel or Adobe lllustrator Layers panel. Click the Line Plotter button |'ﬂZ|
on the MAPublisher toolbar or choose Object > MAPublisher > Line Plotter.

The name of the selected layer and its source coordinate system are displayed under Current Layer.

Input Coordinate System
The Input Coordinate System sets the system in which the starting point coordinates are entered. It also applies to
the coordinates of each vertex when the Point by Point option is selected.

When the Use Current Layer's coordinate system option is selected, coordinate values can be entered in the current
coordinate system of the MAP View containing the selected layer.

When the Use: [coordinate system] option is selected, the coordinate system link becomes enabled. Click the link to
open the Select Coordinate System dialog box and choose a coordinate system as required.
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When the selected or default coordinate system is projected, X and Y coordinates are entered as the unit of the
coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate system is Geodetic,
Lat/Long coordinates are entered as degrees. The degree format is selected from the Format drop-down list—see
chapter 6 for details on the supported formats.

Note: The Input Coordinate System is not applied to the distance settings when plotting a line by Course & Distance.
In that case, the layer's coordinate system applies.

Starting Point

Enter the coordinates of the first point of the line in the X, Y or Long, Lat fields. Click the MAP Locations button to
choose a MAP Location (if available).

Options

The Close Path option controls if the path will be closed automatically or not. When using Line Plotter on a Line
layer, this option is disabled by default. On an Area layer, the Close Path option is enabled by default—it is not
recommended to create open paths on an area layer.

A minimum of three vertices are required to create a closed path. If less points are entered, the path is left opened
by the Line Plotter.

Plot Line Point by Point

The Point by Point option in the Additional Line Points drop-down list provides a method to add consecutive line
vertices (or nodes) by typing in the coordinates of each point. This option is typically used to create a line from a list
of known locations. (Alternatively, Join Points could be used to connect points already plotted on the map.)

To add a new point, click the Add button or click the Add MAP Locations (if available). Then enter the new point
coordinates based on the selected Input Coordinate System and Format (if the coordinate system is geodesic). To
remove a point, select a row and click the Remove button.

Plot Line by Course and Distance

The Course & Distance option of the Additional Line Points drop-down list allows to define each consecutive line vertex
by its heading (azimuth or angle relative to the north direction) and real-world distance from the previous point.

The Method drop-down list offers three options to define the real-world distances:

«  (artesian: Distances in the map projection. They represent the distances as measured on the map and
multiplied by the scale. This option is only available if the layer's coordinate system is projected.

«  Geodesic: Shortest distances along the Earth's curvature. Geodesic distances are also known as
Great-Circle distances and are typically used for navigational purpose maps. They represent the actual
covered distance while walking or in a moving vehicle.

«  Rhumb Line: Distance along the Earth curvature at constant heading. They are typically used for
navigational purpose maps to represent routes of constant direction.

Note: Once the next vertex position is calculated on the map, the path segment is the straight connection between
the points. The paths are not drawn curved to follow geodesic or rhumb lines
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The North Type drop-down list contains two options to define the north direction when the method is set to Cartesian:
«  Grid North: Refers to the northward direction of the map projection grid lines—Grid North is constant
throughout the map.
«  TrueNorth: Refers to the actual direction to the geographic North Pole. The True North direction can vary
depending on a point position on a map. Similarly, graticule longitude lines are pointing to True North
as well as MAP North Arrows (see chapter 14).

Note: The Geodesic and Rhumb Line methods are by definition using the True North as northward direction. The
North Type drop-down list is therefore disabled in these cases.

The Units drop-down list allows to select a linear unit for the distance. By default, the Units list is set to the Point Units
of the current layer's coordinate system, if it is projected. If the current layer's coordinate system is geodesic, the
Units list is set to Meters.

The Direction drop-down list indicates the direction of the heading angles. Typically, navigational headings (or
azimuths) are given in Clockwise direction. However, the natural angle direction in Adobe lllustrator is Counter-clockwise,
which may be preferred for simple drawing purpose.

Once all options are set, click the Add button to create a new entry of heading and distance. To remove an entry,
select a row and click the Remove button.

Click the Import list of headings and distances button to browse for a text file (.txt) containing headings and
distances. No column headers are required. Values listed should follow the format of heading then distance.
For example, a text file that contains four headings and distances will look like:

266.883,400773.2079
13.548, 365969.5053
270.353,322701.9679
331.837,99368.0284
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Target - Indicate the MAP Area
layer to plot the area on

Input - Specify which input
coordinate system to use

for plotting the Corner and
Opposite Corner coordinates

Area Plotter

Object > MAPublisher > Area Plotter or MAP Toolbar I‘{EI

Location type: Bounding box

Area Plotter
Target: l [Al Land_area v] [ oK J
-

() Page coordinates (Global Rulers)

Coordinate system: NAD83 /UTM zane 10N
[F] use: wiGs a4

nput format: [Proected units Location type: Position

Options - Specify shape as

Rectangle or Ellipse. This ptions: Options:
dialog box shows location Shape: Shape:
type as Bounding box. To the § = . =
N . Location type: |Bounding box ~ Location type:
far right shows options for
Position location type. Corner: Point - Specify —eFoint:
i o X: 489,804.352676 m anchor point )
Corner - Specify X and Y P W 491,825.815044 m
coordinates to use as a corner o Y 5459,642.321347 i anq X andY ¥ 5,458,529,709688 m
coordinate of it ) o =
of the area _
Opposite Corner: Dimensions —e Dimensions:
o X: 491,823.519044 m Specify units, Units: | Meter =
Opposite Corner - Specify X and : ; [ ]
width and height . —
Y coordinates to use as the « Yi 5,458,520.709688 m | of the area Width:  300.000000000000000 m =
opposite corner of the area Height:  500.000000000000000 m —

D Constrain dimensions

MAP Locations - Choose
predefined MAP Locations or
Artboard locations (corners)

FUNCTIONALITY
The MAPublisher Area Plotter creates new rectangle or ellipse polygons on MAP Area layers by using page or world

coordinates, and by location type (using either a bounding box or by a single coordinate position). Use it to
create precise area shapes based on coordinate locations.

PREREQUISITES

Area Plotter only works with | £ Area layers.

USING AREA PLOTTER

On the MAPublisher Toolbar, click the Area Plotter button |@| or click Object > MAPublisher > Area Plotter. This
opens the Area Plotter dialog box.
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Input Coordinates

The Input sets the coordinate system in which the starting point coordinates are entered. Input coordinates can
either be Page Coordinates or World Coordinates.

When the Page coordinates (Global Rulers) option is chosen, page coordinate values (in pixels) can be entered for the
Corner and Opposite Corner coordinates.

When the World coordinates option is chosen, the MAP View drop-down list becomes enabled. Choose the appropriate
MAP View to use. Its coordinate system is displayed directly below the MAP View drop-down list. The options in the
dialog box will change to reflect a geodetic or projected coordinate system and corner values can be entered either
as (a variation of) decimal degrees or in projected units. To use an alternative coordinate system, click the Use check
box, and click the coordinate system link. Choose an appropriate coordinate system in the Select Coordinate System
dialog box.

Shape and Location Type Options

There are two shape options to choose from when plotting areas: rectangle and ellipse. More importantly, two
location types determine how the shapes are plotted: Bounding box and Position.

When Bounding box is chosen, enter (map page or map world) coordinates into the Corner and Opposite Corner
coordinates to define the area. A preview of the area can be seen on the artboard (you may have to move the Area
Plotter dialog box to see it). Note: Any corner and its opposing corner can be used for the bounding box.

Corner. Corner

Opposite Corner

Opposite Corner

Rectangle, Bounding Box

Note: The bounding box for an ellipse is the same as the rectangle.

Ellipse, Bounding Box
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When Position is chosen, choose a coordinate point position relative to the shape. These point position options
include Center, Upper left, Upper right, Lower left, and Lower right. In the Dimensions section, enter a width and
height and the appropriate units to plot. A preview of the area can be seen on the artboard (you may have to move
the Area Plotter dialog box to see it).

Point position
®

Point position
Ll

Rectangle, Position (Center) Ellipse, Position (Center)

Use of MAP Locations as Coordinates

Area Plotter

Target: | [ Land area -

Input:
) Page coordinates (Global Rulers)

Coordinate system: NAD83 fUTM zone 10N
[ use:  WGs 84

Input format: | Projected units

‘Options:
Shape: Rectangde v

of X 489,804.352676

o Yo 5459,642.321347

Dimensions:

Units: [ Meser

Width: 400.000000000000000 m

2 3
- 0 0 -0 o =8

Height: 800.000000000000000 m

[] Constrain dimensions

MAP Location 8
MAP Location 2
MAP Location 5
MAP Location 9
MAP Location 7

Artboard 1 »

More MAP Locations...
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To choose MAP Locations as coordinates, click the MAP Locations
button and choose an appropriate one from the context menu.
Alternatively, choose MAP Page Locations or Artboard Locations from
the same context menu.

Click the More MAP Locations in the context menu to open the Select
MAP Location dialog box. The X and Y coordinates and coordinate
system are displayed in a list. The Artboard Locations tab shows the
page coordinates for the Upper left, Upper right, Lower left, and Lower
right corners.



MAP Area Plotter Tool

Tools > MAP Area Plotter Rectangle Tool | [zl| / MAP Area Plotter Ellipse Tool | @

FUNCTIONALITY

Use the MAP Area Plotter Tool to quickly draw georeferenced rectangles and ellipses to MAP Area Layers.

USING THE MAP AREATOOLS

The MAP Area Plotter Tool consists of two tools: Rectangle and Ellipse. There are two ways to use these tools: click and
drag to draw the shape; or single-click to open the Area Plotter dialog box and specify plot options.

Draw using Click and Drag

To draw a shape of unspecified size, click and drag in the artboard until the desired area is achieved. Use keyboard
modifiers to help draw shapes more efficiently: hold the Alt key (Windows) or the Option key (Mac) to draw from

the center; hold the Shift key to constrain the proportions; or hold the space bar to move the area. Enable Adobe
lllustrator Smart Guides to snap to features for better control when drawing. Release the left mouse button to finish
drawing the area.

Enter Specific Dimensions

To draw a shape of specified size, single-click at a point in the MAP document at the desired location to plot the
shape using options in the MAP Area Plotter dialog box (see previous section). By default, the area is centered over the
click point and its coordinates populate the X and Y boxes. Enter width and height values to specify a dimension. A
preview of the area can be seen on the artboard (you may have to move the Area Plotter dialog box to see it).
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Cartographic
Tools

MAPublisher has several special cartographic tools to handle
artwork on MAP layers without distorting georeferencing or
negatively affecting MAP attributes.

Create Halo creates halo around text and features. The

MAP Vector Crop Rectangle Tool trims all the vector data

(on all active layers) falling outside of a crop area. The MAP
Measurement Tools allows users to measure distances in
page or world units and to save the measuring path as an art.

Topics covered in this section:
Create Halo

Scale & Rotate By Attribute
Dash Offset

MAP Measurement Tool

MAP Themes are covered in Chapter 9.
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Create Halo

Object > MAPublisher > Create Halo or MAPublisher Toolbar ||

Output
Create graphicstyle

Create Halo

Output:

Optionally, create a halo
graphic style without
applying it immediately
to artwork

Apply to layer - Optionally,
immediately apply halo
to MAP layer (to layer
group, all art on layer, or
selected art on layer).
Appearance - Choose halo —+
colour, size, opacity and
feather settings

[7] create graphic style:

1 [7] Apply to layer:

: Appearance:
 Colour:
i size:
L
* Opacity:

£ [] Use feather:

Graphics Style

o Graphic soyls name is vali.

[ [T! Feature Labels = ]

@ Apply to layer group
) Apply to all art on layer

) Apply to selected art on layer

C=0M=10 Y=95K=0 ~ |
200p% |2
D 100% =

5.00 px

Preview:
Type: [T Text =
Background colour: A
.
Preview

Text colour: ! Black

Textsize:  50.00pt

FUNCTIONALITY

The Create Halo tool creates halo graphic styles and applies halos to MAP layers.

PREREQUISITES

Preview - Choose Area,
Line, Point or Text type
to change the preview
display below. Adjust
the background colour if
necessary.

Preview display - Shows a
preview of the settings
made in this dialog box.

Text or Symbol preview
options - Changes
depending on Preview
type. Text: adjust text
colour and size. Point:
adjust point symbol and
scale (%).

Halos can be immediately applied to a MAP layer. A Non-MAP layer cannot have halos directly created for them,

however, graphic styles can be created and applied to Non-MAP layers manually.

Swatches and colours should be created before creating halos.

USING CREATE HALO

Click the Create Halo button Iél on the MAPublisher Toolbar or click Object > MAPublisher > Create Halo.

Output

There are several ways to output halos: create a graphic style, apply it to a MAP layer, or do both.

Halos can be independently created as a graphic style without having them applied. They are saved to the Adobe
lllustrator Graphic Style panel and can be applied at a later time. To create one, click the Create graphic style check
box and enter a unique name. Then adjust the Appearance settings.

Halos can be directly applied to a MAP layer without having to create a graphic style. Click the Apply to layer check
box and choose a MAP layer from the drop-down list. Choose one of the options to apply halos to layer group, all art
on layer, or to selected art on layer. Then adjust the Appearance settings.
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Appearance

Set halo appearance settings based on Colour, Size, Opacity and Feather. All Appearance changes can be seen in the
preview display.

The Colour drop-down box is populated with swatches from the Adobe Illustrator Swatches panel. The Size setting
affects the halo size. By default, the Size units are in pixels. Right-click the Size box to choose different units. Use the
Opacity slider or spin box to adjust the transparency of the halo (0% for no halo, 100% for opaque). The Use feather
option creates a soft gradient around the halo (default of 5.0 pixels). Increase feathering for a softer appearance,
decrease feathering for a sharper appearance.

Preview

The preview provides an idea of what the halo may look like on the artwork of you MAP layer. There are four
preview types: Area, Line, Point and Text. The Area and Line preview provides a link to change the fill, color and
stroke of the preview feature. The Point preview provides options to choose a symbol from the Symbol drop-down
list. The Text preview provides a link to change text options such as colour and size. For all types, the background
colour can be adjusted (by default, no colour is set). These Preview options do not affect the halo and only provide
you with an idea of what the halo may look like in a combination of settings.

RESULTS

Halos applied to a MAP layer are immediately visible (text example below). The Adobe lllustrator Appearance panel
shows that there is a Fill (halo) positioned at the bottom for this Type object. The halo can be adjusted in the panel.
This may be useful in cases where a few outliers need some fine tuning to make them more visually appealing.

APPEARANCE
- P

When enabled, halo graphic styles are saved to the Adobe Illustrator Graphic Styles panel. They are not applied
unless the Apply to layer option is enabled.

GRAPHIC STYLES
NEREECE
=
[Orangz Hala -
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Scale & Rotate By Attribute

Object > MAPublisher > Scale & Rotate By Attribute or MAPublisher Toolbar IEI

Scale 8 Rotate By Attribute

Target Layer - Choose the
target layer whose artwork ——-te Target Laven-.[ P! Hotels_point
should be scaled or rotated

[C] selected art only

Rotate - Specify angle or choos: Rotate:
attribute value from target layer

) Specified angle: | 0.00 dearees

At pression Mode Toggle

Rotate objects/patterns - Rotate . Choose between Attribute
patterns only applicable to Rofate cbjects Mode or Expression Mode
Area and Line MAP Layers RIS (ability to build expressions).

Scale - Choose to scal Scale:
uniformly or non-uniformly oo

(see below). Specify scale i
value or choose attribute @ From attribute: [ Scalevalue v]

value from target layer.

@ From attribute: [ R Rottevalue

©) Specified value: | 100

Scale objects

Scale objects/p / and effects e
Scale patterns and strokes and St
effects only applicable to Area and Scale strokes and effects

Line MAP Layers L

Scale Non-uniform
Scale:

Scale Horizontal - Specify ———e Horizontak

horizontal scale value () Specified percentage: | 100.00%
or choose attribute i
value from target layer @ From attribute: R [ [R] ScaleHorizontalValus v]
Scale Vertical - Specify ——e  Verticak:
vertical scale value or () Specified percentage: | 100.00%

choose attribute value

from target layer @ From attribute: K | K RotateVaue -

Scale objects
Scale patterns

Scale strokes and effects

FUNCTIONALITY

The Scale & Rotate By Attribute tool provides options to scale and rotate art objects using specified values or the
target MAP layer's attributes.

PREREQUISITES

MAP Attributes used for scale and rotate must be of type Integer or Real (see Chapter 5).

To only scale or rotate specific art objects, they must be selected first.
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USING SCALE & ROTATE BY ATTRIBUTE

Click the Scale & Rotate By Attribute button IEI on the MAPublisher Toolbar or click Object > MAPublisher > Scale &
Rotate By Attribute.

Choose a Target MAP layer from the drop-down list. All art on the target layer is scaled or rotated unless the Selected
art only option is enabled.

Rotate

Click the Rotate check box to enable the rotate settings. To rotate by a value, in the Specified angle spin box, enter
a value from -360 to 360 degrees. To rotate by a MAP Attribute, click the From attribute drop-down list and choose
one. Alternatively, click the Attribute/Expression Mode toggle button to change the input settings. Build an
expression (see Chapter 5) to determine rotate value.

By default, the Rotate objects option is checked. The Rotate patterns option is enabled only when the targetis a
MAP Area or Line layer. When the Rotate patterns option is enabled and checked, the Rotate objects option can be
unchecked (which will mean that only patterns are rotated).

Scale

Click the Scale check box to enable the rotate settings. There are two scale options: uniform and non-uniform.

The Uniform scale option means that all art is proportionally scaled. In the Specified value spin box, enter a value
from 0 to 1000 percent. To scale by a MAP Attribute, click the From attribute drop-down list and choose one.
Alternatively, click the Attribute/Expression Mode toggle button to change the input settings. Build an expression
to determine scale value.

The Non-uniform scale option provides independent horizontal and vertical scale settings. For each Horizontal and
Vertical scale settings, in the Specified percentage spin boxes, enter a value from 0 to 1000 percent, or choose a MAP
Attribute from the drop-down list, or build an expression to determine scale value.

By default, the Scale objects option is checked. The Scale patterns and Scale strokes and effects options are enabled
only when the target is a MAP Area or Line layer. When either of these two options are enabled and checked, the
Scale objects option can be unchecked.

Note: Scaling or rotating non-point objects may cause the georeferencing for affected features to become
inaccurate. To maintain accurate georeferencing, scale and rotate using the MAP View Editor.
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Dash Offset

Tools > Dash Offset | % |

Dash Offset

Apply to all strokes - Use setting to adjust ——re ) Apply to all strokes: |0.00 pt :
dash offset for the selected path @ Spedfy individually: Cancel
Stroke Dash Offset Preview

Specify individually - Specify individual —te 050 pt 100 pt

dash offset values for each stroke of Il 1000 pt 200 pt

the selected path
[ 3000 pt -200 pt

e T T

M 5000 pt -6.00 pt

Note: Applying dash offset changes will remove any
wvariable stroke settings on the selected path.

FUNCTIONALITY

The Dash Offset tool can be used on paths and compound paths to shift or offset dashes by a specific point value.

PREREQUISITES

A path or compound path with a dash must first be selected before that Dash Offset tool can be used. A path must
have multiple strokes before they can be individually adjusted. Dash Offset only works on one path at a time.

USING DASH OFFSET

Click the Dash Offset button f"_él in the Adobe Illustrator Tools panel.

There are two options to apply dash offset: apply to all strokes (of selected art) and specify individually. Choose
Apply to all strokes and increase or decrease the offset (range of -100.00 to 100.00). Check the Preview check box to
view how the dash offset settings look on the artboard.

When a selected path has multiple strokes applied to it, the Specify individually option is enabled and lists the stroke
colors and stroke weight. In the Dash Offset column, the dash offset can be individually adjusted for each stroke.

Note: Variable stroke settings (such as corner alignment, arrowheads, and arrowhead scale) on the selected path
are removed when applying a dash offset.
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MAP Measurement Tool

Tools > MAP Measurement Tool Q\,
FUNCTIONALITY

The MAP Measurement Tool measures distances (between two points), path distances (multiple points), azimuths,
and the perimeter and area of closed paths in page or map units. Furthermore, the measuring path can be
converted to a line or area in the currently selected layer.

PREREQUISITES

To measure ground distances (great circle distance in map units), the Adobe lllustrator file must contain at least one
MAP View with an assigned coordinate system.

The map units used by the MAP Measurement Tool are set in MAPublisher Preferences. Use the current layer's map
units or select alternative units. The layer's map units are defined in the coordinate system definition of the selected
MAP View and can be viewed in the MAP View Editor by clicking the information button of the Source Coordinate
System (called Point Style in the Definition tab)—see chapter 4 and Appendix A2 for details.

The Adobe lllustrator page units can be accessed and changed in the Document Setup dialog box (Adobe Illustrator
menu File > Document Setup > Units drop-down list).

To use vector snapping while measuring, enable the Adobe Illustrator Smart Guides (Adobe Illustrator menu View >
Smart Guides). The snapping tolerance is set in the Adobe lllustrator Preferences for Smart Guides (Adobe lllustrator
menu Edit > Preferences > Smart Guides).

USING THE MAP MEASUREMENT TOOL

Click the MAP Measurement Tool button | <. in the Adobe lllustrator Tools panel. The cursor becomes a cross -

MAP Layers are measured in map units (great circle or real world distances). Select a MAP Layer and then click to
measure. The units of the layer's parent MAP View will be used in the measurements.

Non-MAP Layers are measured in page units (distances on the page). Select a non-MAP Layer and then click to
measure. The units of the document will be used in the measurements.

Note: While the MAP Measurement Tool is enabled, users can change the selected layer in the Adobe Illustrator
Layers panel. If the new selected layer is contained in a different MAP View, the distance values are updated
accordingly on the screen automatically without having to start a new measurement — e.g. if the MAP View
scale is different, the measurement will significantly change.

When Adobe lllustrator Smart Guides are enabled, the MAP Measuring Tool can snap to existing anchor points.
When the mouse cursors is near enough a point, Adobe lllustrator highlights it as shown in the image below.

/
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Measure Distance

By default, the MAP Measurement Tool measures distance between two points.

Click a starting point to begin measuring. As the mouse moves on the artboard, a distance label indicates the
distance (and azimuths, if enabled in MAPublisher Preferences) from the starting point to the current mouse
position. A second click digitizes the end point. As soon as the second point is clicked, the measurement is ended

and the total distance is displayed.
E’\ %

Total distance: 1108.085350 usft ™

A

Measure Path Distance

Click a starting point to begin measuring. Before clicking a second time, hold down the Shift key. The cursor

changes from —|- to 3. A new point is added on the path, but the measurement does not end.

Keep holding the Shift key while adding more points along the path. As the mouse moves on the artboard, a total
distance label indicates the length of the path already digitized and the distance from the last added point to the
current mouse position.

While digitizing the measuring path, hold the Alt key (Windows) or Alt/Option key (Mac) to display the length of each
digitized path segment.

Before adding the last point, release the Shift key. As soon as the last point is clicked, the measurement is ended
and the total distance is displayed. Hold the Alt key (Windows) or Alt/Option key (Mac) while clicking the last point to
display all annotations (segment lengths and total distance).

)
~§ b
$L

Segment: 833,592 usft
Total distance: 2845.43154% usft

1147.345156 usft
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Measure Perimeter and Area

To measure the perimeter and area of a closed path, follow the same steps as measuring the distance of a path.
When digitizing the last point, release the Shift button and place the mouse cursor over the start point — a box is
drawn around the starting point — click to close the path and end the measurement.

Hold the Alt key (Windows) or Control key (Mac) while digitizing to display the length of each segment.

Perimeter: 2483.107054 m
Arsa: 28BB85.023306 m2

Note: Holding down the Shift key while clicking the start point again prevents the path from being closed and the
measurement can continue.

Convert Measurement Line to Art
When any of the above measurement methods are finished, two options are available:
1. Click anywhere on the artboard once to clear the measurement line and label

2. Hold the Shift key and click anywhere on the artboard once. This converts the measurement line to an
Adobe lllustrator art object, adds it to the current layer and applies the current stroke settings.

A new click on the page starts a new measurement. To exit the MAP Measurement Tool, select another tool in the
Adobe lllustrator Tools panel.

MAP Measurement Tool Preferences
Access the MAP Measurement Tool Preferences by double-clicking the MAP Measurement Tool button Q on the
Adobe lllustrator Tools panel or from the menu Edit > MAPublisher Preferences > MAP Measurement.

Set the number of decimals for the measurement values, enable display of azimuths, and change the digitized path
and new segment colours. See chapter 1 for more information on MAPublisher Preferences.
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Geoprocessing

The Adobe lllustrator environment offers lots of flexibility
when working with vector art. To enhance Adobe lllustrator
functionality, MAPublisher introduces many geometry
operations designed specifically for cartographic purposes.

Create a proximity around lines using the Buffer Art tool.
Change the direction of lines using the Flip Lines tool; useful
for road mapping applications. Easily join points, lines and
areas to create seamless datasets. In addition, simplify lines
to reduce the amount of vertex points, while retaining spatial
referencing.

o E
=

Topics covered in this section:

,,g% Join Areas
'3 Join Points
7; Join Lines
A }\\\‘3, Simplify Lines
= Flip Lines
Buffer Art

Vector Crop
MAP Vector Crop Tool
Crop to Shape

| St Thomay g
i |
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Join Areas

Object > MAPublisher > Join Areas* or MAP Toolbar

&

ot

Attributes - Determines how

Join Areas ! e
attributes will be handled
Target Layer - Layer on which —te Target Layer: | [A Lakes v]  Attrbutes: once features are joined
the join will be performed into a single object. For
Join Type - Defines art to be o Attribute Operation Options string fields choose to
- ——e Join Type: .
joined. Ch Il art - FeatureCla  Clearif different  N/A either Clear the field, Clear
Joined. Lhoose all art on () Join all selected areas on target layer if different (two or more
layer or choose to join all 1
Y jom © 30 areas by attrbue: Mamel Joinon A unique values are found),
or selected art on similar "
attribute values. [] only join selected areas Name2 Clear if different N/A sort Least Alphabetical (Z-A)
or Most Alphabetical (A-Z).
Join Method - Group areas —— e Join Method e Clarif difesent | WA For Integer or Real fields
- —— Join 1 S
. , options include Clear the
creates Adobe lllustrator [ ScaleRank Clear if different  N/A e
groups of joined art =) CRIZEES field, Clear if different (two
Create a compound ath' @ Create compound areas or more unique values are
P P (@ Apply to every grouped component found), return the Sum or
for each grouped art Dissolve borders between adjacent sub-areas ,
with the option to outline (") Only apply to grauped components that satisify: Average of the grouped
group or leave internal Fl values or enter the Largest
roup borders intact <) & Value or Smallest Value of
group : Empty expression. In paosition: 0 the grouped fields.

— Only apply to grouped components that satisfy:
Use an expression to define which
joined areas the above attribute field
options will apply to.

FUNCTIONALITY

Join Areas groups art objects based on a specified similar attribute value. An attribute field is defined and a new
object is created for each unique value within that field. Options can be set to create Adobe lllustrator groups or
compound paths, while either maintaining the outlines of the original features or dissolving sub-areas into the
larger area.

USING JOIN AREAS

To use Join Areas, choose Object > MAPublisher > Join Areas or click the MAPublisher toolbar button |E| Choose
the Target Layer on which Join Areas should be performed. Specify the Join Type to either Join all selected areas on target
layer or Join areas by attribute. Specify an attribute which the join will be based on. It is noted in the Attributes section
Operation column as Join on.

Select the Join Method type to either Adobe lllustrator Group areas or Create compound areas. For the latter option,
choose to Dissolve borders between adjacent sub-areas. Not checking this option will maintain the borders of individual
areas. For example, when grouping the countries of the world by its Continent field attributes, the Continent field
will result in five new objects, one for each continent. Dissolving borders between adjacent sub-areas will leave the
continent outlines. Choosing not to dissolve, the outline of each country will remain. In both cases, there will be one
object for each continent in the attribute table.

When areas are joined, many attributes that were valid to the original lines may no longer be valid. For example,
after joining the countries of the world on the Continent field, the field containing country capitals will no longer
be valid, as each continent does not have one capital. Thus, operations can be set to determine how each attribute
field is handled. By default all attribute operations are set Clear if different, meaning that the attribute is cleared if
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there are more than two unique values present after the join. Depending on the attribute type (string, boolean,
integer or real) other operations include Clear, Sum, Average, Smallest Value, Largest Value, Least alphabetical, Most alphabetical
and Concatenate. The last three operations can only be applied to string attribute types. Alphabetical sorting returns
either the first or last item from an alphabetized list of attributes. Concatenate joins string values together and
separates them with a separator.

There are two options to apply attribute operations to grouped components. Choose Apply to every grouped component
option to apply all. Alternatively, choose Only apply to grouped components that satisfy to enable the expression builder
to enter an expression that will only apply the attribute operations to values of the object where the expression
condition is met. All other values that aren't satisfied will be cleared. For example, the expression "Continent =
Africa" would only apply the operations to attributes of the object that has the attribute "Continent" and value of
"Africa". All attributes for this art object will maintain its attributes.

RESULTS

To tell if areas are joined after executing the Join Areas function, look for visual differences of the features on the
map or look in the Adobe lllustrator Layers panel. Depending on the join method, compound areas or grouped
areas, the Layers panel will display the results. In the example below, the original Lower 48 layer is shown and two
join method possibilities. The Group areas method shows states grouped by the attribute Sub Region (W S Cen,
Pacific, etc). The Create compound areas method shows states joined by compound path (and in this case, with the
option Dissolve borders between adjacent sub-areas enabled).

Original Join Method: Group Areas Join Method: Compound Areas

e e —— [ —
JmEs - [ gEET.s [ gEES s §
®| @] <Compound Paths (o] ® | v [#]w s cen Q B [#] <campound path:» o

® <Path= ° ®| [ [E]wncen o B [{] <Compound paths 5]
& [#] «Compound path- o | ®[ I [F]san Q | <Compound Path> [5)

® «Paths [o] LI I [F] Pacfic 5] LI [#] <cempound Path= 5]
El ] <path= o ® | b [Fnens o Eln [d] <Campound Path o
& <Path= [s] ® b [ ] men o B [®] <Compound paths [5)
& [ <Compound path Q ® b @] wid At Q | (@] <Path> [5)

® (L] <path= [o] LI DEESCen 5] LI (] <Path= 5]
El [[] <path= o F_[}EENC&H ° 3 Eln [£] <patn> ° 3
® ] =p=th= o [0 [Jeavert B - | [ever -
& ] <raih- o Blayers ® @ o @ 8 Layers ® cd & 3

® (1] <path= [o]
m [55] < path o T

8 Layers R
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Join Points

Object > MAPublisher > Join Points* or MAP Toolbar

o

o

Input Layer - Use this drop-down list to Join Bt
select the Point layer containing the Source:
symbols you wish to join. Layer: Pl Mare Routes_point ]
'
All Points / Selected Points (©) Allpoints @ Selected points
You can choose to join only those
points that have been selected or all Destination:
points on the selected MAP Layer. byeE Joined_paints_layer D Layer - Enter the name of’che:l
output layer. This new layer will contain
Close paths - Check this option to —— [Bilcceerats the generated lines.
generate an Area layer. If unchecked, a
Line layer will be generated. Group By: Group By - Specify the attribute column
Column: [ [§] #Mame -] containing similar values to determine
Sort By Available Columns - Select an each group of points
attribute column containing —| SortBy:
a:ﬁzr:gg%ﬁlzistgo:;éttﬁi'::lzr:nﬂfg Available Columns Sort Order Sort Order - Contains a hierarchical list of
the Sort Order #LayerName I Order the columns specified to sort by.

' R #Pagex To remove a column from the Sort
R 2PageY Order, click the Remove button.
M =1 ]
[B] #HorizontalScale Move Up / Move Down - You can move
#VerticalScale columns up and down the
[R] #Rotation Sort Order hierarchy by clicking the
8] #5tyle appropriate button .
[B] #MapX
Rl #MapY Add/ Remove buttons - Click to add or
Name remove attributes from the lists

Join Points allows a group of point symbols to be joined to form a line, based upon attribute values used as sorting
criteria. For example, it is common to form a line based on points collected by a GPS device. When Join Points
is completed, a new map layer is created that contains the line art. The generated line layer contains the same

common attribute column that was used to group the points together.

PREREQUISITES

Join Points can only function on P’ Point layers, and can be used on both currently selected point symbols or all the
point symbols on a specified layer. There must be at least two attribute columns on the specified point layer in order
to use Join Points. To open the dialog box, choose Object > MAPublisher > Join Points or click the Join Points button

a‘o on the MAPublisher toolbar.
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USING JOIN POINTS

From the Source Layer drop-down list, select the Point layer containing the points to be joined. Then choose a join that
is based on either All Points or only Selected Points.

Specify a name for the Destination Layer that this operation will generate. By default, the program will generate a
Line layer. To generate an [£] Area layer (by linking the line end to the start) check the Close paths option.

In the Group By Column drop-down list, select the attribute column containing the common attributes used to join
the point together. For example, to join points based on a unique ID, select the column containing the common ID
names. This will result in point symbols containing the same name being joined together.

A logical order by which the points are being joined must be specified because each point will be represented by
anode in a line string. To properly join points, a sort order must be chosen based on an attribute columns. These
should be attribute columns which contain rising alphabetical or numerical values. For example, GPS data may
contain an attribute that specifies the order in which the points were collected (first node, second node, etc).

In the Sort By Available Columns list, select the primary sorting column. This should be the attribute column that
contains the best fit for rising alphabetical or numerical values. For example if points have rising values from 1-10,
the point with a value equal to 1 will be at the start of the generated line, and the point with a value equal to 10 will
be at the end of the line. Select a column and then click the Add button to place the column into the Sort Order list. If
all the values contained in the first Sort By column are unique,it is not required to set a secondary column.

If the first Sort By column contained any similar values, a secondary column must be specified. Again, click a column
in the Sort By Available Columns list, and then click the Add button to place the column in the Sort Order list. Similarly
third, fourth and fifth Sort By columns can be specified in the same manner if previous columns contain similar
values. Note that the Sort By columns are a hierarchy with the topmost specified column being used for the primary
sort, then the second, then third, etc.

To move columns up or down the hierarchy after they have been specified, simply select the appropriate column in
the Sort Order list and click either the Up or Down button.

To remove any Sort By columns from the hierarchy, select the column in the Sort Order list and click the Remove button.
Note that a maximum of five columns can be used to sort points into a logical order. If the columns specified to sort

by do not distinguish an ordering between certain points, the order of these points in the attribute table will be
used to determine the order of the nodes in the generated line string.

RESULTS

When all the options have been set click 0K to join the points on the specified layer. An |£] Area or | L Line layer will
be generated, depending on the specified output layer type, which will be placed in the same MAP View as the
Input Point layer which has been joined.
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Target Layer - Layer on which—

the join will be performed

Destination - Defines line —{

features to be joined. Join
original lines on target

Join Lines

Object > MAPublisher > Join Lines* or MAP Toolbar .+

@ Join original lines on target layer

Join Lines
| Target Layer: [ ) roads_center_line v] Attributes:
Attribute Operstion  Options
|+ Destination:
Street Clear if different N/A

[T pen_pattern Clear if different N/A

Attributes - Determines how
attributes will be handled
once features are joined
into a single object. For
string fields choose to
either Clear the field, Clear

() Copy results to new layer: | Mew layer o
if different (two or more

unique values are found),
sort Least Alphabetical (Z-A)
or Most Alphabetical (A-Z).
For Integer or Real fields
options include Clear the
field, Clear if different (two
or more unique values are
found), return the Sum or
Average of the grouped
values or enter the Largest
Value or Smallest Value of
the grouped fields.

layer or copy results to a

new layer.
Join Options:

Proximity - Assign a —{--e Proximity: 0.013889 =

proximity value to  Llu [ ciose seqment gaps
determine how close
Only join lines with shared values from:

together (in map units)

the lines must be in order [7] only join selected lines
to be joined. Optionally,

choose appropriate units. & (@

2@ Apply to every grouped component

() Only apply to grouped components that satisify: e—

Empty expression. In position: 0

Close Segment Gaps - If

two line segments are
separated by a distance
less than the Proximity
value, checking this
option will create a line
segment that connects
the two lines. Otherwise a
compound path is created.

‘— Apply to every grouped
component - Choose
to apply Join Lines
options to every
grouped component

Only apply to grouped
components that satisfy:

Use an expression to
define which joined lines
the above attribute field
options will apply to

Only join selected lines: Only join lines with shared
Check to only join values from: - Check to
selected lines (before this join lines that have
dialog box is opened) shared attribute values

FUNCTIONALITY

Join Lines allows a group of line features to be joined based on a common attribute. For example, it may be desirable
to join all segments of a particular street by the common attribute of street name in order to create a single line
element representing that street. When Join Lines is completed, a new map layer is created that contains the joined
lines. These lines contain an attribute column based on the column used to join them.

Join Lines can be very useful for reducing the size of a data file by joining related lines and thus reducing the
number of segments and associated data present in the file. It is also very useful to run Join Lines prior to labeling
with Label Features in order to reduce the occurrence of duplicate labels (see chapter 10 Labeling).

PREREQUISITES

Join Lines can be executed on |L| MAP Line layers.

USING JOIN LINES

To use Join Lines, click the Join Lines button " on the MAPublisher toolbar or choose Object > MAPublisher > Join
Lines or. In the Target Layer drop-down list, select the Line layer where the join will be performed. In the Destination
options, choose either to perform the join on the original target layer or specify a name for the new line layer that
MAPublisher will create to hold the joined lines.

Under Join Options, a Proximity value should be entered and proximity Units assigned. Units can be specified in map
units or page units. A proximity value of zero will only join line segments that are touching. If the distance between
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the end of a segment and the start of another is greater than the set proximity value, these lines will not be joined.
If two line segments in the selection are separated by a distance less than the set proximity value, check the Close
segment gaps option to create a line segment that connects the two lines. When not selected, a compound path will
be created. By default, the Only join lines with shared values from option is checked. Specify an attribute which the join
will be based on. It is noted in the Operation column as Join on. For example, when joining streets, join based on a
common identifier or street name. To further narrow down which lines should be joined, check the Only Join selected
lines option. These lines should be selected prior to opening the Join Lines dialog box.

When lines are joined, many attributes that were valid to the original lines may no longer be valid. For example,
after joining street line data, an attribute that contains address ranges will no longer be valid because values will
not be unique anymore. Thus, operations can be set to determine how each attribute field is handled. By default all
attribute operations are set Clear if different, meaning that the attribute is cleared if there are more than two unique
values present after the join. Depending on the attribute type (string, boolean, integer or real) other operations
include Clear, Sum, Average, Smallest Value, Largest Value, Least alphabetical, Most alphabetical and Concatenate. The last three
operations can only be applied to string attribute types. Alphabetical sorting returns either the first or last item from
an alphabetized list of attributes. Concatenate joins string values together and separates them with a separator.

The Concatenate operation has options to adjust the separator. When Concatenate is chosen in the Operation
column for an attribute, the text Using defaults; double-click to edit appears in the Options column. Double-click the
text to open the Concatenate Operation Options dialog box. Choose a separator from the Use drop-down list or
specify a custom one.

Concatenate Operation Options

Serrato
@ Use: [ Comma then space -] | Cancel

) Custom:

Set string attribute size: 200 =

If the attribute size is already larger than this, it will
remain unchanged.

String attribute sizes may become lengthy due to a join. Adjust the set string attribute size setting to increase or
decrease the maximum number of characters of which the attribute field can store.

There are two options to apply attribute operations to grouped components. Choose Apply to every grouped component
option to apply all. Alternatively, choose Only apply to grouped components that satisfy to enable the expression builder
to enter an expression that will only apply the attribute operations to values of the object where the expression
condition is met. All other values that aren't satisfied will be cleared. For example, the expression "Street = Main St"
would only apply the operations to attributes of the object that has the attribute "Street" and value of "Main St". All
attributes for this art object will maintain its attributes.
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Simplify Lines

Object > MAPublisher > Simplify Lines* or MAP Toolbar [+

Simplify Lines

Proximity - Set the simplification Proximity: 0.050000 3 | Kilometes ~ ] OK
tolerance (type or use arrows)

based on specified units
Vertex Count:

Original: 13113 Units - Select page units or map
Vertex Count - Shows the original —— units (angular or linear unit list
number of vertices of the Simplified: 11634 (83%) depending if the map coordinate
selected lines. Click the Preview system is projected or geodetic)
i used for the proximity tolerance
button tt_) display the ngmbgr of « Uses Douglas Peucker e simpification p y
vertices after simplification. T i e me mhe s

FUNCTIONALITY

Simplify Lines allows for the simplification or generalization of vector line and area data. It uses the popular
Douglas-Peucker algorithm for removing nodes and vertices during simplification. For more information about this
algorithm, see Appendix A1.

Simplify Lines is used to reduce the number of points required to represent a vector-encoded line where the lines
are approximated by a stream of X-Y coordinates. The operation can be used on [Li| Line or |A] Area layers and
removes nodes based upon a proximity value in either Page Units or Map Units. The list of Map Units depends on the
MAP View coordinate system—e.g. angular units (page units, degrees, etc) for geodetic coordinate systems; linear
units (such as metre, feet) for projected coordinate systems.

The Proximity value or simplification tolerance is based on the vertical difference between the begin/end line

and points off a line, not the distance between anchor points on the line. The Douglas-Peucker algorithm takes
the proximity value and iterates through the line vertices to determine the points that fall within the specified
proximity distance off the line and removes those vertices. Once all vertices are determined to be greater than the
proximity value, the line processing ends. A smaller proximity value will usually result in a fewer number of nodes
being removed.

USING SIMPLIFY LINES

To use Simplify Lines, choose Object > MAPublisher > Simplify Lines or the MAPublisher toolbar button d.~"° .Entera
proximity value in Page Units or Map Units by making a selection from the Units drop-down list. Page Units are the units
of the current document. Enter a proximity value in the unit specified by typing a value or by using the arrows.

Click the Preview button to see the simplification result before committing to it. The Vertex Count shows how many
vertices are in the simplified result (and calculates a percentage of overall simplification). Adjust the proximity as
necessary in order to achieve the desired results particular to the scale and coverage area. Click 0K to perform to
complete the simplify operation.
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RESULTS

All selected lines or areas are simplified according to the settings. Simplified lines or areas will not be simplified
again unless the tolerance value is increased. For example, if a line has been simplified with a proximity of 1.5 km,
then it will not be simplified again until the tolerance is set to a value larger than 1.5 km.

In practice, it means that simplified lines can be selected again with non-simplified lines to run the operation again,
when the Simplify Lines operation is run only the new lines will be simplified (unless the proximity value is increased).

Notes: It is a good idea to perform simplify lines on artwork before exporting a Flash map. This will reduce the file
size and improve performance and loading times.

Bezier curves cannot be simplified using the MAPublisher Simplify Lines tool. To smooth the appearance of
paths using Bezier curves, use the Adobe lllustrator Simplify tool located in the menu Object > Path > Simplify.
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Flip Lines

Object > MAPublisher > Flip Lines* or MAP Toolbar |
FUNCTIONALITY

MAPublisher Flip Lines reverses the endpoints of a line or an area (open or closed path).

Adobe lllustrator Brushes and Type on a Path tools are designed to position patterns and text depending on the
direction of the endpoints. Two consequences of this are:
«  Labels are placed upside down and backward when using the MAPublisher labeling tools (MAP Tagger
tool and Label Features, see chapter 10 - Labeling).
«  When applying graphic styles with a brush pattern to paths (manually or using MAPublisher MAP
Themes), patterns are not applied at the right side of the line or in the expected orientation.

In order for the labels or patterns to be consistent for a group of lines, flipping lines may be necessary.

PREREQUISITES

Lines can be flipped on [Li| Line and [ A Area layers.

USING FLIP LINES

To flip lines, select the lines and then choose Object > MAPublisher > Flip Lines or click the Flip Lines button |+ on
the MAPublisher toolbar.

Notes: Flip Lines is a discrete operation. It may not be apparent that the lines are flipped.

When exporting Area layers to GIS formats, polygon outlines must have a positive #Area value in the MAP
Attributes panel. If some values in the #Area column are negative (and #AreaDirection is equal to Counter
Clockwise), Flip Lines can then be used to reverse the #AreaDirection and convert the #Area to a positive value.

For compound paths, the #AreaDirection property is always equal to Indeterminate, even though compound
paths can be flipped.

The MAPublisher MAP Tagger tool and Label Features have an option to enable Flip upside-down labels to create
text in a consistent orientation, without requiring the use of the Flip Lines operation (see chapter 10).
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Buffer Art

Object > MAPublisher > Buffer Art or MAP Toolbar | &%)

Source Layer - Specify the layer to Buffer At
base the buffer art on. To buffer onIy—L Source: =
selected art on the specified layer, L|lejayer: [EiRwvers 3
check the option below it.

[] Only buffer selectzd art

value and choose appropriate L= Units - Select a unit to use for the

units to buffer the art by Lt1e@ staticvalue: 25000000 m < buffer values. The default is the
current map unit.

Staticvalue - Enter a speciﬁc‘L B

[ Add buffer at intervals of: | 0,000000 m

Attribute value - Buffer by values —-re ) Attribute value: | [T] =Opacity
contained in an attribute table e[| Merge buffered results by buffer width value

Merge buffered results by buffer width J Destination:

value - Dissolves separate segments b - Select the Area layer
to create one buffer area @ New layer: A . .
9) New layer: Buffered art which will hold the buffered
This layes willinherit the souce layer's atribute schema objects or create a new layer
Options:
Apply Style - Enable to choose —[w] apply style: Stroke: 1% [100% 5] =[ro0pt

stylization options

FUNCTIONALITY

MAPublisher Buffer Art creates area objects of specified distance around point, line, and area features. This may be
useful when attempting to calculate distances on each side of a road, creating proximity around fire hydrant points,
or buffering parcel lots.

USING BUFFER ART

If required, select the art to buffer and choose Object > MAPublisher > Buffer Art or the MAPublisher toolbar button.
Buffers are added to all art on the specified layer, unless the option to only buffer select art is checked.

The buffer width can be entered as a fixed value or by selecting an attribute column that contains numeric values.
With the Staticvalue option checked, a buffer is created with the specified value. With the Attribute value option
checked, a buffer is calculated and created based on the value related to the selected object in the attribute table.
Set the buffer value units in the Units drop-down list. For example, a value of 5 map units will create a buffer of 5
map units around a feature.

Optionally, enable Add buffer intervals of and specify an interval distance to create equally spaced rings around
features. This is also known as creating concentric rings.

Enable the Merge buffered results by buffer width value option to remove any compound path segments and create one
resulting buffer area. This is also known as dissolving buffers.

Choose an existing Area layer as the destination for the new buffer. Alternatively, specify a new layer name to create
a new layer where the buffer areas will be stored.

Buffer Options
Enable the Apply Style option and choose a preset Graphic Style or Custom stroke, fill and transparency.
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Vector Crop

Object > MAPublisher > Vector Crop or MAP Toolbar  [&]

Location type: Bounding box

MAP Vector Crop ] Target - Target to crop
everything, MAP Views,

Input: Target:
,-’ " layers and sublayers

") Page coordinates (Global Rulers)

Input - Specify which input —— e © Alllayers in document

coordinate system to use for @ Allayersin: | @ Hotels

lotting Corner and Opposite Coordinate system: NADS3 / UTM zone 10N i . X
i ° C Zp W © only: [T Feature Labels Adv?"‘Ed .AdvanCEd cropping
orner coordinates [ Use: wes 54 options dialog box
Indude sublayers

Input format: [Projected units

Options - Specify shape as

Rectangle or Ellipse. This Options: n .
dialog boxdshovgs Iocatiﬁn Shape: Location type: Position
type as Bounding box. To the ——* .
ypfar right showz options for e options:

Position location type. Corner: i =

« X 491,823.819044 m
Corner - Specify X and Y —— . .
pecty o ¥: 5,458,529.709588 m Point - Specify —ePaint:

coordinates to use as a corner -
anchor point

i _ X: 480,333.520369 m
of the bounding box Opposite Corner: and Xand Y 4
o M 490,154.901555 m coordinate of it Y 5,458,621.157222 m
Opposite Corner - Specify X ——+o | . B B
«F ¥ 5,459,154.601168 m Dimensions —e Dimensions:

and Y coordinates to use as
the opposite corner of the
bounding box

Specify units,  units: [Me= -]
width and height
of the crop area

Width:  200.000000000000000 m =

Height:  800.000000000000000 m -

[T] Constrain dimensions

Vector Crop Advanced Options

Advanced
Point Text - Choose how ——— e Point Text: Points: m
point text is handled (7) Vectorize and crop [T Vectorize and crop Points - Choose how points are

when intersected by a
crop boundary

@ Crop textbased on: Cancel handled when intersected by
¢ : Cropping Boundary:
- a crop boundary
@ Origin of first character  acauracy for bezier cropping boundaries: Reset

o) MR i Cropping Boundary - Adjust
Path Text - Choose how ——{ePath Text: Freemies le=aaate accuracy for vectorizing a
point text is handled () Vectorize and cop bezier path when intersected
when intersected by a © Crop path orly by a crop boundary

crop boundar:
P y @ Crop textbased on:

@ Origin of first character
() Text bounds

[ Crop path

Mote: Attributes and feature type support will be lost when vectorizing points or text.

FUNCTIONALITY

The MAPublisher Vector Crop trims vector data to a rectangular or ellipse area by using page or world coordinates,
and by location type (using either a bounding box or by a single coordinate position). Use it to create a precise crop
of a larger dataset based on coordinate locations (by bounding box or position). It is very useful for creating map
insets (smaller maps centered on specific areas).



PREREQUISITES

Before using Vector Crop, ensure that layers being cropped are visible and unlocked in the Adobe lllustrator Layers
panel. Invisible and locked layers are not cropped. The extent of the map that will remain after cropping must be
visible on the screen, so make sure to zoom out sufficiently prior to starting the vector crop tool.

Note: Text typed on a path may not return to their prior state after an undo.

USING VECTOR CROP

On the MAPublisher Toolbar, click the Vector Crop button || or click Object > MAPublisher > Vector Crop. This
opens the MAP Vector Crop dialog box.

Input Coordinates

The Input sets the coordinate system in which the starting point coordinates are entered. Input coordinates can
either be Page Coordinates or World Coordinates.

When the Page coordinates (Global Rulers) option is chosen, page coordinate values (in pixels) can be entered for the
Corner and Opposite Corner coordinates.

When the World coordinates option is chosen, the MAP View drop-down list becomes enabled. Choose the appropriate
MAP View to use. Its coordinate system is displayed directly below the MAP View drop-down list. The options in the
dialog box will change to reflect a geodetic or projected coordinate system and corner values can be entered either
as (a variation of) decimal degrees or in projected units. To use an alternative coordinate system, click the Use check
box, and click the coordinate system link. Choose an appropriate coordinate system in the Select Coordinate System
dialog box.

Shape and Location Type Options

There are two shape options to choose from when plotting areas: rectangle and ellipse. More importantly, two
location types determine how the shapes are plotted: Bounding box and Position.

When Bounding box is chosen, enter (map page or map world) coordinates into the Corner and Opposite Corner
coordinates to define the area. A preview of the area can be seen on the artboard (you may have to move the Area
Plotter dialog box to see it). Note: Any corner and its opposing corner can be used for the bounding box.

Corner Corner
o .

Opposite Corner Opposite Corner

Rectangle, Bounding Box Ellipse, Bounding Box
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When Position is chosen, choose a coordinate point position relative to the shape. These point position options
include Center, Upper left, Upper right, Lower left, and Lower right. In the Size section, enter a width and height and
the appropriate units to plot. A preview of the area can be seen on the artboard (you may have to move the Area
Plotter dialog box to see it).

Point position Point position
® Ll

Rectangle, Position (Center) Ellipse, Position (Center)

Advanced Options

For point text, Vectorize and crop will create

an outline of the text and then crop it.

This option does not preserve text editing .Renaissance Vancouver Hotel Harbourside
ability. It should be used in situations where

having text is still important and requires a  p.pgrell Suites Hotel
clean cut (e.g. inset or key map). s _Fairmont Hotel

.The Barclay House Bed and Breakfast

To preserve text while cropping, use the
Crop text based on option. The Origin of first Original layout before crop
character sub-option determines whether

the first character of text is within the crop area or
not. If it isn't, the text is cropped. The Text bounds
sub-option determines whether the text bounding
box is within the crop area or not. If it isn't, the text The Barclay House Bed and Breakfast
is cropped.

Renaissance Vancouver Hotel Harbourside
.

.Fairmont Hotel
Crop based on origin of first character

Renaissance Vancouver Hotel Harbourside
L]

'Rer
.The Barclay House Bed ¢ .The Barclay House Bed and Breakfast
Suites Hotel Pendrell Suites Hote.l
: Fairn Fairmont Hotel
Vectorize and crop Crop based on text bounds

172 | Chapter 8: Geoprocessing



For path text, the similar options will yield the same results as explained above. One difference is the Crop path only
option, which is used to crop the path text to the crop shape. To preserve text while cropping, use the Crop text
based on option. Similarly, enable the Crop path check box to ensure the path is cropped.

For points, Vectorize and crop will create an outline |
of the points and then crop it. This results in small

areas that are now partially cropped. . .

For paths, to crop to a shape of unspecified size,
click and drag in the artboard until the desired

crop area is achieved. Use keyboard modifiers to Poi bol Vectorized and dvoi bol
help draw shapes more efficiently. oint symhol ectorized and cropped point symho

RESULTS

On all visible and unlocked layers:

- Text objects that have their anchor outside of the cropping boundary are deleted. Text objects with
their anchor inside the cropping rectangle are retained completely.

- Points falling outside of the cropping boundary are deleted (the position of the center of the symbol is
relevant). Symbols that have their center inside the cropping rectangle are maintained as a whole.

«  Lines are clipped at the boundary of the cropping rectangle.

«  Areas (polygons) that are completely out of the cropping boundary are deleted. Areas intersecting with
the cropping boundary are clipped and closed following the edge of the boundary.

The overall result is a map coverage reduced to the cropping boundary. See examples on the next page.

Notes: The purpose of Vector Crop is to cut vector data (points, lines and polygons). However, some Adobe
lllustrator specific objects may not be cropped properly using this tool:

- Blend and Live Paint objects

«  Any art using effects that have been rasterized

«  Custom art such as scale bars, grids/graticules, north arrows (expand custom art to crop)

«  Compound shapes

«  Legacy and overflowing text

«  Locked objects (command box: either treat locked layers as unlocked or skip locked layers)
«  Hidden layers (will be skipped)

. Images

"Skipping art because topology is invalid" messages display in the MAPublisher Log when a line intersects
itself along the border of your crop boundary. "Hidden layer" messages display in MAPublisher Log.

Due to an Adobe lllustrator limitation, text on a path may flip after a crop. This can be corrected by checking
the Flip option in the Type on the Path Options dialog box (choose Type > Type on a Path > Type on a Path Options).
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Crop Examples

@l.llo
O S L g Crop result: lines and areas are
o i ; O"‘“’;’- crppped, text wiFh first letter

N/ within the cropping rectangle
S '(’5" et and symbol with center pointin

Q— B Q-—— rectangle are maintained. The
& e i o MAP Objects can be scaled for a

better fit in the document.

Original map

Create Inset

Create a map inset using Vector Crop:
«  Open any map, and make a copy of it (choose File > Save a Copy).
Leave the original map open, make the copy the active document.
«  Use MAP Vector Crop to crop the area of special interest.

«  Make the original map active. In the MAP Views panel, select the option menu Import MAP View from
document. Select the MAP View from the copy .

@I.ﬂlc
. Paris -..'5"".‘ ! :‘~P(5£
G)hﬂ . O' \‘““8 i
N @""“‘, - 1 i
Bordeaus |
é"“"’"’" e
Original Copy and Crop

The map now contains two MAP Views (at least). Their relative position can be managed from the MAP View Editor,
as well as the scale of the inset map.
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MAP Vector Crop Tool

Tools > MAP Vector Rectangle Crop Tool / Tools > MAP Vector Ellipse Crop Tool

FUNCTIONALITY

Use the MAP Vector Crop Tool, to quickly crop MAP Layers using rectangles and ellipses. This tool can be used using two
methods: crop using click and drag or crop using specific dimensions.

PREREQUISITES

Before using the MAP Vector Crop Tool, ensure that layers being cropped are visible and unlocked in the Adobe
lllustrator Layers panel. Invisible and locked layers are not cropped. The extent of the map that will remain after
cropping must be visible on the screen, so make sure to zoom out sufficiently prior to starting the vector crop tool.

Open MAPublisher Preferences to adjust crop settings for MAP Crop Tool. These are the same Advanced settings for
Vector Crop and Crop to Shape.

USING THE MAP YECTOR CROP TOOL

The MAP Vector Crop Tool consists of two tools: Rectangle and Ellipse. There are two ways to use these tools: click and
drag to draw the crop shape; or single-click to open the MAP Vector Crop dialog box and specify crop options.

Crop using Click and Drag

To crop to a shape of unspecified size, click and drag in the artboard until the desired crop area is achieved. Use
keyboard modifiers to help draw shapes more efficiently: hold the Alt key (Windows) or the Option key (Mac) to draw
from the center; hold the Shift key to constrain the proportions; or hold the space bar to move the area. Enable
Adobe lllustrator Smart Guides to snap to features for better control when drawing. Release the left mouse button
to finish cropping the area.

Crop using Specific Dimensions

To crop to a shape of specified size, single-click at a point in the MAP document at the desired location to specify a
starting crop location using options in the MAP Vector Crop dialog box (see previous section). By default, the crop area
is centered over the click point and its coordinates populate the X and Y boxes. Enter width and height values to
specify a crop size. A preview of the crop area can be seen on the artboard (you may have to move the Area Plotter
dialog box to see it).
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Crop To Shape

Object > MAPublisher > Crop to Shape or MAP Toolbar IEI

.
Crop To Shape
Target - Specify which layers —— Target:
to crop: all unlocked layers in =
document, all unlocked layers {081 oy e Erve s it Cancel
in a specific MAP View, or a ) Allunlocked layersin: | @ Hotels v
specific layer (and sublayers). @ orly: ] Hoteln_peit . Advanced..,
Indude sublayers

Crop To Shape Advanced Options

Advanced
Point Text - Choose how —— e Point Text: Points: [—IUK
point text is handled ) Vectorize and arap [] Vectorize and crop Points - Choose how points are
. - Cancel i
when intersected by a @ Crop textbased on: Cromping Bounda handled when intersected by
crop boundary o = 53 a crop boundary
©) Origin of first character  accuracy for bezier cropping boundaries:
© Textbounds B Cropping Boundary - Adjust
Path Text - Choose how ——+ePath Text: Cresmas L e accuracy for vectorizing a
point text is handled ) Vectorize and crop bezier path when intersected
when intersected by a by a crop boundary

(©) Crop path only
crop boundary @ Crop text based on:
(@ Origin of first character
() Text bounds
[ Crop path

Note: Attributes and feature type support will be lost when vectorizing points or text.

FUNCTIONALITY

Use Crop To Shape to quickly crop MAP Layers using shapes other than rectangles and ellipses.

PREREQUISITES
Before using Crop To Shape, ensure that layers being cropped are visible and unlocked in the Adobe lllustrator Layers

panel. Invisible and locked layers are not cropped. The extent of the map that will remain after cropping must be
visible on the screen, so make sure to zoom out sufficiently. Crop To Shape only works with closed paths (areas).

USING CROP TO SHAPE

To crop to a shape, select a closed path object and click the Crop To Shape button |E| on the MAPublisher Toolbar, or
click Object > MAPublisher > Crop To Shape. This opens the Crop To Shape dialog box.

In the Crop To Shape dialog box, choose the layers to target for crop: All unlocked layers, All unlocked layers in a
specific MAP View, or only a specific layer (and sublayers).
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The All unlocked layers option will crop everything from an unlocked layer.

For the All unlocked layers in [a specific MAP View] option, choose a MAP View from the drop-down list. Only
unlocked layers in the chosen MAP View will be cropped.

For the Only [layer] option, choose a specific layer from the drop-down list. Only objects on that layer will be
cropped. Optionally, click the Include sublayers check box to include sublayers belonging to the chosen layer.

Advanced Options

The Advanced options here function the same as explained in the Vector Crop section.

The Baiclay
-

Pendiall Suites Hotzl
-

ilves Sher
- -

Vectorize and crop

[ g—

.ﬂayshom'l'heWesling Hatel

Loast Plaza Hotel & Suites

se Bed and Breakfast

.Fainmont Hotel

Sunsetinn & n Vancouver Wall Center

OpusHotel

Sanch'nan Hotel Vancouver City Centra

The Barclay House Bed and Breakfast
.Pendrell Suites Hotel

Sheraton Vancouver Wall Center
.

Crop text based on origin
of first character

.The Barclay House Bed and Breakfast
Pendrell Suites Hotel

Sunset Inn & Suites .Slmatun\fanwuvw Wall Center
-

Crop text based on
text bounds
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= _ MAPublisher MAP Themes provide tools for a variety of
7 4'.['?9_\“ BE“ g N7 4 thematic mapping operations. Stylesheet themes are used
"'ké;gs p;e&zk ; /. for quick, easy and accurate styling of points, lines, areas
S rerticipo el N / AN\ and text. Chart themes produces feature specific bar and pie
WU charts while Dot Density themes aid in the generation of the

thematic dot density maps.

No map is complete without a legend. Easily create MAP
Theme legends with a wide array of options to adjust and

ﬂ,.

Verma tweak its appearance.
o ~darz
‘_"‘? o ﬂ The topics covered in this section are as follows:
- - MAP Themes
%njaﬁ:;* . \ _ Stylesheet Themes
SJaukums % Dot Density Themes
X Chart Themes

e

MAP Theme Legends
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MAP Themes

Window > MAPublisher > MAP Themes or MAP Toolbar m
OVERVIEW

MAP Themes, new to MAPublisher 8.4, are a collection of thematic cartography tools designed to increase
productivity by automating how styles and symbols are applied, chart production and data plotting. The former
MAP Stylesheets have been integrated into MAP Themes and is now called Stylesheet theme. Two new types are the
Chart theme and Dot Density theme.

The new Stylesheet theme offers enhancements over the previous version of MAP Stylesheets. Adobe Illustrator
graphic styles can be assigned to stylesheet rules and stroke fill and opacity can now be assigned on a per rule
basis within the Stylesheet dialog box. The Stylesheet dialog box now offers a Rule Generator where attributes can be
automatically classified using a variety of common classification methods.

The Chart theme offers an interface for quickly generating individual bar and pie charts for a chosen attribute of
selected features. The Dot Density theme provides a thematic mapping tool that assigns a unit value to Illustrator
symbols and randomly distributes symbols throughout associated areas based on attribute values.

MAP Themes offer a lot of flexibility. They can be edited, applied, duplicated, exported and cleared without affecting
the spatial referencing of map features.

= New MAP Theme - Opens the
MAP THEMES Mew MAP Theme... New MAP Theme dialog box to specify

Gountry Ares Styleshect I Duplicate "Chart Theme" theme type and options
Roads Styleshest J
s
MAP Theme List - List of MAP —— Tt Styleshoct Edit "Chart Theme"... o——— Duplicate Selection - Create a duplicate of the
Thgmes in t'he current document. ] Waypoint Syt i — selected MAP Theme
D eromoed ey | e seect -
first, organized and color : Delete "Chart Theme" Ei‘!l‘ Selection - Op?ns the MAP Theme Editor
sorted by Area, Line and Point sge Dot Density Theme - dialog box to edit the selected MAP Theme
Stylesheets, Chart Themes and & MAP Thamas 2 OOw U 3 Clear MAP Theme application .
Dot Density Themes. Create Legend... Apply Selection - Apply selected MAP Theme
Vi to the document
iew Log...
Export MAP Themes... Delete Selection - Delete selected MAP Theme

Create Legend - Create a legend

based on the selected theme I A S

Clear MAP Theme application - Removes the

P application of the MAP theme from the

Apply MAP Theme - Apply selected

MAP Theme to the document document, not the theme itself
New MAP Theme - Opens the —— (reiate ng::: ;’ CTrheate alegend from the
New MAP Theme dialog box to selecte eme

iy th ;
specify theme type and options View Log - A log viewer that provides

Delete MAP Theme - Delete ————————————— information on processes performed on
selected MAP Theme individual MAP Themes

Export MAP Themes - Export MAP Themes to an
Adobe lllustrator document

Import MAP Objects - Import MAP Themes from
another open document

Preferences - Opens MAPublisher Preferences
on the MAP Themes Panel property sheet
(see chapter 1)
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Load Symbols and Styles

The symbology used by MAP Themes are directly related to the symbols and styles which exist in several Adobe
lllustrator panels. In order to correctly function, MAP Themes require that symbology or styles are established in the
corresponding Adobe lllustrator panels:

For Stylesheet themes:

[A] Areastylesheets:  GraphicStyles panel (Window > Graphic Styles)

Line stylesheets:  GraphicStyles panel (Window > Graphic Styles)

P Point stylesheets:  Symbols panel (Window > Symbols)

Text stylesheets:  Character Styles panel (Window > Type > Character Styles)

Fill/Stroke: Swatches panel (Window > Swatches)

For Chart and Dot Density themes:

Appearance: Graphic Styles panel (Window > Graphic Styles)

Labeling: Character Styles panel (Window > Type > Character Styles)
Fill/Stroke: Swatches panel (Window > Swatches)

Symbols: Symbols panel (Window > Symbols)

Custom symbology can be added to the Adobe lllustrator Graphic Styles, Symbols and Swatches panels. Another
great source of styles comes from the custom graphic style, symbol and swatch libraries installed by MAPublisher.

To open MAPublisher supplied graphic style, symbol and swatch libraries, navigate to the following panels:

Graphic Styles panel options menu > Open Graphic Style Library > MAP Graphics
Swatches panel options menu > Open Swatch Library > MAP Swatches

Symbols panel options menu > Open Symbols Library > MAP Symbols

These styles and symbols are stored in Adobe lllustrator documents in the Helpful Styles & Symbols folder. To create
a style library, simply create your own Adobe lllustrator documents containing your symbols, graphic styles and
character styles and save them to the appropriate Helpful Styles & Symbols subfolder. See Appendix 4 for more
information.

Along with the ability to style map art using Adobe Illustrator Graphic Styles and Symbols, MAP Themes allow users
to manually specify stroke, fill and scale properties on a per rule basis.
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FUNCTIONALITY

Apply MAP Themes

There are several ways to apply a MAP Theme. Click the Apply button in any of the Edit Theme dialog boxes to
immediately apply theme options to the map document. Another way is to click the Apply MAP Theme button in
the MAP Themes panel. This method is useful for applying themes at a later time. Save the theme settings made in
any of the Edit Theme dialog boxes and in the MAP Themes panel, select a MAP Theme and click the Apply MAP Theme
button. Alternatively, choose Apply "[theme name]" in the MAP Theme panel options menu.

Clear MAP Themes

Click the Additional MAP Themes options button and in the context menu, click Clear [Theme]. This does not delete
the MAP Theme, it only removes the style from the data.

Duplicate Themes

A document can contain as many MAP Themes as desired. Choose Duplicate "[theme name]" to create a copy of an
existing MAP Theme. The rules and styles are preserved during a copy. This is useful when creating different styles
for a map; each theme can have the same rules, but different visual properties. To apply the different themes, clear a
previous theme and apply another one.

Export MAP Themes

To export MAP Themes, choose Export MAP Themes from the panel options menu. In the Export MAP Themes dialog
box, click a check box beside each theme to select it for export. Click OK and a Save dialog box will prompt for a file
name. MAP Themes are exported to an Adobe Illustrator document and are considered MAP Objects. They can be
imported using the Import MAP Objects function. See chapter 4 for more information about Import MAP Objects.

Export MAP Themes

Select MAP Themes to export:

Object

a Charts
illy Chart Themel
&P Chart Theme2
4P Chart Theme 2

MAP Theme Log

MAP Theme processes can be viewed in the log file associated with each type of theme. View the log through the
Additional MAP Theme Option context menu. Logged theme processes include the start and finish time of theme
processes along with the number of pieces of art found and the number of pieces stylized.

X MAP Theme Log for Liseracy Rate’ 17 Add/Remove Item from Selection
_ MAPTheme Log Operations . — Add or remove warning or
Lists completed processes for critical messages
the selected theme. Use the Layes Mevsage o]
Show buttons below to filter e b HiA Started bpplying ot 30112000 20515 PM. Clear Selection - Clear selected
information, warning, and O world_aiea , 220 of which esstully stybeed,
o DA Finished applying st 30/11/2010 30515 PM feature on the map
critical messages. Export,. e————
= Export - Save log to a text file
Show - Show general

restow: [ [ [ ZoomTo - Zoom to the selected

information, warnings and = feature on the map

critical messages.
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Stylesheet Themes

OVERVIEW

Stylesheet themes are able to read and work with the data found in the MAP Attributes panel and used to quickly
style MAP Layers using Adobe lllustrator symbols, graphic styles and character styles.

Theme rules can be created in two ways: manually (one by one) or generated using a data classification method.
In addition, themes can be applied to data on a one-to-one basis, where specific attribute values are assigned with
a specific style or symbol (e.g. each country its own distinct colour) or with attribute value ranges (e.g. a country's
population growth that falls within a range of 2.9 to 4.6% and a colour used to represent it).

FUNCTIONALITY

Create New Stylesheet

To create a new stylesheet, click the Create New Map Theme button [Tz in the MAP Themes panel. Alternatively,
choose New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme dialog box,
where the theme name, theme type, and feature type for a new stylesheet is specified. With Stylesheet selected as
the theme type, the Feature Type drop-down list contains a list of available feature types: Area, Line, Point and Text.

New Stylesheet MAP Theme
New MAP Theme
Name - Specify a name for the Theme Name: ~ Stylesheet Theme
new Stylesheet =
Theme Type: [ £ stylesheet 07
L Theme Type - Select Stylesheet from
Theme Options: theme type drop-down list
Feature Type - Specify a feature Feature Type: [ [ Area - ]
type for the stylesheet: Tip: Deuble-click i the Theme panel o edit the theme.
Area, Line, Point or Text

Stylesheet themes are displayed in the MAP Themes panel. To edit a Stylesheet theme, double-click a Stylesheet
name or select Edit "Theme Name" from the MAP Themes panel option menu. This opens the Edit Stylesheet Theme
dialog box

MAP THEMES
Area Stylesheet Theme
Line Stylesheet Theme
& Point Styleshest Thems
Text Stylesheet Theme

4 MAP Themes = e T @

Note: It may be useful to enable the Base attribute schema on option and then choose an appropriate MAP layer in
the Undefined Layer dialog box (see Chapter 4) before attempting to apply Stylesheet MAP Themes to a new
layer. The new MAP layer will inherit the chosen attribute structure and applying Stylesheet MAP Themes will
be easier because creating or editing the attribute structure is not required.
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Stylesheet Theme Editor

The Edit Stylesheet Theme dialog box is where rule generation and styling takes place.

Visual properties - Click to edit
reset options (see below)
|

Batch G te Rules
Generate multiple rules
based on different

Theme Name - Edit name of Edt Styleshest Theme |

classification methods.

Stylesheet theme

.
Layers - Opens the Select A A th Vissl propertes: Mot resat)

110 || Layers: workl_area

Layers dialog box

D T rr——

s M ol b &
Rule Operations ———e Fules: 2l L Bl
Add a rule Pl Fop GrwRe-DAto0T Wamez Pop_Grw_ftt: 0.4 8 0.7
Copy arule _‘;7| W rhpara Pl Ll | St oty rues f act quslfies for ths nie
= | o Pop_Gre Rt 181029
Remove selected rule I Du nat apply tie rue
. o Pop Grw Rtdftob3 Fapresion:
Move Up/Down - Edit rule  em—
[ Fop Grw Rt v |am a4

hierarchy (seen in Legend) R —
< =| 0.7

Dxpresson: Pop_Gre Bt >= 0.4 AND Pop_Grw RE<0.7
Rule List - Selectable list of ——————— Apply Visual Properties:
named lrulgs.The green stdes

check mark indicates a valid

Expression. A red X indicates
- X Streker: ] Pone]

an invalid Expression.
Sireke opacity!
Stroke weight:

7 Fa | M cooMms0n ¥m100 K0

=)

&

Fll epacity:

[

—

See Add Stylesheet Rules with

E Rule Generator.

Edit Visual Property Ramps
sty | Edit visual properties for
generated rules.

o—l— See Edit Visual Property Ramps.
| Rule Name - Edit rule name as

it will appear in Legend

Stop applying rules if art qualifies
for this rule - Limit application
of subsequent rules to art
that meets rule criteria

Do not apply this rule - Prevent
rule from being applied

Expression - Determines which
range or subset of data to
| style for each generated rule.
I See Assign Expression.

—————— Apply Visual Properties - Style

properties applied to the
selected rule.
See Apply Style Properties.

EE

The Theme name is reflected in the MAP Themes panel and can be edited.

At least one MAP Layer must be specified before generating rules. Click the Layers button to open the Select Layers
dialog box to choose applicable layers. Multiple layers can be chosen, however, rules can only be generated on a
per layer basis (meaning multiple rules can not be created across multiple layers simultaneously). Selected MAP

Layers are listed beside the Select Layers button.

The Auto-assign setting can be used to auto-assign any imported layers to the stylesheet that have the same
feature type or only auto-assign layers to the stylesheet if they match a pattern. This may be useful when importing
layers that are similar to an existing stylesheet theme and will decrease the amount of setup time for each one. The
pattern type can consist of Equals, Starts with, Ends with, Contains, and Wildcard. Auto-assign can be set to be case

sensitive for each pattern.

The Visual properties setting can be used to either reset visual properties before applying rules or reset visual
properties for art that does not qualify for any rule. The Clear instead of reset setting removes all styles from art

objects, sets fill and stroke to none and returns opacity to 100%.
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Add Stylesheet Rules Manually

To add a single rule, click the Add Rule button. Rules are shown in the rule list on the left hand-side of the Edit
Stylesheet Theme dialog box. When a rule is selected, the settings for it are active to the right where its Name,
Expression and Visual Properties can be assigned.

Note: Use caution when assigning a Stylesheet theme to grouped objects or compound paths, the graphic styles
may not apply universally.

Assign Expression
The Expression section provides options to define the criteria in which the data chosen will be styled. There are two
modes to define an expression: simple and advanced.

By default, the Simple Expression mode is displayed and is intended to facilitate quick expression generation.

Comparison - Operators used
to compare values

Values - List of values in the
3 selected attribute column
Expression:
Pop_Gri_Rt . ~ [fuu]e— Toggle Mode - Toggle between
Simple and Advanced mode

Attribute Column - Attribute column
of the associated MAP Layer

Range operator - Click to activate
the second row to enable the
composition of range expressions

-

Expression: Pop_Grw_Rt == 0.4 AND Pop_Grw_Rt < 0. pression - The completed
expression

First, choose an attribute column from the drop-down list or manually type in an attribute name. Secondly, choose
from a comparison operator from the drop-down list:

>  Greaterthan >= QGreater than or equal to
< Lessthan <= Less than orequal to
= Equalto I= Notequalto

Finally, type or choose value against which the comparison will be applied. To create an expression based on a
range, click the Range operator check box to enable an additional comparison and value input pair.

Property and read-only attributes cannot be selected in the Simple Expression mode. To use property and read-only
attribute values, click the Toggle Mode button to switch to the Advanced Expression mode.

Expression Builder - Create an
Expression: expression in the Expression
Expression - Type or use the ——e Pop_Grw_Rt >= 2.9 AND Pop_Grw_Rt <= 4.9 7 Builder. See Chapter 5.
Expression Builder to define ’ - .
P " The expression is valid. Expression Library - Choose an existing

an expression. .
P expression. See Chapter 5.

In Advanced Expression mode, construct more complex expressions and to use read-only and property attributes.
The Expression Validity icon will report « if the expression entered is valid. Otherwise it will report (& and include
additional warning notes. Alternatively, use the Expression Builder l=7] to create and edit expressions. To use a saved
or recent expression, use the Expression Library (). See chapter 5 for more information on both.
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Apply Visual Properties

The Apply Visual Properties section provides many options to style data including graphic style, stroke, stroke
weight, fill, scale and opacities. Depending on the type of stylesheet feature type, the style properties may differ:

For Area and Line feature types

Style - Select a predefined
graphic style for selected rule ———s[] styke:

Stroke/Opacity/Weight - Choose a ———s[] stroke:
predefined swatch style. Adjust
the transparency of the stroke.
Adjust the stroke weight (in pts)

[ stroke opacity:
[7] Stroke weight:
Fil:

[ Fill opacity:

Scale - Adjust the scale of style
and stroke properties ———e[_] scale:

Opacity - Adjust the transparency ———e[ gpacity:
for all properties

Apply Visual Properties:

L] Default] o— Toggle Mode - Toggle between
Simple and Advanced mode
[/ Nare] v}
0%
1.00 pt
C=0M=100 Y=100K=0 -
! L Fill/Opacity - Choose a
(TEBD predefined swatch style.
Adjust the transparency
of the fill.
100%
100%

Click the check box beside each option to enable it. The Style option contains a drop-down list of styles that exist in

the Adobe lllustrator Graphic Styles panel.

For Point feature type

GraphicStyle - Select a
predefined graphic style to
apply to the selected symbol

Symbol - Choose a predefined ——[] symbol:
point symbol style.

Rotation - Specify a custom ———e[ rotation:
symbol rotation

[] Scale:
[] Opacity:

Apply Visual Properties:
[ Graphic style: | [ [Default]

@ [MAPublisher Default Symbol]

0.00

100%

100%

Angle is relative to MAP View

o—— Toggle Mode - Toggle between
Simple and Advanced mode

The Symbol option contains a drop-down list of symbols that exist in the Adobe Illustrator Symbols panel.

For Text feature type

Graphic Style - Select a
predefined graphic style to

A
apply to the selected text —I—-D

Symbol - Choose a predefined Style:

character style symbol style. Font:

Fontssize - Choose font size Font size:
[ Stroke:

Graphic style:

Font - Choose font and style

[] Stroke weight:
[ Fill:

[ Opacity:

pply Visual Properties:

L] [pefault] .— Toggle Mode - Toggle between
[ T Normal Character Styie] _] Simple and Advanced mode
Famiy: [ Arial -
Style: [Regu\ar v]
1200pt =
(] Dvone] |
1.00 pt
[] Done] |
100%

The Style option contains a drop-down list of character styles that currently exist in the Adobe Illustrator Character
Styles panel. Note that enabling the Font and Font size options will override the Style option.
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Click the Toggle Mode button to toggle between Simple and Advanced mode for style properties. In the Advanced
mode, an expression can be entered manually, created with the Expression Builder or chosen from the Expression
Library. This essentially allows attribute information to be used as the basis for style properties.

Apply Visual Properties:
Graphicstyle: [§] & Type = MNode™

Symbaol: [ @ [MAPublisher Default Symbol]

[7] Rotation: 0.00 Angle is relative to MAP View
[ Scale: 100% z
] Opacity: 100%

‘ﬁ
S |

Expression Builder - Create an
expression in the Expression
Builder. See Chapter 5.

Toggle Mode - Currently in
Advanced mode

By default, the Scale is 100%. Editing the scale will alter the symbol size (points) or stroke weight (areas and lines).

The maximum scaling factor is 1000%.

The Opacity setting adjusts the transparency of all visual properties. For area and line feature types, there are
separate fill and stroke opacity settings. Combine with the Opacity setting to increase overall opacity.

Move Simple Expression to Advanced Expression

It is possible to move an expression from Simple Expression mode to the Advanced Expression mode. This may
help when tweaking rule expressions to achieve optimal thematic results. To move a simple expression, right-click
below the Simple Expression input settings (on the Expression line) and click Move to Advanced in the context menu.

Expression:
[R] Literacy - 6.0 -
Expression: Literacy >= 86.0 AND Literacy
QJ Copy to clipboard
Apply Properties: = Moveto Advanced
[T style: [ ] Default]
The expression will appear in the Advanced Expression mode.
Expression:
Literacy >=66.0 AND Literacy < 86.0 7]

«” The expression is valid.

Note:
the Simple Expression mode.

An advanced expression cannot be moved to a simple expression. Doing so will remove the expression from
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Add Stylesheet Rules with Rule Generator

To generate multiple rules based on a classification, click the Batch Generate Rules button in the Edit Stylesheet

Theme dialog box. Th

is opens the Rule Generator dialog box:

Layer - Select source Iayer-L

Attribute - Select attribute
to generate rules for

Rule Generator

Source:

reLayer:

Empty expression, In position: 0

Load - Load the selected

ttribute: | [R] Pop_Grw_Rt -

attribute values

Load

Data Classification:

Source - Displays number of-

e: 220 value(s) (50 unique) from Pop_Grw_Rt

values and unique valuesJ

(lassification Method

Equal Intervals, Quantiles,
Natural Breaks (Jenks-
Caspall) or Unique Values
Data Classes - Number of
classes to classify by
Inclusive Boundary - Choose
either start value or end
value to include as class
data boundary

Visual Property Assignment—-—e

Set the style properties
for the data classifications
above. The styles are

Netural Breaks (JenksCaspal) v | Datadasses: 5 |+

7]

Inclusive boundary: [Start value

Add - Add these rules to

— the Rule list

— Overwrite - Overwrite

and remove all existing
rules in the Rule list

global and affect all of

Expression Start End Fill
1 -0.4 <= Pop_Grw_ Rt <2 -0.400000000000000 2000000000000000
2 2<=Pop_Grw Rt <3 2.000000000000000  3.000000000000000 [
3 3<=Pop Grw Rt< 4.2 3.000000000000000  4.200000000000000 [
4 82 <= Pop_Grw Rt <52 4.200000000000000  5.200000000000000
5 5.2<= Pop_Grw Rt <=63 5.200000000000000  6.300000000000000
[] Add rule expressions to Recent Expressions in Expression Library Add rule for ignored expression
Visual Property Assignment:
[ Setstyle: Fram lstof 0 stylefs)s | Select... [l [ setscaie: 1% 1o [100% Revers [
[] setstroke: [ 111 +  Grays [ set fil: [
Reverse colour ramp [] Reverse colour ramp
[C] setstroke opadity: | 0% to |100% Rever @ [] set fill opacity: | 0% to |100% Reverse [E
[ setstroke weight: | 1.00 pt [ setopaty:  |0% 1 [100% Reverse [aal

the rules.

Data d; table
Table that shows the
expression, starting
and ending range
values and any of
the visual property
assignment settings.

The Rule Generator generates rules on a per layer, per attribute basis (however, if multiple layers share a common
attribute, it can be chosen). Once a MAP Layer and attribute are chosen, click the Load button to populate the

Data Classification table below it. The default classification method is Equal Intervals, but can be changed to any

of the data classification methods described below. The classification is dependent on how many data classes are
specified. In addition, set the start or end value as the inclusive boundary which determines whether the data range
starts or ends on a boundary value. Enable the Ignore option and enter an expression (or use the Expression Builder
or Library) to specify data values that will be ignored.

Stylesheet MAP Themes support four types of data classification methods:

Equal Intervals

This classification method sets the value ranges in each category equal in size. The

entire range of data values is divided equally into the number of categories chosen.

Quantiles

of units in each category.

Natural Breaks
(Jenks-Caspall)

This method classifies data into the number of categories chosen with an equal number

This classification method is based on the Jenks-Caspall algorithm. It uses an empirical
approach based on minimizing the sum of absolute deviations around class means.

Using arbitrary set of classes, it calculates a total error and attempts to reduce this error
by moving observations between adjacent classes.

Unique Values

This method creates a category for each unique value in the chosen data set. This

method is most appropriately used when there are few unique values within a data set.
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Use the Visual Property Assignment section to specify how the data classifications are styled. Each style property
(except for stroke weight) can be set in two ways: as a ramp or as a single application. By default, the Ramp mode
is enabled. This applies a style property to all data classes in a ramp manner (ascending to descending, or if the
reverse option is checked, descending to ascending). When a style property is in Single Value mode, the options
available change. This option applies the same style property to all data classes.

For Area and Line feature types

Visual Property Assignment: Ramp mode - Style is

i lication
[T setstyle: From list of 0 style(s): | Select... [F] set scale: 1% v to |100% |5 Reverse In ramp app
@ @ mode. The style

Single Value mode——— Setstroke: 1 C=0M=0Y=0K=80 - =) set fil: EEE Warm 8 ~| [ —— ramp is applied to all
The style is in single i i
yl 'sing FeommEreT data classifications
value application in ascending (or
mode. The same style [[] setstroke opadity: | 0% H| to [100% [ Reverse @ [T] set fil opacity: | 0% H| to [100% [ Reverse @ descending) manner

appllest'oaIIAdata [C] Setstroke weight: [ 1.00pt 2 [] Setopacty:  |0% |+ to |100% |- Reverse @
classifications.

For Point feature types
Visual Property Assignment:
[] setstyle: From list of 0 style(s): Select... @ [[] set scale: 1% to |100% |+ Reverse @
[C] setrotation: |2.00 [+ to |360.00 |7 Reverse @ [F] setgraphicstyle: Fromlistof 0 style(s): | Select... @
[[] setopacity: |0% o to [100% (= Reverse @

For Text feature types
Visual Property Assignment:
[T set style: Fromlistof Ostyle(s): | Select... [ O setstroke: [ 1] +  Grays ()
Reverse colour ramp
[ set fil: EEE + Gays [ O setstrokeweight: [Lo0pt [
Reverse colour ramp
[C] set font: 6 Adobe Arabic [ set font size: 12.00ptf2]| to [32.00 pt2 Reverse ]
Bold
[C] set graphic style:  From list of 0 style(s): Select... [i] [] setopacity: 0% to | 100% Reverse [i]

Any enabled style options are shown in the data classification table under its own column heading and each
classification its respective style setting. When additional classes are added to the table, visual styles that are in
Ramp mode will be adjusted proportionally. For example, a layer has an opacity ramp from 0% to 100% and each
of its three classes has an opacity value of 0%, 50% and 100%. When a fourth class is added, the opacity for each
class is proportionally changed to 0%, 33%, 66% and 100%. This works best for visual properties that may be
continuously adjustable such as scale or colour gradients. A warning icon appears when there is a greater number
of classes than colour swatches (groups) or styles. This will lead to colours or styles being repeated.

When the rules and style properties are set, click Add or Overwrite. Add adds more rules to the Rules list. Overwrite
clears all existing rules in the Rules list and replaces it with the current rules and styles.
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Edit Visual Property Ramps

Instead of overwriting rules just to change styles, click the Edit Visual Property Ramps button in the Edit Stylesheet
Theme dialog box to edit existing applied styles.

Edit Visual Property Ramps

Affected rules: Changes:
« Pop_Gru Rt: 0.4 -2 Name Stroke Fill
¥ or . =
& Pop_Grw PP R it -
« Pop_Grw, - Pop_Grw_Rt:2 -3 =
« Pop_Grw Rt:52-63
Pop_Grw Rt:3-4.2 o= "By |
Pop_Grw_Re4.2-52 = H=0
Pop_Grw Rt: 5.2 - 6.3 = H=0
Overwrite Visual Properties:
[T] setstyle: From list of 0 style(s): @ [7] setscale: 1% to | 100% Reverse @
Set stroke: C=0M=0Y=0K=20 -0 [E Set fil: WEM+ Gresn - @
[ Reverse colour ramp
[7] Set stroke opacity: 0% to [100% Rever @ [T set fil opacity: | 0% o | 100% Reverse @
New Property - Add new [T set stroke weight: | 1.00pt [ setopadty:  |0% to |100% Reverse [l

style property to rules

Changes - Original (left)
changed to adjusted
style property (right)

Property Change - Adjust
existing style property

Select (or deselect) existing rules from the Affected rules list and change style properties in the Overwrite Visual
Properties section. Changes made to rules with existing styles are reflected in the Changes table where a green
arrow indicates the new style changes. Similar to the Rule Generator, any new style properties added are reflected
in the Changes table. All style changes to rules are updated in the Edit Stylesheet Theme dialog box. There is no
need to recreate existing visual properties in order to maintain them.

For MAPublisher dialog boxes that have adjustable size, distance or length settings can have its units converted
very easily. Simply right-click the spin box and choose a new unit of measure. The value in the box automatically

converts to the chosen units.

Size: 3.00 pt

Appearance: [BE] syl
Fill:

@) Use symbol:
Symbol: @ [MaF

Scale: 100%

Opadity:

Current ruler units (px)

Inches (in)
Centimeters (cm)
Points (pt)

Picas (p0)
Millimeters (mm)
Pixels (px)

Use preference (px)

]Z =|Loopt 2
3l

D 100% [+
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Dot Density Themes

OVERVIEW

Dot density themes are sometimes called dot distribution maps because they show where particular data
characteristics occur. It uses dots or other symbols to represent the number of occurrences of a given data
characteristic in a particular location. Each dot or symbol used on the map may represent a single entity

(one dot = one person) or as a one-to-many entity (one dot = 1000 people). The data is read from each MAP Layer
and MAP Themes quickly styles the data using Adobe Illustrator symbols and graphic styles.

Since dot density maps are most useful for showing where particular data occur, they only work on area MAP
Layers. Most often, symbols are used to represent data occurring within a bounding polygon such as a census tract,
zip code or county. Use caution when analyzing dot density maps, it should be understood that the dots or symbols
do not always indicate the exact location of the data.

FUNCTIONALITY

Create New Dot Density Theme

To create a new Dot Density theme, click the Create New Map Theme button [Tz in the MAP Themes panel.
Alternatively, choose New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme
dialog box, where the theme name, theme type, and feature type for a new Dot Density theme are specified.

New Dot Density MAP Theme
New MAP Theme
Name - Specify a name for the Theme name: Dot Density Theme oK.
new Dot Density theme T [ '] [—]
3 ;

Theme Type - Select Dot Density from
theme type drop-down list.

Tip: Double-chck in the Theme panel to edit the theme.

Dot Density themes are displayed in the MAP Themes panel. To edit a Dot Density theme, double-click it or select
Edit "Theme Name" from the MAP Themes panel option menu. This opens the Edit Dot Density Theme dialog box.

MAP THEMES

Dot Density Theme ————|[ 3#%s Dot Density Theme

"7'
-
¢
g
@

1 MAP Theme
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Dot Density Theme Editor

The Edit Dot Density Theme dialog box is where attribute, density and symbols are chosen.

r b |
Edit Dot Density Theme
Theme name - Change the —-re Theme name: Dot Density Theme
default theme name
Layer - Select source layer — e Layer: [ [A] fsatoronto_area vl [ Cancel ]
Attribute - Select attribute — e Attibute: | [T] #Opacity -
to base density on
Data range - Displays the Datarange: Not loaded
minimum and maximum Dot value: 10.00 =
values of chosen attribute .
Dot value - The value B
represented by each dot “D“t ubuess
@ Spedfy:
Dot styk:
Specify - Choose a simple — -4 Size: 3,00 pt y
dot style, size and
appearance (stroke, Appearance: Stroke: [|Z] [Mone] - ] ] =|rooptp
stroke width and fill)
using Custom Mode. Fill: [ Il Sp=cify colour hd ] |
Alternatively, click the .
toggle button to switch (2 Use symbal:
to Graphic Style mode 3
o choo?e Ia prg,-deﬁned Symbaol: @ [MaPublisher Default Symbol]
graphic style. Scale: 100%
Use Symbol - Choose a —{4 } =
custom symbol to use and e U 100%[=
set its scale and opacit; h
pacity Advanced:
[ Always regenerate dot positions when applying

Dot density is created on a per layer, per attribute basis. When an attribute is chosen from the drop-down list, click
the Load button. The data range displays the minimum and maximum values for that attribute. These values should
be taken into account when determining a one-to-many dot density and dot value.

A dot value of 1.00 represents a single (one-to-one) entity. A dot value greater than 1.00 represents a group
(one-to-many) entity. See Considerations for Dot Density Maps.

Dot Options

Choosing dot size is a subjective decision based on visual perception limits and aesthetics (see Considerations for
Dot Density Maps). There are two main options to style dots: simple and symbol. Choose the Specify option to use
simple dot styles from the drop-down list. By default, the Appearance options are in Custom Mode. Click the toggle
button to switch to Graphic Style mode, where a graphic style can be chosen from the drop-down list. Alternatively,
choose the Use symbol option to use symbols sourced from the Adobe Illustrator Symbols panel. Adjust the scale and
opacity as necessary. Check the Always regenerate dot positions when applying to randomize the dot positions when the
Apply button or Apply MAP Theme button in the MAP Themes panel is clicked.

Note: Only basic appearances can be applied to dot density dots. Adobe Live Effects, graphic styles with opacity,
multiple strokes and other non-basic appearances or effects cannot be used.
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After a Dot Density MAP Theme is applied, the effect is listed in the Adobe Illustrator ~_aeeeasance |[IIIIINE|
Appearance panel. Select an area containing the dot density effect and click Dot Compound Path I
Density in the Appearance panel to open the Dot Density dialog box. This dialog S|, -~ "
box differs from the Edit Dot Density Theme dialog box. The Dot Density dialog box
can be used to fine tune the dot density appearance of individually selected areas
instead of making a global change.

Considerations for Dot Density Maps

When creating one-to-many dot density maps, several considerations should be noted: enumeration units, dot size,
dot value and dot placement. The scale, size, shape, and distribution of data across enumeration units (e.g. census
tracts or block groups) can cause variations in how a dot density map is patterned. On average, smaller sized and
more regularly shaped enumeration units result in a more realistic density map.

The dot value and dot size should be determined together to get an idea of how many dots will populate the map.
Take into consideration the minimum and maximum values of the selected attribute. A rounded dot value should
be chosen for easy approximation. There is a trial and error phase when choosing the most appropriate dot value
and size. Generally, a medium sized dot should be chosen. Small dots produce a widely dispersed dot pattern and
may convey disproportionate map accuracy. Large dots produce overly dense dot patterns and hide any noticeable
map patterns. As a general rule when an appropriate dot value and dot size are chosen, two to five dots should be
seen in enumeration units with the smallest values. MAPublisher allows for automated, random placement of dots.

L]

al,

Tzt

he

L
»
-

]

Too sparse Optimal
When the value for a particular feature is lower than the "Dot value', a dot may not be assigned for that object. This
happens because MAPublisher only accepts values that are greater than fifty percent of the dot value to be given

a dot. For example, if an object has a value of 4,000 and the dot value is 5,000, it will be assigned a dot because it

is greater than fifty percent (or 2,500) of the dot value. Alternatively, an object that has a value of 2,000 will not be
assigned a dot because it is less than fifty percent (or 2,500) of the dot value.
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Chart Themes

OVERVIEW

Chart themes come in two types: bar chart and pie chart. A bar chart is represented by rectangular bars with
lengths proportional to the attribute values that they represent. A pie chart is comprised of a circle divided into
sectors, showing attribute value proportion. These charts are generally placed near the center of the aggregation
area (e.g. census tract or state).

Chart data is read from attributes from a MAP Layer and MAP Themes quickly styles the data using Adobe lllustrator
symbols and graphic styles. Charts can plot both discrete and continuous data. Some examples of discrete data
include voters or hair color. Some examples of continuous data would be temperature or height.

FUNCTIONALITY

Create New Chart Theme

To create a new Chart theme, click the Create New Map Theme button [T in the MAP Themes panel. Alternatively,
choose New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme dialog box,
where the theme name, theme type, and feature type for a new Dot Density theme are specified.

New Chart MAP Theme
New MAP Theme
Name - Specify a name for the Theme name: | Chart Theme 1 oK
new Chart theme [—]
Theme type: | glf Chart N -] E

Theme Type - Select Chart from theme
type drop-down list.

Tip: Double-ciick in the Theme panef to edit che theme.

Chart themes are displayed in the MAP Themes panel. To edit a Chart theme, double-click it or select Edit "Theme
Name" from the MAP Themes panel option menu. This opens the Edit Chart Theme dialog box.

MAP THEMES
Eﬂ; Bar Chart Theme
'q@ Piz Chart Theme

2 MAP Themes T T ¥

194 | Chapter 9: MAP Themes

Chart Themes



Chart Theme Editor

The Edit Chart Theme dialog box is where the chart type, style and its options are chosen:

Theme Name - Edit name
of Chart theme —I_

Output Layer - Choose —
which layer where
charts are saved

Layer - Choose a layer —
to load the Attribute

Edit Chart Theme

@ Theme name:  Chart Theme

e Cutputlayer: | O Chart ~

.
Type: fillly Bar chart ~

[] 1gnore:

SourceData | ChartOptions | General Options | Title | Labels [

Type - Choose chart
type: Bar chart or
Pie chart

Tabs - Switch

Unempl_Rate

drop-down IistJ

Move Up/Down - Adjust
placement of attribute

[:J Indust_Grwth
M Inflat Rate
W Arable Pct

in the bar or pie chartJ

Chart Attributes
Add attribute
Remove attribute

Attribute: | [R] Unempl Rate  ~

Label:  Unempl Rate

Appearance:

sk 7@ s
e wows

between tabs for
more options

= | Loopt

Scaling - Click to
open the chart
Scaling dialog box

Actual size

App - Adjust
the stroke, stroke
width, fill, and
opacity of each
attribute using
Custom Mode
(default) or Graphic
Style Mode

Preview quality: |Medium

Show actual size

Chart Preview

A preview of the
chart with current
settings. Adjust
quality of preview
in the Quality drop-
down list

The Theme name is reflected in the MAP Themes panel and can be edited. Specify either Bar chart or Pie chart from
the Type drop-down list. Depending on the type of chart chosen, several appearance and option settings will differ.
Choose the appropriate Legend layer to store the charts from the Output layer drop-down list. Enable the Ignore

option and enter an expression (or use the Expression Builder or Library) to specify data values that will be ignored.

Add Source Data

In the Source Data tab, choose a MAP Layer to load its attributes from the Layer drop-down list (Text layers are not
supported). Only the attributes of a single layer may be chosen at a time (meaning mixing layers and attributes

is simultaneously is not possible). Click the Add attribute button to add an Unspecified attribute slot into the list.
Select an <Unspecified> item in the list and choose an attribute from the Attribute drop-down list. The attribute
name is automatically used in the Label box, however it can be edited. Any changes to label and appearance are
reflected in the attribute list as well as the chart preview. To change the sort order, select an attribute in the list and
click the Up or Down arrow.
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Adjust Bar Chart Appearance and Options

To change the appearance of an attribute, select one from the list to enable its appearance properties. The
Appearance section, in Custom Mode (default), has adjustments for stroke, stroke opacity, stroke width, fill and
fill opacity. Alternatively, click the Toggle Mode button to switch to the Graphic Style Mode. In that mode, choose
a predefined graphic style from the drop-down list (sourced from the Graphic Styles panel). Changes made are
reflected in the style indicator in the attribute list as well as the chart preview at the bottom of the dialog box.

SourceData | ChartOptions | GeneralOptions | Tide | Labels |
Unempl_Rate Attribute: | [K] Unempl_Rate -
style Indi Col id) i:::::i’:’th Label:  Unempl_Rate Stroke
chi:)y sehows a prev(i)e(\)/\: B Aroble Pt “""““’""“A | — Stroke Opacity
of the bar chart style stroke: A ® [100% ] =[100p: [y Stroke Width
Fil: @& 0% 2
— Fill Opacity

Fill
Toggle Mode

In the Chart Options tab, adjust basic bar chart settings—width, height, bar orientation and bar spacing. Other
options include setting the bars relative to maximum data value. In this case, all the bar values are divided by the
maximum value and then drawn as a relative proportion to it. For point layers, an alignment control is available to
position the chart.

Initial Alignment - For Point layers only.

Choose alignment position for the chart.
It will only be aligned the first time.

Bar orientation - Choose vertica.I”%
up/down or horizontal right/left :

SourceData | ChartOptions | General Options | Title | Labels |

Bar style - Choose Normal or : Bar orientaton: Initial Alignment:
Stacked chart style r style: g g g
Bar thickness/Maximum bar length : © hidknece wom B =00

Adjust the size of each bar :

Bar height relative to - the bars
are adjusted to a relative :
maximum attribute data value :

Charts will only be aligned the first time they are created; when

bar length: = - P
ximum bar leng 40.0px updating & chart, its current position is preserved.

 Bar height relative to: [Chartmax value v

Bar spacing: 0.0px 2

Bar spacing - space between
each bar :

In the General Options tab, enable the Apply style to chart option to choose a predefined style. The Sort Values
option sorts (from left to right) increasing and decreasing values (not shown in the chart preview). The Draw chart
border option is not enabled by default; click the check box to enable it and adjust its appearance options.

Apply style to chart - Choose

graphic style to apply to the :

entire chart :

Sort Values - Sort the bars

in either increasing or :
decreasing order (nof

shown in preview) |

Draw chart border - Enable :

to draw a border :
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Chart Options

General Options | Tite | Labels |

-/l ® %] = 1optfs

[T Apply style to chart: | [, [Default]

[ sort values: J Descending

Draw chart border: Stroke: [ 1 Specify colour
Filt: ([ ivonel

-] 1@ [100%

Margin: 5.0 px [+

Margin - Adjust the
space between the
chart and the border

Border style - Adjust the stroke, stroke width, fill,
and opacity of each attribute using Custom
Mode (default) or Graphic Style Mode



Adjust Pie Chart Appearance and Options

The Pie Chart Appearance options differ slightly from the Bar Chart options. Only the options applicable to pie
charts are shown here. The other Appearance options function identically as explained in the previous section.
The Explode option creates separation of a selected attribute (slice) from the rest of the pie chart. To adjust the
separation of all slices, use the Explode option in the Options section.

SourceDats | ChartOptions | General Options | Tite | Labels |

e Gl T —
Indust_Gruwth
M Inflat_Rate Label: Arable_Pct
M Arable Pct Appearance:
() soe A @ [0l = [coopt e

Explode:  3.00 px —

Explode - Adjust how
far the selected
attribute is separated
from the pie chart

In the Chart Options tab, adjust basic pie chart settings—pie radius, hole radius, explode and rotation. The Hole

Radius option creates a hole in the middle of the pie chart and results in chart that looks like a ring. The Explode
option here is different than the attribute Explode option in that this applies to all the slices and not just a single
slice. The Rotation (default at 0) starts at the top (12:00 o'clock position) of the pie chart and rotates clockwise

(negative rotation values cannot be used) up 359 degrees.

The General Options function identically as explained in the previous section.

Source Data Chart Options

General Options | Tite | Labels |

Pie Radius - Adjust the size of

. iPeradus:  50.00px |2
the pie chart {He radus P

i iust si ‘Hole radius:  0.00 =
Hole Radius - Adjust size of ——e "= =0 px

the hole in the pie chart

‘Explode:  0.00px |2

Explode - Adjust the %RUE“W 0 5

separation of all slices :
Rotation - Adjust the rotation
of the pie chart from 0 to
359 degrees H

For any adjustable size, distance or length setting, right-click the spin box to change the units.

SourceData | ChartOptions | GeneralOptions | Titie | Labels |

Tnitial Alignment:
ooo

Bar thickness: 0opx 2
Maximum bar length:  0.6in =
s arentation @ Current ruler units (px)
Bar spacing: 0.0 px V' Inches (in)
Bar height relative to:  [Charems CE_"W"E&" fem)
Points (pt)
Picas (p0)
Millimeters (mm)
Piels (px)

oo
oo

arts wil only be aligned the first time they are created; when
dating a chart, its current position is preserved.
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Chart Labeling

There are multiple options to label both bar and pie charts. In the Edit Chart Theme dialog box, the Title and
Labels tabs contain labeling settings. By default, all labeling options are disabled. Click the check box beside Show
title, Show attribute value labels and Show attribute name labels to enable labeling options for each one. The Show
attribute name labels option only applies to bar charts. The labeling options are shown below with an example of
what some of the settings do.

Appearance - Adjust the font
and font size of the title. | [“sourcepata | ChartOptions | General Options | Tite | Labeks | Examples
Specify a title in the box or
choose from an attribute
that contains text
Alignment - Align the title to
the left, center or right
Show titleline- Add aline { |} —
below the title. Adjust | | Aignment: ‘
its style properties using [ show title ne: ] stroke: | [l specy colour W © [1w0n2] =[roopt
Custom or Graphics Mode. :

Shrink title to fit chart - Adjusts

Show title Show title
{ Appearance: Il 2vicl Black, 12.00 0t Age Groups
) Specify: Chart Title

) From attribute: S| #LayerName

|

[Z] shrink title to fit chart

the title so that it is : Show value labels
proportional to the overall : 169
size of the chart : 22, Y%
0,
Offset - Adjust how far the ‘ 14%
label is from the chart | Source Data | Chart Options I General Options | Title ‘ Labels ‘
N . . 0,
Rotation - Align the title to Show attribute value labels [*] Show attribute name labels 19%
. : 0
the left, center or nght Appearance: . Arial Black, 12.00 pt Appearance: . Arial Black, 12.00 pt 29%
Dlsplaye(:j degma:s -|Set how C offset: sopx |2 Offset: il
many decimal places are : Show name labels
i T ? Rotation: 0 = Rotation: 0
shown with each label : : P
Align value labels - Align all ; Displayed decmals: 0 [ wae [
chart values horizontally 1 [7] Align value labels Aot 10 S8
L H N s
Label with pie percentage - ¢ [] Label with pie percentage EEme

Only for pie charts. Place
percentage beside slice. :

Show name labels - These
options only applies to bar
chart themes

Click the Appearance text link to edit labels in the Edit Text Rendition dialog box. Click the Rendition toggle to
choose a predefined character style in Character Style mode or set appearance options in Custom mode.

Edit Text Rendition Edit Text Rendition

Font: T 1200pt = Character style: [ [] [Normal Character Style] -
=

[7] underline
[7] Strikethrough

Advanced: Advanced:
Graphic style: [[/] Mione] = Graphic stye: [[7] MNone] =
Note: If a Graphic Style is selected, its stroke & fill are interleaved with the Note: If a Graphic Style is selected, its stroke & fill are interleaved with the
spedified font stroke & fill as follows: spedified font stroke & fill as follows:

1. Graphic Style stroke 1. Graphic Style stroke

2. Font stroke 2. Font stroke

3, Font fill 3, Font fill

4. Graphic Style fill 4. Graphic Style fill

Custom mode Character Style mode
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Chart Scaling

There are multiple options to adjust how charts are scaled. In the Edit Chart Theme dialog box, click the Scaling
button to access the Scaling dialog box. There are two options to scale charts: fixed size or use a value from an
attribute. The fixed size option scales all the charts equally by the set percentage. From the initial size, a scale above
100% increases chart size and a scale below 100% decreases chart size.

To scale from attribute, click the attribute drop-down list and choose the appropriate attribute. Click the Load
button to load the data range so that the Scaling dialog box knows which values to use. When the data range
values are clicked, they populate the boxes below (Normalize and Tie to value).

Use the perceptual scaling option to create a more visually accurate depiction of the scale. Perceptual scaling
modifies the scaling slightly in a way that tends to make users perceive the relationship between scaled symbols as
intended. When checked, the scaling will not be mathematically accurate but should be viewed as visually accurate.

. . Scaling
Fixed size - Scale the chart at
aset percentage —— () Fixed size: 100%
From attribute - Scale the chart & From atirbute: | [ OTHER

based on an attribute value. Load

X Datarange: 808 to 3,939,070 (Mean: 199,532) Load
the data range to obtain values.

Use perceptual scaling

Use perceptual scaling

Adjusts the scaling so that it _ )
is more visually accurate () Attribute value is scale percentage

@ Normalize: 3933070 +| =100%

Attribute value is scale percentage

Use this option if the attribute is

contains percentage values

©) Attribute value determines scale from range:

Minimum: [ 5% : Tie to value: 808
@) Discard when value is below minimum
Normalize - Enter a value to set it as 100%.
Other values scaled based on it. SR T
Masimum: [ 100% : Tie to value: | 3339070
Attribute value determines scale from range
Use the data range to determine scale.
Option to tie values to the minimum Bound values to maximum
and maximum.

@ Discard when value is above maximum

Use the Attribute value is scale percentage option to scale the charts directly using the values for the selected
attribute. The maximum scale value allowed is 999 percent. Any values that do not conform will be marked by the
MAP Themes Log as an error and the scale for that chart will not be applied.

Use the Normalize option to set a value as 100 percent. All other values are converted to a percentage based on
the set value and used to scale the charts. For example, if an attribute has a value of 2000 to be normalized as 100
percent, that means a value of 1500 will be considered as 75 percent, effectively reducing the size of the chart.

The Attribute value determines scale from range option contains a number of setting to fine tune how the scale

is set based on a range of values. The settings of the Minimum (default 5%) and the Maximum (default 100%) are
based on the minimum and maximum of the data range. The Tie to value box specifically states which value in the
range that is set as the Minimum or Maximum. It has two options available where any values below (minimum) or
above (maximum) can be discarded or bound. This may be useful if there are extreme low or high values that could
affect the scaling.
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MAP Theme Legends

OVERVIEW

A legend can be created from any MAP Theme—Stylesheets, Dot Density and Charts. Each theme has its own
options and settings to create a legend. A legend is composed of boxes to represent area layers, lines to represent
line layers, point symbols to represent point layers and text for text layers.

FUNCTIONALITY

MAP Theme legends must be added to a '@ Legend layer. One can be created first using the Add MAP Layer button in
the MAP Views panel and choosing a Legend feature type (see chapter 4). Alternatively, MAP Themes will create one
if no Legend layers are present.

To create a legend, select a MAP Theme and click the Create Legend button at the bottom of the panel. Alternatively,
choose Create Legend in the panel options menu.

MAP THEMES

Ares Styleshsst Theme -
& Point Styleshest Theme

Text Styleshest Theme

Eﬂg Bar Chart Theme

'&@ Piz Chart Thame

a2+ Dot Density Theme

7 MAP Themes = U~ T A

Create Legend

The Legend Editor dialog box will differ depending on the type of MAP theme chosen: Stylesheets open the
Stylesheet Legend Editor, Dot Density opens the Create Dot Density Legend, and Charts open the Create Chart Legend.

Similar to other MAPublisher functions, the legend editors are dependent on several Adobe lllustrator panels
including Swatches, Graphic Styles, and Character Styles to style legend symbol elements. Populate these panels
with swatches and styles before creating legends.

Legends are not dynamically linked to the MAP Themes. When MAP Theme styles change, a new legend must be
generated. Select a MAP Theme that already has an existing legend, click the Create Legend button and adjust
the settings to create a new legend. It is most useful when tweaking a legend to make it match or fit a layout
design. Furthermore, legend elements can edited freely using the Direct Selection tool, in isolation mode or if it is
ungrouped (menu Object > Ungroup).
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Stylesheet Legend Editor

The Stylesheet Legend Editor is used to create legends from point, line and area Stylesheet MAP Themes.

Output Layer - Select a
Legend layer as output

Legend Entries
Add entry
Remove entry

Create Stylesheet Legend

put Layer: | O Chart =

Legend Entries | Legend Key Options | Title I Border ‘

E] Pop_Grw_Rt:0.7to 1.8
Pop_Grw_Rt:18t0 20
Pop_Grw Rt 29to 46

Pop_Grw_Rt: 4.6 t0 6.3

Pop_Grw_Rt: -04t00.7 Display name:

Pop_Grw_Rt: -0.4t0 0.7

Display expression:

Pop_Gri_Rt >= -0.4 AND Pop_Grw_Rt < 0.7

Display name - Rule
name displayed in

legend (if enabled)

Preview:

[iFop Grw Rt: -0.at0 0.7
[iPop Grw Rt: 0.7 t0 1.5

Pop Grw _Rt: 1.5 to 2.9
[iFop Grw Rt: 29t0 4.6
[liPor Grw Rt: 4.6t0 6.3

Display exp!
Expression
displayed in the
legend (if enabled)

Preview quality: [Medium

Show actual size

Legend Preview - A
preview of how
the legend key
looks with current
settings. Choose
from several
preview qualities
and actual size.

In the Legend Entries tab, the Legend Entries list determines how many items are listed in the legend. Use the Add
and Remove entry buttons to adjust how many entries are listed and use the Up and Down arrows to adjust the
hierarchy. Select a legend entry and adjust the Display name and Display expression. These labels are used in the
legend and are dependent on whether or not the Include name and Include expression options are enabled in the
Legend Key Options (below).

Indude name - Check
to include the legend

Indude name:

entry names i——e [ Indude expression:

Include expression -
Check to include the :
legend rule expression
Indude icon - Check to
include the legend
icon. Set the size, icon
style or use Advanced
to match legend :
entries to rules.

Indude icon:

Aligment:
Columns:

Space between entries:

Legend Entries | Legend Key Options |'rn1a | Border \

B 2l Black, 12,000t
B ~rizl Black, 12,00t

20.00 px

Icon style: |Rectangle -

1% 20.00px 5

Alignment - Align the
i legend elements to
: the left, center, or right

Columns - Specify
: number of columns in

1 +

3.00px  [%

* the legend

| Space between entries -

i The distance between
: each legend entry

In the Legend Key Options tab, the Include icon option is enabled by default. This is the legend icon to the left of
an entry display name. Edit the size of the graphic using the vertical and horizontal size adjustments. Click the
Advanced button to apply more than one rule style to a legend layer. This may be useful in cases where two styles
such as one for a highway and one to represent high traffic volume, can be both chosen for one legend entry to
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represent a high trafficked highway. In addition, there are many shapes available in the Icon style drop-down list.
The Icon style list is different for Line and Area Stylesheet themes (unavailable for Point Stylesheet themes). Use
the Alignment option to align the legend entries left, center or right. Use the Columns option to adjust how many
columns are in the legend. The minimum number of columns is one and the maximum number is dependent on
how many legend entries exist. The Space between entries option determines the distance between each entry.

| LegendEntries | Legend key Options | Tite | Border |

Draw title:
Label: Legend

Style: B 2zl Black, 12.00pt

[ Draw title line:
B | stroke: | [l Spedfy colour B ® |05 =|Loopt

Spacing: [3.00px

In the Title tab, use the Draw title options to add a title to the legend. Specify a title in the Label box and use the
options to align and set a style. Enable the Draw title line to place a horizontal line in between the title and the
legend entries. The Element spacing option determines the distance between the title, title line and legend entries.

| tegend Entries | LegendKey Options | Tite | Border |

Draw barder:

Margin: 5.00px =

In the Border tab, use the Draw border options to add a border around the legend entries. Toggle between Custom
Mode and Graphic Style mode to choose border style settings.
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Create Dot Density Legend

The Create Dot Density Legend dialog box is used to create a legend from Dot Density MAP Themes.

Dot icon size - The dot size
represented in the legend

Dot spacing - The space between

-t Dot icon size:

Create Dot Density Legend

Output layer: | 'O Dot Density Legend
10.00 px Use actual size

the dot and the legend label

Dotspacng: 5.00 px =

Legend label - Label is entered
by default. Edit to change it.

Legend label: is equal to %wvalues.

Yvalue % will be replaced with the dot's value from the theme,

Appearance - Adjust the legend
label font and font size

Border - Check to place
border around legend
entries. Use options to

style border.
Margin - Adjust the distanceJ

between the border and
legend label

Appearance: [l Arial Black, 12.00 pt
Barder: stroke: | [l Black -l ® wwk] = o
Fill: “Z [MNone] vl Z @) (100%|:
Margin: 5.00px =
Preview:
«is equal to 5.
Preview quality: |High Show actual size

By default, the Use actual size check box for the Dot icon size setting is enabled. Uncheck it to manually set a size (in
pixels). The preview shows how the legend will look depending on the settings. Adjust the Dot spacing option to
increase or decrease the distance between the dot and the legend label.

The Legend label box provides the legend with a title. It uses a %value% variable to determine the value from

the Dot Density theme. To adjust the value, close this dialog box and edit the Dot Density theme. Click the label

appearance link to change the label font, style and size.

By default, the Border option is enabled. Use the options in either Custom Mode or Graphic Style Mode to set the
style of the border. Increase or decrease the value Margin option to adjust the distance between the legend label

and the border.
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Create Chart Legend
The Create Chart Legend dialog box is used to create legends from Chart MAP Themes.

Create Chart Legend
Outputlayer: Preview:
- ji 3 .|
Label appearance - Adjust t‘he abel appearance: [l Arizl Bold, 12.00pt
legend label font and font size ] Draw tite:  |L=genc = Align center
; 1 : -
Draw title - Check to place a Appearance: [l Ariel Bod, 12,00 pt
title. Use appearance options Draw tite ine:
to style the title. | stroke: | [l Black W © [100%[] =[1oopt
Draw border - Check to place [] Draw border: Stroke: W® wos[s = voopt [2
: AGE_5_17
border arqund legend entries. - A @ w0 2 5_
Use options to style border. AGE_18_28
Margin - Adjust the distance Margin: 5.00px [+ AGE_30_48
between the border and L ostyle: I ~cE_50_84
legend label AGE_85_UP
Style - Choose either Standard Style Options:
or Chart style Icon size: 0.00px (5] x 2000px [T
Style Options - Depending on Columns: ! =
Standard or Chart style, these Elementspacng: 3.00px [+
options will differ. See below.
Preview quality: High Show actual size

Click the Label appearance link to change the font, style and size of the legend entry labels.

Use the Draw title options to add a title to the legend. Specify a title in the title box and use the options to align
and set a style. Enable the Draw title line to place a horizontal line in between the title and the legend entries. Use
Custom Mode or Graphic Style Mode to set the line style.

By default, the Draw border option is enabled. Use the options in either Custom Mode or Graphic Style Mode to
set the style of the border. Increase or decrease the value Margin option to adjust the distance between the legend
entries and the border.

The Style drop-down list has two options: Standard and Chart. The Standard option gives the legend an icon and
label style (see above screenshot).

Standard style options

Style:

Style Options:

Icon size: 0.00px (5 x 20000px (5

Columns: 1 =

Element spacing:  3.00 px =
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The Chart option provides more options to create a legend that is representative of the chart. When the legend is
created for bar charts, these options are provided:

Bar chart style options

Style Options:

Chart size: 100.00px 5 x 100.00px 5
Label offset: 3.00px |2

Do not apply chart graphic style

Align labels

Label angle: 45 deg =

Barsizes:  |Increasing

The chart size is the overall size of the chart, not the individual bars themselves. The Label offset is the distance
between the bars and its respective label. The Do not apply chart graphic style option removes any graphic styles
that were applied to the chart when it was created. The Label angle rotates the label to a specified degree. Bar sizes
can be set to Increasing, Decreasing or Equal. These are for visual purposes only and do not reflect the actual data.

When the legend is created for bar charts, these options are provided:
Pie chart style options

Style Options:

Chart size: 100,00 px (5 x 100,00 px |5
Label offset: 3.00px |2

Do not apply chart graphic style

Ignore explodes

Rotation: 0 deg =

By default, the Ignore explodes option does not display an exploded pie chart in the legend when it is checked. Set
a Rotation to rotate the pie chart clockwise.
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Text and
Labels

One of the most useful features of MAPublisher is the ability
to create labels for map objects using values from the MAP
Attributes panel. Manually entering and placing labels is not
necessary, provided that the labeling information is included
in the map attributes of the MAP Layer being labeled.

MAPublisher provides two methods of adding labels
to a map, both of which contain options to place labels
intelligently using defined label settings.

One way to create feature labels is to first select all the
features to be labeled and use Label Features to label all of
them by specified attribute values.

An alternate method involves using the MAP Tagger Tool to
apply labels individually, also by specified attribute values.

As a complement to the labeling functions, Create Knockouts
masks the part of line features covered by text labels for
improved text legibility.

Topics covered in this section:
Label Features

MAP Tagger Tool

Create Knockouts
Right-to-Left Text

Text Utilities

For more advanced labeling capabilities refer to chapter 17
about MAPublisher LabelPro (additional license required).
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Label Features

Object > MAPublisher > Label Features or MAP Toolbar @9

Label Features

A o =]

Ly ke Targed Shyte

Layer - Lists the Point, Line and Area
layers that can be labeled. Only

% [ Hotess_pomt S HOTEL sas [ Hotel Labels =

e style-Labelsare styled based on

2 I Poads e 5 ROADNAME [T Park Labelt - Rosd 52y
selected features can be labeled. = - the chosen Character style
3 I Parks peea 5 PakMame [ Park Labeks Park Styte
Attribute - Select the attribute that ! 1 Target - The target text layer is where
contains the values you wish to use all the labels will be stored

as labels for the selected features = -
| B anseng | 1 e sem | P rontsenngs

:| Macement senuracy: @ Low (fanie)
Label Settings - Click the appropriate ——
tab to assign label settings and :
rules for each layer type (see below)

tage [skrwe, s bl o e bt

o rws o atte

arger s ares:

FUNCTIONALITY

The Label Features tool creates labels based on attributes of selected features on Area, Line, or Point MAP layers.
Features selected on multiple MAP layers can be labeled simultaneously. Additional settings to fine tune labeling
are available, such as alignment to lines of latitude, minimum font size, horizontal scaling and label position in order
to place labels intelligently.

PREREQUISITES

Labels need to be added to a Text layer. Use Add MAP Layer in the MAP View panel to create one (see chapter 4)

For best results, set up character styles for type font, size, justification and color in the Character Style panel (Adobe
lllustrator menu Window > Type > Character Style). To use a generic style, select the appropriate style before using
the Label Features tool and MAPublisher will generate labels based on those settings. Otherwise labels applied will
appear in the current default color, font and font size.

LAYER LABELS

Layer and Attribute

The Layer column shows the Area, Point, or Text layers that currently have selected features to label.

For each layer, the Attribute drop-down list is populated with the attributes of that layer. Click to choose the
appropriate attribute to label with.

Target

In the Target coloumn, specify a Text layer that the labels will output to. Note that labels can only be created for Text
layers in the same MAP View as the MAP layer.
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LABEL SETTINGS

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude,
minimum font sizes and horizontal scaling to best place labels within polygons and paths. These label settings are

common to Label Features and the MAP Tagger Tool (including MAP Contour Tagger).

|Al Area Labels

Labels curve with lines of latitude
For projected layers, choose this option to
generate curved text along latitude lines

Adjust label if larger than line - Specify rules
for the scaling of text if the text will not fit
inside the area object in its entirety.

Click the Up or Down buttons to adjust
the order in which the rules will be
implemented in the labeling process.

[ Area Settings ‘ Ul Line Settings | P! Point Settings

Placement acauracy: @ Low (faster)

(© High (slower, forces label within area boundaries)

——® [] Labels curve with lines of latitude

Reduce font size to a minimum of: |5 pt

® [7] Adjust label i larger than area:
Reduce horizontal scaling to a minimum of: [10%

Wrap labels that are too long

Pl Accuracy - To quickly generate
labels, choose Low. To force labels within
the boundaries of area of complex shape,
choose High.

Set all labels to the same minimum size - When
at least one label has been reduced in font
size due to the implementation of rules,

then all text items will be reduced to that
font size (Label Features only)

et alllabels to the same minimum font size

MAPublisher places Area labels depending on the shape and size of the area polygon. Click the Area Settings tab to
see all the area label settings.

The High Placement Accuracy option makes more advanced calculations for the label positions so as to force them to
fall within the area boundaries (useful for areas with strange shapes, for example some S shape islands). However, it
does slows down the labeling process so a Low accuracy can be preferable depending on the expected results.

When the Labels curve with lines of latitude option is selected, MAPublisher creates a path that conforms to local lines
of latitude and place the text along it. If this option is not selected, the labels are placed horizontally. This option is
enabled only for MAP Views set with a projected coordinate system.

Labels can be modified if they exceed the size of the area in the current default font size. Check the Adjust label if
larger than area option to activate the label reduction rules. These rules are executed in a hierarchical order and can
be reordered with the Up and Down buttons. The Reduce font size option allows to reduce the size of the font to a
specified minimum size in points. The Reduce horizontal scaling allows text to be scaled horizontally by the fraction
specified. The Wrap Labels that are longer than area option adds a carriage return at the nearest space in the text.

Note: The Wrap Labels that are longer than area option is not available if the Labels curve with lines of latitude option
is checked.

Label Features also provides an additional option which is not available with the MAP Tagger tool. If any of the labels
have been adjusted in size due to the deployment of an area adjustment rule, all labels can be resized to the same
size by checking the Setall labels to the same minimum font size option.

When a specified rule cannot be implemented successfully, MAPublisher will default to placing the label centered
over the area. In situations with compound areas, MAPublisher labels the largest area in the compound.
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Line Labels

Label type - Select whether text should
follow lines or be placed at a point near

Distance from start - Controls how text is I wsasetmgn | I neSettngs | B puk Satange the selected line. Path length option
placed relative to the line: Labed type (Fokm e, create textena path = | Path e (et - creates short or long text on path.
Autq - places text at midpoint for straight—. Dutance from vt s = Reverse right-to-left paths (flip upside-down text)
lines and ﬁnd§ the §moothest portion 7] Reverse right e paths (A upakde-own text) Always enabled by default, it automatically
] closest to the mld90|nt for curved lines. Smoath ines with offser: 4,00 orients labels uniformly. Disabling this
Fixed - allows for precise placemlent of;ext Labalposition: L sassine Lfeature will not flip the label.
along a line. i
9 I © usceter Smooth lines with offset - Check to smooth
—§— ) Center

the generated text path. Then, specify an

Adjust label if larger than line - Specify rules ——e ™ aus e e tan we: offset distance for the text path from the

for the scaling of text if the text will not fit -

L . original.
onto the text path in its entirety. R AERe e e =
Click the Up or Down buttons to adjust 2 : - Label Position - Choose how the text will be
the order in which the rules will be placed on the generated text path
implemented in the labeling process. : oY font Set all labels to the same minimum font size

When at least one label has been reduced
in font size due to the implementation of
rules, then ALL text items will be reduced
to that font size (in Label Features only)

MAPublisher places Line labels depending on the curvature and length of the line string. Click the Line Settings tab to
see line label settings. Choose a Label type to either Follow line and create text on a path, Follow line and create point text or
Don't follow line and create point text. The first option creates text that follows a path where its position can be adjusted
along it. The second option creates text that follows the angle of the path, but uses a point of reference. The last
option places the text at the middle point of a line and uses a point of reference.

MAPublisher controls where text is placed along lines by using the Distance from start option. Choosing Auto will place
text at the midpoint for straight lines and, for curved lines, will find the smoothest portion of the curved line closest
to the midpoint. When Fixed is chosen, the distance from start is set as a percentage of the length of the line.

Reverse right-to-left paths (flip upside-down text) is enabled by default and will automatically orient labels uniformly if
some lines are flipped. Disabling this feature will not flip labels.

When the Smooth lines with offset option is enabled, MAPublisher creates a smoothed version of the selected path for
each text object in the layer and places the text along it at the specified offset value. The labels can be dragged and
positioned at any position along a line. When Line Smoothing is not enabled, the labels follow the original path.

Note: For lines with a high number of vertices (e.g. contour lines), using the Line Smoothing option significantly
speeds up the labeling process.

The Label position option allows for the selection of the vertical position of the labels relative to the line. Three
options are available:
«  Baseline: places labels above the generated text path.
«  Descender: places the portion of a letter in a Latin-derived alphabet that normally extends below the
baseline of a particular font above the generated text path.
«  (enter: places the label on the generated text path.

Labels can be modified if they exceed the length of the line in the current default font size. Check the Adjust label if
larger than line option to activate the label reduction rules. These rules are executed in a hierarchical order and can
be reordered with the Up and Down buttons. The Reduce font size option reduces the size of the font to a specified
minimum size in points. The Reduce horizontal scaling option allows text to be scaled down horizontally by the
percentage specified.
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Label Features also provides an additional option (not applicable for the MAP Tagger Tool). If any of the labels have
been adjusted in size due to the activation of a line adjustment rule, all labels can be resized to the same size by
checking the Setall labels to the same minimum font size option.

When a specified rule cannot be implemented successfully, MAPublisher will default to placing the label centered
over the line. Also note that text generated for Line labels will be automatically orientated above the lines,
irrespective of the direction of the line.

P Point Labels

B svea sergs | T unwserngs | P Fomt Sentrgs

Label Position - Choose the position of the ———ewse peaton: Battamtadde -
label relative to the point symbol. The
preview displays label position.

Labels curve with lines of latitude ——— | Lutis curve vt e of lame
For projected layers, choose this option to Wt sounding style bk

generate curved text on latitude lines. tardart Use style labels '_SPeC'ﬁC options
to label symbols marking a water depth

position according to hydrographic
conventions. See details in this chapter.

Click the Point Labels button to assign MAPublisher Point Label Settings.

The Label Position offers nine position options for the text anchor. Choose one of the placements in the drop-down
list: Upper Left, Upper Middle, Upper Right, Left, Center, Right, Bottom Left, Bottom Middle, Bottom Right. A preview
shows the label placement.

When the Labels curve with lines of latitude option is selected, MAPublisher creates a path that conforms to local lines
of latitude and places the text along it. If this option is not selected, the labels are placed horizontally. This option is
enabled only for MAP Views set with a projected coordinate system.
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Special Point Labels: Sounding Style Labels

The Use sounding style labels option is specific for users wishing to label point symbols marking measured water
depth positions. These types of labels are officially known as Charted Soundings and its representation on official
navigational charts are ruled by international standards.

The aspect of the soundings is always according to the following rule: Numerals representing the decimeter part of
a sounding should be visibly smaller than those representing whole metres and positioned slightly lower than the latter
(subscript). Zero decimeter values must not be shown.

For example: 12 92

Note: Traditionally, slanted text (in italic) represents depth values in metre, straight text represents depths in feet.

On official nautical charts, the actual depth symbol is not plotted — the label itself indicates the depth position.
Two options are possible for the soundings' placement relative to the depth point:

«  Usestandard label style: soundings are placed in such a way that the centre of gravity (geometric centre) of
the set of numerals (integer and decimal parts) coincides with the position referred to. This option is the
most commonly used.

«  Center on whole number: soundings are placed in such a way that the center of gravity of the integer part of
the number coincides with the position referred to.

;JZ H Depth .[. position relative
: 43 to label (if it was drawn). Y 4 4

Sfandard styl Centered on whole number

Note: More information on these standards can be found on the International Hydrographic Office Website,
www.iho.int, see publication S-4 (formerly M-4).

The relative size and position of the decimal (subscript) relative to the integer number (regular type) is controlled
by the Adobe lllustrator document setup. Choose the menu File > Document Setup to change the subscript size and
position under Type Options. These settings should be performed prior to running the labeling function because
they affect the labels placement relative to the source symbols.

LABEL FEATURES RESULTS

When all the Layer Label Options have been set and the Label Settings have been specified click OK to label the
selected features.

Labels applied using Label Features appear in the current default color, font and font size (as set by the selected
character style).

If the destination text layer and source layer have the same attribute schema, the attributes of the labeled features
are copied as attributes to text features (to apply MAP Themes for example).
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MAP Tagger and MAP Contour Tagger Tool
Tools > MAP Tagger Tool [F&y] and MAP Contour Tagger Tool
FUNCTIONALITY
The MAP Tagger Tool and MAP Contour Tagger Tool are interactive labeling tools that use the attribute data of selected
features as a source for the labels. These tools function similarly to the Label Features function, however, labels are
created by clicking features on the artboard. It provides greater control over the initial placement of the label. For

the MAP Tagger Tool, labels are placed at the position of the mouse click and leader lines can easily be created in
dense areas. For the MAP Contour Tagger Tool, labels are placed for Line layers only and works best on contour lines.

PREREQUISITES
Labels are added to a Text layer created using the MAP Views panel.

For best results, set up a character style for type font, size, justification and color in the Adobe lllustrator Character
Style panel. Select the appropriate style while using MAP Tagger tools otherwise labels will appear using the default
color, font and font size.

Double-click the @ tool to enter new label settings or to edit settings. Click and hold the button to switch to the
MAP Contour Tagger tool .

MAP TAGGER TOOL SETTINGS

Source Layer and Column

First set the options in MAPublisher to determine the attribute values that will be converted to text labels. The Source
Layer list shows all Area, Point and/or Text layers in the current document.

For each layer, the Column drop-down list is populated with the attribute structure of that layer. Select the column
that holds the desired attributes to label the data with.

Target Text Layer

In the Text layer drop-down list, specify the Text layer that the labels will be output to. Note that labels can only be
created in text layers in the same MAP View as the Source Layer.

LABEL SETTINGS

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude,
minimum font sizes and horizontal scaling to best place labels within polygons and paths. These Label Settings are
common to Label Features, MAP Tagger Tool and MAP Contour Tagger Tool (Lines only).
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TAG MAP DATA

Ensure the label settings are completed. With the MAP Tagger Tool enabled, click a map object to add a label for it. It
may be convenient to lock the layers in the Adobe lllustrator Layers panel or disable undesired features by setting
the attribute column option to No attribute selected for those data layers that do not require labeling to avoid
undesired results.

The following list of keyboard modifiers can be used for additional labeling options with the MAP Tagger Tool:
%> = click map object with MAP Tagger Tool

Standard label Line labels are placed at click point and assigned angle of line at click point
) Area labels are placed horizontally at click point
P! Point labels are placed horizontally at click point

Label horizontally Line labels are placed horizontally at click point

0+
Create leader line Line labels are placed horizontally. Leader line connects text to line feature.
Bt +drag Area labels are placed horizontally. Leader line connects text to area feature.

P! Point labels are placed horizontally. Leader line connects text to point feature.
Label and move Line labels are assigned angle of line at click point and can be moved immediately
8, +drag Area labels are placed horizontally and can be moved immediately

P Point labels are placed horizontally and can be moved immediately

Note: To create custom leader lines use a graphic style. Create or load a graphic style and select it in the Graphic
Styles panel while using the MAP Tagger Tool function.

The labeling procedure for MAP Tagger Tool differs slightly. Labels are placed by drawing a line and dragging it across
lines (instead of clicking features to label them). This is particularly useful for contour lines, routes or rivers that are
positioned near each other. The label follows the path.
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Create Knockouts

Object > MAPublisher > Create Knockouts or MAP Toolbar

Create Knockouts ———————————+— (lear- Click here to remove all

Feature Layer - Select the line layer that

will be masked with knockout: Layer(s): <Specify layers> C\Ea\l tz;ikrzutj;;?m the selected

Text Layer - Select the layer containing Textlayer: [I:I] Feature Labels vl [ Cancel ]
the base text for the knockouts Lo Mask opacity: 100%

(100% creates transparent knockout)

Mask Opacity - Set the mask opacity 7® [¥] Replace existing knockouts
-+ [I] Use diipping mask instead of opacity mask {only use when exporting to PDF or PostScript)

Replace existing knockouts - Clear the Pl Round comers using radus: [5.00px |2 Round corners using radius
existing knockouts in the Feature Creates mask corners that are
Layer before adding new ones. Do not rounded to a specified radius
choose this option to append new @ Knockout boxes:
knockouts to the existing ones. Leftbuffer:  0.00px
Use clipping mask instead of opacity mask Rightbuffer:  0.00 px boxes - Set a bufer size

Choose only if exporting document around the text box

to PDF or PostScript. It uses a
clipping mask instead of an opacity

Top buffer: 0.00 px
Limit to cap height - Check this

option to limit the text box height

W [ [ EE

Bottom buffer: 0,00 px

mask beneath the label. [T Limit to cap height to the size of capital letters.
() Text shaped Text shaped knockout - Set a buffer
Buffer size: [L1.00px knockout based on the shape of
the text
FUNCTIONALITY

The Create Knockouts function masks parts of line features that are covered by text. The knockouts can be created
for any MAP Layer. All lines in the selected feature layer are affected by the function. A knockout is created for all
text in the selected . Text layer.

Knockout - Knockout extents —— """
_K | n g St re et_— Line Feature - Line feature being masked

Text Feature - Text base for the knockout mask

The opacity of knockout masks can be set in the Create Knockouts dialog box and can be modified afterwards
through the Adobe lllustrator Transparency panel.

By default, the size of the knockouts correspond to the Adobe Illustrator text bounding box—that includes
ascenders and descenders (e.g. bottom of letter g). This size can be increased by adding a buffer in pixels (side, top
and bottom) or limited to the height of capital letters. Optionally, choose the knockout to correspond to the shape
of the text. This allow for finer control over the appearance of the knockouts.

Create Knockouts can either append new knockouts to the selected feature layer or replace the exiting ones. It is
also used to clear knockouts that were previously created with the function.

Note: Any text layer can be used to create knockouts, it does not have to be generated by MAPublisher Labeling
functions. The Feature and Text layers do not have to be in the same MAP View.

PREREQUISITES

Create Knockouts requires any type of MAP Layer and a | L | Text layer to be unlocked and visible.

All features in the selected layers will be affected by the function. Text and features that are not supposed to be
masked must be moved to a different layer beforehand.
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USING CREATE KNOCKOUTS

To access the function, click the Create Knockouts button on the MAPublisher toolbar. Alternatively, choose
Object > MAPublisher > Create Knockouts from the main menu.

Layers

In the Create Knockouts dialog box, click the Select Layers button to choose at least one Feature Layer (visible and
unlocked), and then choose a Text layer from the drop-down list. Use the Layer Type Filter to filter which layers
are shown. Text in the selected text layer should overlap with some of the features in the selected feature layer to
get reasonable knockout results.

Mask Opacity

The Mask Opacity option sets the opacity of the masks created behind the text: a 100% setting creates an opaque
mask (the feature will be invisible behind the text) and a 0% setting does not hide any features at all.

Replace Existing Knockouts

The Replace existing knockout option clears the existing knockouts on the selected Feature Layer before adding the
new knockouts. This is useful when running the Create Knockouts function again after adjusting the settings
slightly. To append the new knockouts to the existing one, make sure this option is not checked.

Knockout Boxes

Several parameters are available to set the size of the knockout. By default, the knockout corresponds to the Adobe
lllustrator text bounding box. That bounding box can be slightly taller than the characters in the selected text
because it takes into account the size of ascenders and descenders (e.g. | and g characters). To increase the size

of the knockout, four buffer options are available: Left Buffer, Right Buffer, Top Buffer and Bottom Buffer. Buffer sizes are
entered as pixel values. The Limit to cap height option reduces the knockout size to the height of the capital letters. For
example, this option is useful when labeling contour lines that are close to one another where the regular knockout
size could create masks that overlap from one contour to the next. The knockout boxes are represented below by
the dashed line (for visual reference only).

IS — e sl N A
—King Street- -iKing Street+ —:/KLDQ..SI eet-
S S S S——

Default knockout size Buffer knockout size (2 px) Limit to cap height
knockout size

To achieve a knockout that does not conform to a box, choose the Text shaped knockout option and specify a buffer
size. This creates a knockout that is based on the shape of each text character. It allows for finer knockout control.
Optionally, use the Round corners using radius option to round knockout box corners.

. / /
—King-Street-
7 T
Text shaped knockout (1 px)

Note: Text shaped knockouts may increase document file size.
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KNOCKOUT RESULTS

All art in the MAP Layers are masked by the text objects in the selected Text layer, where appropriate.

To achieve the knockout effect, Create Knockouts applies an opacity mask at the layer level as can be seen in the
Adobe lllustrator Layers panel.

Layer with Opacity Mask - In Adobe Illustrator,
adashed line under a layer name indicates
that the layer has an opacity mask

This masking does not affect the MAP Layer attributes or properties.

Edit Knockout Masks Opacity
The opacity of all the knockouts within MAP Layers can be edited using the Adobe lllustrator Transparency panel:

1. Inthe Adobe Illustrator Layers panel, click the target button next to the master layer name (_} .

2. Choose Window > Transparency to open the Transparency panel.
3. IntheTransparency panel, click the right-side preview to start editing opacity mask.

+ TRANSPARENCY

Normal w Opacty:| 100+ |Yoe] Opacity - Percentage of opacity
(transparency)
&l . = DCT'P
o . — | [|nvert Mask
Exit Edit Opacity Mask Edit Opacity Mask - Click to
Click to stop editing edit opacity mask
opacity mask [|1sclate Blending  [H] Knockout Group

I:‘Opac'lty & Mask Define Knockout Shape

4.  Click the left-side preview in the Transparency panel to exit the opacity mask editing mode.

Note: If for some reason the knockouts are not selected when you exit the opacity mask editing mode, the next
time you return to this mode, they will not be selected by default—you'll have to select the knockouts again
from within the opacity mask editing mode (click the object or use the Layers panel target button).

CLEAR KNOCKOUT MASKS

Open the Create Knockouts dialog box, ensure that the MAP Layers that contain the knockouts are selected and
click the Clear button.
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Right-to-Left Text

Object> MAPublisher > Right-to-Left Text or MAP Toolbar|EI‘|

Right-To-Left Text

Target - Choose which text to
» A s
apply right-to-left correction to

and whether to apply it to only @ Texton layer: [ [T world Areas - ]
al

K
ncel
selected text or not @ Altextin document

[ Apply to selected text only

Settings:
Preset - Choose a preset or u: Preset: [Leﬂ*tciight -
custom settings below
Composer engine: [Standard - } Composer engine - Choose from
A _— - Standard or Adobe World-Ready
Paralgraph dllelmon - Choosle a L.eft [T Paragraph direction: | Left to right Composer to handle text
to right or Right to left direction
Diaits- Ch hich | [T] Justification method: | Default Justification Method - Choose from
igits - X °9S,ew \ch language o Arabic or Naskh justification
numeric digits are to be typed [ Digits: Default
Kashidas - Check to insert [ Kashidas

Kashidas in Arabic language

FUNCTIONALITY

Many right-to-left languages, such as Arabic and Hebrew, require additional language-specific processing to get
the correct glyph output given the incoming character stream. The Right-to-Left Text tool is used to apply proper
formatting to right-to-left languages.

USING RIGHT-TO-LEFT TEXT

From the main menu choose Object > MAPublisher > Right-to-Left Text or click the MAPublisher toolbar button IZI'I

In the Target section, choose the target text to be a MAP Text layer or target all text in a document. Optionally,
check Apply to selected text only to only apply formatting to text that was selected before opening the dialog box.
In the Settings section, the Preset contains options (Left-to-right, Arabic, Hebrew) that sets Paragraph direction,
Justification method, and Digits. Any other settings chosen are considered as Custom.

The Composer engine has two modes: Standard and Adobe World-Ready Composer. The Standard mode uses the default
Adobe lllustrator text engine. The Adobe World-Ready Composer enables support for complex script languages
(such as Arabic and Hebrew).

The Paragraph direction can be chosen as Left to right or Right to left (this is the result, not the current text).

The Justification method can be left as Default (the same as the language set in the Character panel) or set to Arabic or
Naskh. To convert text to right-to-left without changing the justification or location of text, uncheck all options and
set the composer to Adobe World-Ready Composer.

Choose the language in which numeric Digits are to be typed. The Default setting means that the numbers will be in
the same language as set in the Character panel, otherwise, choose between Arabic, Hindi, or Farsi digits.

Kashida is a type of justification that elongates characters at certain chosen points. Kashida justification can be
combined with white-space justification to various extents.
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Text Utilities

Object > MAPublisher > Text Utilities or MAP Toolbar | |

Text Utilities

Target - Choose which layer to Target:
apply text utilities to or choose
to apply it to all text in the
document. Optionally, only apply
it to selected text.

(@ Textonlayer: | [T] Feature Labels copy

@ Al text in document

[ ©nly apply to selected text

Preview

Actions - Choose an action to Action: Convert text on a path to point text

o

perform it on the target text.
More actions below. Actions
explained on the next page.

Action: [Separate multine text =

Sreak multiine textinto single pieces of text.
Options:
[T Create aroups

Action: [merge text =

Merge multiple lines of textinto a single text object.

[T] Merge on attribute: | [S] namn

Action: Extend overflowing text -

Find text with the red + and extend the path so that all text is wisible.

Action: Fip upside down text -

Modify upside down text to be shown at a more appropriate orientation.

Action: Shorten text path -
Modify the text path so itis only as long as the actual text by removing extra ine segments at start
and end.

Action: Set text alignment -

Change the insertion point of point text without moving the text.

Options:

Alignment [ = Left =

FUNCTIONALITY

Takes the first and last paint of text on path, and makes rotated point text.

Action: [Rectify point text to angle -

Rotates specified text to this angle if the current angle falls between the angle +/- the tolerance
angle.

Options:
Rotate to  0.00% +| for text within a tolerance of 5.00° —
Action: Drai shape around text =

Draws a shape around text,
Options:
Outputlayer: © Selectlayer: | [T] Feature Labels copy

@ Create new layer

) Same as text
Fill: [] one] ¥ | 7] ® [100%

Leftbuffer:  0.00 px
Rightbuffer:  0.00 px

Topbuffer:  0.00 px

& [ [ [

Bottom buffer: 0.00 px
[T Limit to cap height

[ Create single box for multiine text

Action: [oraw anchor point for text =

Output layer: Select layer:
@ Create new layer

Same as text

The Text Utilities dialog box centralizes many text related actions that map makers require. Many of these text
actions have come about due to the complexities of working with text, geographic data and follow cartographic
conventions. Common text issues that Text Utilities can handle are correcting upside down text, separating
multiline text into single line and cropping text path to text length. These actions can be applied to either all text
layers or specific text on a layer. Optionally, actions can be applied to selected text only.

USING TEXT UTILITIES

From the main menu choose Object > MAPublisher > Text Utilities or click the MAPublisher toolbar button ||.

In the Target section, choose the target text to be a MAP Text layer or target all text in a document. Optionally, check
Apply to selected text only to only apply formatting to text that was selected before opening the dialog box.

In the Actions section, choose an action to be performed (actions explained on the next page). Only one text action
may be performed at a time. Click the Preview button to see how the text may be affected.
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Actions Original Result
Convert text on a path to point text ! St
Converts text on a path to point “La : £<'31.1,re
text removes curvature and creates W.[enqa ca
"straight” text. {
Separate multiline text
Separates multiline text into BJlJ-e BJLLe
individual lines of text (the points Spr—mgﬁ Spnngs
starting each line in the result). Park Park

Example result produces three separate lines of text.

Merge text Main Main
Merge multiple lines of text into St t St t
a single text object. Not available Nort! Nortt

when "All text in document" is
chosen as the Target.

Extend overflowing text
Extends text elements that contain
overflow.

GRANG:

il

Flip upside down text
Flips upside down text (corrects
left-to-right direction)

L

Shorten text path
Remove extra line segments at the
start and end of a path

RO .

Set text alignment

Change the insertion point of
point text without moving the
text. Alignment can be set to left,
center, or right.

Blue Springs Park  Blue Springs Park

Example result produces right justified text.

Rectify point text to angle

Rotates point text to any angle
for text within a specific tolerance
angle.

Edwardst ~  Edward>t

Example result rotated 8 degrees for text within a 10 degree tolerance angle.

Draw shape around text

Draws text shapes or boxes around
text. Change the style using the
appearance options. Optionally,
limit box to cap height of text and
choose a specific layer for output.

OxfordSt | Oxford St

Example result has a box shape with side, top and bottom buffer of 4 px.

Note: some text may not appear centered if no descenders are present and the limit to cap
option is disabled.

Draw anchor point for text

For point text, it draws an anchor
point at lower left. For path text it
is relative to the left anchor point.
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~ -~ . MAP Selections
... andData
- Organization

‘ 5 MAPublisher contains tools for selecting data graphically and
d=a\; e, by attribute values.

The MAP Selections panel provides functionality to create,
: B T edit and save multiple selection criteria: based on attribute
pe | . o ? expressions, manual art selections or spatial filters. MAP
£ Selections are saved with the document.

£5 i s The Split Layer function allows to split MAP Layers based on
3 . attributes values to facilitate data management.

] The topics covered in this section:
' MAP Selections

Merge Layers

i bl Split Layer

0
AN

]
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MAP Selections

Window > MAPublisher > MAP Selections or MAP Toolbar *§*

MAP Selections Panel

MAP Selections List - MAP Selections saved —— ——*
in the current document j MAP Selection Name - Name given to the

MAP Selection. It can be changed in the
Three different types of MAP Selections: Edit MAP Selection dialog box.

- Attribute Filter foo

+ Art Selection "_] MAP Selection Parameters - Summary of
+ Spatial Filter (&) the selection parameters. They can
be changed in the Edit MAP Selection

Invalid MAP Selections for the currently
selected layer are marked with an
additional "= sign.

dialog box.

T— Delete MAP Selection - Delete highlighted
MAP Selections

Panel options: Create New MAP Selection- Opens the New
MAP Selection dialog box (below)

New MAP Selection...
Get Subset of Current Selection - Makes a

Duplicate "Texas Roads" o————— Duplicate MAP Selection - Copies the . . .
———— selected MAP Selection selection within the current selection
—I_ Remove from Current Selection - Removes
Delete "Texas Roads”... Edit MAP Selection - Opens the Edit MAP the highlighted criteria from the current
Apply as New Selection Selection dialog box selection
Add to Current Selection Add to Current Selection - Adds the
i S ey highlighted criteria to the current
Get Subset of Current Selection Import MAP Objects - Opens the Import selection
: . MAP Objects function (see chapter 4) Apply as New Selection - Makes a new
mport MAP Objects... ~e——————— N R - -
selection using the highlighted criteria

Preferences... o Preferences - Opens the MAPublisher

Preferences on the MAP Selections

property sheet

MAP Selections Panel Preferences

e Predprre ey

MAPL,
fw Expression Builder
S Gerweal
[ imporn Mg Date
[0 MAR Astsibutes

T MAP LabelPro

4= MAP Location

S MAP Measuresnent
4 W M Selnctiong

T Panel
g MAP Styleshes
@ WAPViews | MAP Selections > Panel

Show filters on two lines - cleared

[ Show selections on two lines

Show filters on two lines - selected

222 | Chapter 11: MAP Selections and Data Organization
MAP Selections



Name - Assign or edit the name of
the MAP Selection

Layer(s) - Choose layers to base
the selection on. By default, the
selection will be done on the
currently selected layer.

Clickto « make a different choice
in the Select Layers dialog box

New/Edit MAP Selection

New MAP Selection

Mame: My Map Selection

Type: | fw Attribute Filter

fo) Attribute Filter

Type: I Fia Attribute Filter

—I—q Layer(s): <Use current layer>

Expression: PERIMETER > 139.23327

« The expression is valid.

Select Layers

Layer Mame
e —
B coralp 2000 _sees
W stpark_jan9_srea
W mirvp_ares
P cities fobMd_peien

Use curment ier Seiect A

)

Type (new MAP Selection only) - Choose
the MAP Selection type:
- fu Attribute Filter

_| Art Selection
« (@) Spatial Filter

pression - Enter or edit the expression

e :directly into the entry field, or access

" Expression Builder - see chapter 5

[ Expression Library - see chapter 5

Show Selection - Highlights the Art

Selection on the artboard —45'10"\' Se‘emﬂ] [ ReD‘Taue ] [

_1 Art Selection
Art must be selected first.

Type: | ] Art Selection

Store the currently selected art.

Edit Art Selection

acd |

Replace - Replaces the saved Art Selection
with the current artboard selection

Spatial Relationship - Choose the method —
applied for the spatial filter:
« Intersect and contain: objects that
intersect or are contained within the
delimiting features will be selected
« Fully contained: only objects that are
fully contained within the delimiting
features will be selected

Filter Text By - Choose the specific
behavior for selecting text:
« First letter of text: the position of

the first letter of a text is used to ———sFilter text by:

make a selection
« Full size of text: the bounding box
of the text is used for the selection

Do not select art on the same layer as the 'Filter —
Using' art - Check this option so as not
to select art that is on the same layer
delimiting feature

) Spatial Filter

Type: [ (&) Spatal Fiter

Filter Using: [?Exisﬁng MAP Selection

Existing MAP Selection: I "] My Map Selection

Options:
Select from Layer(s): <alllayers>
L——eSpatial relationship:

—=[/| Do not select art on the same layer as the 'Filter Using' art
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p Validity - Indicates if the
expression is & valid or @ invalid.
If invalid, additional information is
reported

Add - Adds the current artboard
selection to the saved Art Selection

Filter Using - Choose where the features

that delimit the spatial filter are taken

from:

. Y Existing MAP Selection: select a MAP
Selection name from the Existing MAP
Selection drop-down list

__| Art Selection: use the current art
selection (see options above for edit)

- {0 Attribute Filter: enter new attribute
filter parameters (see Attribute Filter

dialog box above)

Select From Layers - Choose layers to
select from. By default, the selection
will be done on all layers.

Click to « make a different choice in
the Select Layers dialog box (see above)
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FUNCTIONALITY

The MAP Selections panel provides options to build, edit, save and apply multiple selection criteria based on:
«  Attribute Filters: selections based on attributes and properties of MAP Layers
«  ArtSelections: saved selections (done with the MAP Selections filters or with the Adobe lllustrator
selection functions)
«  Spatial Selections: selections based on a feature's position relative to another (e.g. select points
contained in a given area).

MAP Selections are saved in the Adobe Illustrator document. The Import MAP Objects function (see chapter 4) provides
a method to exchange MAP Selections between documents opened in Adobe lllustrator.

Expressions created for Attribute Filter type MAP Selections can be saved in the Expression Library so that it can be
used in MAP Attributes and MAP Themes stylesheets (see chapter 5 and chapter 9, respectively).

PREREQUISITES

To save or use a MAP Selection, at least one piece of art must be selected on the artboard before creating a new
selection. This selection does not have to be on a MAP layer, although it must be visible and unlocked.

CREATE A MAP SELECTION

To open the MAP Selections panel, choose Window > MAPublisher > MAP Selections or click the MAPublisher toolbar

button *F .

To create a new MAP Selection, click the Create New MAP Selection button "E} or the panel options menu to open the
New MAP Selection dialog box.

Enter a meaningful Name for the new MAP Selection to facilitate its use. For example, a MAP Selection could be
named Cities or Countries with 80% or higher literacy or US Highways.

Choose the desired MAP Selection Type: Attribute Filter, Art Selection or Spatial Filter.

Attribute Filter

Attribute Filters select objects on one or more MAP Layers based on the features' attributes values or properties.
The selection criteria is an expression created from attributes names, values and/or preset functions.

By default, the selection is done on the currently selected layer. Users may choose a different layer or more layers by
clicking the = button to open the Select Layers dialog box. Check any layers that may need to be included.

In the Expression field, enter a valid expression. Optionally, click the & button to open the Expression Builder dialog
box or click the |[@ | button to select an expression from the Expression Library — see chapter 5 for more details.
The Expression Validity icon will report if the expression entered is valid ¥ or invalid @ (and will include additional
warning notes).

Note: The expression validity depends on the layer selection since it is based on some attribute column names.
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The following are some examples of basic expressions which can be entered for use as selection filters.

Expression Result

NAME = “Ontario” All items with the value “Ontario” in the NAME column are selected.

Result: Items with the value “Ontario” OR “Alberta” in the NAME column

NAME = “Ontario” OR NAME = “Alberta”
are selected.

All items with values less than one million in the POPULATION column are

POPULATION < 1000000
selected.

Only items containing the value “Ontario” in the NAME column AND

NAME = "Ontario” AND POPULATION < 1000000 values less than one million in the POPULATION column are selected.

Note: MAP Selections created in versions earlier than MAPublisher 8.3 are converted to MAP Selection Attribute
Filters, based on the <current layer>.

Art Selection

To store a current selection — done through the MAP Selections panel or using the Adobe Illustrator selection
functions (e.g. Selection tool, menu Select or Layers panel) — select the MAP Selection type Art Selection. No
parameters are required for this type of MAP Selection.

The current selection must be performed before creating a new MAP selection.

Spatial Filter
A Spatial Filter MAP Selection selects sets of objects based on their position on the artboard.

A Spatial Filter is based on a selection of features, the boundaries of which are used as a limit for the final selection.
The Filter Using drop-down list sets the selection of these features. Three options are available:
- 7 Existing MAP Selection: the delimiting features are taken from a saved MAP Selection. The MAP Selection
name is chosen in the Existing MAP Selection drop-down list below.
. - Art Selection: the current artboard selection is used (the selection must be performed before creating the
new Spatial Filter). The current selection is stored as part of the Spatial Filter for later use.
«  fwAttribute Filter: the delimiting features are selected based on new attribute filter parameters (see
Attribute Filter MAP Selection).

Once the delimiting features are specified, additional Options can be set.

By default, all objects contained within the delimiting features will be selected, regardless on which layer they
belong to. The Select From Layer(s) option can be applied to limit which layers will be included in the final selection.
To do so, click the |« button to open the Select Layers dialog box. Note that MAP Layers and Non MAP Layers are
available for selection.

The Spatial Relationship drop-down list offers two options for the selection method:
« Intersect and contain: objects that intersect or are contained within the delimiting features will be selected.
«  Fully contained: only objects that fully contained within the delimiting features will be selected.

The option Do not select art on the same layer as the 'Filter Using' art is meant to avoid art that is on the same layer as

a delimiting feature from being selected based on that feature. For example, if the Spatial Relationship is set to
Intersect and contain, all areas that share a boundary with an area that is a delimiting feature will be selected. With
this option, areas that are on the same layer as the delimiting feature will be excluded from the selection.
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EDIT A MAP SELECTION

To edit an existing MAP Selection, click the selection name in the MAP Selections panel and choose Edit MAP Selection
in the panel options menu. Alternatively, double-click the selection name.

The Edit MAP Selection dialog box allows to rename the MAP Selection and to edit the selection parameters. The dialog
box options depend on the MAP Selection type.

When editing an Attribute Filter, the selection layer and the expression may be edited as new.

When editing an Art Selection, three options are offered:
«  Show Selection: shows the stored Art Selection on the artboard.
«  Replace: if art is selected, replace the stored Art Selection with the current selection.
«  Add:ifartis selected, add the current selection to the stored Art Selection.

When editing a Spatial Filter, all the parameters may be changed. If the Filter Using option is set to an Art Selection,
the same edit options as above are available (Show Selection, Replace and Add).

DELETE A MAP SELECTION

Click one or more selection names in the MAP Selections panel, then click the delete button 4 or choose Delete
MAP Selection in the panel options menu.

Note: Use caution when deleting, some selections may be dependent on others.

MAKE SELECTIONS

When a MAP Selection is first created, the matching art is automatically selected. Saved MAP Selections can be
applied again at any time.

Note: MAP Selections based on Attribute Filters that are set to <use current layer> may become invalid when a
different layer is selected because its attribute schema may not match the expression.
There are four methods for applying a MAP Selection (available as buttons and menu items):

Apply as New Selection Clears the current selection and selects any art on the current layer that meets
the criteria of chosen selection filters

Add to Current Selection Adds any art on the current layer that satisfies chosen selection filters to the
current selection

Remove from Current Selection | Deselects any art on the current layer that is selected and satisfies chosen
selection filters

Get Subset of Current Selection | Deselects any art on the current layer that is selected and does not satisfy
chosen selection filters

Note: These selection combinations can themselves be saved as an Art Selection.
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Merge Layers

Object> MAPublisher > Merge Layers or MAP Toolbar ||

.
Merge Layers
Source - Choose the MAP View —— e Source: Attributes:
and Feature type to include . Ny
inth i Map View: @ eastusa - Source Destinaticn
in the merge operation Cance
Feature type: 4 [ eastusa_ares
[Rl AREA [R] AREA
(B eastusa_area STATE_NAME STATE_NAME - Attributes - Layer attributes
B westusz area STATE_FIPS STATE_FIPS are listed under Source and
SUB_REGION SUB_REGION Destination columns.
LayerList - Choose which MAP STATE_ABBR STATE_ABBR
Layers are included in the I POPULATION I POPULATION Click a Destination attribute
merge. Their attributes show B 5::;“’“ AREA to choose the appropriate
up in the list to the right. - - ne. This is where th I
P 9 STATE_NAME STATE_NAME ° e‘b ts SA” be et giou ce
STATE_FIPS STATE_FIPS attri l:“eWI e copied or
moved to.
SUB_REGION SUB_REGION
Select All Deselect Al - -
STATE_ABER STATE_ABBR
Destination - Enter a new —— - Destination: M POPULATION [T POPULATION
destination layer name. Layer: B Lowers
Copy or move the art to the _
- @) Copy art to destination layer
new destination layer.
() Move art to destination layer

FUNCTIONALITY

Merge Layers combines at least two MAP Layers of the same feature type into a new MAP layer based on its
attribute values. The art from the source layers can either be copied or completely moved to the new layer
(including its attributes).

This tool is particularly useful to combine layers that contains multiple objects. In the example above, eastusa
(eastern United States) and westusa (western United States) are being combined to form one layer containing both.
Merge Layers can be used as a preliminary to exporting layers to other GIS formats.

USING MERGE LAYERS

On the MAPublisher Toolbar, click the Merge Layers button |:-:¢| or click Object > MAPublisher > Merge Layers. This
opens the Merge Layers dialog box.

Source

In the Source section, choose a MAP View from the drop-down list to load its MAP layers. Click the Feature type
drop-down list to filter the layer list to only show a specific feature type (only layers of the same feature type can be
merged together). In the Layers list, click the check box of at least two layers to include them in the merge. When
chosen, layer attributes are shown in Attributes box.

Destination

In the Destination section, enter a new name in the Layer box. The new layer will be of the same feature type of the
source layers. The Copy art to destination layer or Move art to destination layer options are available to copy or move
the source art to the new layer.
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Attributes

The Attributes section displays the MAP layers chosen for merge. Click the arrow the arrow beside each MAP layer
to display its attributes.

The attributes are split into two columns: Source and Destination. The Source column shows the attributes for

all MAP layers. The Destination column shows where the Source attributes will be moved or copied to in the
destination MAP layer. To change the destination attribute, click it to reveal a drop-down list (which contains every
attribute from all chosen layers) and choose a new attribute. Alternatively, choose Drop to exclude it from the
destination MAP layer.

RESULTS OF MERGE LAYERS

The result of a merge when using at least two MAP layers is a destination MAP layer containing all artwork and
designated attributes. When the source layers have the exact same attribute schema (provided no changes to
destination attributes are made) the result in the destination MAP layer will be the same attribute schema.

Attributes:
Source Destination
Bt ) nen e
STATE_NAME STATE NAME =
STATE_FIPS STATE_FIPS Layer: | N owordt (Damasseieckod) R— |
SUB_REGION SUB_REGION BIARLA BISTATE MAME  [SISTATEFIPS  SISUBASGION  [SISTATEADGR  MIPOPULATION =
[S] STATE_ABBR STATE_ABBR 1 10757300 New Mexico n Min NM 18006 E
[ POPULATION  [I] POPULATION 1 BAAISETIO0N.. Texss 4 W5 Cen ™ MESLED
s [ westusa_area > 13 000334998 Oklaboma & WS Cen oK 345065
[R] AREA [R AREA |4 113712679000 Arizons (] M az 5130632
[S] STATE_NAME STATE_NAME |5 H2196.95%0000_ Karsss 2 WHCen =3 2,688 418
[S] STATE_FIPS STATE_FIPS 6 104101230999 Colorado ] Min 4] 430121
SUB_REGION SUB_REGION 17 157776308999 Caldoemia ] Pacific cA 33871648
[S] STATE_ABER STATE_ABER 18 B4ETL0GN0N. Uik 4 Min T 2133168
[ POPULATION [I] POPULATION 19 110850575000 Mevads n Whtm NV 1508257 -
49 areas sokected ]

When source layers have different attribute schemas, the designated attributes in the destination layer may be
empty for the opposing layer (unless the attribute was specifically set as a destination for the other layer).

Attributes:

Source Destination

4 [B canada_area

AREA Kl AREA
CODE [S] cope
NAME NAME
M POP1931 1M POP1%1 - e e s SOULNAE SOOI SUSMGN SOAEAeS  [HRALAION .
AME et R I L 1A% hes STATE S X 4 ATE A CRLATION  *
[RI POP9L SQMI K] POPL_SQMI [ Bt - sy
I POP2001 I POP2001 : oo b MonOucta whem ez
4 B westusa_area P -1 I wr i
AREA Rl AREA > - Wekogon 5 Packe . T
R ot oms P e s
STATE NAME ~ [S] STATE NAME Mantcta e sivew e ol
STATE_FIPS S] STATE_FPS T, B e s e :
SUBREGION  [S] SUB_REGION [, ma s 15,8
et Cohambia e auuma ot

STATE_ABER STATE_ABBR
[l POPULATION [ POPULATION

W ol RS

Note: After a merge of MAP layers containing sub-layers, the original sub-layer structure is maintained.
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Split Layer

Object> MAPublisher > Split Layer or MAP Toolbar

Split Layer

Source Layer - Indicates the currently selected layer Source layer: [B] Provinces_Ontario

Action:

. . . @ Copy art to destination layer
Action - Select the option to copy or move objects

from the source layer to the destination layer

@) Move art to destination layer

Split art that satisfies this expression - Choose this

Method:
Split art to new layer(s) by unique attribute value @ Splitart to new layer(s) by unique attribute value: methoq tocreate a pew layer fro_m objects
Choose this method to split the selected that satisfy the specified expression.
| ‘ ttine P ¢ atwbute: [ [I] #Opacty -
Al of the seected atriute column n || © Star ettt e soresa | xpesion-Enter oredit the expression directy
. . i into the entry field, or access:
the Attribute drop-down list. Expression: & &

S .+~ Expression Builder - see chapter 5.

i [ Expression Library - see chapter 5.
Destination - Enter the name of the new layer Destination: H
to be created (split art by expression) or New layer prefix: i Expression Validity - Indicates if the expression
enter a layer prefix (split by attribute value). Capy atirbute schema is « valid or @ invalid. If invalid, additional
Use Copy attribute schema option to copy the i information is reported.
attribute schema to the new layer =

FUNCTIONALITY

Split Layer divides a MAP Layer into new MAP layers based on its objects' attribute values. The new layers can either
contain a copy of the original objects or objects can be moved from the source layer.

The split can be done:
«  Based on an expression: when an object's attribute values satisfy the specified expression it is added to
a new layer.
« By unique attribute value: objects that have a same attribute value are grouped into a new layer. Hence
multiple layers are created (one per unique value).

This function is particularly useful to split a layer that contains a lot of objects. For example, a road layer with classes
such as street, highway and toll road could be split in three distinct layers. Split Layer can be used as a preliminary
to running MAPublisher LabelPro (to allow labelling of multiple classes with different styles, see chapter 17), or to
exporting layers to external GIS formats.

USING SPLIT LAYER

The MAP Layer to be split must first be selected in the MAP Views panel or in the Adobe Illustrator Layers panel,
then click the MAPublisher toolbar button or click Object > MAPublisher > Split Layer.

In the Action options, specify if the split art should be either copied or move to the new layer.

Note: If the source layer is locked, the only option is to copy to the new layers.
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When the Split art that satisfies this expression method is chosen, enter a valid expression in the Expression field, build an
expression using the Expression Builder &, or select an expression from the Expression Library |[El — see chapter 5
for more details (the expression validity icon ¥ will report if the expression entered is valid. Otherwise it will report
thatitis invalid (@ and include additional warning notes). A layer name for the new layer must be entered in the
Destination section.

When the Split art to new layer(s) by unique attribute value method is chosen, choose an attribute name from the Attribute
drop-down list. Each new layer created will contain only art that share the same attribute value. By default, the
name of these layers correspond to each single attribute value. In the Destination section, enter a prefix to be added
every layer name.

The Copy attribute schema option duplicates the attribute schema from the source layer to the destination layer.

RESULTS

When Split Layer is run, a message is displayed that indicates the number of layers that will be created. Click Cancel
to cancel the Split Layer command or click Create layers to continue.

MAPublisher

18 unique values found.

<+ Create 18 layers.
18 layers will be created to accomodate the unigue values found on the source kyer.

Depending on the method chosen, one or more new layers are created according to the splitting criteria. The new
layers are placed on the top of the layers hierarchy in the Adobe lllustrator Layers panel.

The new layers have the same feature type as the source MAP layer and are included in the same MAP View.

If the Copy attribute schema was enabled, the new layers contain the same attributes as the source layer.
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Working With
Images

MAPublisher contains tools for working with georeferenced
raster images such as aerial photography and satellite imagery.

The Register Image function accurately registers raster images
with georeferencing information to vector map data.

Export raster images to various georeferenced formats
through the MAP Views panel.

Georeferencing information for raster images are usually
stored in a separate text file where the image and its
associated reference file have the same file name but a
different file extension.

The reference file formats that can be read by Register Image
or written to by Export Image are:

World (*.tfw)

Image Report (*.irp)

Maplinfo TAB (*.tab)

Blue Marble Reference (*.rsf)

ER Mapper ERS (*.ers)

ListGeo (*.Igo)

GeoTIFF (*.tif) (contains both the image and reference data)

Topics covered in this section:

Register Image
Export Image
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Object > MAPublisher> Register Inage or MAP Toolbar -ng

Register Image

Register Image

Register Image

Upper Left Placement:

OK

Tie Points' - Change the tie point
of the image by clicking another
corner of the graphic

Pixel Size' - Specify the size of each
pixel in the selected map unit
(updates the Effective Map Size).

Register Image supports non
square pixels.

Cancel

o} X: 488415.857391819 m
|
| i 5460814.46475946 m
|

Load File....

Image Size: 1260 by 907 pixels

HeiPixel= [ X: 3.7032021174 m
¥: 3.7032030604 m

Constrain proportions

Constrain Proportions - Check this
option to maintain X and Y pixel
proportions (in map units)

Effective Map Size X/Y! - Specify the

Pl XYt - Specify the coordinates
(in map units) of the selected corner of
the raster image

Load File - Choose a file containing

the georeference information for the
selected raster image. The information
from the file will be inserted into the
appropriate fields.

Effective Map Size:

X and Y size of the image in map
units (updates the Pixel Size)

r X: 4666.03466796875 m
¥: 3358.80517578125 m

Rotation: 0.000

Rotation - Displays the amount of
rotation of an image

* Editing these options is
not required when using

e Fille Ce System:

MADS3 { UTM zane 10N Meser -7

the Load File function.

Undefined Layer
This dialog box appears if the image to
register is not placed on a MAP Layer

Create or Add to existing MAP View
Choose to create a new MAP View

Undefined Layer - Layer 5

Please specify the destination MAPView for the image layer

@ Create new MAP View

or choose an existing one from
the drop-down list

Feature type - Choose Image

Cancel

©) Add to existing MAP View: | @ 10m-admin-0-countries

[ m mage -]

feature type

ature type:

Advanced:

[] Base attribute schema on: | [IL Rivers
Check this aption to inhesit the attribute stucture from the specified layer.

FUNCTIONALITY

Refi File Coordinate System - Indicates
the coordinate system of the loaded file
(for GeoTIFF images). Set to Unknown
by default.

Units - Select a unit to use for the
specification of georeferencing
information. The default selection is the
current map unit.

Register Image applies geospatial properties to raster images imported using the Adobe lllustrator Place command.
Register Image uses a coordinate system and coordinates—entered manually or loaded from a reference file—
to properly georeference and scale an image. If the coordinate system of an image matches one of existing
vector data, the image can be scaled and rotated to fit the vector data. If no matching vector data is found in the
document, a new MAP view can be created to store the cartographic information of the image to allow for data
digitization with accurate positioning.

Note:

a product like Avenza Geographic Imager to transform images.
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PREREQUISITES

To use Register Image, the geospatial properties of the raster image must be known. Some raster image formats
store the relationship between source image coordinates (pixel location) and real-world reference coordinates

in an associated reference file but do not save the coordinate system information (e.g. world file *.tfw). The
commonly used GeoTIFF format is embedded with geographic information such as position and coordinate system.
Depending on the image format, check the position and coordinate system of imagery with the data provider
before attempting to use this tool.

To import a raster image into a document, select a layer from the Layers panel (Image MAP Layer or not) and
choose the Adobe Illustrator Place command (File > Place). The image is placed on the artboard, but is not spatially
referenced at this point—it needs to be registered.

Notes: When placing an image, do not use the Convert Layers to Objects option. It will treat images that may have
multiple layers as grouped objects and will prevent it from being registered properly.

Using an embedded, unflattened image with an existing transparency may result in incorrect registration.

USING REGISTER IMAGE

With an image selected, choose Object > MAPublisher > Register Image or click the Register Image button "'*{B on
the MAPublisher toolbar.

If the image is placed on a MAP Layer, the Register Image automatically registers the image using the coordinate
system of the MAP View containing that MAP Layer.

If the raster image was not imported to a MAP Layer, the Undefined Layer dialog box will appear. Choose either to
create a new MAP View based on the image or choose to add the image to an existing MAP View. In either case, the
Image feature type is the only one available for rasters. It is recommended to use the Image feature type for image
registration and for better layer management and workflow.

When creating a new MAP View, the anchor point and scale are derived from the registration information
(placement and image size). In the case of GeoTIFF images, the MAP View coordinate system is automatically read
from the image header—for other image formats, the coordinate system has to be specified manually in the MAP
View Editor after the registration process (see chapter 4 for more information on Specify coordinate system).

Registration using Reference File

To register an image using a reference file, click the Load File button and navigate to the folder containing the file.
The reference file may have the same name as the image, but may have a different extension (.irp, .tfw, .tab, .rsf, .ers
or.Igo). In the case of the GeoTIFF format, the image file itself contains both the image and reference data and the
needs to be chosen to retrieve the georeferencing information.

The values contained in this reference file are automatically entered into the image parameters. If the file is in
GeoTIFF format, the image coordinate system is read and displayed under Reference File Coordinate System—for other
file formats, the coordinate system is left as unknown.

Chapter 12: Working With Images | 233

Register Image



Manual Registration

To manually enter image parameters, one of the following combinations must be available in page units or map units:
- The XandY coordinates of one corner of the image and the X and Y Pixel Size.
«  The XandY coordinates of one corner of the image and the X and Y size of the image.

First choose the units to use for entering parameters by making a selection from the Units drop-down list. Then, click
the appropriate corner of the graphic to indicate the image placement point and enter the X and Y coordinates for
this location in the adjacent fields. Next set either the Pixel Size or Effective Map Size. The Pixel Size is the value of a single
pixel in the units set. The Effective Map Size is the X and Y size of the whole image in the units set. Setting either
option will update the other accordingly.

Note: MAPublisher Register Image supports the registration of images having non-square pixels.

RESULTS

When registering GeoTIFF images, a warning message will be displayed if the coordinate system of the image
does not match the selected MAP View's coordinate system. When registering images not in GeoTIFF format while
creating a new MAP View, the coordinate system of the MAP View has to be specified in the MAP View Editor to
finalize the georeferencing.

Provided that the coordinate system, placement and size of the raster image are correct, the image will be scaled
and registered. When matching vector data is available, the image will fit to the artwork. The MAP Location Tool can
be used to check the positions (see chapter 4).

Notes: Raster images cannot be transformed into another coordinate system. If the vector data is transformed
through the MAP View Editor Perform Coordinate System Transformation function after the image has been
register, the image will have to be transformed externally (with Avenza Geographic Imager for example) and
registered again in MAPublisher.

Registered images will be scaled and rotated together with the vector data, but not automatically. After

the vector data has been scaled or rotated using the MAP View Editor, Register Image must be used to apply the
image referencing information. In the case of a manual registration, it is recommended to use the Export
Image function before applying the changes to the vector data (see next paragraph). This way, registering the
image again is only a matter of loading a reference file.

SUPPORTED GEOREFERENCED IMAGE REFERENCE FORMATS

World File (*.tfw, *.tifw, *.wld, *.eww, *.jgw, *.jpw, *.pgw, *.sdw, *.eww, *.blw, *.dmw)

World files contain the affine relationship between source image coordinates (pixel locations) and real-world
reference coordinates (lat/long or other real-world coordinate units). World files simply contain a computed
relationship between source image coordinates and reference coordinates and not the complete reference point
information. World files do not support storing coordinate system information.

IRP Image Report File (*.irp)
IRP Image Report files are ASCII report files indicating the coordinates of the four corners of the raster file and the
pixel size in ground units to allow for georeferencing of the image in other image processing, CAD, or GIS programs.
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Mapinfo TAB File (*.tab)

Maplinfo Table file formats save the complete reference point list information such that it can be loaded again in the
future. Mapinfo TAB files support storing coordinate system information.

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area Hotine Oblique Mercator Hotine Oblique Mercator 1pt
Azimuthal Equidistant Lambert Azimuthal Equal Area* Polyconic

Cylindrical Equal Area* Lambert Conic Conformal Robinson*

Eckert IV* Mercator* Sinusoidal*

Eckert VI* Miller Cylindrical* Swiss Oblique Mercator
Equidistant Conic* Mollweide* Stereographic Transverse Mercator
Gall Stereographic* New Zealand Map Grid

* Coordinate Systems using this projection will not be stored when saving the reference file.

Blue Marble Reference File (*.rsf)

The Blue Marble Reference Settings File saves the complete reference point list information such that it can be
loaded again in the future. Within a Blue Marble Reference File, the first line contains the version of the file format
(not to be confused with the version of the software) and the total number of points in the file. The remaining lines
contain, in each line, the point ID, the x (row) pixel, the y (column) pixel, the z (elevation) value which is usually 0.00,
followed by the ground coordinates expressed as Latitude or Northing (Y), Longitude or Easting (X) and Elevation
(Z). The last value indicates whether the point described on that line is included in the solution, 0 = not included
and 1 =included. Blue Marble Reference files support storing coordinate system information (all are supported).

ER Mapper File (*.ers)

The ER Mapper header file is an ASClI file describing the raster data in the data file. The entire header file holds
information about the data source and is contained in the DatasetHeader block. There are two compulsory
sub-blocks, the CoordinateSpace block (to define the coordinate space and location) and the Rasterinfo block (to
define the characteristics of the data in the accompanying data file). The Rasterinfo block my contain a number of
optional sub-blocks. To completely define coordinate information in an ER Mapper header file you need to include
the following data: datum, projection, coordinate type, units, X and Y dimensions for cell size, registration cell X and
Y values, registration cell coordinates, and possibly null cell value. Coordinate information is frequently, but not
always, given for the upper left corner of an image. This would be registration cell X and Y values of 0.0 and 0.0.

For most projections registration coordinates are entered as eastings and northings, the coordinate type will be
"EN', and units will be meters (or occasionally feet). If you are using latitude and longitude the projection is Geodetic,
coordinate type will be "LL", and the X and Y dimensions for the cell size will be in decimal degrees.

ER Mapper files support storing a limited number of pre-defined coordinate systems. Check the coordinate system
details to ensure the ER Mapper identifier exists as the issuer for the coordinate system to be saved. The file will still
be exported however the coordinate system will not be saved with the reference file.

Note: ER Mapper reference files do not support rotated images. When attempting to export a reference file with a
rotated image ER Mapper will not be listed.
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ListGeo file (*.lgo)

A ListGeo files are text files containing the GeoTIFF metadata information (or tags), which can then be read, and
may also be used as input to other programs.

GeoTIFF File (*.tif, *.tiff)

Tagged Image File Format (TIFF or TIF) is a common raster graphic file format and one of the most common
geospatial image formats you are likely to come across. Many raster geographic images from GIS systems are stored
in this format. A GeoTIFF is a TIFF file with embedded geographic information such as position and scale in world
coordinates, coordinate system or an explicit list of ground control points.

Note: The only way to differentiate a regular TIFF image from a referenced GeoTIFF image is to open it in a spatial
imaging software application (such as Avenza Geographic Imager).

Unlike the other geographically referenced image formats discussed in this section, GeoTIFFs do not require a
separate reference file. When registering a GeoTIFF image in MAPublisher, the same file name must be selected in the
Load File dialog box—the required georeference information is contained in the file header.

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area Lambert Azimuthal Equal Area Polar Stereographic
Cassini-Soldner - Cassini Lambert Conic Conformal (1SP) Polyconic
Cylindrical Equal Area Lambert Conic Conformal (2SP) Robinson
Equidistant Conic Lambert Cylindrical Equal Area Sinusoidal
Equidistant Cylindrical Mercator Stereographic
Equirectangular Miller Cylindrical Transverse Mercator
Gnomonic New Zealand Map Grid Transverse Mercator (South Oriented)
Hotine Oblique Mercator Oblique Mercator VanDerGrinten
Laborde Oblique Mercator Oblique Stereographic
Orthographic
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Export Image

MAP Views panel options menu > Export Image

Export Image
I : Embedded P
s m‘je " moeaee Save As... % Save As - Choose a destination name
Image colour model: RGE " .
and directory for the exported image
Georeference type - Select the output Geareference type: [World file (TFW) - ]
) forrT\at for the georefergncing [ Justexport reference fie
information for the selected image
Format: (e -] Format - Choose from TIFF, PNG or
JPEG as the export format

FUNCTIONALITY

MAPublisher has the ability to export placed raster files as georeferenced images for use in other programs

or for archival purposes. This can be useful in a number of ways. For example, when working with an image for
which there is no georeferencing file, use the MAPublisher Export Image function to create a georeferenced image
file based on the coordinate system of the MAP View. If the MAP View contains georeferencing information, Export
Image can be used to save a raster layer to a georeferenced image format. It is also possible to convert the vector
artwork to a georeferenced raster image. MAPublisher can export selected images as TIFF, PNG or JPG with a choice
of the reference file formats or as a GeoTIFF (see the previous page).

USING EXPORT IMAGE

With an image selected, go to the MAP Views panel options menu > Export Image.

In the Export Image dialog box, the Georeference type drop-down list has seven available reference file formats: World
File (TFW), Image Report file (IRP), Mapinfo TAB file (TAB), Blue Marble Reference file (RSF), ER Mapper file (ERS), ListGeo file (LGO) and
GeoTIFF. When exporting to a TIFF, PNG or JPG file, any of reference type can be used. When exporting to a GeoTIFF,
only a single file is produced since both the image and the georeference information are included.

By default, the JPEG image quality setting is 75, the PNG compression level setting is 6, and TIFF has no
compression.

Note: Image MAP layers are not included when an entire MAP View is exported to a spatial format (e.g. shapefile).

RESULTS

When all of the export options have been set, click the Save As button. Specify a name for the TIF file and the folder
location where it will be saved. The reference file will have the same file name as the TIF and will be saved to the
same location.

This image file can be subsequently used in imagery applications, such as Avenza Geographic Imager for Adobe
Photoshop, or in other Adobe lllustrator documents using MAPublisher.

Notes: Exporting a linked image in CMYK color mode or an embedded image with an existing transparency may
create incorrect color results. For the former situation, an image must either be set to a different color mode or
embedded. For the latter, the transparency must be removed from the source file.

If a MAP View is rotated, the exported image will not store any rotation parameter (it will be automatically
rectified—oriented north up).
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Grids and
Indexes

MAPublisher contains tools to easily create map grids and
map indexes. Grids can be created for reference purposes,
or to follow designated lines such as latitude and longitude
(graticule), with optional labeling (cells or axis).

A grid or a graticule can be used as a base to generate

index files. MAPublisher outputs a text file containing grid
indexes of text or map object locations that can contain map
attribute information.

Topics covered in this section:

Grid and Graticules
Make Index
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Grids & Graticules

Object > MAPublisher > Grids & Graticules or MAP Toolbar|E|
FUNCTIONALITY

The Grids & Graticules tool generates a grid or graticule based on a coordinate system (either of the current MAP View
or a chosen one). Each type of grid or graticule has numerous options for customizing grid lines, line labels, and cell
references. Three types of grids and graticules are available:

Index Grid | Divide the map into a grid of a specified number of rows and columns.

Graticules | Draw lines of latitude and longitude of a specified interval aligned over a
specified location.

Measured Grid | Lay out a series of grid squares of a specified linear unit size, aligned over a
specified location.

Once a grid or graticule is created, it can be resized dynamically using the corners of its bounding box anchors. To
edit it, select it and click the Grids and Graticules button on the MAPublisher Toolbar.

PREREQUISITES

Grids and graticules must be created on 'ﬁ_| MAP Legend layers. A new legend layer will be created automatically if
one is not present in the document. In the case that there are multiple legend layers in a MAP View (and neither are
selected), you will be prompted to choose one.

By default, Grids & Graticules uses Arial 12 pt black or the Normal Character Style as the style for line labels. Custom
character styles should be created (Window > Type > Character Styles) before using Grids & Graticules. Alternatively,
use the Custom mode to change text appearances directly in the dialog box.

By default, Grids & Graticules uses a default grid line style (black, 1 pt stroke width). Custom graphic styles should
be created before (Window > Graphic Styles) before using Grids & Graticules. Alternatively, use the Custom mode to
choose the style options directly in the dialog box.

The MAP View must have a coordinate system assigned in order to plot a grid. Graticules and Index Grids can be
generated for any coordinate system. Measured Grids cannot be generated for geodetic coordinate systems.
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USING GRIDS AND GRATICULES

Click the Grids & Graticules button on the MAPuinsherTooIbar|E| or choose main menu Object > MAPublisher >

Grids & Graticules.

In the Grids & Graticules dialog box, the left hand panel lists the grid collection (grids and graticules created for a

single object). Multiple grids can be created and edited in one collection. Three types of grids are available: an index
grid, a graticule, and a measured grid (if the coordinate system is not geodetic). An option to load grid settings from

an existing configuration file is available. When a grid or graticule is added or chosen, options will appear to the

right of the list. Grid ling, line label, and cell reference options will differ depending on the grid or graticule chosen.

Girids B Gratacules.
) 53] ‘Gred Dinsensions: C =)
& By rumber of columnsirows: 1
; Coeme: 19 :
E3 i Rordes Ao W Provim .|
Linst Labels | :
Cell References s el O S
. . & Gepticules Gnd e —_— —
) Grid («_ﬂlettlon —— G L Create Grid - Click Add
Colletion o grids and R button and choose

graticules for one Grids Cell References a grid type to create.

Graticules object. Use the When no grids have

toé) buttons tgdachiJ, co;:]y, o Eratic..ulej : e i been created, this is

W Deww bt of latitude and longtude of & specdied ntenval aligns . .
andremove grids Use the oyt | shown in the main
Grids & Graticules
change the object draw dialog box.
order. Double-click grid
name to rename it.
# Load From F " .
| Load gad settings i el file Load From File - Load a saved grid
from a configuration file
Coel |
Harne Cate modified  Type Size

To save a grid (or a collection of grids) to configuration files, click the Save
Settings button, then choose a folder to store the grids.

Two configuration files are created per grid: grid settings and label settings.
Grid settings configuration files contain information for all related grid
options (e.g. ticks, intervals, offsets, borders). Label settings configuration
files contain information for all related label options (e.g. axis labels,
rotations, fonts, styles). Label settings are saved with _labelData appended
to the file name.

matiules
Gridd_tanellTata.cty

Graticules Gred.clg

Measured Grid.cfg Measured

Grid_lsbelData.cfg

Index Grdicly Indlex

Grid_labeiliata, ety

When loading settings from a file, choosing the grid setting configuration file will automatically load the label
setting configuration file with the same name. If only the label setting configuration file is chosen, you will be

prompted to choose the accompanying grid

Note:

Graphic styles, character styles, fonts, and swatches that are used on one system may not be available on
another system. A warning message will appear in the even that any of these are missing.

Chapter 13: Grids and Indexes

Grids & Graticules

241



Index Grid

The Index Grid is a grid that is based on a specified number of columns/rows or cell size in page units. By default, the page
units are specified in MAPublisher Preferences (see Chapter 1). The By cell size in page units option may result in
partial cells being created. When this option is chosen, the Partial cells get labeled option is enabled (in order to
include them in the indexing process) in Cell References. The Minimum size of cells setting is used to set the minimum
size of the partial cells to be labeled—cells that are smaller than this minimum will not get labeled and will not be

used for indexing.

By default, a grid is created for the entire extent of the MAP View. To limit the grid to only a certain extent, click
the Set Bounds button to define grid bounds. Use artboard corners, coordinates, or MAP Locations to define grid

boundaries.

See the following pages for detail on how to adjust and style grid lines, grid border, line labels and cell references.

L 3 |
] By number of columns/rows
He— ~ Select this option to create a

= | grid with the specified number

of rows and columns

o——— By cell size in page units

Select this option to specify
the cell size in page unit

(as specified in the Adobe
Illustrator Document Setup)

Geids & Gratscules
i Grid Collection: } d Aurd Dimaenucny:
& By number of columnsirows:
A # Index Grd
Giid Lines Couwet 10
b o Giid Bordes ows: 1 rpriem
Darder Interval
Line Labels By ok wite i page it e Tt
Cell References
arad Baunds:
et Bounds..... |
Specify Bounds.
Corne
' X -753588.980003 m
?
. . o T 1263419445522 m [
Corner and Opposite Corner - Specify onpasite
coordinates for the grid bounds. pposite torner:
Click the MAP Locations button o X 4579230.561894 m ?
to use defined page or world & ¥ 2741915004086 m
positions or artboard corners. Artboard 1 +
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Grid Bounds - Set the grid
bounds to MAP Locations or
artboard corners. See below.
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MAP Locations... o
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Upper left
Upper right
Lowver left

Lower right




Grid Lines

Draw Grid Lines - Enabled by default. Draw
solid lines or intercepts (where grid lines
intersect). Click the style link (shows
stroke) to edit line appearance.

Grid Border

Draw Border - Enabled by default. Draws
a solid border. Optionally, choose to
increase offset from grid cells. Click the
style link to edit line appearance.

Draw Ticks Along Border - Draws tick marks
along the grid border. Choose to
increase offset from center of tick and
set orientation away/toward map face
or prime meridian/equator. Click the
style link to edit line appearance.

Border Intervals

Draw Border Intervals - Draws border
intervals around the grid bounds. Use
the Minor and Major Intervals settings
to set a size (height). The Subdivide
Major Intervals option draws lines in the
subdivision intervals and can be set to
be drawn at even or odd intervals. Click
the style link to edit line appearance.

Line Labels

Coordinate Values Along Grid/Graticule Border
Click the Easting and Northing style link
to edit label appearance

Label Orientation - Settings that affect all,
east/west, north/south, or individual
labels. The West/East/North/South
settings are enabled based on
drop-down option. Click the style link to
edit its appearance.

Corner Labels - Click the style links to edit
the appearance, offset, rotation, and
format of corner labels

Remove overlapping labels

Remove overlapping labels from other
grids listed lower in the Grid Collection

Cell References

Place labels off cell by - Select a label offset
from the grid bounds

Border style- Affects border reference
labels. Click style link to edit appearance

Centerstyle - Affects center cell labels.
Click link to edit text appearance

Alpha/Numeric on left/right, top/bottom
Choose to swap the alpha and numeric
along the left/right and the top/bottom

Row/Column order - Chose descending or
ascending row/column label order
Advanced - Custom start alpha and

numeric characters, reference separator,
and reference label order

Grid Line Options:
4] raw Grid Lines
 Sokdine
Interoepts wih se:
| FEI

Border Uptions:

4 Draw border:
Offset from g bourds: 0000w |3
I Lot Black

Dwvaw Ticks Along Dorder:

Draw Border Intervals:
style: [l LotBlack
Miter corners

Minor Intervals:

Division size: 10.00 px k2
Major Intervals:
Division size: 10,00 px -

Subdivide Major Intervals:

Intercepts ———— + +

Ticks along border——e

Tick oflset—l
Subdivide major
Border between Major intervals (top)
and minor interval border  (odd interval)

Miter corner

Border ——¢

Subdivide major —4
intervals (left)
(odd interval)

Minor intervals

Top: [Oddintervals ] Bottom: [Odd intervals )
Left: [Oddintervals ~ | Right: [Odd intervals -]
Line Labehog: -
X H
1 Label placement control - Click the labels to
Corner label

Coorduate Vakses Aloag Grd [Gratiosle Border:

S crmntation on o borders. )

West: Offeet: 0o, Rotitor

Format: @ deomals, b formatang

T¥ine does nat bt bounds, label: fione
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Shile: I avisd ek, 12,0004
¥ label orientaton: Offsct: O ox. Botation: 0
¥lasbal orientation: Offeet: O 0w, Botaten: 0
Format: Qeomals, Mo frmatirg

Flamoen cverpping labele

Cell Aeference Labeling:

7] Use eastng styie

toggle between X, Y, Both, or Disabled

-— Y

North label

& e———90° rotation

Corner labels

72127266 1 ::e——Offset

West label  =>:0s57c0

Format
(decimal places)

Cell References:
Pl Lok el by 0:009x
Sorder stvies I o Black, 12.00 00
Carter utyle: I ol ek, 12,0000
Redereace Grder:
§ Mgha on leftjright, ruseric lapbation

Murmic on leftight, sisha on lopjbatiom
Descendng
Column crder: | Ascending

B order:

4| wartial Colis Get Labeled:
Mo sze of cels 10% |2

Cell Ref Labels - Click the border and center
labels to toggle between enabled and disabled

Column order
(descending) Border label
10 % o—Offset
A A10 A9
Row order —
(ascending)
- B B10 B9e— (Center label
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Graticules

The Graticules option places grid lines at specific intervals of latitude and longitude (in degrees). Specify the interval
for lines of latitude and longitude and, as required, a latitude and longitude value to pass through (in degrees). Use
the vertices slider to increase or decrease the number of vertices used in the graticules (use a higher number if the
graticules are highly curved due to the current projection). Grid bounds limit the extent of the grid. Use artboard
corners, coordinates, or MAP Locations to define grid boundaries.

See the following pages for detail on how to adjust and style grid lines, grid border, line labels and cell references.

Grids & Graticules Latitude Interval - Specify the interval

! Grid Collectice: D) [ (@) oomwde: = for each line of latitude
A | & Geavicutes Gid it g : cancel | . .
- Gand Lires [ —— & e———————— Pass through latitude - The line of

Vertices - Use the sl s AP . Pt latitude that must be included (any
. ertices - Use i e slider e ;"‘:'" + o [Bavesernce., great circle). Must be in decimal

o increase or decrease Cell eterences degrees.
the number of nodes to ol ¢
create the graticule line Drsplay Optices: ) Longitude Interval - Specify the

(use more for curved) Vertces: Fewer 4 Hore interval for each line of longitude

c: i Pass through longitude - The line of

longitude that must be included
(any meridian). Must be in decimal
degrees.

Grid Bounds - Set the grid
bounds to MAP Locations or
artboard corners.

Grid Lines  cumeopions

7 Draw Grd Lines.

Draw Grid Lines - Enabled by default. Draw & Sole Ine
solid lines or intercepts (where grid lines nterceps ik
intersect). Click the style link (shows B Lo Solid grid lines
stroke) to edit line appearance. i
Show Ticks Along Grid Lines - Draw tick S = Tick marks
marks along grid lines. Choose to (Away from prime

place ticks at specific intervals, specific
pass through, tick length, offset and
orientation. Enable Tick follows line
direction to allow ticks to have the same
angle as grid lines where it meets at

the border. Enable the Use grid style
option and click the style link to edit line
appearance (shows stroke).

meridian and equator)
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Grid Border

Draw Border - Enabled by default. Draws
a solid border. Optionally, choose to
increase offset from grid cells. Click the
style link to edit line appearance.

Draw Ticks Along Border - Draws tick marks
along the grid border. Choose to
increase offset from center of tick and
set orientation away/toward map face
or central meridian/equator. Tick follows
line direction angles ticks at border. Click
the style link to edit line appearance.

Border Intervals

Draw Border Intervals - Draws border
intervals around the grid bounds. Use
the Minor and Major Intervals settings
to set a size (length), pass through, and
division size (height).

The Subdivide Major Intervals option
draws lines in the major intervals and
can be set to be drawn at even or odd
intervals. Click the style link to edit line
appearance.

Line Labels

Coordinate Values Along Grid/Graticule Border
Click the Longitude and Latitude style
links to edit label appearance

Label Orientation - Settings that affect all,
east/west, north/south, or individual
labels. The West/East/North/South
settings are enabled based on
drop-down option. Click the style link to
edit its appearance.

Corner Labels - Click the style links to edit
the appearance of corner labels

Line Tick Labels - These settings only
enabled when "Show ticks along option
grid lines" is checked in Grid Line
Options section. Click the style links to
edit the appearance of line tick labels.

Remove overlapping labels
Remove any labels that overlap the
labels set here

Cell References

Place labels off cell by - Select a label offset
from the grid bounds

Border style- Affects border reference
labels. Click style link to edit appearance

Center style - Affects center cell labels.
Click link to edit text appearance

Alpha/Numeric on left/right, top/bottom
Choose to swap the alpha and numeric
axis labels along the left/right and the
top/bottom

Don'tlabel - Click check boxes to not label
first/last row or column

Advanced - Custom start alpha and

numeric characters, reference separator,
and reference label order
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Measured Grids

The Measured Grid option creates a grid based on a grid cell size specified in map units, when the current MAP View
is in a projected coordinate system. The cell size is specified in the Width and Height boxes (the map units can be
specified in the Units drop-down list). Measured grids may contain partial cells. The pass through can be specified
by entering an X, Y position (Grid passes through point) or choosing an alignment position relative to the page extent
(Preset origin). Grid bounds limit the extent of the grid. Use artboard corners, coordinates, or MAP Locations to define

grid boundaries.

See the following pages for detail on how to adjust and style grid lines, grid border, line labels and cell references.

Gridls & Gratcules

Cell Size - Specify the width and
height of each cell in the grid. The

Units drop-down provides many
units of measurements to use.

Grid Bounds - Set the grid
bounds to MAP Locations or
artboard corners.

e Q) [ @) o= o = |
7 e 1020020 | e e
e e 1t Gid Lines Height: 1000000 - = =
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Grid Lines  suteootonc
| Dwaw Grid Lines
Draw Grid Lines - Enabled by default. Draw B aive
solid lines or intercepts (where grid lines wrcaots wih s 1500 o
intersect). Click the style link (shows B iomes
stroke) to edit line appearance. Tick marks —

Shaw Ticks Along Grid Lines:

Show Ticks Along Grid Lines - Draw tick
marks along grid lines. Choose to place
ticks at specific intervals, specify a

pass through, tick length, offset and

orientation. Enable Tick follows line
direction to allow ticks to have the same
angle as grid lines where it meets at

the border. Enable the Use grid style

option and click the style link to edit line
appearance (shows stroke).
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Grid Border

Draw Border - Enabled by default. Draws
a solid border. Optionally, choose to
increase offset from grid cells. Click the
style link to edit line appearance.

Draw Ticks Along Border - Draws tick marks
along the grid border. Choose to
increase offset from center of tick and
set orientation away/toward map face
or central meridian/equator. Click the
style link to edit line appearance.

Border Interval

Draw Border Intervals - Draws border
intervals around the grid bounds. Use
the Minor and Major Intervals settings
to set a size (length), pass through, and
division size (height).

The Subdivide Major Intervals option
draws lines in the major intervals and
can be set to be drawn at even or odd
intervals. Click the style link to edit line
appearance.

Line Labels

Coordinate Values Along Grid/Graticule Border
Click the Easting and Northing style link
to edit label appearance

Label Orientation - Settings that affect all,
east/west, north/south, or individual
labels. The East/West/North/South
settings are enabled based on
drop-down option. Click the style links
to edit its appearance and formatting.

Corner Labels - Click the style links to edit
the appearance of corner labels

Line Tick Labels - These settings only
enabled when "Show ticks along option
grid lines" is checked in Grid Line
Options section. Click the style links to
edit the appearance of line tick labels.

Remove overlapping labels
Remove any labels that overlap the
labels set here

Cell References

Place labels off cell by - Select a label offset
from the grid bounds

Center Style- Click the style link to edit the
text appearance

Axes Style - Click the style link to edit the
text appearance

Alpha/Numeric on left/right, top/bottom
Choose to swap the alpha and numeric
axis labels along the left/right and the
top/bottom

Partial cells get labeled - Check this option
to label cells that do not reach its full
size (in page units)

Minimum size of cells - the minimum size of
partial cells before being labeled

Barder Optis:
4| Uraw Barder:
Offent from grid bounds: Q.00 px |7
W Lot

v Tickes Along Border:

7| raw Border Intervals:
strie: I Lot ek

] Miner cormers

Mamar Inleruab:

Interval size:  40000,000

Pags Srough:  0.000 nm

Dhmensre: 1000

Major Intervals:
Interval szes  200000,000
Past Srough:  0.000 “m
Dnvision sive= 10,00 px
| Subcvde Mar Intervals:
Top: | Ocd e vl
eft: [ mervels. = mght:

Line Labeling:

Ticks along border

Tick offset—l

Subdivide major
intervals (top)

(odd interval) Border

Miter corner—

Subdivide major —|
intervals (left)

HHHET

A
[T TT1

(odd interval)
Major interval size—¢

Minor interval size—¢

= | Bottom: [Odd mteeak -

| ot -]

Xlabel

Eastng stie: .Ammuﬁon:
st eryie: [l e vinck

¥ label orientation: O¥Feet 0 oo, wm,a

Fomat:

Line Tick Labebs:

Style: I s_-u.m._l.i.me:

orzentl Gnentaton: 9 o)

Verncal srentabon: Qffct: GE‘ Rotaten: 0, Algrment: Center
Format: 0 decrale, o formatang

Femove overlapping labels

Coll Reterence Labeling:

Cell References:
Place labels off ool by: 0.00 pxc
I oalBack. 120008

W acaiites, 000t

Berder shvie:
Center style:
Reference Orter:
# Kioha on Ieftiricht, rumeric tno/oetine

Pumeric on leftjkight, sipha on topjbattom
Cokorn orcder: | Agcamraing

Blow erder:

7| Partial Cells Get Labeled:
Minwmum sz of el 10% 5

‘—(omer label

o———Ylabel

Tick label

] e esstng strie

Corner labels

2741 915mN]

West label

240 0000m N L1 1 1

Line tick label ————————= 2100000

HEHE

- Minor interval division size
Major interval division size

i Label placement control - Click the labels to
i toggle between X, Y, Both, or Disabled.

North label, format:
Full value with units
and Direction
=e———90° rotation
o—Offset

75,3689mA

Column order
(ascendinf)

1

Border label

2, Offset

A
Row order —

A1 A2

(ascending)

B1 B2 — (enter label

Advanced - Custom start alpha and

numeric characters,

reference separator,

and reference label order

Chapter 13: Grids and Indexes

247

Grids & Graticules



Grid Line and Border Styles

Click the grid line and grid border style links to open the Edit Appearance dialog box. The are two modes to edit the
appearance of grid lines: Custom and Graphic Style.

Custom mode

Switch Mode - Click to switch to bl Ao oncs Stroke Weight - Set the stroke width of
Graphic Style mode — ks H® ol = LEII]lpt s [I] the grid/border line. 1.00 pt is default.
Stroke - Choose a colour from the Stroke Opacity - Set the transparency of
drop-down list. Alternatively, click the [LCEIJ the stroke or fill. 100% is solid.
colour chip to pick a custom colour.
Graphic Style mode
Edit Appearance
. ) . Style - Choose a graphic style from the
Switch Mode - Click to switch to — Style: Graphic Style 1 'J [ oK ] G:'aphic Style pagnelp i’
Custom mode ’
Cancel

Line Labeling

The Coordinate Values along Grid/Graticule Border options affect the coordinate labels of the grids and graticules (X,Y

for indexed and measured grids; Lat, Lng for graticules). In the label placement control, click a label indicator to
change its status: disabled, X, Y or X&Y for grids; disabled, Lat, Lng, Both for graticules. When the mouse hovers over label
indicators or label options, green highlight appears to indicate its relation.

Click the label style links to open the Edit Text Appearance dialog box. The are two modes to edit the appearance
of grid labels: Custom and Character Style. Character styles must be defined in the Adobe Illustrator Character Style
panel before use in this dialog box.

Edit Text Appearance
Switch Mode - Click to switch to — (B Font: [ anal < | 4T 12o0pt £
Character Style mode [Black B Font - Set the font family, font style, and
ﬂ} font size with these settings.
. Stroke: - = | 1.00
Stroke/Fill - Choose a colour from the oke: | ] ore] 1A =[ro00t
drop-down lists. Alternatively, click the Fill: [ |
colour chip to pick a custom colour. [7] Underline
[ strikethrough
Advanced:
Graphic Style - Choose a graphic style —-—eGraphic style: [Z [Mone] -
from the Graphic Style panel. Note: If a Graphic Style is selected, its stroke & fil are interleaved with the
specified font stroke & il as follows:
1. Graphic Style stroke
2. Font stroke
3. Font fil
4. Graphic Style fil
L

Click label orientation links to open the Label Orientation dialog box. Label offset and orientation can affect all
borders at the same time, left-right/bottom-top, or individually (west, east, north, south).

3

Label Orientation

Offset from border or line - Specify Offset  5.00px :
an offset to place labels further
away from the border or line

Rotation - Choose from
Rotation: | No rotation — No rotation, 90° counter-clockwise,
90° clockwise, and 180°
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Click the Format links to open the Label Format dialog box (applies to Index and Measured grids).

al

Label Format - Available UTM format styles or | Label Format

choose No UTM Format:
Label Format: Ho UTM Format OK .
123.4000m| wi abelforma I = == '} [—J Apply locale formatting
'34090mE  Full value with units and Direction
123409 Ful value Number of decimals: 0 : to numbers - Apply
1234 Thousands with leading value number formatting
34 Thousands value onl Label values: ICoard\nates - J N
oy o v . ) according to the locale
3 Ten Thousands value erly | SrmETCEEtat settings in MAPublisher
Label values / Append units to labels - Include 7] Apaly locale formatting to numbers Preferences. Only for
unit to labels. Only for Index grids. 4 Indexgrids.

For a graticule, only these label formats apply:

Label Format

Label Format - Choose a label

format style. The drop-down Label Format: [Decimal degrees (5+[.d%]) ok ]
list includes Degrees Minutes )
Seconds format variations. Hmbeofidecmes /0 =

Cell Reference Labeling

The Cell References options affect the indexing labels of grids and graticules. In the label placement control, click a
label indicator to change its status: border labels (A, B or 1, 2) and center labels (A1, A2, B1, or B2). When the mouse
hovers over label indicators or label options, green highlight appears to indicate its relation. To swap the border
alpha and numeric border label positions, choose either Alpha on left/right, numeric on top/bottom or Numeric on left/right,
alpha on top/bottom. The Row order and Column order settings set the border labels in ascending or descending order. The
position is relative from the top-left corner of the grid. Specify the border label distance from the grid border using
the Place Labels off cell by setting—a negative value places labels inside the grid. Click the Center style and Border style
links to edit text appearance.

Advanced Cell Reference Labeling

Click the Advanced button to access additional grid extents and labeling options.

Advanced To edit the first alpha or numeric value used for cell labels, change the Start alpha
S — index at or Start numeric index at values. To omit certain alpha characters from cell
Startalohaindex ati A references, enter them into the Do not use characters box. For example, it may be

Start numeric index at: 1

useful to omit the characters “”and “O” for indexing purposes (when entering
alpha characters to omit, separate characters with a comma). Enter a character
into the Reference separator box. For example, a ~ separator will yield a label like so:
A~1.The Reference label order can be set to either alpha-numeric (A1) or numeric-
alpha (1A).

Do not use characters:

Reference separator:

Reference label order: @
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Generating and Editing the Grid

Grids & Graticules When all the options have been set, click the Preview button to display a preview of the result. The
Grids and Graticules dialog box can be minimized in the preview mode by clicking Hide In Preview.

Cancel

Click OK to create the grid or click Restore to return to setting up the parameters. The grid is plotted
on the legend layer using the entered parameters.

When the grid is added to the artboard, use the bounding box of the generated grid (View > Show Bounding Box) to
resize it. Re-sizing grids horizontally or vertically will add, remove or re-size (index grid) component cells in the grid.
All grids within a grid collection will be affected. Note that grids with specified bounds cannot be re-sized this way.

After transforming a MAP View containing a grid, the grid will be transformed and scaled within its current bounds
(the physical extents of the grid on the page is not edited). The grid may have to be resized manually.

To change any parameter without generating a new grid, simply select the grid and click the Grids & Graticules
button from the MAPublisher toolbar. This opens the Grids and Graticules dialog box populated with the current
parameters of the grid. All parameters can be edited, even the grid type selection.

IMPORTANT NOTES

Manually editing grid text positions, fonts, and colours is not possible in its default custom art state. To manually
edit a grid, it will need to be expanded (Object > Expand). However, this will prevent any opportunity to further edit
the grid using the Grids & Graticules dialog box. When expanded, grids cells are converted to both polygons (from
index) and lines.

Please see Appendix A3 for more information on working with grids and graticules in MAPublisher.
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Make Index

Object > MAPublisher > Make Index or MAP Toolbar A-1

Make Index
Current Grid: - Select from available grids urrent Grid:
or MAP Area layers to make index from MAP View: @ NorthernOntario
Layer: 0 Legend

| — Advanced - Click this button to open

the Advanced Options dialog box
Make index based on label position - An index ——-+e () Make index based on label position (below) to specify additional options

will be created by assigning one index for the index format
location for each label found on the
selected label text layer

Layer(s): Stations_text

4

j-‘ @) Make index based on label and matching feature position
Make index based on label and matching ezl I Stations,_text =
feature position - MAPublisher will Feature layer: P populated_points_point =

determine what features to index by U

matching label text on the indicated .
Label layer to the indicated attribute
on the Feature layer. An index will be
created for every grid cell in which the Feature layer: | [P] populated_points_point
labeled feature can be found.

Spatially filter the source art

e () Make index based on feature position and attribute value Check this checkbox to limit
index to labels or art intersecting
chosen bounding geometry.
Attribute: Il #Opadty

Make index based on feature position and Filter area Iaygr - Selegt alayerand
attribute value - An index location is corresponding attributes to filter by.
added for each feature found on the
selected label Feature layer. The index @ Byartonlayer: D r— Using MAP Selection - Select a saved
label will be the value of the selected MAP Selection to filter by.
Attribute for each feature.

Spatially filter the source art

Using MAP Selection:

Specify Bounding Attributes - Select

one or more attributes from the

= < bounding art to be included in
the index.
Advanced Options
Advanced Options
Sort by - Choose to sort the By: Select Additional Attributes:
entries in the index file by Format: From: Using common Attributes
. 5 P
either Feature label or Grid —_— censed [T #0pacity
cell address 5 Single-ine condense “ayertiame
Singleine expanded 2Pagek
Output Format — © Multiine #PageY - )
Single-line condensed I =. Select Additional Attributes
Creates one index entry [ Treatorouped text as a sng entry :ED"?IE ‘ Select one or more
. ontFamily .
for each unique label. The . ) #Name ftttr:)u‘te; tof:)le a_rided
index is compressed in the B #HorizontalScale o the index file. The
format: A1-3;82,4 i) (L alee]2 s )7 ()2 Rl =VerticalScale selected attributes appear
The defimiter wil be the one selected above. #Text in separated columns
. . To che the attribute order, edit the sch the MAP Aftribute: #TextLe h imi
Smgle-hne expanded p:;nefnga e attribute order, edit the schema in the ibutes #R:(;:;:t djlmlted by the chosen
Creates one index entry P — ssiyle Index Separator.
for each unique label. The #MapX
index is in the format: g'"‘”m j;':;'“ ASTiES #Map¥
monton i
AT,A2A3,82,83 vancouver AC2L2,3
Multili az HospitaliZoo
ultiline
Creates one index per Main St — 7] Apply locale formatting to numbers (e.g. thousand Apply locale formatting
b
label recurrence to Choose to
X apply locale formatting
Treat grouped text assingle entry —  SPecify Index Separator— — CIECk abutton to open the (e.g. decimal separator
Select this option to create a Select a delimiter to separate the Edit Separator dialog box. as dot or comma), see
single index for grouped text different elements of the index file: Choose between Tab, None MAPublisher Preferences.
label, attribute, grid column, grid or a Custom separator.

row, continuous spanning, discreet
spanning and next in the list. Choices
are reflected in Sample Indexes.
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FUNCTIONALITY

The Make Index feature can be used to generate a map index based on the position of text elements or map features
in a grid (index or measured), a graticule or a MAP Area Layer. Index files generated using this function are produced
as a simple text file and sorted alphabetically (by label or cell reference). A typical file would be formatted as follows:

Millwood Road B4
University Street A4
Broadway Ave B5

For text elements, the position of the first letter of the text is indexed. For map features of type Line or Area, all cells
intersecting the feature are index. For map feature of type Point, the center of the symbol is indexed.

The index file contains a header indicating the name of each column (name, attribute name [if applicable], and grid
locations).

PREREQUISITES

To create a map index, an Index grid, Measured grid, Graticule or MAP Area layer can be used. This grid must exist on
a Legend layer and not be expanded (by Adobe lllustrator). An index will be created even if grid labels are hidden.

The [ 1 | Text layer containing the labels to be indexed and/or the Feature layer must be located in the same MAP View
as the grid.

USING MAKE INDEX

Click the Make Index button on the MAPublisher Toolbar A-1 or choose Object > MAPublisher > Make Index.

«  The selected grid will be used as the index reference.

+ When no grid is selected, Make Index will detect a grid in the document. If more than one grid is
found, the Select Index Grid dialog box opens. Click the Previous Grid or Next Grid buttons to browse through
available grids in the document. The selected grid is highlighted on the artboard.

«  Alternatively, Use area layer as grid (choose appropriate area layer and grid label attribute). This layer can
be of irregular shape (non-rectangular).

Select Index Grid

@ Use index grid
ere e g vas deected,pecn ke b e

wish to use for this Index

MAP View: € world
Layer: 0 Legend

[ << Previous Grid ] [ Next Grid »>

(©) Use area layer as grid

Area layer: [ world_area

Grid label attribute: | [I] #Opacity
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Index Based on Label Position

Select the Make index based on label position button to generate an index using this method. Then choose one or

more layers containing the text to be indexed from the Label layer drop-down list. This method creates an index by
assigning one index location for each label found on the selected text layer. For example, if the label "High Street" is
only found in grid cell A4, the only entry for "High Street" in the index file would be as follows: High Street A4

Index Based on Label and Matching Feature Position

This method creates an index by matching label text on a selected Label Layer to the indicated attribute on the
Feature layer, creating an index entry for every grid cell in which the feature can be found. Note that only features
that have labels will be indexed. For example if "High Street" passes through grid cells A3, B3 and C4, each grid cell
will be in the index — on a single or multiline (see advanced options). For example as: High Street A3, B3, C4

Use this function as follows:
«  Select the Make index based on label and matching feature position option to generate an index using this method.
«  Choose the layer containing the text to be indexed from the Label layer drop-down list.
«  Choose the layer that was used to generate the labels from the Feature layer drop-down list.
. In the Label text matches attribute list, select the attribute column in the selected Feature layer which matches
the labels to be indexed.

Index Based on Feature Position and Attribute Value

This method creates indexes for map features that have not been labeled.

The map features to be indexed are contained in the selected feature layer. Any MAP Layer of type Point, Line or Area
contained in the same MAP View as the grid can be selected.

The index position is based on each feature on the grid — for Area and Line layers all cells that intersect with the
feature are indexed; for Point layers the cells that contain the center of the feature symbol are indexed.

The actual index label listed in the output index file corresponds to the value of the selected Attribute.

Spatially Filter the Source Art

This option affects the range of feature labels, feature labels and art, or pieces of art selected to be indexed.

Choose the Byart on layer option to limit index creation to those entries that intersect the bounds of the art on the
specified layer.

Choose the Using MAP Selection option to limit index creation to those entries that intersect the bounds of the art
selection resulting from the application of the chosen pre-defined MAP Selection.

Click the Specify Bounding Attributes button to open the Specify Attributes dialog box. Use this dialog box to select
multiple attributes from the bounding art to be included in the index.
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Advanced Formatting Options
To set additional options to control the formatting of the index file, click the Advanced button.

The Sortindex by option controls the order of the index entries. The default setting is Feature label — entries are
ordered based on the label text (alphabetical). Alternatively, Grid cell can be selected to sort by the cell indexes.

The Specify Index Separator indicates which delimiter is used to separate the different columns in the index file (label,
additional attributes and indexes). To change a specific delimiter, click the separator button in between the two
desired elements. The separator options are Tab, None, or a Custom delimiter. When using a custom delimiter, type the
desired character(s) in the adjacent text field. The separator settings are reflected in the Sample Indexes section.

The Treat group text as single entry option is required to create a single index for grouped text. Enabling this option is
recommended to create index for labels created with MAPublisher Label Pro because the generated text is often
grouped (e.g. multiline labels or along a curve).

There are three output formats for indexes (examples are using the default separators):

Output format Description Example Notes

Single-line condensed | One index for Label A1-3; |- Adash (-) indicates a range: A1-3 means the label
each unique B2,4; F-H9 is found in cells A1, A2 and A3; F-H9 means the
label is created, label is found in cells F9, G9 and H9. The ranges
condenses grid by number are grouped first and then the
locations ranges by letter.

« A comma (,) indicates a list: B2,4 means the label
is found in cells B2 and B4 but not B3.
+ A semicolon (;) separates each entry.

Single-line expanded | One index for Label A1, « A comma (,) separates each entry.
each unique A2, A3, B2,
label is created B4, F9, G9,
H9
Multiline One index Label Al - Each entryis onits own line
for each cell Label A2
reference is Label A3
created

Users can add more attributes to the index file by selecting one or more attributes from the Select addition attributes
drop-down list. Additional attributes are inserted in the file in columns between the label and the grid locations,
separated by the chosen Index Separators. For example:

Label Attributel Attribute 2 Al-3;B2,4;F-H9
Note: Duplicated labels that have different selected attribute values, will have a separate entry in the index file

(single-line options). Duplicated labels that share the same attribute values will have a single index entry but
each location will be reflected in the cell references.
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The Apply locale formatting to numbers option applies number formatting according to the locale settings in the
MAPublisher General Preferences (e.g. 10000 may be written 10,000 or 10.000 or 10 000).

Saving the Index File

When all indexed options have been set, click the Save As button. Then specify a name for the text file, and the

location where it will be saved. The index file can be opened in a text editor, or placed back into the document
using the Adobe Illustrator Place function®.

*  Adobe lllustrator (54 Mac 0S X users: It is recommended to copy the index contents into a text box instead of using

the Place function.

Chapter 13: Grids and Indexes | 255

Make Index






" wesT
WHITELAND?
§  WEST
GOSHEN

(!

\sT
DFORD

S -]
7

. PENNSBURY

EAST

WHITELAND.

EAST "%
GOSHEN

WESTTOWN

CHADDS FORD

TREDYFFRIN

WILLISTOWN

DGMONT
{o
—
e r
£
THORNB 3
o ]

CoNCORD | e

BETHEL

Scale Bars and
North Arrows

MAPublisher contains tools for plotting accurate scale bars
and north arrows onto your map.

The Scale Bar tool offers a number of different designs that
you can choose from, including double-bar designs for the
placement of scale bars in multiple units.

North Arrows are created from selected artwork on the page
using the Create North Arrow tool and are immediately aligned
to true north.

Topics covered in this section:
Scale Bar
Create North Arrow
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Select Style - Click the up or down

Scale Bar

Object > MAPublisher > Scale Bar or MAP Toolbar k-

button to browse through the
scale bar styles.

Preview Panel - Displays a preview

of the generated scale bar.

Units - Select the desired
map units to be used in the
selected scale bar.

Object > Edit Scale Bar
Scale Bar
(a] o
0 500 1000 1500 2000 2500
Tip: Edit an
esisting scale bar
Main Bar Unused by sslecting 7, and

clicking on the

Units: Kilometer -7 mene Object =

} @ ]w Edit Scale Bar
e Interval: 500 600000

Interval - Specify the length of
each interval in the selected
map unit.

Maintain relative size - Check this
option to convert the interval
values when units are changed

Labeling Options:

Tick label appearance - Select the
Adobe lllustrator Character
Style to be applied to the text
Tick label spacing - Specify the
spacing between the scale bar
and scale bar label.

Sy

Interval Options:

Number of labeled intervals: 5interval(s)
Number of horizontal lines: 0 line(s)
Number of intervals to subdivide: 0 interval(s)

Number of sub-intervals:

[C] Add interval left of '0'

[¥] Maintain relative size

2 sub-interval(s)

Maintain relative size

=] |5interval(s)
0 line(s)
= |0interval(s)

2 sub-interval(s)

7] Apply locale formatting to numbers (e.q. thousand separators) in interval labels. $———————————————

Interval Options:

Labeled intervals - Enter the
number of interval which will
comprise each bar.

Horizontal lines - Select the desired
number of horizontal lines to be
included in the scale bar. Used

with certain scale bar styles only.

Intervals to subdivide - Enter the

Labeling Options:
1@ Tick Iabel

W ivizl Black, 12.00 pt

-f® Tick Iabel spacing: 0,00 px

Display scale value - Check this
option to enable options to
position the scale value above
or below the bar and left,
center or right aligned.

Display units to right of last interval label
Check this option to display the
interval unit at the end of the last
interval label.

Display page to map units ratio

Check this option enable

options to show the scale as
page unit to map unit ratio
(select from Inches, Centimeters
and Millimeters), the decimal
precision and placement.

Page unit and World units - Check
these options to be able to
specify custom labels. These
override the unit labels specified
in the Scale Bar dialog box.

Scale App

[7] Display scale value:
e [I] Display units to right of last interval label

e [] Display page to map units ratio:

Customize Labels

I Show above

Page units for captions: Inches
Predsion: 3 decimal(s)
Placement: i show above

= Align left

number of scale bar intervals to
be subdivided.

Sub intervals - Select the number
of sub-intervals for each
subdivided scale bar interval.

Apply local - Use the locale
format settings specified
in the General section of
MAPublisher Preferences

Add interval label left of '0' -

Customize Labels

Opens the Customize Labels dialog box. Use
it to change the label of page and world units
and adjust the appearance and variable of
scale and ratio labels. See below.

Customize Labels

Unit Label Overrides:

Page unit: Inch

World units (Main Bar):

Formatting:

Set the scale label style in the
Edit Text Rendition dialog box.

Scale label: Scale 1:%scale%

Kilometer

Scale 1:21,095,269
- Ratio appearance: [Jl] Arial Black, 12.00 pt

Apply locale formatting to numbers (e.q. thousand separators) in Scale and Ratio

Scale appearance: [l Azl Black, 12.00 pt

“aorld_per_page% “world_units%

Description

Scale value

Value entered in 'Page unit
Value entered in 'World units'

Ratio label: 1 %:page_unit%h =
1Inch = 535.820 Kilometer
Variables:
iables - Use these Variable Name Useable In
variables in the Scale and CERED Eoeians
Ratio label text boxes. “page_unit% Ratio label
shworld_units% Ratio label
Sworld_per_page%  Ratio label

258

Scale Bar

World units per page unit
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Places an interval label left
of the zero marker on the
scale bar.

Apply locale formatting to numbers
Insert a comma (or another
locale format) to the scale and
ratio numbers.

Scale Label and Ratio Label

Set the scale or ratio label. Use
the variables available below. A
preview of the scale or ratio is
shown below the text box.



FUNCTIONALITY

MAPublisher contains ten different scale bar designs that may be incorporated into a map. After creation,
MAPublisher scale bars can be subsequently resized using the bounding box (for example to add or remove
component intervals). Scale bars can also be edited by selecting the Object > Edit Scale Bar menu item.

PREREQUISITES

To accurately create a scale bar, a MAP View must contain accurate georeferencing information and the coordinate
system must be projected. (i.e. not in degrees). Scale bars are added on 'ﬁ_| Legend layers. If no legend layer is present
in the document, a new legend layer will be created automatically. To manually create a new Legend layer, use the
Add MAP Layer button on the MAP View panel and specify a feature type of Legend (see chapter 4 for more details).

If a custom character style is to be used for the labels of the Scale Bar, it is also advisable to establish this style
(Window > Type > Character Styles) before opening this dialog box. Alternatively, use the Edit Text Rendition dialog
box to specify the font, colour, size and style of text to use.

ADDING A SCALE BAR

Click the Scale Bar button k= on the MAPublisher toolbar or choose Object > MAPublisher > Scale Bar.

Standard Options

Use the Up and Down buttons to select a scale bar design. Note that some scale bar designs contain two bars and
when such a design is selected, the Second Bar column of options is enabled.

In the Units drop-down list, specify the units for the scale bar intervals to be based on. The default units are that of
the current MAP View.

In the Interval text box, specify a real-world distance that each interval of the scale bar will represent. This number
will be in the unit specified in the Units list.

Note: A scale bar cannot be created on a MAP View that contains a coordinate system using custom (user defined)
point styles or units.

Specify the number of cells in the scale bar by entering a number in the Number of labeled intervals scroll box.

Depending on the chosen style of scale bar, it may be required to specify the Number of horizontal lines that will
compose the scale bar.

To subdivide some of the intervals or cells in the scale bar, specify a number in the Number of intervals to subdivide scroll
box. The subdivided cells begin at the left side of the scale bar. The Number of sub-intervals that compose each of these
cells can be specified in the next scroll box. As required, choose to Add an interval left of zero.
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Labeling Options

Click the Tick label appearance to adjust the tick labels of a scale bar in the Edit Text Rendition dialog box. Choose a
predefined Character Style in the Graphic Style mode or set font, stroke and fill options in the Custom mode.

In Graphic Style mode, labels can be styled using predefined Adobe lllustrator Character Styles. Graphic Styles can
be applied to these labels by choosing one from the Graphic style drop-down list. In Custom mode, labels can be
styled using the font, font size, stroke, stroke width and fill options available.

Edit Text Rendition Edit Text Rendition
P [mad <)@ bl Craracter sty [ L] orma Coractr 7] 7
Concdl
swoke: A =[1oom
A: ]
[7] Underline
[] strikethrough
Advanced: Advanced:
Graphic style: [Z] [ione] = Graphic style: [Z [ione] =
MNaote: If a Graphic Style is selected, its stroke & fill are interleaved with the Note: If a Graphic Style is selected, its stroke & fill are interleaved with the
spedfied font stroke & fil as follows: spedfied font stroke & fill as follows:
1. Graphic Style stroke 1. Graphic Style stroke
2. Font stroke 2. Font stroke
3. Font fill 3. Font fill
4, Graphic Style fil 4, Graphic Style fil
Custom mode Graphic Style mode

Adjust the Tick label spacing to increase or decrease spacing between the tick label and the scale bar.

The Display scale value option shows the scale value above and to the left of the scale bar (by default). The position
and alignment can be changed using the respective drop-down lists. The Display page to map units ratio option adds the
page unit to map unit ratio label (select from Inches, Centimeters and Millimeters). Use the decimal precision and
placement options to adjust the appearance as necessary.

To further enhance the look of scale bar labels, click the Customize Labels button. Under the Label Unit Overrides
section, check the options to override the Page unit and World unit labels and type text into the text boxes. Under
the Formatting section, click the Scale and Ratio appearance links to open the Edit Text Rendition dialog box (same
as above) to adjust the font, color, size, stroke and fill of the scale and ratio labels. Type text into the Scale and Ratio
label text boxes to specify custom labels along with using the available variables (e.g. %page_unit%). The variables
represent stored values from the Scale Bar dialog box and the map document. A preview of the scale is shown
below each of the text boxes.

Click OK to place the selected scale bar on the legend layer at a default position (centered on the artboard).
The Adobe lllustrator editing tools may be used to move the scale bar to a desirable location.
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EDIT A SCALE BAR

Use the bounding box of the generated scale bar (View > Show Bounding Box) to resize. Resizing scale bars
horizontally will add or remove intervals from it. Resizing vertically will adjust the width of the bars.

Scale bars can also be resized using the Adobe lllustrator menu Object > Transform >Transform Each, by changing
the horizontal or vertical scales.

To change the design of the scale bar, or to modify any parameter without generating a new version, select the
scale bar and access the Object > Edit Scale Bar menu item. This will re-open the Scale Bar dialog box and the current
parameters of the bar are available for editing.

Note: Manually editing a scale bar is not possible in its default grouped state. However, manual editing is still
possible if the object is expanded first (Object > Expand). Note, that this will break the dynamic link between
MAPublisher and the scale bar and it cannot be edited through the Object > Edit Scale Bar menu item
anymore. Please see Appendix A3 for more information on working with scale bars in MAPublisher.
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Create North Arrow

Object > MAPublisher > Create North Arrow or MAP Toolbar |y
FUNCTIONALITY

The Create North Arrow tool converts selected art into a directional true north arrow.

In this process, the selected art is rotated toward true north at the art location. This property is maintained through
subsequent moves of the map, projection or rotation.

The true north is the direction to the geographic North Pole — this direction may vary on a map depending on the
selected MAP View coordinate system. To visualize this, think of the lines of latitude in a graticule (see chapter 13) —

these lines can be straight or curved.

Note: True north usually differs from magnetic north (the direction of the magnetic north pole, which varies in time
and space) and grid north (the direction northwards along the measured grid of a projected map).

PREREQUISITES

Any Adobe lllustrator artwork (path or symbol) may be used as a base to create a north arrow. The only requirement
is that the art resideson a 'ﬁ_| Legend layer, and be selected.

This Legend layer must be hosted by the MAP View base for the alignment of the north arrow.

Note: Sample north arrow symbol designs are included with MAPublisher. In the Symbols panel options menu,
choose Open Symbol Library > MAP Symbols > Other Symbols > North Arrows.

CREATING A NORTH ARROW

Select the piece of art to be converted to a north arrow and click the MAPublisher toolbar button r}] .
Alternatively, choose Object > MAPublisher > Create North Arrow.

Upon creation, the selected art is aligned to true north, based on the coordinate system of the host MAP View and
its position on the map. If the north arrow symbol is repositioned on the map, it will be re-oriented to the true north
at the new location.

Note: If the selected art is not already a symbol, it is converted to an Adobe Illustrator symbol and is added to the
Adobe lllustrator Symbols panel.

262 | Chapter 14: Scale Bars and North Arrows

Create North Arrow



TS N

MAP Web
Author

Users should have a basic understanding of HTML syntax
to use this feature.

MAPublisher introduces the MAP Web Author tool that
exports Adobe Illustrator documents with GIS attribute data
to interactive Flash maps complete with callout bubbles,
rollovers, layer control, pan and zoom controls.

Like other MAPublisher functions, MAP Web Author is
completely built-in to Adobe lllustrator. Interactive Flash
maps can be exported without any additional coding or
software requirements. Therefore, users are not required to
have Adobe Flash installed to benefit from this tool.

Flash map export offers controls for the layers visibility.
Additionally, map features (point, line, and area) can be
identified from the attribute information when users type a
keyword in a search box.

Users with a good understanding of HTML, CSS and
JavaScript will be able to customize maps to embed into any
web page using the MAP Web Author APl and CSS tools.

Topics covered in this section:
MAP Web Author Workflow
MAP Web Author Panel
Web Tag Dialog

Web Export Dialog
Advanced Features
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MAP Web Author Workflow

MAPublisher is installed with tutorial materials. It is recommended that users work with the exercises in order to
gain familiarity with MAPublisher tools. The tutorial materials have an exercise dedicated to the new MAP Web Author
panel. The following workflow can be used for guidance.

1) MAP COMPILATION WITH ADOBE ILLUSTRATOR / MAPUBLISHER

Users must create their map document using MAPublisher 8 and Adobe Illustrator tools. If the only purpose of the
map is to create a Flash map, consider at this stage the document size parameter, as this determines the size of map
viewer extents in the Web browser.

2) PREPARING FOR MAP WEB AUTHOR

264

a) Create a working directory

Create a folder on your computer. This folder is used to store all the components for the Web Flash map and
the exported Flash files.

b) Prepare graphics for callouts

Images or Flash animations that will be used in the Web tagging process must be grouped in a Source Media
Folder. When inserting graphics using a MAP Attributes field for multiple artwork, note that it is not possible to
change the graphic dimensions in the Web Tag Dialog. Graphic dimensions should be set beforehand.

c) Set document size for the Flash map
If the document size hasn't been set at step one (document creation), it should be modified through the
Adobe lllustrator menu File > Document Setup prior to Web export.

Note: Changing the document size after artwork is created may result in the adjustment of MAP View
Scale, symbol and text sizes as well as stroke widths.

d) Use attribute table information for callouts

To use attribute information for Web tags, it must be organized using the MAPublisher MAP Attributes panel.
This may require creating new attribute columns for elements such as Website links or graphic file paths.

e) Data preparation

Run the crop tool, simplify lines and remove unneeded attributes.
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3) USING MAP WEB AUTHOR

a) Setup the Source Media Folder

Users have a choice between entering an absolute or relative path for the Source Media Folder.

Note: If animage is placed under C:\Work\Flash_Project\Images\Mylmage\Mylmage1.jpg, and the Source
Media Folder is C:\Work\Flash_Project\Images, then the path \Mylmage\Mylmage1.jpg must be typed
in the Web Tag Dialog (or in the MAP Attributes panel when using attributes).

b) Create callout bubbles

Using the Web Tag Dialog, insert content (such as a title, images and text) into the callout bubbles Use the
Callout Preview to see an example of how the callout bubble will look, prior to the export process.

4) EXPORT FLASH DOCUMENTS

The settings entered in the Web Export Dialog are determined by the desired aspect of the Web map. It is
recommended that users try different configurations. Here are some basic examples:

<5 Canada I+l
5 !

Canada I+l |

et |

57 Major oty names ¥ Magor ciies [7 Canada peovince

Simple MAP - No layer control, no navigation
(Basic Settings). No Search box (Advanced .
Settings). | -

Default Style Map - Built-in layer control and
navigation button added through the
Basic Settings only.

No Advanced Settings required.

Customized Style Map - External layer control
and navigation button added through the
Basic Settings. Removed zoom buttons
and changed callout bubble style through
Advanced Settings.

5) VIEWING FLASH MAPS WITH A WEB BROWSER

Download the latest Flash Player version (http://get.adobe.com/flashplayer/) and install it. Open the Flash map in a
Web browser to view it (i.e. select the exported HTML file and open it locally).

Note: If the Flash Player Security Sandbox is set to Network during the export, the folder permissions must be set in the
Adobe Flash Player Settings Manager, as explained earlier in this chapter. If the option Auto or Local has been
chosen during the export, the map can be opened while offline with no further settings.
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MAP Web Author Panel

Window > MAPublisher > MAP Web Author or MAP Toolbar |_

MAP Web Author Panel

MAF WEB AUTHOR ? Specify Source Media Folder...

Edit - Opens the Web Tag Dialog.
Create or modify Web tags

Remove - Delete Web tags of any
selected objects

AllWeb Art - Select all artwork that have
aWeb tag in the document

Previous/Next Web Artwork - Navigate
between Web tags. Status displays how
many Web tags are selected.

Zoom - Zooms to selected Web tags

Tag

Selection

f

Export

|— Specify Source Media Folder - Specify the
directory path to the media files

Export to Web - Opens the Web Export
Dialog to finalize settings for export

—fall web Art | [ Web Art On Layer ¢

£ | Zoom To Selected Art

Web Arhwiork 1 of 13 selected.,

Specify Source Media Folder

Web Art on Layer - Select all the artwork
that have a tag in the currently
selected layer

Specify Source Media Folder T — Browse - Browse to the directory
Absolute Path - Select this option to set containing the media files (images and
an absolute path (best used when —| Source Media Folder: Flash animations)
working on a single computer) ©) AbsolutePath ® Relative Path
Relative Path - Select this option to seta Reset Reset - clear the current Source Media
path relative to the current location of A empey relative path indicates the same folder as the document, Folder settings
the Adobe lllustrator document (best

used when files have to be moved).
Newly created documents must be saved
for this option to be enabled.

FUNCTIONALITY

The MAP Web Author tool exports a MAPublisher document as an interactive Flash map for Web display. Together
with the map artwork, Web tags (also known as callout bubbles) are included in the export. Prior to the export
process, the MAP Web Author panel is used to create, edit or modify these interactive objects.

Web tags can either be populated one object at a time or for a selection of objects. To create or edit multiple Web
tags, select artwork and click the Edit button. Using this method, the same Web tag format is applied to all selected
artwork. Information can be entered manually or extracted from the MAP Attributes fields (when available for the
object layer). At any time, Web tags can be edited or modified by selecting them and clicking Edit.

Text and image formatting is created using simple HTML (Hyper Text Markup Language). The results can be checked
in the Callout Preview window available in the Web Tag Dialog.

Additional settings such as customizing the navigation and callout bubbles are available during the export process.
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PREREQUISITES

In order to use MAP Web Author, first complete a map using MAPublisher and Adobe lllustrator tools. The Adobe
lllustrator artboard will determine the size of the Flash map. It is recommended to set the document size before any
work is started. The document size may be changed using the Adobe lllustrator Arthoard Tool at any time. Using pixel
units is the most practical to determine Flash map sizes in a Web browser.

To populate Web tags, MAP layers must have relevant attributes populated in their MAP Attributes tables. For example,
to insert links to graphics (images and Flash animations), the MAP layer must have a dedicated attribute field
containing a path (e.g. \images\picture1.jpg). The Source Media Folder containing the graphics must be organized
properly. The supported image formats are JPEG, PNG and GIF and supported Flash animation format is SWF.

Notes: Not just any map can be made into a Flash map. A print ready map does not necessarily mean that it is a
Flash ready map. Unneeded art and attributes should be removed, lines should be simplified. Layers that do
not require tagging will still be exported.

Only the active artboard will be exported to Flash (Adobe Illustrator CS4/CS5 only).

MAPublisher Flash export requires the Firefox version of the Flash Player to be installed. Full support for Internet
Explorer Flash plug-in is partially complete at the time of printing. Also, the user is no longer warned if the Flash
plug-in is not installed/detected prior to loading the Flash map, instead, a link is provided when an attempt to
load the file is made. To ensure compatibility, download and install the latest Flash Player at http://get.adobe.com/
flashplayer/otherversions.

USING MAP WEB AUTHOR

Specify the Source Media Folder

The Source Media Folder is the directory containing graphics that might be displayed in the Web tags (callout bubbles).
The path to this directory is chosen through Specify Source Media Folder in the MAP Web Author panel options menu.

Either an Absolute Path or a Relative Path may be entered. An absolute path refers to the full folder directory path
(e.g. C:\folder1\folder2...). A relative path refers to the folder path from the current location of the Adobe Illustrator
document. In the example below, the relative path starts from \MAPWebAuthor_Tutorial.

Absolute Path example < towiviskcy Relative Path example I maPWebAuthor Tutorial

| MAPWebAuthor_Tutarial (5] Flash_Canada.ai

121 Flash_Canada.ai | ImageFiles AB.png
BC.png
Canada.png
f——— MB.png
NB.png
NFpng
NS.png
NV.png
NWT.png
ON.png
PELpng
raes acm
sK.png SK.png
YK.png

] ImageFiles ABpng
8C.png
Canada.png
MB.png
NB.png
NFpng
NS.png
NV.png
NWT.png
ON.png

YKpng

If the Adobe lllustrator file is to be exchanged between computers, it is good practice to use a Relative Path to avoid
having to reset the link to Source Media Folder when the files are moved.
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Add, Edit and Remove Web Tags

To add or edit a Web tag, select a piece of artwork and click the Edit button in the MAP Web Author panel. This opens
the Web Tag Dialog where the Web tag settings can be defined. When multiple artwork is selected, any settings made
in the Multiple Web Tag Dialog are applied for all of the selected artwork. They may be individually modified by scrolling
through the Web tags or at a later time by selecting the artwork and clicking the Edit button.

To remove Web tags, select artwork with an associated Web tag and click the Remove button.

Note: Document artwork (lines, areas, points) associated with callout bubbles are also called Web Art. Only Web Art
will be searchable in the resulting Flash map (see Export to Web). Text cannot be tagged as Web Art.

Selection

Select any artwork in the document and the MAP Web Author panel displays the number of Web tags (assuming
the artwork contains a Web tag). To select all the artwork with Web tags in a document, click the All Web Art button.
To select all the artwork with Web tags on a specific layer, select the layer in the Adobe Illustrator Layers panel, and
click the Web Art On Layer button. Use the navigation buttons to consecutively move to the previous or next artwork
that contains a Web tag.

The Zoom To Selected Art option centers the Adobe lllustrator document view to the selected artwork with Web tags.
Check this option and use the Previous/Next Web Art buttons to navigate between them.

Export to Web
The Export to Web button opens the Web Export Dialog described later in this chapter.

268 | Chapter 15: MAP Web Author
MAP Web Author Panel



CalloutTitle - The title of the
callout bubble

Callout Image - Choose Manually
to browse to the media.
Choose By Attribute and type
the attribute name containing
the path to the media.

Image Width and Height - Specify
the image width and heightin
pixel or use default size

HTML Tags and Graphic Tools

Use these tools to edit the text.
From left to right: Bold, Italic,
Link, Line Break, Unordered
List, and Image. Chart options
include Bar Chart and Pie Chart.
The insert attribute drop-down
list contains attributes
contained in the layer.

HTML Supported Tags - Open
Adobe Flash documentation to
view more information about
supported HTML tags

Web Tag Dialog

Web Tag Dialog

Width: 190 px

Image Path: No Image Specified Height: 150 px

-— Callout Preview - Open or close the

preview of the callout bubble

- -I— Callout Size - Set the size (width
and height in pixels) of the
callout bubble

Auto Size - Check this option to
automatically size the callout
bubble around its contents

Callout Editor - Edit the callout
contents. Supported HTML tags
may be used to format the text
and images in the contents

) Manualh [] Auto Size
=D Width: Height:
@ By Attribute T
______________ -
i
[ Bl e e - A
|3 Click here t see which HTML tags are supported in Flash,

Trigger External URL (Advanced)
Hover URL: Target:
Click URL: Target: -

The spacified URL(E) will be lbaded whan the user hovess or cicks on this art. Uisa the target tag 1o load the URL in a spacfic html frame.

Previous Next

Trigger External URL (Advanced)

- Control how URLs are opened
when either clicking or hovering
over Web art. Framesets or target
must be created to direct the Web
page to a specific frame.

Previous and Next - Click Previous or Next button to
switch from one Web tag to another (enabled when
multiple artwork is selected).

Callout Bubble example

FUNCTIONALITY

Callout Image - as set in the

E—]\ = &

Callout title ————e Santa Fe Depot

r=— ==

Address:

-
=
|

1050 Kettner Baulevard

Callout Image section |

|
[Major tntersection: || contents frame.
4

| S

Callout Contents - can contain text,
images and graphics. Set in the

Click the Edit button in the MAP Web Author panel to open the Web Tag Dialog (Multiple Web Tag Dialog if multiple artwork is
selected). These dialog boxes are used to design the Web tags (callout bubbles) using HTML. These callout bubbles
appear when objects in the Flash map are clicked or hovered over. Not all objects in the map need to be associated
with a callout. Use the Callout Preview to see how the HTML affects the Web tag.
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PREREQUISITES

In the Web Tag Dialog, text and image parameters are edited using HTML tags. HTML tags are key codes written
between less than (<) and greater than (>) signs, that indicate how the Web browser should display the text. There
are opening and closing version for most (but not all) of the tags, and the text to be affected is contained between
the both tags. Both the opening and closing tags use the same key code but the closing tag is preceded by an initial
extra forward slash sign (/).

Examples of text formatting
Opening Tag Closing Tag Result
. Text
<b>Maps of the World</b> —— Maps of the World

<i>Maps of the World</i> —— Maps of the World

Examples
Some HTML tags are used to insert links and images.
e <a href="http://www.avenza.com'>Avenza Web Page</a>
— Creates a link to www.avenza.com accessed when clicking "Avenza Web Page" text.

—» Inserts an image (picture.jpg located in the Source Media Folder).

HTML ignores extra spaces and returns, therefore tags such as <br> (to create line breaks) and <p> (to start a

new paragraph) should be used. In addition to the HTML tags, MAPublisher can use text extracted from the MAP
Attributes table. The reference to the attribute field name is indicated between two percent (%) signs. For example,
%AttributeName%.

Examples of using attribute fields
o <b>%Street_Name%</b>
— Main Street

e <img src="sourcemedia/%image%' hspace="0" vspace="0" align="left" >
—» Displays image indicated in the attribute called "image" (a string text). hspace and vspace sets the
horizontal and vertical space left blank around the image. The align setting sets the image alignment to the
left of the page.

e <a href="http://%WebSite%" " >Avenza Web</a>
—» Avenza Web (opens the Website value indicated in the WebSite attribute).
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USING THE WEB TAG DIALOG

Callout Setup and Preview

The Preview button opens or closes the preview of the callout. As text and graphics are inserted, the preview gets
updated to show the aspect of the callout bubble prior to export. Set the Height and Width of the callout bubble in
pixel units or use the Auto Size option. This option sets the size of the bubble automatically based on the contents of
the callout.

Note: Flash is used to generate a callout preview of exactly what you will see in a web tag. However, due to some
known Flash Player HTML rendering limitations, some callouts may not appear in a Web browser exactly as
shown in the MAP Web Author preview. For example, ordered and unordered lists (<ol> and <ul> tags) are
not recognized by Flash Player so they do not modify how the list is rendered and all list items will be shown
using bullets.

Insert a Title

Callout bubbles can be given a title. The title can be typed in as text, but it can also be formatted using HTML tags
and MAP Attribute values. The attribute field name must be entered between percent (%) signs, e.g. %TITLE%.

Insert an Image or Flash Animation

Images and Flash animations (SWF) can be inserted into callout bubbles. To insert graphics manually, choose the
Manually option and browse to the graphic file. To use an attribute value containing the path to the graphic file,
choose the By Attribute option and type the attribute field name into the box. The attribute field name must be
entered between percent (%) signs, e.g. %Image_File%.

By default, the original graphic size is used. To change the graphic size, enter a new Width and Height into the boxes
(the width/height ratio is maintained). The Callout Preview shows the size of the graphic. The By Attribute option is
not available for Multiple tagging.

Note: The maximum size for a callout is 800 pixels by 800 pixels. When this limit is reached, graphics are
automatically scaled to fit (aspect ratio is maintained).

Add and Edit Contents

The Weh Tag Dialog provides a series of tools to create HTML tags more quickly. The Table title (next page) shows the
tag buttons and functions that are available.

To insert a tag into the callout editor box, click a tag button. Then type callout text in between the opening and
closing tags. Alternatively, highlight text with the cursor and click a tag button to wrap tags around it. Use the
Callout Preview to see how the text, links or charts are displayed.

Aside from the HTML tags, the Web Tag Dialog provides a drop-down list to pick MAP Attributes (visible attributes only).
Choose an attribute from the drop-down list and it will be entered into the callout editor box.

Note: MAP Attributes column names are case sensitive.
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Tag button Tag Function HTML tag example Result

Bold <b>Madrid, Spain</b> Madrid, Spain

Italic <i>Land Parcels</i> Land Parcels

Orlando,

Line Break orlando,<br>Florida .
Florida

<ul> i . Roads
<li>Roads</li>

Unordered List <lisAvenues</1i> - Avenues

</ul>

Hyperlink <a href="http://www.avenza.com”>Avenza Page</a> Avenza Page

Insert Image <img src="ImageFile/Canada.png”>

<chart type="pie” showlLegend="true” values=""keyl”,
Pie chart “Yattribl%’ | “key2”, “%attrib2%’” colors="0xff0000,
Ox00ff00” width="180" height="180" >

B key1

key2

<chart type="horizontalbar" showlLegend="true" keyz

showAxisValues=""true" values=""keyl", “"%attribl%" -

Horizontal bar chart "\ oo™ s yateribaw " colors="0xFFO000, OX00FFOO" <=

width="180" height="180" >
0 20 80

Horizontal
Vertical <chart type="verticalbar" showLegend=""true" =
Vertical bar chart showAxisValues=""true"” values=""keyl", "%attribl%" =
| "key2", "%attrib2% " colors="0xFf0000, OXOOFFO0" . [ |

width="180" height="180" >

kvl k=v2

Additional information for pie and bar charts:

«  keyl: Legend for the first value. Enter a text in between single quotes. For example: 'Table Title'

«  %attrib1%: Attribute that contains the first numerical value for the graph, as found in the MAP Attributes
panel. For example, if the attribute is named MALE_POP enter '%MALE_POP%'

- key2: Legend for the second value. You can enter a text of your choice in between ' sign. For example:
'Female Population'

« %attrib2%: Attribute that contains the second numerical value for the graph, as found in the MAP
Attributes panel. For example, if the attribute is named FEMALE_POP enter '%FEMALE_POP%'

- colors: enter a list of colors for the chart (first color, second color etc...). The color values must be entered
in hexadecimal values. For example, use the Adobe Illustrator Color Picker and select color : the hex
value (below the B of RGB). However, lllustrator writes the color as #BC1E1E, but in MAP Web Author,
the # sign by Ox (zero-x) replaces the # — so OXBC1ETE must be entered.

«  width and height: Size of the graph in pixels.
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Advanced HTML tag combinations can be used to create more effects. For more information and a complete list of
HTML tags supported by Adobe Flash, click the link on the Web Tag dialog box or go to http://livedocs.adobe.com/
flash/9.0/main/wwhelp/wwhimpl/common/html/wwhelp.htm?context=LiveDocs_Parts&file=00000922.htmi.

Auto Size Option

When this option is used, the callout bubble automatically resizes to fit its contents.

Trigger External URL

The Trigger External URL options allow an advanced Web designer to load a specified HTML document (designated
by its URL address) into a targeted HTML frame. Attributes may be used (i.e. %ATTRIBUTE_NAME%). This option
occurs when the Web Art is clicked or hovered over.

A Web browser can be divided into multiple panes called HTML frames in order to present documents in multiple
views, which may be independent windows or subwindows. For example, within the same window, one frame
might display a static banner, a second a navigation menu, and a third the main document that can be scrolled
through or replaced by navigating in the second frame. An example layout could be as follow:

r—-——=-=-= _| _______ A
| | |
Frame 1
| | |
e . |
Frame 3
| | |
| Frame 2 | |
I I I
L — — — — — I a

Names of frames created by Web designers must begin with an alphabetic character (a-z/A-Z). Some special
purpose HTML frames have reserved names with a leading underscore. The following reserved names are available
for selection from the Target drop-down list.

_blank  Loads a linked document into a new blank window (unnamed).

_self Loads a linked document into the same frame in which the link was
clicked (frame containing Flash map).

_parent Loads a linked document into the immediate parent of the document
the link is in (frame containing Flash map).

_top Loads a linked document into the entire window, clearing the frames.

To use the Trigger External URL options, enter the URL address of the HTML document to open in the Hover

URL or Click URL fields. The specified URL can be any page available locally or any external Web page (for

example http://www.avenza.com). In the Target drop-down list, enter the name of the destination frame (type in the
name given by Web designers or use one of the four available reserved names).
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Export Location- The destination
folder of the exported
Flash documents

Layer Controls - Lists all the layers
in the active artboard. All layers
will be visible, but only checked
layers under User Toggle can be
shown/hidden by a user.
Options - Set layer export
options. Show a layer at certain
zoom levels, set initial layer
visibility and static content is
affected by pan and zoom.

Compress Metadata File - Check
this option to compress the
map data file, map.xml

Preserve Appearance - When
unchecked, path simplifications
are applied by Adobe Illustrator.

Simplify Outlines - Check to

simplify outlines of tagged
artwork in the Flash map

JPEG Image Quality &

Web Export Dialog

Export Settings

Web Export Dialog

ExportSettings | Viewer Style | Viewer Settings |

Export... }—-— Export - Export the document to

{-+—e Export Location:  Ci\Jsers\mlaw\Documents\Untited-1\jndex, html

Simplify Outlines of Tagged Artwark

Drag the slider to control
the amount of JPEG file
compression

Compress Map Data File map.xml {recommended)

{+—- ] Lse Preserve Appearance Setting For Flash Export

User Toggle Layer Name Options B
Public_Schools_point
Post_Offices_point
B Interstates_line
Highways_line E
[} Ramp_line
Parks_area
Streets_line _
Land_area
] MAP_TITLE i
Map Settings
Width: 1585 px 5 PanX: 0px 5 Initial Zoom: 100% =
Height: 1585 px = Pan'¥: 0px = Minimum Zoom:  100% | =
Maximum Zoom:  500% |5

Flash Player Security Sandbox: |Auto

Close

a Flash map

Map Settings

Width and Height - Size of the
Flash map in the browser.
Cannot be larger than the
Adobe lllustrator document.
Set to Artboard - Reset the width
and height to its original values
PanXand PanY - Initial pan shift
applied to the Flash map (from
top-left corner)

Initial Zoom - Zoom level when
the Flash map is opened
Minimum Zoom - The minimum
zoom level that the map can
be set to

Zoom - The maximum

zoom level that the map can
besetto

Flash Player Security Sandbox
Provides a restricted area for
the map that prevents access
to private data. Depending

Viewer Style - Use these
setting to control the
style and position of

navigation objects and ———e ¢

map elements. Any
changes to the default
settings will output a
new CSS file.

Use External CSS File - If
an external CSS file

is specified, it will
override any of the
settings specified
above. When a CSS file

is specified, an Edit link ——e! v russmas cos e

is enabled. It opens
the file in the system's

Reset To Dntmy

Mavmabon
] Urabile ravagaten
W, e v et
| o Foomng Vedge:
¥ them ewch e
At beaty Do 12 Sea o Hewin
‘Sho Clck Caioust for Search Semte
¥ e Layes Lt
]
¥ Dracg Mag g Mouse 3 Par

Tpressicas
o Expressiern n Search Bon

b Enze e v Wk Tt

JPEG Image Quality &Resolution: ~ Low 0 High on location of final Flash map,
choose Local or Network. It is
set to Auto by default.

Viewer Style Viewer Settings
See next section for more details See next section for more details
Expertfemngs | Vewsr Soie | e Semngs . Dot Satinge | vewer Sivie. | ewer Sencs
Have Vakse o e

Calout Bublbles
¥ Do tha Ok Clit bl
Une Lighebrn Sty for ok Callnt
¥ Srcom tha viwer Callat Bubble
Une Full Gt Cormnt S e Callat
e the Frued Ponen ot Bubie

) ne Corsros Iruteact of Meame for Callat Pratn

Elsatie Ve Maigation Avmatons

e Low Stage Gty Durry Armatons

Asrbutes

Exzurt ) Amistes Vo Mas Featres

default text edtior.
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FUNCTIONALITY

Use the Web Export Dialog to set the look and feel of the Flash map: style navigation objects and map elements such as
buttons, the search box, overview map, layer list, callout bubble, zoom slider, and highlight lines and colours. These
are the final settings before exporting the document as a Flash map.

Navigation buttons - Pan up, pan down, L Search e—— Search hox - Type text into search box
pan left and_ pan right buttons. 1 ) and it searches through the contents
Home button in the center of the * o of all the exported callout bubbles.
pan buttons centers the_ map to its * = Results are highlighted on the map.
original view. “'._ g Canada i+l
. -t ;-J
Zoom Slider - Move the slider arrow . ) l J" £ " Populstion 31,672,887
up or down to zoom in or out, = Area 994570 ki’
respectively. Use the Zoom In or Whiteharse ‘f ‘

Zoom Out buttons to zoom at . wﬁ{ ga_“‘“lﬂ Bubble - Web tag (;r _POI:‘-U\IZI .
specific increments. R Y P isplays content created in the We
x Tag Dialog

Province: New Brunswvick

L5

£ Population: 723900
- e Capital City: Fredericton

Edme

Highlighted Lines - By default, objects
clicked on are highlighted in blue,
objects hovered on are in green
and objects found by the search are
in yellow

Go to the government website

Victoria' s 1
© Winnipeg
: Québec ) P 'O

Overview Map - Displays the full

extent of the map at all times. When
zoomed into the main map it shows
the zoom extent. The zoom extent is
interactive and can be used to pan
around the map.

Layer list - Check boxes toggle ————e [+/] Major city names
layer visibility. Only layers [¥] Major cities
checked under User Toggle are [¥] Provinces
shown in the layers list.

PREREQUISITE

Web tags must be first created using the Web Tag Dialog.

USING WEB EXPORT DIALOG

In the MAP Web Author panel, click the Export to Web button |E| to access the Web Export Dialog. The Web Export Dialog
contains two tabs. The Export Settings tab controls the export location, layer options (visibility, toggability, etc.) and
the Flash map settings. The Viewer Settings tab control the appearance and disposition of the Flash widgets.

WEB EXPORT DIALOG - EXPORT SETTINGS

In the Export Location box, specify the directory that will store the HTML index file (by default index.html) and Flash
export files. Click the Export button to complete the Web export.

Layer Controls

To insert a layer list in the Flash map, at least one layer check box under the User Toggle column must be checked
(Export Settings tab) and the Show Layer List option must be enabled (Viewer Settings tab). Layers that are checked
are included in the Flash map layer list and can be toggled on or off. The layers that are unchecked are exported, but

can not be toggled on or off.
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Layer Export Options

Itis also possible to customize the visibi

lity and zoom of each layer. Double-click [Double Click Here To Set Layer Options]

to access the Layer Export Options dialog box.

Initial Visibility - Show or hide —
the layer when the map is first
loaded in a Web browser.

Zoom Range Visibility - By default, —|
the layer is always shown.
Choose a zoom level range for
the layer to be visible within.

.
Layer Export Options
Layer Export Options
e Initial Visibility
@ Shaw the layer when the map is initially loaded
(©) Hide the layer when the map is initially loaded

{~e Zoom Range Visibility
@ Always show the layer
) Only show the layer at zoom levels:

From:

When the layer is outside the
zoom range, it is hidden.

To:

Static Content Layer - By default, —® Static Content Layer
the layer will be affected by pan
and zoom. Choose the second
option so that a static layer is
not affected by pan and zoom.

@ Pan and zoom the layer in the viewer

©) The layer will not be affected by panning and zooming

Map Settings

Use these settings to change how the Flash map is displayed in a Web browser:

Change the width and height of the Flash map. It cannot be larger than the Adobe Illustrator document.
Click the Set To Arthoard button to reset the width and height to its original values.

Set the initial position of the Flash map upon load using Pan X and Pan'Y (if zoomed-in).

Set the initial zoom upon load. Set the minimum and maximum zoom that the map is allowed to have.

Additional Settings

Images in Adobe lllustrator are exported as JPEG. The JPEG Image Quality & Resolution slider sets the compression level
of exported images. This setting does not apply to images included in Web tags.

The option Use Preserve Appearance Settings For Flash Export flattens the artwork to a single layer before exporting. It is
recommended to maintain the artwork quality. However, some known issues with Adobe Illustrator Flash export
cause some documents to fail to export with this option enabled.

The Flash Player Security Sandbox provides a secure area in which a Flash map will load. Three options are offered:

276

Auto: If the file is opened from a Web based URL, the sandbox is automatically switched to Network.

If the file is opened from a file folder, the sandbox switches to Local.

Network: When Network is selected, Flash Player classifies assets (including SWF files) from the Internet
in separate sandboxes that correspond to their Website origin domains. By default, these files are
authorized to access any resources from their own server, but can not load any local files or resources
unless these are enabled through the Flash Security Settings (see later in this chapter).

Local: With this option, Flash Security Settings are not required, however only contents from the local
host computer can be accessed by Flash Player (i.e. hyperlinks, APl will not function). This option is
recommended when distributing Flash maps on CD, for example.
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The Compress Map Data File (map.xml or map.xml.zip) is used by the Flash viewer to get information on the initial zoom
level, Web tag content, tagged object geographic coordinates. It is recommended to keep this option enabled to
use a compressed version of this file (map.xml.zip) to maintain a fast loading map. However, advanced users may
use the uncompressed version (map.xml). For example, an advanced user could create programs that automatically
update the Web Tag contents. Once compressed, this file cannot be uncompressed to map.xml. If this file is required,
the export must be run again with this option disabled.

Note: In MAPublisher 8.0, the metadata file was named map.afm or map.afm.compressed. The decision was made to
change the file extensions because these file formats were not recognized by all Web servers.

WEB EXPORT DIALOG - VIEWER STYLE

To set the style and position of the MAP Web Author map viewer controls, users can edit the Viewer Style list or use a

CSS (Cascading Style Sheet). CSS is a style sheet language that enables the separation of document content (HTML,
JavaScript) from document presentation — it is a simple mechanism for adding style (e.g. fonts, colors, spacing) to

multiple Web pages at once.

The Viewer Style list contains MAP Web Author map viewer controls which include navigation buttons, zoom slider,
search bar and callout bubbles. Each control can be styled and positioned by adjusting basic property values. Users
can export with the default values without further adjustment. If any control properties are changed from the
default values, a custom CSS file is exported to the export data folder.

Note: The controls in the Viewer Style list contain only basic properties, for more advanced designs an external CSS
file should be used (see below).

Map viewer controls and properties in the Viewer Styles list are as follows — all positions are relative to the top left
corner of the Flash map:
«  PanUp Button (Top, Left) - Position of the pan up button.
«  PanDown Button (Top, Left) - Position of the pan down button.
«  PanLeftButton (Top, Left) - Position of the pan left button.
- PanRight Button (Top, Left) - Position of the pan right button.
«  PanHome Button (Top, Left) - Position of the pan home button.
«  Zoom InButton (Top, Left) - Position of the zoom in button.
«  Zoom Out Button (Top, Left) - Position of the zoom out button.
«  Zoom Slider (Top, Left) - Position of the zoom slider widget.
«  (Click Callout Bubble (Corner Radius, Show Arrow, Drop Shadow, Fill Colors Start, Fill Colors End) - style of a
callout bubble when it is clicked.
«  Hover Callout Bubble (Corner Radius, Show Arrow, Drop Shadow, Fill Colors Start, Fill Colors End) - style of a
callout bubble when it is hovered over.

S —

a

DropShadowAngle (here 45°)

“ S DropShadowDistance
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+  Fixed Position Callout Bubble (Top, Left, Width, Height, Corner Radius, Draw Bubble, Fill Colors Start, Fill Colors
End) - position and style of a static position callout bubble.

«  (lick Highlight Line - (Visible, Color, Transparency, Line Thickness).

+  Hover Highlight Line - (Visible, Color, Transparency, Line Thickness).

«  Search Highlight Line - (Visible, Color, Transparency, Line Thickness).

«  SearchBox (Top, Left) - Position of the search box.

«  LayerlList (Top, Left, Width, Height) - Position and size of the map layer list.

«  Overview Map (Top, Left, Proportion) - Position and proportion (relative to map size) of the overview map.

For advanced users, the appearance of the MAP Web Author map viewer can be fully customized using CSS. Enable
the Use External CSS File option and browse to a CSS file. The file will overwrite any of the configurations made in the
Viewers Style list. Using an external CSS file for styling the viewer is advantageous because more visual aspects of
the viewer can be set—such as, callout bubble style, text font, images for buttons—and external CSS can be reused
for multiple maps. If the need arises, the external CSS file can be updated after the map has been exported.

The CSS implementation is based on the Adobe Flex 3 CSS system. Only class selectors are supported. Full
documentation is located at http.//www.avenza.com/mapublisher/mapwebauthor/css. This site includes full maps,
CSS samples and examples of CSS code.

WEB EXPORT DIALOG - VIEWER SETTINGS

In the Viewer Settings tab, check/uncheck any of the options to enable/disable them. Most of these options are
enabled by default unless otherwise specified. The visibility of these controls may also be set through an external
CSS file (specified in the Viewer Style tab).

Navigation
« Enable Navigation - Displays all of the navigation buttons, search box, layers list and overview map.

«  Show Panning Widget - Show pan widget in map viewer.

«  Show Zooming Widget - Show zoom widget in map viewer.

«  Show Search Box - Show search box in the map viewer.
+  Automatically Zoom to Search Results - Zoom the map viewer to search results. Disabled by default.
«  Show Click Callout for Search Results - Show click callouts for search results. Disabled by default.

«  Show LayerList - Show the layer list in the map viewer.

«  Show Overview Map - Show the overview map in the map viewer.

- Drag Map With Mouse to Pan - Allows the user to pan the map using the mouse in the map viewer.

Callout Bubbles
+ Show the Click Callout Bubble - Display a callout bubble when a feature with a Web tag is clicked.
«  Use Lightbox Style for Click Callout. Disabled by default.
« Show the Hover Callout Bubble - Displays a callout bubble when a feature with a Web tag is moused over.
«  Use Full Callout Content for Hover Callout - Displays full callout bubble when option to show hover callout
bubble is enabled. Disabled by default.
« Show the Fixed position Callout Bubble - Displays a fixed position callout bubble. Disabled by default.
« Use Centroid Instead of Mouse for Callout Position - places the callout bubble position of a feature with a Web tag on
the centroid. Disable it so that the callout position occurs where the mouse position is.
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Animations
- Disable Viewer Navigation Animations - Enabling this option disables panning and zooming animations. Disabled by
default.
« Use Low Stage Quality During Animations - Lowers the quality of animations for improved performance. Disabled by
default.

Attributes
« Export All Attributes With Map Features - Forces all attributes to export, regardless of whether they are used in a Web

tag or not. Disabled by default.

Expressions
« Allow Expressions in Search Box - Allow users to type expressions into the search box. Disabled by default.
« Allow Expressions in Web Tags - Evaluate expressions in web tags at runtime. Disabled by default.

EXECUTE WEB EXPORT

Click the Export button to execute Web export. The export summary is displayed in the Web Export Log.

The export creates an index.html file and an index_data folder in the export location (the "index" name is default, a
custom name can be substituted here in the Export Location box). Some of the important files are:

« map.xml.zip (or map.xml when the Compress Map Data File option is not checked).

«  MAPublisherViewer-local.swf and MAPublisherViewer.swf (map viewer implementation files).

« map_L#swf (where # is the layer number; one file per layer when option to toggle is checked).
View the README.txt file inside the export data folder for more information about each file.

The Web Export Log displays several export file size statistics: the total SWF file size and the metdata file size. These file
sizes are meant to warn the users when files get very large. Large files should be avoided as they may be very slow
to open on a Website.

Web Export Log
Export Folder - Link to the export —L b Export 109
folder. nght-Fllck to c'opy link le Export folder: C:fUsers/p biisher 8/Tutorial Guide & Dats /Tutorisl Datajcanad: [:«Exwt Export Again - Return to the Web
location to clipboard. t folder permissions in the Flash Player Global Security Settings panel Export Dialog
Set Folder Permissions - Set folder J Layer G ioerticey S
permissions. Read more Major city names map_LLswf 0 10KB
- Major cities map_L2suf 0 1KB
about Fla§h §ecunty gnd Provinces map_L3.suf 2936 156 KB
permissions section. background map_L4.swf 0 TKB
Layer List - List of the exported
layers, including file name,
number of vertices and file size
Total SWF File Size - Total file size ——-e Total SWF fle sze: 174k8
Ofthe Created SWF ﬁles' This size should be less than 600KB for best performance.
- e Metadata (xml) file size: 15 KB
Less than 600 KB is ideal. This size: shoukd be less than 50 KB compressed {or 400 KE uncompressed) for best performance,
To reduce exported fle sizes:
. i « Use the "Smplify Lines™ toal to reduce the number of vertices in your data.
Metadata (.xml) File Size - Size of « Exportas few attributes as possile. Only atiributes that appear in Web Tags are exported.
the created metadata.xml file. * Un-check the "Use Preserve Appearance Setting for Flash Export” setting.
« Use a lower "JPEG Image Quality &Resolution” setting.
Less than 50 KB C‘?mi_)“?ssed « Reduce the number of raster images used in your map.
(xml.zip) is ideal.
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Flash Security and Permissions

When exporting a Flash map intended for Web distribution, choose the Network option in the Flash Player Security
Sandbox drop-down list. If a Flash map is intended for only local use, choose the Local option. By default, the Auto
option is chosen and automatically detects whether the Flash map is run on a network or locally. If the Network
option is selected, the Global Security Settings must be configured in the Adobe Flash Player Settings Manager
before an Internet browser can properly view the Flash map without posting it on a server. If the Local option is
chosen, it is not necessary to set folder permissions. However, files exported with this option will not work for a
Website and will have to be exported again with either the Network or Auto option.

Click the Set Permissions button in the Web Export Log dialog box to access the Adobe Flash Player Settings Manager
(http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html):

AR P AR rmgas @ 1. Click Edit Locations.
- u.;f,,ﬁwﬁ:.,f rip 2. Click Add Location.

et ety Tha o 3. Click Browse For Folder or copy the full path as written in
the Web Export Log dialog box and click Confirm.

8128 Using an bides

Abveays 8k & anways deny

Alwarys trast fies n thise cabons

- The folder is added to the list of trusted locations. Locations
can be modified or deleted at a later time.

Note: You must be connected to the Internet in order to set these permissions.

View Flash Map

To view the exported Flash map, browse to the Flash export folder (as specified in the Web Export Dialog) and open the
file index.html (or name specified in Export Location) in a Web browser. Check that the Web browser has the latest
version of Flash Player installed (http://www.adobe.com/products/flashplayer/). An outdated version may cause the
Flash map to display incorrectly.

Note: Depending on the security settings of the Web browser used, some warnings may appear when opening files
exported with Local option enabled. These can be ignored.
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Advanced Features

Additional to the common MAP Web Author functions, users with good knowledge of HTML and Javascript can
benefit from some advanced features. The information for these features is provided on the Avenza Systems Inc.
Website (www.avenza.com) to allow for frequent updates. This information is available to all MAPublisher customers.

EXTERNAL CSS

As explained earlier in this chapter, the visual aspects of the widgets that appear in the MAPublisher Web Author
viewer can be configured using CSS (Cascading Style Sheet). The CSS implementation is based on the Adobe Flex 3
CSS system. Only class selectors are supported.

Refer to the Web page http://www.avenza.com/mapublisher/mapwebauthor/css for information on how to edit the
CSS file and for a reference to the list of classes available for styling and their supported properties.

MAP WEB AUTHOR JAVASCRIPT API

The MAP Web Author JavaScript APl allows developers to embed and interact with maps produced by MAPublisher
in web pages.

Some Web pages have been developed on the Avenza Systems Inc. Website to provide a guide to the APl and are
available to all MAPublisher customers. They include an API reference, FAQs and examples.

For more information please refer to http://www.avenza.com/mapublisher/mapwebauthor/api.

The Web Author examples are also provided on the MAPublisher DVD.
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. Export
& _‘..tf:'_ P Geospatial PDF

G Adobe lllustrator documents with GIS data can be exported

NAT'L

o e A to georeferenced PDF files thanks to the MAPublisher Export
Y Geospatial PDF feature.

A geospatial PDF is an Adobe Acrobat file that contains
T geospatial coordinates. With coordinates, users can view and
¥ interact with the PDF to find and mark location data.

MAPublisher exports all the MAP Attributes data in an Adobe
lllustrator document into the geospatial PDF. Attribute values
B can subsequently be accessed and searched in Acrobat 9

B - (and 8 with limitations).

Geospatial PDF exported with MAPublisher can be used in
Adobe Acrobat to:

«  Find and mark location coordinates

«  Measure distance, perimeter, and area

. View coordinates in measurement units in

various formats/units

«  Copy location coordinates to clipboard.

«  View attributes of map objects

+  Reopen geospatial PDF in Adobe lllustrator with
e MAPublisher capabilities maintained.

GILA RIVER
NDIAN RES.

Topics covered in this section:
Export Geospatial PDF
View Geospatial PDF

S NATI, FORES
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Export Geospatial PDF

File > Export> Geospatial PDF or MAP Toolbar '@

Geospatial PDF Settings

Export attributes for layer:
Object Export Attributes
4 @ MAPViews Export Attributes - Enable which
S ol ere
MAP View name: click the check & slaska_area .
box to enable/disable the 4 @ Hawaii Map M del Tree Pref Setth
attribute export of all layers in & hawaii_area M° ; Ir_?e 'ZF'QT(QS -settl ef
the selected MAP View 4 @ UsAMap odelTree display options for
P More Cities the selected layer (shown):
B! uscities_point Use attribute for item name
MAP Layer name: click the check LI usroads_line Enable display of attribute
box to enable/disable the attribute B usa_area name rather than the Adobe
export for the selected layer lllustrator object name in the

Model Tree Preferences [ usa_area Adobe Acrobat Model Tree. Then

Use attribute for item name: [ STATE_NAME i choose an attribute from the
drop-down list.

Item Sorting: Item Sorting:
Sortorder: | Ascending - Sortorder - choose Ascending or
Descending for the sorting order

Embed Al file within PDF - Enable this
option to preserve the Adobe .
lllustrator editing capabilities in Check Use Natural String )
the exported PDF ——f+e [¥] Embed Al file within PDF Comparison to sort numerical
values in a natural order (e.g. 1-2-

10 rather than 1-10-2)

|:| Use natural string comparison

FUNCTIONALITY

The Export Geospatial PDF function exports any MAPublisher document containing a MAP View with a specified
coordinate system to the Adobe Acrobat geospatial PDF format while retaining the georeference and attribute
information. All layers are exported to PDF, including non MAP layers (regular Adobe lllustrator layers).

The geospatial PDF files exported from MAPublisher are compatible with Adobe Acrobat 9 and later. The Adobe
Acrobat Analysis Tools allow viewing and marking coordinates, viewing attributes, measuring distances, perimeters
and areas.

With Acrobat Pro and Pro Extended, the measurement tool is always enabled. To enable this tool in Acrobat Reader
9 (standard), the file must first be opened in Acrobat Pro to enable annotations on the PDF (menu Comments >
Enable for commenting and analysis).

Note: Geospatial PDF files can also be opened in Adobe Acrobat 8, however no geospatial information will be
visible, only attributes.

PREREQUISITES

Export Geospatial PDF can only be used with MAPublisher documents, meaning that it must contain at least one
MAP View with a specified coordinate system. All coordinate systems within MAPublisher are supported, including
user-defined systems*. Multiple MAP Views are supported with no limitation. Individual document size must be
smaller than 14,400 pixel by 14,400 pixel to maintain correct georeferencing.

* With some unusual coordinate systems, measurements in Adobe Acrobat may not give proper results. This is an Adobe Acrobat
limitation. Predefined coordinate systems with an EPSG code will provide accurate results.

284 | Chapter 16: Export Geospatial PDF
Export Geospatial PDF



Depending on the expected behavior of the geospatial PDF, settings for MAP Views, MAP Attributes, and MAP
Layers may need additional attention. See sections below.

Adobe lllustrator documents created using MAPublisher legacy versions (8.1 or earlier) as well as documents
created by third-party software (such as Cartographica) must be opened, saved and closed with at least
MAPublisher 8.3 prior to exporting to geospatial PDF. If these steps are not taken, a warning may be prompted on
export and the Adobe Acrobat data tools (see later in this chapter) will not function properly.

Note: Some Adobe lllustrator effects are not supported during export. The attributes will not be visible for objects
with the following effects' :

«  All Adobe Photoshop effects

- Any effect that modifies the outline shape of the artwork will cause attributes to fail. (i.e. Warp effects,
Convert to Shape, 3D effects, Distort and Transform, and some of the Pathfinder effects).

«  Any effect that rasterizes the art will cause attributes to fail (several SVG filters do this).

- GradientFills are supported, although transparency gradients (going from opaque to transparent) and
Gradient Mesh are not supported.

Geospatial Information Extents

A geospatial PDF only contains geographic information in the extent covered by a MAP View. In other words, Adobe
Acrobat Geospatial Location Tool and Measurement Tool will not work outside the spatial extents of a MAP View. To
increase the extents of the MAP View so that it covers a larger part of the document, create a polygon on a MAP
area layer.

Layers and MAP Views Structure

All layers in the Adobe lllustrator document are exported including locked and hidden layers. The visibility status
is maintained in the exported geospatial PDF, however not the locking status. Locking layers must be done within
Adobe Acrobat.

Layer name and order are maintained as they are in the Adobe lllustrator document (with the exception of nested
layers). Layers must have a unique name. If multiple layers have the same name, a warning message is prompted
upon export. Adobe Acrobat does not support nested layers therefore only top most layers are maintained in the
exported geospatial PDF. Objects in nested layers are still exported but they are included in the top most layer. It is
not recommended to use nested MAP Layers because their attributes will not be exported unless the master layer is
also a MAP Layer.

All MAP Views are exported in the order that they appear in the MAP Views panel (alphabetical): the top most

is exported first and lowest is exported last. If some MAP Views are overlapping, the positions shown in Adobe
Acrobat are calculated based on the coordinate system of the latest exported MAP View (the lowest one in the MAP
Views panel). When working with inset maps, the inset MAP View should be placed at the bottom of the tree in the
MAP Views panel (using an appropriate MAP View name since the order is alphabetical).
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MAP Attributes

The Geospatial PDF Settings dialog box allows the user to customize which layer attributes to export. When attributes
are exported, only visible attributes for map objects are exported to PDF. The attribute name displayed in the Adobe
Acrobat Model Tree Property list corresponds to the attribute Display Name specified in the MAP Attributes panel.

Prior to exporting, users can delete or hide/display relevant attributes in the MAP Attributes panel (through the Edit
Schema dialog box or using the Show/Hide button). The Edit Schema dialog box is also used to change the attribute
display name - see chapter 5 for details):

Edit Schema

[a] [m =1 | Name: STATE_NAME

) #Name Display Name: STATE_NAME [ — ] Display Name - Attribute name
[ #AreaDirection nes displayed in the Object Data pane of

i\S’ETMDUM o the Model Tree
tyle
[R] #StrokeWeight £|| size:
[R] #Perimeter

[B #PathClosed

[R] #AriScale Visible Visible - Set the visibility status of the

k7 - .
g Aﬁ:: [ Read-only selected attribute column

Column - Select the column to edit [ Derive value from expression:
S] STATE_FIPS

[S] SUB_REGION
51 STATE ABER =

»

25 2

Default value:

Expression: | [@

USING EXPORT GEOSPATIAL PDF

To export to geospatial PDF, choose File > Export and select Geospatial PDF in the Save as type (Windows) or Format (Mac)
( drop-down list)—or click the Export Geospatial PDF button l@ on the MAPublisher Toolbar.

After selecting an export directory and file name, the Geospatial PDF Settings dialog box opens to offer the export
options described hereafter.

Export Attributes For Layer

The Export Attributes For Layer tree lists all the MAP Layers that can be exported with attributes Area layer, |Li| Line
layer or | P| Point layer), sorted by MAP View and document. To select which layers will have their attributes exported:
«  Click the Export Attributes check box for each individual layer to enable or disable the export of attributes.
«  Click the Export Attributes check box for a given MAP View to enable or disable the export of attributes for
all layers within the MAP View.
+  Click the Export Attributes check box next to the document name or next to MAP Views to enable or disable
the export of attributes for all layers of all MAP Views.

Layers that are exported without attributes will be visible in the Adobe Acrobat Layers panel but not in the Model Tree.

Notes: Due to Adobe Acrobat limitations, attributes of Text layers cannot be exported. In addition,
<compound path> objects that have an element outside the artboard are exported without attributes.
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Model Tree Preferences

In Adobe Acrobat, the Model Tree displays a list of all the map objects in the document along with their attribute
information (if applicable), organized in a tree structure in MAP View/Layer Name/Object Name—see next section
on how to view Geospatial PDF.

The Model Tree Preferences options control, by layer, how objects will be displayed in the Adobe Acrobat Model Tree.
To set these options, first select a layer in the Export Attributes for Layer tree. The name of the selected layer is then
written next to the Model Tree Preferences caption.

The Use attribute for item name option assigns a specific attribute value as a name to objects prior to export in order to
make the geospatial PDF more readable for users.

By default, the name of the objects displayed in the Structure Pane of the Model tree are derived from the map
object's name as shown in the Adobe lllustrator Layers Panel. The default names given by Adobe Illustrator

to objects are often meaningless an end user. For example, lines and areas have a default name of <Path> or
<Compound Path>, points have the name of the symbol or ordering number.

To use a specific attribute value as an object name, enable the Use attribute for item name option and choose the
desired attribute column from the drop-down list.

MAP Views Panel Adobe lllustrator Layers Model Tree Objects List

Model Tree

f,b -
[=HE2 Non-Map Layers
= Title
= &3 Canada MAP View
) canada_area
FE) dties_point
=& world MAP View
EHED world_area
= Zimbabwe
=1 Zambia
= zaire
B Yugoslavia
&= Yemen
= Western Samoa
= Western Sahara
= Vietnam

=1 Vanaziala

The Item Sorting options control the order of the objects in the object tree (even if objects are not renamed):
+  Inthe Use attribute for item name drop-down list, choose the attribute column that will be used for sorting.
«  IntheSortOrder drop-down list choose Ascending or Descending order.
«  Enable Use natural string comparison to sort numeral values by natural order (e.g. 1,2,10 instead of 1,10,2).
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Embed Al File Within PDF
The Embed Al file within PDF option preserves the Adobe lllustrator editing capabilities in the resulting PDF.

This option is enabled by default. When the Adobe lllustrator editing capabilities are preserved, users will be able
to retrieve MAP Views, MAP Layers and MAP Attributes when opening the exported geospatial PDF in Adobe
lllustrator. When this option is disabled, the geospatial PDF will open in Adobe lllustrator with no georeferencing or
attribute information and all layers will be merged into one—this may be useful for secured documents.

Note: If a preserved geospatial PDF is opened in Adobe Illustrator and some changes are made, the file will have to
be exported again using the Export Geospatial PDF function. Simply saving the document will not maintain
the geospatial capabilities of the PDF.

RESULTS

The exported geospatial PDF can be opened in Adobe Acrobat—the geographic reference and attribute
information are available for query (see next section).

The MAPublisher data is accessible through the Object Data Pane of the Model Tree - this displays either the coordinate
system of a MAP View, if a MAP View is selected in the Model Tree, or the exported attribute information of a
selected object.

Property value

Coordnate System: WS 84 World Mercator
Scale: 1: 250000000.000000
Rotaton

Carberra

60
17285044,000000000
L5

MAP Views properties Attributes properties

Notes: Layers exported without attributes can be seen in the Adobe Acrobat Layers panel, but not in the Model Tree.

During export, a warning may appear: "Multiple Art Objects Matched - One or more map objects may be
missing attribute information". This simply states that the layers listed in the warning have objects that are
close enough in proximity to each other that they are indistinguishable. There is an option in the warning to
select these objects in the event that the user may want to work on them.

The default PDF settings are applied, regardless of any specific preferences set elsewhere:
«  Compatibility: Acrobat 8, PDF 1.7.
«  General: Embed Page Thumbnails and Create Acrobat Layers from Top-Level Layers.
«  Compression: no image compression, Compress Text and Line Art is enabled.
. Security: no master or user password required.

To change PDF file settings (compression, password access, etc.) open the exported geospatial PDF file in Adobe
Acrobat Pro or Pro Extended (version 9 or higher) and resave the document.
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View Geospatial PDF

Geospatial PDF files are compatible with the geospatial tools introduced in Adobe Acrobat 9. The availability of
these tools depends on the user's Acrobat version (Reader, Standard, Pro or Pro Extended), but no additional
Acrobat plug-in is necessary to use geospatial PDF.

All traditional Adobe Acrobat tools apply with the following being the most relevant:
«  Search: selects objects with matching name first, then objects that have a matching attribute value.
«  Acrobat Layers panel: displays all layers and controls the display and lock of the layers.
+  Object Data Tool: to select map objects and display their attributes in the Adobe Acrobat Model Tree
(Structure Pane and Object Data Pane).

Geospatial PDF files can also be read in Adobe Acrobat 8, however, the attribute information is only accessible
(through the menu Tools > Object Data > Object Data Tool) and it does not have the geospatial tools that are
available in version 9.

Adobe Acrobat 9 has the following special tools to access geospatial information:
+  Measuring Tool: to measure distance, area and perimeter.
«  Geospatial Location Tool: to display, mark and query geospatial locations.
«  Geospatial Registration Tool: to spatially register any PDF document by digitizing control points (Adobe
Acrobat Pro Extended only).

These tools and the Object Data Tool are found on the Analysis Toolbar (menu View > Toolbars > Analysis).

Object Data Tool - Enable selection Analysis ® Geospatial Registration Tool
of MAP objects and display name ¥ Register PDF documents

and information in the Adobe —la (Acrobat Pro Extended only).
F [
@ ¢ WD

Acrobat Model Tree (menu View >
Navigation Panels > Model Tree).

Measuring Tool - Measure ial Location Tool
distance, perimeter and area. Display, mark and query
geospatial locations.

Snap Types Measurement Types

NNNXTNN

The settings for the Measurement and Geospatial tools are found in the Adobe Acrobat Preferences (menu Edit >
Preferences), under the category Measuring (Geo).

[— =2

e Dl e Uit S Ly

T
g Lemn
gt Comtent

LRI SPRES TSI P S———

Soap bt Cotoe. [ ety [CHRG

3] iom't oo Transsmsiscy Liyur i SacTHF and 1P60 2900 images
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These analysis tools are described in detail in the Adobe Acrobat documentation that can be found under the

Adobe Acrobat menu Help > Adobe Acrobat Help or on the Adobe Website www.adobe.com.

Not all tools are available for every Adobe Acrobat version, below is a matrix showing the features availability per

Adobe Acrobat version:

Acrobat 9 Reader Acrobat 9 Standard Acrobat 9 Pro
Acrobat 9 Pro Extended
(Windows only)

Geospatial Measuring Tool
Measure distance/perimeter/area v v v
Store measurements as comments v v v
Export/import PDF comments v v v
Geospatial Location Tool
Show on-screen coordinates v v v
Search for/zoom to a location N4 v v
Mark location with right click X v v
Copy coordinates to clipboard X v v
Geospatial PDF Registration Tool
Create from GeoTIFF/JPG2000 X X N4
Georegister a PDF map/image X X v
Add shapefile layers to a map X X v

*To enable the measurement tool in Acrobat Reader 9, the file must first be opened in Acrobat Standard, Pro or Pro
Extended to enable annotations on the PDF (menu Comments > Enable for commenting and analysis).

Notes: The extended tools of Adobe Acrobat Pro Extended are not necessary for MAPublisher users because these
functions can be performed by MAPublisher. Adobe Acrobat Pro Extended is currently not supported for Mac

operating systems.

By default, viewing coordinates with the Geospatial Location Tool will show latitude and longitude in WGS84
when the Always display latitude and longitude as WGS 1984 option is enabled in Adobe Acrobat preferences.
A map with a geodetic base other than WGS84 should have the Always display latitude and longitude as WGS

1984 option unchecked.
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MAPublisher
LabelPro™

MAPublisher LabelPro is a comprehensive collision-free
labeling solution integrated into MAPublisher. Using rules
and styles for text placement, it extracts label information
from map layer attributes and performs fast, intelligent,
cartographic text placement. Placement rules can be saved to
afile and imported into other labeling work sessions.

Topics covered in this section:
MAPublisher LabelPro
MAPublisher LabelPro Settings
MAPublisher LabelPro Styles
MAPublisher LabelPro Rules
Label Verification

MAP LabelPro is available as an optional add-on to
MAPublisher. To purchase a MAPublisher LabelPro license,
please contact sales@avenza.com or visit www.avenza.com.

For information on how to activate a purchased or evaluation
license please refer to chapter 1.

Note: The evaluation version of MAPublisher LabelPro
scrambles the text of placed labels but preserves the
case, spacing and punctuation, so that the results give
a sense of how actual labels would be placed based on
the rule settings.
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Attribute - Select the
attribute column
containing the data to
be used as labels for

MAPublisher LabelPro

Object > MAPublisher > MAP LabelPro or MAP Toolbar |§|

Destination - Specify

a destination from a
list of available text
layers. The destination

Priority - For multiple layers

being simultaneously

labeled, assign a priority
level to each. The same

Style
new

or choose from a
list of established

-Createa
label style set of rules or create
custom rules that

dictate how labels

Rules - Select a default ~ Suppression Layer

Repository for labels
that could not be
placed based on the

Save & Label - Save the
current settings in the
LabelPro configuration
dialog box and perform
the labeling operation
based on these settings
Save - Save the current
settings in the LabelPro
configuration dialog
box without performing
labeling process

Setup Layers - Open the
Setup Layers dialog box to
choose which layers are
to be used for labeling
and/or obstacles

Advanced - Specify user
defined extents for
labeling operations

style - Opens the

Style dialog box

rules- Opens the

Rules dialog box

the
g box

selected features layer holds the labels.  priority can be set to label styles are placed rules set
multiple layers.
]
MAP Labeifro |
[ . ———
Source - Displays MAP —-l—o Souren Altnbute Deitinatsn Preanty Style Rudes Suppeession Layes | | Save 8 -
Views and its associated « 18 San Francisco Dewnton e o
MAP L. h P P Public_Schools point (5] SCHODL MAME ] SCHOOL labels 1 Sehoal Label Style School Label fude [ SCHOOL labels | .
ayers chosen for I sreets tne 5 STREETMAME [T STREET tsbeis 1 Street_Label Seyte  Street Label Fule [ STREET labels Cancel
labeling in Setup Layers (B #aks_ares 5 PARK_MAME (D) PARY_lsbek 2 Park_Label Style  Park_Lobel fide [ PARK Libek =
Seh Layers. -
Advorced... | ®
Olntacke Layers: Source Art: v a2
« KN San Francisco Downtown @ Label all a2 on source layers
Obstacle Layers - Displays MAP — P fost_Offices_pomnt % Lt oty ot "
Views and its associated & rw;"-ﬁlwhwﬂl Export Setirga...
MAP Layers specified @ i
: arks_area
as obstacles during the
labeling session
Label all art on source layers : Import/Export Settings - Import
By default, only generate text | or export a MAP LabelPro
labels for all data contained : Settings file (*.Ips), a format
on the source layers : that stores all the settings in
Label only selected art on source layers : the current dialog box
When enabled, generate text
labels for currently selected data :
on the source Iayerfj
Po pP-up menus
Right-click (Windows) or Ctrl-click (Mac) to display the menus:
In Source:
Source MAP View Source MAP Layer
Set destination layer - Set the same = Edit
destination layer for all source | S S 4 Add to obstadle list - Add all or the A Eitsyle.  e———————kdi
layers in the MAP View [ Set suppression layer H J selected layer to obstacle list §  Editrules.. ‘—'L
Set suppression layer - Set the same J ) | Al Rockfil @ Addto obstacle list Edit
suppression layer for all source = Movealltoobstaclelist ~e————— Moveto obstaclelist- Move allor ——e = Move to obstacle list
layers in the MAP View @ Remove all from labeled list e—— the selected layer to obstacle list @  Removefrom labeled list
% Setup layers... 1 ) & Setup layers...
Remove from labeled list - Remove
all or selected layer from the
source list
In Source column header:
Resize [column name] tofit content g o, Resize ‘Source to fit content
Resizes only the selected columns &  Resize all to fit content
_r P— Setup layers - Opens
Resize all to fit contents - Resize the & |[>etp byers.. Setup Layers dialo
width of all columns to fit content
Ina Obstacle Layers. Add to labeled list - Add all or the
Obstacle MAP View selected layer to the list of Obstacle MAP Layer
source layers
©  Add all to labeled list — ©  Addto labeled list
= Movealltolabeled st~ Move to labeled list- Remove from ——e = Move to labeled list
@ Removeallfrom obstaclelist e——  the obstacle list and add all or @ Remove from obstacle list
1 the selected layer to source list
&  Setup layers... %  Setup layers...
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FUNCTIONALITY

The MAPublisher LabelPro labeling engine offers advanced labeling capabilities beyond those available in
MAPublisher Feature Text. The MAP LabelPro engine contains sophisticated algorithms that solve many of the most
common map labeling problems such as complex conflict resolution across multiple layers, the ability to specify
data as obstacles and the ability to create complex labeling conventions via user defined rules. The MAPublisher
LabelPro engine uses map data attributes for labeling and provides a much greater level of sophistication and
control that can be configured through an intuitive user interface. Data layers may be assigned an order of
prioritization for labeling sequences and existing text can be recognized as obstacles for multiple labeling sessions
if necessary. Placement rules and properties, once set, can be saved to a file and imported into other files or shared
over a network.

Only Point, Line and Area layers can be labeled using MAPublisher LabelPro, however, Text layers may only be used
as obstacles.

PREREQUISITES

MAPublisher LabelPro can only be used in conjunction with MAPublisher documents. MAPublisher LabelPro
generates static text, meaning the map extent and scale should be established prior to labeling. Once placed, labels
do not maintain a link with the source data.

Before labeling with MAPublisher LabelPro, it is necessary to create the destination | L | Text layers (where the new
labels will be contained). To use suppression layers (for labels that could not be placed by MAPublisher LabelPro)
create other text layers for this purpose. To create a new text layer, use the Add MAP Layer function in the MAP View panel
(see chapter 4):
«  Set the feature type to Text.
«  To copy the attributes from the source MAP layer to the label destination layer, check the option
Base attribute schema on and select the appropriate layer to copy its attribute schema.

For each source layer, MAPublisher LabelPro derives the labels from a selected attribute column. Use the

MAP Attributes panel to analyze and/or edit the information prior to labeling. For instance, to force some labels to be
stacked, users can insert the characters && in the MAP Attribute value to indicate a Carriage Return — this can be
done by combining two columns into a new one or using the Find and Replace function.

It is not possible to label based on an expression (e.g. a road layer with classes such as street, highway and toll road
can only be labeled with a single style and rule). To label multiple classes of a layer, use the Split Layer option of the
MAP Selections to create new layers for each class (see chapter 11).

In the MAPublisher Preferences section for MAP LabelPro, base rule and style folder paths can be set. By default,
invisible objects are ignored by MAPublisher LabelPro (they will not be labeled or used as obstacle). To take them
into consideration, uncheck the Ignore invisible artwork option. Also, check the Merge multiline text option to create
single line text labels. See chapter 1 on MAPublisher Preferences for more information on this topic.

USING MAPUBLISHER LABELPRO

To start MAPublisher LabelPro click the MAP LabelPro button |E§| on the MAPublisher Toolbar or choose the menu
Object > MAPublisher > MAP LabelPro.
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MAPublisher LabelPro Settings

SETUP LAYERS

Before labeling, the Setup Layers dialog box must be configured to specify which MAP Layers are to be labeled
and which layers, if any, will be denoted as obstacles. Obstacles are map objects that are included in the conflict
resolution decision making process, and are considered objects that must be avoided when trying to place a label.
The Setup Layers dialog box displays all valid MAP Views and their MAP Layers in the document. To mark a layer for
labeling purposes or as an obstacle, check the appropriate check boxes to the right of the layer name. All layers are
listed, but only layers that are checked will be included in the labeling process or considered as obstacles.

Note: Layers may be used as both a label and an obstacle concurrently. It is possible to perform labeling operations
for multiple MAP Views simultaneously, however, source data layers and destination text layers must belong
to the same MAP View.

Label - Enable the check box for

Setup Layers each data layer to be labeled.
Enabling the option beside the
Name - Displays all MAP Views Name Label Obstacle OK mél:a\ﬁzr\:)::ir:r? :(\J”r”a‘lelllizlfjata
and the layers within them a San Francisco D 5 =
€ San Francisco Downtown la f
N yers that belong to it.
that may be specified for HIGHWAY_INTERSTATE |abels B
labeling purposes LAND. labels |
MAP_TITLE
PARK_labels [l
SCHOOL labels ]
STREET_labels O Obstacle — Check this option
SUPPRESSED_labels /| should you want the
P pUSt—_Off"ES—F'D'"t_ ] contents of the layer to be
P/ Public_Schools_point used as obstacles for label

conflict resolution

ADVANCED OPTIONS

In the Advanced options dialog box, set the Label Placement Area option to the extents based on the current
artboard or the extents of labeled source layers. To set Label Margins, enable the option and enter the extents of the
label container in increments of the current document units. Data that is outside of the label margins is disregarded
in the labeling process.

Extents of the current artboard (AETWERE
(Default) Label all designated data
Label Placement Area:
that falls within the extents of the _ - -
@ Extents of the current artboar
current artboard. -
| [ o(") Extents of labeled layers

Extents of labeled layers — Label data —,_
only to the extents of the selected

MAP Layers. » [ Label Margins:

Top: 0.00in
Left: 0.00in
Label Margins — Enable the check box FEE |EE
to add margins to the Bottom: |0.00in
selected extents.

Obstacles:
ObSKE(I?s - Enable the .CheCk box to |} Paths without stroke are not considered

specify that paths without stroke obstades

are not considered obstacles.

Note: These settings are applied in conjunction to the settings from the Source Art section in the main MAP LabelPro
configuration dialog box. Units for margins are determined by Document Setup in Adobe lllustrator.
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SOURCE AND ATTRIBUTE COLUMNS

("MAP LabelPro These settings determine which attribute information is converted
into text labels for a respective layer. The Source column shows the
Source Attribute Area, Point and Line layers in the document that have been enabled
4 [@ San Francisco Downtown for labeling through the Setup Layers option. For each layer listed
P/ Public_Schoals_point [§] SCHOOL_NAME in Source column, the Attribute column holds a drop-down list
Streets_line [S] STREETNAME populated with the attribute structure of that MAP layer. Specify the
Parks area [SI PARK_NAME appropriate attribute to be used for generating that layer's labels.

Note: By default, label case is left exactly as it is found in the attribute table. To modify a label's case, see the options in
the Label Case drop-down list located in the Style dialog box of each layer.

DESTINATION AND SUPPRESSION TEXT LAYERS

The layers on which generated labels should be placed are specified in the Destination and Suppression Layer
column drop-down lists. Destination layers will contain only the labels that could be placed successfully on the
map based on the defined rules. Suppression layers are repositories for labels that could not be placed successfully
according to the rules and have not met all placement conditions. For best viewing results after labeling, hide the
suppression type text layers. Alternately, the suppression layer can be set to Ignored and unsuccessfully placed labels
will not output to any layer.

Note: Rows that have incomplete configuration settings (locked destination or suppression layers/unspecified
destination layers) are displayed in red under the Source list in the configuration dialog box. It is normal
for a certain percentage of labels to not succeed in being placed due to rule or data conflicts. Information
regarding the success rate of placement can be reviewed by enabling one of the Statistic type options
located in the Options frame.

PRIORITY
The Priority setting allows for complex hierarchical labeling sequences.
The priority is the order of preference in which labels are placed. Layers
Destination Priority Style with a priority of 1 will be placed first (or have a high priority). Layers with
a priority of 12 will be placed last (or have a low priority). Consequently,
[T SCHOOL labels 1 School_Label Style layers with a low priority might have more suppression labels generated
[I] STREET labels 1 Street_Label_Style for them. Priorities are set by selecting a number in the Priority drop-down
[Tl PARK labels 2 Land_Label_Style

list for a respective layer.

Note: A maximum of twelve priorities may be assigned at any given time however the same priority number can be
assigned to multiple layers.
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MAPublisher LabelPro Styles

POINT AND AREA STYLES

The Style dialog box is used to set label style properties for each map layer. To access the dialog box, click the Style
edit button . Set the text properties for font family, style, size and colour. A sample preview of the stylized text
is shown in the large text box. Once the desired settings have been made, they can be collectively saved into a style
file by clicking Save As. MAP LabelPro offers a pre-configured default style of 12 point Arial as a base labeling option.
Once saved, Styles are added to the Styles drop-down list in the MAP LabelPro Configuration dialog box.

-

Style
" ) . = Preview — Text sample (result may not
Family - Specify the font for the labels Family: [ r Arial -] [ oK ] be exact for some font families)
Style - Indicate the desired font style Style: [Regu\ar -] =
. . . . = ]
Size - Specify the font size Size:  25.00pt[> Sam |e @ Save As — Save the current settings
Colour - Click the color chip to colour: i p = into a style file
open the Adobe lllustrator
o CdO/Gflplee’flﬂOg'ﬁ(I)ok Label case: [Leave as is - Label Case - Select the appropriate
elected colour values will be g = label case from the drop-down list:
converted to the document e Opadity: ¥ Wkl . Leave as is: keep case set in
colour mode (e.g. CMYK to RGB). attribute vlalue

« Convert to lower case: e.g. abcd
« Convert to upper case: e.g. ABCD

Opacity - Specify the level of
packy - Specty « Convert to proper case: e.g. Abcd

opacity for the labels

Save As

Name - Enter a name to Mame: Land_Label_Style -
save the style

This is very helpful in maintaining labeling consistency among similar mapping projects or when multiple users are
working on the same project. Existing styles may be deleted by selecting it from the Style drop-down list and then
clicking on the [3£] delete button. Style files are saved to either a point, line or area folder depending on the type of
map layer it is associated with.

By default, styles are saved in the following location:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Styles
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Styles
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/Styles

The default save path for the Styles can be modified in the MAP LabelPro section of the MAPublisher Preferences
dialog box. Choose Edit > MAPublisher Preferences (Windows) or choose lllustrator > MAPublisher Preferences (Mac).

Notes: On Windows, labeling with PostScript Type 1 fonts that are not placed in the Windows system font folder will
produce an error message Failed to perform label placement: FontNotFound Exception. In these very rare cases,
the font files should be copied from the Adobe font folder (usually under C:\Program Files\Common Files\
Adobe\Fonts\Reqrt\Base) to the Windows font folder (found from Control Panel > Fonts). Notably, Myriad font
is such a PostScript Type 1 font that is not installed on the Windows font folder by default.

Attributes consisting of Unicode characters must be labeled with a Unicode font that contains the
appropriate characters. For example, attempting to label Japanese characters with an Arial font will result in
an error or incorrect results.
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LABEL LINE DATA WITH SYMBOLS

MAPublisher LabelPro has the ability to place labels inside symbols. A typical application of this would be
numbered highway route shields. To label lines with symbols, check the Label with symbol check box to enable
the symbol options. Choose an appropriate symbol set from the Symbol File drop-down list and select a symbol
from the Symbol drop-down list. Use the Height option to change the size of the symbol in the Adobe Illustrator
document unit (e.g. inches or millimeters).

Style

Family: [ T Arial - ] oK

Style: [Regu\ar - ] Cancel

Size: 15.00 pt = S |

ample
Colour: . p
Opacity: D 100% 5
Label with symbol — Enable this Label with symbol
check box to activate the
symbology options —r® Symbal File: [generic_sh\elds‘lsf
Symbaol: @ United States Interstate Height:  7.00pt [ Height- Specify a height manually
Symbol file ~ Choose a symbol file ' Blue Interstate Shield or allow the symbol to be scaled
(Isf) that contains the desired = () Cide automatically to fit the label's text
set of symbols Empty Highway Shield via the Auto option.
Empty Shield
Symbol - Choose lthe symbol frgm Hexagon e
this drop-down list ) Horizontal Oval
" Pentagon

Rectangle
Rounded Rectangle =
Square
United States Interstate -

Symbols are stored in the location set in the MAPublisher Preferences (see chapter 1). The default locations are:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Symbols
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Symbols
Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/LabelPro/Symbols

Notes: The label font size and a fixed symbol height (not Auto size) affect how a label is sized inside a symbol. For
example, if a fixed symbol height of 0.5 in is used, but the label font size of 5 pt, the symbol will be 0.5 in but
the label inside will be no greater than 5 pt. If the label font is set to 50 pt, but the fixed symbol size is 0.5 in,
the label will have a maximum size of whatever fits inside the symbol or the selected font size.

Each symbol file has one version in RGB colour and one in CMYK.

Labeling with symbols is only available for Line layers. To label areas with symbols, use the Plot Centroids
function from the MAP Point Plotter (see chapter 6).
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MAPublisher LabelPro Rules

MAPublisher LabelPro provides users with an intuitive, easy to understand
graphical user interface for setting up labeling rules. Each Point, Line and Area
rule dialog box has numerous label placement options for a high level of label
Bules detail and a variety of configurations.

To access label rules, click the Rules edit button [l in the Rules column of the

l Highway Labels = ]E]I main MAP LabelPro dialog box. Depending on the layer type, this will open
[Default] either the Area, Line or Point Rules dialog box. Configure label rules and, if
[Default] needed, save the rules to add it to the Rules drop-down list.

Rules operate in a very similar approach to Styles in that once added to the
Rules list, they can be immediately applied, reused later in the same file or in other documents provided they are
being applied to the same type of data. Rules are saved to the Area, Line or Point folder depending on the feature
type of the MAP layer.

MAPublisher LabelPro offers a pre-configured Default rule for each data type. It is loaded by default and used until
new rules have been created or selected. The default rule is a good starting choice as it is configured to be useful
for the most common labeling situations, however, creating custom rules can be very useful when specific labeling
conventions are required.

In an Area, Point or Line Rule dialog box, the sequence in which the rule options appear and are checked have no
bearing on the order of label placement, only whether the option is enabled or not. Adjust the Priority value of
layers to adjust the sequence of label placement. Existing rules may be deleted by selecting them from the Rule
drop-down list and then clicking the delete button (F )

Rules are saved to the location set in MAPublisher Preferences (see chapter 1). The default locations are:
Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8\LabelPro\Rules

Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8\LabelPro\Rules
Mac OS X: Applications/Avenza/MAPublisher 8/ MAPublisher Plug-In/LabelPro/Rules

Note: Labeling results will vary depending on which rules are enabled. If no rules are enabled, MAP LabelPro will
not perform any labeling.
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AREA RULES

The Area Rules dialog box contains the label configuration options for labeling Area layers. Rules can be set by
selecting an area feature type layer and clicking the Rules edit button [=_] in the Rules column. The placement
settings in the screenshot below represent the default configuration, however, these settings may be changed to
match any labeling requirements. Click the Save As button to save the label configuration. The rule will be saved
with a user assigned name. Click OK to apply the current settings.

Area Rules

r Allow stacking — Labels are

l allowed to stack up to a
[¥] Allow stacking |Up to 3lines
placed horizontally inside

maximum of two, three,
- [¥] Allow horizontal inside Alignment: m or four lines. Choose
the polygon Alignment option: Feature,
LIS Ci Left, Center or Right.
Allow dominant angle — Labels 7] i ) [&]
areallowed to be placed || | 7] Allow extening beyord
parallel to the dominant boundary

angle of the polygon

Allow horizontal inside Plocement
Labels are allowed to be —I_

[¥] Allow labels to cross lines

Allow labels to cross lines
Labels are allowed to cross
line features and area

+—e ] Allow outside

Allow extending beyond boundary 5 boundaries.
Allow inside, along
Labels are allowed to exceed boundary
the boundaries of the Allow font reduction Allow font reduction
polygon being labeled ) ) Steps: i S A Automatically reduces the
[T] Allow use of leader lines ol e e e AA label size incrementally,
Allow outside — Labels are Allowed Line Crosses: |3 : %_ selected font by 0.5 o, ¥ necessany when necessary. Each step
allowed to be placed outside Leader Width: Loopt » shrinks the selected font
the polygon being labeled ‘ [ Allow overapping labels by 0.5 pt.
Arrow Style: Style 1 ~
Allow inside, along boundary — E“ o~ Allow ing labels
Labels are allowed to be o Area Labels are allowed to
placed inside the polygon, overlap other labels in the
following the polygon same labeling session
boundary

Allow use of leader lines — Incorporates the use of
leader lines. Options include the number of
lines the leader line are allowed to cross, the
width of the leader line being used and the
style of arrow to be used as the leader line.

About Allow overlapping labels

When the Allow overlapping labels option is enabled, labels are placed without applying other placement rules. In other
words, this discards other specified rules and labels are "forced" at its first position. Generally it is recommended to
leave this option off and use Allow font reduction, Allow stacking, and Allow use of leader lines to increase label placement.

Notes: For Area type data, labels are placed relative to an object's centroid.

For areas grouped in a compound path, the largest area of the compound will be labeled.
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LINE RULES

The Line Rules dialog box contains the label configuration options for labeling Line layers. Rules can be set by
selecting a line feature type layer and clicking the Line Rules edit button [z in the Rules column. The placement
settings in the graphic below represent the default configuration, however, these settings may be changed to
match any labeling requirements. Click the Save As button to save the label configuration. The rule will be saved
with a user assigned name. Click OK to apply the current settings.

Placement - Place labels
using an offset or on a
centerline. Offset labels
Above or Below a line.
Vertical Split places multiple
word labels above and
below the line and relative
to the center of the line. If
the generated label only
has one word, it will be
placed on the suppression
layer. The Centerline option
places labels directly on top
of the line.

Starting Point — Specify where the start of the label will be placed with
options including Start, Center and End. Start will have the start of
the label placed at the starting point of the line, Center will place
the label in the center of the line and End will place the label at the
end of the line. The starting point of a line depends on the direction

of the vertices.

Line Rules

Starting Point
© Start
@ Center
% End

Placement

@ Offset

—

[T Below

[] Vertical spiit

) Centerline

Label joined feature — Places
one label on a line that is
joined together

Label each feature - Labels —
each and every
line segment

@ Label joined feature

{+—e ) Label each feature

’-D Divided highways I
[] Repeat labels

Divided highways — Label
multiple road segments
with a common symbol

such as a shield. Lines must
be within 0.25 inch and
75% of the lines must be
parallel to be considered

a divided highway. The

divided highway symbol
will be placed on the line
with the longest geometry.

i

[F] Allow overhang: | 30.00%

Above: M

Allow stacking

[¥] Allow Iabels to cross lines

Allow font reduction

Steps: 4 & A

Esch step allows LabelPro to shrink the sekeced | A
fonit by 0.5 pt, i necessary

[C] Allow use of leader lines

Allow

Leader Width: L00pt

Line Crosses: |3 : ‘>._/
L]

Arrow Style: Style #1

Spacng: [5.00 [£] [Inches
[ Allow averlapping labels %
[] spread words %
Spacing: [1.00 | [Inches - jaalon B
1

Spread words — Multiple word
labels placed a specified
amount apart

a line at specified amounts

Repeat labels— Repeat labels along

Allow overlapping labels — Check

this option to allow line labels to

overlap with other labels in the
same labeling session

Allow overhang - Labels
are allowed to overhang
the line up to a set
percentage. The
percentage of overhang
is relative to the start of
the label and the end of
the line.

Allow stacking — Labels
are allowed to stack to a
maximum of two lines

Allow Labels to Cross Lines
Labels are allowed to cross
line features and area
boundaries

Allow font reduction
Automatically reduces the
label size incrementally,
when necessary. Each step
shrinks the selected font
by 0.5 pt.

Allow use of leader lines
Incorporate the use of
leader lines. Allowed

Line Crosses permits the
number of lines the leader
line will be allowed to
cross. Leader Width and
Arrow Style adjusts the
thickness and style of the
leader line, respectively.

Notes: Text as obstacles will not work unless the Allow labels to cross lines option is disabled. This is because text
obstacles are treated as areas and not text. Also, text will only be avoided being placed where it intersects

the outline of the shape and not within it.

Using the Placement option Vertical Split may require additional line smoothing (straightening or simplifying).
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POINT RULES

The Point Rules dialog box contains the label configuration options for labeling Point layers and follows the same
conventions mentioned for the previous two data types.

Point Rules I Allow stacking — Labels are
_ . Slocement allowed to stack up to a
plracement bftltlzl::-;n Allow stacking |Up to 3lines « ::afﬁlr:: lljir:ets)f two, three,
the desired order of :] Al t "f‘:r: '
ignment: eawre
priority. Use the Clear @ City
Last or Clear All options ] E
to remove selections. :] G
Unselected positions
will not be considered. CJ .3 LanlEizrmresas Allow labels to cross lines
:] !::w Labels are allowed to
@ City cross line features and
Select positions in order of priority. area boundaries.

Centered on point —
Labels are placed on

the center of the point Allow font reduction
Unselected positions will not be tried.

Allow font reduction

S

Steps: 4 = Automatically reduces the
Allow use of leader lines [ Centered on point = e £ T @ e 3| £ label size incrementally,
Incorporate the use of selected font by 0.5 pt,  necessary when necessary. Each
leader lines. Allowed step shrinks the selected
Line Cr rmi
he c OSSbeS pef i ts [T Allow use of leader lines fontby 0.5 pt.
the number of lines n Nev/ Vilage [] Allow overlapping labels
the leader line will Allowed Line Crosses: |3 : %_
be allowed to cross. || =l New . Allow label
h Leader Width: 1.00 pt . Ci N M
Leader Width and .\_Dﬂ Chleck this option to allow
Arrow Style adjusts Arrow Style: Style #1 point labels to overlap
the thickness and with other labels in the
style of the leader line, same labeling session

respectively.

Note: For each point label there is a fixed minimal zone of 0.3 inches, within which no other point feature can be
labelled. Consequently, when two point features are closer than 0.3 inches of each other, their labels are
automatically placed in the suppression layer (if selected).

SAVE AND LABEL

Once the layers, main configuration, style and rule based options have been completed, proceed to label the map data
by clicking the Save & Label button. Clicking the Save & Label button will save the current settings, close the main
MAP LabelPro configuration dialog box and begin the labeling process.

Progress

Labeling

= = = @)

Generating labels

Due to the complexity of the calculations involved in rule based text placement, it is likely that a progress meter
will be displayed for most labeling processes except those that are sufficiently simple or small. Cancel the labeling

process at any time by clicking on the 8] button in the progress dialog box.
Alternatively, save the current settings without labeling by clicking the Save button. This will close the main MAP

LabelPro configuration dialog box and will not label any features. The dialog box can be reopened later to edit the
saved label settings or be used to label the map.
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Label Verification

The graphic below shows results of a typical labeling result using options such as stack labels, repeat labels, allow
labels to cross lines, and many others.

AN

£

\
BROADMERY . o

Verify that labels were successfully placed in accordance to the rule base set out in the MAP LabelPro configuration.
Also verify that labels were placed on the appropriate Destination text layers. Text failing to meet the labeling
criteria will be placed in a Suppression layer (if one is available and has been set). If no Suppression layer is available,
the non-compliant text is ignored and is not generated. Once placed, the labels are considered standard text and
may be modified using Adobe Illustrator or MAPublisher operations.

Note: Undo and Redo operations are supported when labeling. Be aware that undoing a labeling operation will
also undo any changes to rules, styles or settings made at the same time. It may be useful to save without
labeling, close the MAP LabelPro Editor, re-open it, then proceed to click Save & Label.

.
MAPublisher Log
MAPublisher Log
BEC
Message When Layer Clear
+ K LabelPro iabefing session i4 seconds ago
¥ Starting label generation
&9 Finished label generation Deselect Al
» 4% Placing generated labels 5 seconds ago
&9 Layer Public_Schaols_point's 24 label(s) were placed
&9 Layer 'Streets_line: 352 label(s) were placed; 325 label(s] could not be placed
€9 Layer Parks area'’: 43 label(s] were placed: 1 label(s) could not be placed
&P TOTAL: 419 label(s) were placed
&9 TOTAL: 326 label(s) could not be placed

show: (@] [

Open the MAPublisher Log to view statistical information after the labeling process is completed. This information
is useful in determining how successful the labeling operation was based on the number of labels written to
Destination and Suppression layers. It may help indicate whether adjustments to the rule base are required to
achieve a higher rate of successful placement. The log can be exported as a text file for future reference.
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Appendix 1: Technical Reference Guide

Graphic File Formats

Al
The Adobe lllustrator native postscript file format. Refer to the Adobe Illustrator User Guide for more information.

DoQ

Digital Orthophoto Quadrangle (DOQ) are geographic images from the United States Geological Survey (USGS) and
are stored in the JPG format. They can be placed by Adobe lllustrator and registered by the MAPublisher Register
Image function. DOQ are usually very large files (30 MB or more) and require extremely large amounts of RAM.

DRG

Digital Raster Graphics (DRG) are scanned images of published topographic maps from the USGS stored in TIF
format. They can be placed by Adobe lllustrator and registered by the MAPublisher Register Image function. DRG
are also usually very large files (30 MB or more) and require extremely large amounts of RAM.

EPS

The Encapsulated Post Script (EPS) file is used to transfer PostScript language artwork between applications. EPS
files are easily opened by Adobe lllustrator because the format is widely supported by most graphics programs. It
is the preferred format for export to most illustration and page-layout programs. EPS files are vector based, but can
contain embedded raster graphics and fonts.

GIF
Graphic Interchange Format (GIF) is a colour-indexed graphics format, commonly used for web pages and image file
transfer. Adobe Illustrator can export 8-bit indexed-colour or grayscale GIF.

JPEG

Joint Photographic Experts Group (JPEG or JPG) is a compression technique for raster file formats. The Digital
Orthophoto Quadrangle geographic images from the USGS are stored in this format, which can be imported by
Adobe lllustrator and registered by the MAPublisher Register Image function.

PDF / GEOSPATIAL PDF

Portable Document Format (PDF) is a standardized format developed by Adobe for use across Macintosh, Windows,
DOS, and UNIX platforms. Based on the PostScript Level 2 language, PDF supports both raster and vector graphics.
A Geospatial PDF is an Adobe Acrobat file that retains geospatial coordinates.

TIF/TIFF (GEOTIFF)

Tagged Image File Format (TIFF or TIF) is a common raster graphic file format that can be imported by Adobe
lllustrator. Many raster geographic images from GIS systems are stored in this format, which can be imported
by Adobe lllustrator and registered by the MAPublisher Register Image function. A GeoTIFF is a TIFF file with
embedded geographic information identifying its position and scale in world coordinates.

OTHERS
Please refer to the Adobe lllustrator User Guide for other graphics file formats supported by Adobe lllustrator.
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MAPublisher Import Formats

This section contains descriptions of the GIS formats supported for import by MAPublisher. Here you will find
an overview of the structure of each format, as well as information on supported format versions and elements
unique to each data type. Each file format will carry a checklist covering which core elements are supported by
MAPublisher during its import. You can also refer to the Frequently Asked Questions section in this guide for
information on any issues associated with the various file formats.

Also see chapter 2 on Map Data File Formats.

AUTOCAD DRAWING (*.DWG) AND DRAWING EXCHANGE (*.DXF)

There are two formats used by AutoCAD: DXF and DWG. DXF is a CAD data file format, developed by Autodesk as
their solution for enabling data interoperability between AutoCAD and other programs. The DWG format is used for
storing two and three dimensional design data and is the internal format for the AutoCAD Computer Aided Design
package. DWG is also the common name for AutoCAD proprietary DWG technology developed by Autodesk for
their AutoCAD package.

Supported Elements Supported Geometry
Typical File Extensions *.dwg, *.dxf Aggregate No
Automated Translation Yes Circles Yes
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support No Elliptical Arc Yes
Generic Colour Support Yes Ellipses Yes
Spatial Index Never Polygon Yes
Schema Required Yes Donut Polygon Yes
3D Support Yes Point Yes
Line Yes
Text Yes

Supported Versions
Windows: Releases vrs. R12 to 2007
Mac OS X: Releases vrs. R12 to 2007.

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The
following parameters can be applied to the import:

- Group Entities - Group entities by Layer Name or Geometry.

« Hatches - Check this box if you want MAPublisher to read your hatch patterns upon import.

« White Lines and Fills - Enabling the Import as is option will instruct MAPublisher to import the data true to the
original colour settings contained in the file. Check the Change white lines and fills to black box to import black
lines instead of the files native white lines. Check the Create black background option to incorporate a layer
containing a black background to mimic the AutoCAD environment.
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DELIMITED ASCII TEXT (*.CSV, *.TSV, *.TXT)

An ASCll file containing a tabular data where delimiters separate the columns and rows. Common delimiters are
commas, spaces or tabs. Microsoft Excel and many other spreadsheet programs will export data in these formats.

Supported Elements Supported Geometry
Typical File Extensions *.csv, *.tsv, *.ixt Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes Yes Circular Arc No
Coordinate System Support No Elliptical Arc No
Generic Colour Support No Ellipses No
Spatial Index Never Polygon No
Schema Required Yes Donut Polygon No
Point Yes
Line No
Text No

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The
following parameters can be applied to the import:

« Axis Column - Specify which columns contain the x and y coordinates for the point data to be read in.

- Coordinate Format - Choose the formatting type of the data you wish to import (e.g. Decimal Degrees, Delimited
Degrees Minutes Seconds, Packed DMS) — formats are described in chapter 6.

- Usefirst line as header - Allows the user to enable the first line of the text file to be used as column headings.

ESRI INTERCHANGE FILE (*.E00)

An archive of files that describes a complete Arcinfo coverage. This is either ASCIl or compressed into a binary and is
used to transfer files between different versions of Arcinfo. It is a commonly found format for freely distributed data
such as that found at the GIS Data Depot (http.//www.geocomm.com).

A single EOO file describes a complete Arcinfo coverage. The file itself is actually an archive of several smaller files,
referred to as subfiles. Some of these subfiles have fixed names which do not vary from coverage to coverage, and
follow a predefined data format. The remainder of the subfiles contained within an EQO are the info files. These files
may contain user-defined attributes, and have names which vary from coverage to coverage.

Supported Elements Supported Geometry
Typical File Extensions *.e00 Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support Yes Elliptical Arc Yes
Spatial Index Never Ellipses No
Schema Required Yes Polygon Yes
Geometry Type Attribute e00_type Donut Polygon Yes
Point Yes
Line Yes
Text Yes

There are essentially four types of geometry defined in EQO files, which will be reproduced as layers during import:
Arcs (lines), Points, Polygons, and Text. Prior to the import process, an additional Setting can be made:

« Ticpoints layer - This option enables you to include an additional layer which will hold the registration points for the
imported data. The default is to set to Yes.
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ESRI ARCINFO GENERATE (*.GEN)

Esri simple ASCII storage and interchange format. There are three different types of .gen files each with of its own
syntax one for points, one for lines, and one for text geometries. This is the format exported by Arcinfo generate
command. The *.gen files are use by ArcInfo to transfer coverages to other mapping systems.

Supported Elements Supported Geometry
Typical File Extensions *.gen Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes No Circular Arc No
Coordinate System Support No Elliptical Arc No
Generic Colour Support No Ellipses No
Spatial Index Never Polygon No
Schema Required Yes Donut Polygon No
Geometry Type Attribute arcgen_geometry Point Yes

Line Yes

Text Yes

ESRI GEODATABASES

A Geodatabase is a native Esri ArcGIS data format for storing geographic data. It is a collection of geographic
datasets of various types used in ArcGIS and managed in either a file folder or a relational database. There are two
main types of geodatabases:

«  Single-User: Personal Geodatabases (extension *.mdb) and File Geodatabases (extension *.gdb)

+  Multi-User: server based geodatabases, also known as ArcSDE Geodatabases.

Supported Elements Supported Geometry
Typical File Extensions *.mdb (personal), *.gdb (file) Aggregate Yes
Automated Translation Yes Circles Yes
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support Yes Elliptical Arc Yes
Generic Colour Support No Ellipses Yes
3D Support Yes Polygon Yes
Schema Required Yes Donut Polygon Yes
Transaction Support Yes Point Yes
Enhanced Geometry Yes Line Yes
Geometry Type Attribute geodb_type Text Yes
Encoding Support Yes Raster No
Solid No
Surface No
Zvalue Yes
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ESRI SHAPEFILE (*.SHP)

The Esri Shapefile is a geospatial vector data format for geographic information systems software. It is developed
and regulated by Esri as a mostly open specification for data interoperability among Esri and other software
products. A Shapefile is a digital vector storage format for storing geometric location and associated attribute
information. This format lacks the capacity to store topological information

A single logical Shapefile consists of three physical files, each with one of the following file name extensions:
*shp: Geometric data

*shx: Index to the geometric data

*.dbf : Attributes for the geometric data

These extensions are added to the base name of the Shapefile, creating separate physical files that must all reside
in the same directory. You must select the *.shp file for import. Point, multipoint, polyline, and polygon geometric
data can be stored in *.shp files. However, a single *.shp file can contain only one type of geometry. Each entity in

a *.shp file has a corresponding entry in the *.shx index file and a corresponding row of attributes in the associated
*.dbf file. The order of the entries in each of these files is synchronized. For example, the 3rd geometric entity in the
*shp file is pointed to by the 3rd entry in the *.shx index file and has the attributes held in the 3rd row of the *.dbf.

A single Shapefile may also consist of a number of additional files, with the following file name extensions:

*sbn /*.sbx: Spatial index files for the geometric data. These two files are only generating by an Esri product
however they are not required by MAPublisher for import and will they be generated when exporting data to the
Shapefile format..

*prj: Spatial coordinate system information.

If a *.prj file exists in your Shapefile directory, holding the coordinate system information of the Shapefile, this will
automatically be read by MAPublisher on import. If your Shapefile folder does not contain a .prj file you will be
required to specify the coordinate system in order to fully utilize MAPublisher.

Supported Elements Supported Geometry
Typical File Extensions *shp (*.shx, *.dbf, *.prj) Aggregate Yes
Automated Translation Yes Circles No
User-Defined Attributes Yes Circular Arc No
Coordinate System Support Yes (if have *.prj) Elliptical Arc No
Generic Colour Support No Ellipses No
3D Support Yes Polygon Yes
Schema Required Yes Donut Polygon Yes
Transaction Support No Point Yes
Geometry Type Attribute SHAPE_GEOMETRY Line Yes
Text No
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GEOGRAPHY MARKUP LANGUAGE - SIMPLE FEATURES (*.GML)

GML was designed as a geographic interface language for the Geo-Web. It is currently in draft as an ISO standard
(ISO 19136). The goal of the format is to provide users with a set of abstract base objects that can be built into
working real world datasets. It uses as XML base to store geometry and feature information that can easily be
transported across the Internet.

The GML simple feature profile was created by the Open Geospatial Consortium as a restricted subset of the GML
specification. It provides a reduced geometry and metadata profile that can be shared across many GIS tasks. This
simple feature model can be used as a base to generate local application profiles for a specific work area. Since the
GML models base abstract classes, these application profiles (schemas) are required for accessing and processing
any GML datasets. Generally, GML data has a *.gml extension, and requires any application specific schema files
(*xsd). For more information on GML, and the GML simple features profile, please visit the Open Geospatial
Consortium web site: www.opengeospatial.com

Supported Elements Supported Geometry
Typical File Extensions *.gml (*xml) *.xsd Aggregate Yes
Automated Translation Varies Circles No
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support Yes Elliptical Arc No
Generic Colour Support No Ellipses No
3D Support Yes Polygon Yes
Schema Required Yes (*.xsd) Donut Polygon Yes
Transaction Support No Point Yes
Geometry Type Attribute xml_type Line Yes
Text No

GOOGLE EARTH (*.KML, *.KMZ)

KML is an XML-based language for managing the display of three-dimensional geospatial data in the programs
Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies a set of features for display. Each
feature always has a longitude and a latitude and can have other data, such as tilt, heading, and altitude. KML shares
some of the same structural grammar as GML. KML files are very often distributed as KMZ files, which are zipped
KML files with a .kmz extension. MAPublisher uses KML version 2.2 specifications for import and export.

Supported Elements Supported Geometry
Typical File Extensions *kml, *.kmz Aggregate Yes
Automated Translation Yes Circles No
User-Defined Attributes Yes Circular Arc No
Coordinate System Support Yes Elliptical Arc No
Generic Colour Support Yes Ellipses No
Spatial Index Never Polygon Yes
Schema Required No Donut Polygon Yes
3D Support Yes Point Yes
Line Yes
Text No

Prior to the import process, additional Settings can be made, which will affect how the selected KML file will import.
The following parameters can be applied to the import:

« Allow Random Colour Mode - This option allows Adobe Illustrator to generate random colour settings for the data.
- Expand Network Links - Checking this box will enable the use of network linked KML files.
- Import KML Properties as Visible - Check this option to make KML properties visible attributes (hidden by default).
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MAPINFO INTERCHANGE FORMAT (*.MIF)

MIF is a published ASCII storage format used by the Maplnfo. It is used as a file format for map and database
exporting/importing in Maplnfo software products. The Maplinfo Reference Manual describes the MIF format and all
constants it uses for colour, style, symbol, and fill patterns. MaplInfo Interchange Format Files are often called MIF or
MIF/MID files.

A single logical MIF file consists of two physical files, having the following file name extensions:
*mif : Geometric data
*.mid : Attributes for the geometric data

These extensions are added to the base name of the MIF file, creating separate physical files that must all reside in
the same directory. You must select the *.mif file for import.

Each entity in a *.mif file has a row of attributes stored in an associated *.mid file. A single .mif file contains many
different types of geometry however, the associated attribute in the *.mid file must have the same number and
type of fields for each entity in the *.mif file. The order of the entries in the two files is synchronized. For example,
the second geometric entity in the *.mif file has the attributes held in the second row of the *.mid file. The number
and type of attributes associated with each entity is specified by the user. There must be at least one attribute field
in the *.mid file.

Supported Elements Supported Geometry
Typical File Extensions *mif (*.mid) Aggregate Yes
Automated Translation Yes Circles Yes
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support Yes Elliptical Arc Yes
Generic Colour Support Yes Ellipses Yes
Spatial Index Never Polygon Yes
Schema Required Yes Donut Polygon Yes
Geometry Type Attribute mif_type Point Yes
Line Yes
Text Yes

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The
following parameters can be applied to the import:

- Import as Visible Attributes - Enable this option to view the pen and brush pattern values in the imported attribute
table.

The MAPublisher MID/MIF importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded
rectangle, region (polygon), and text geometric data in *.mif files. Each geometric entity present in a *.mif file has
display properties such as pen and brush width, pattern, and colour. Supported MID/MIF properties are as follows:

MAPublisher supports the import of line weights (0-7), colours (24 bit RGB), strokes (1-71). It also supports fonts
(family, style, justification) for text. In order to use line patterns and fill patterns you must have opened or accessed
the style library equivalents. Two library files have been created, MIF - Line Styles.ai and MIF - Area Styles.ai, which
provide support for many of the standard Maplinfo pen styles (stroke patterns) and brush styles (fill patterns). These
files can be found in the Helpful Styles & Symbols folder installed with MAPublisher. Please refer to your Adobe
lllustrator User Guide for details about how to add these libraries to your Adobe lllustrator Graphic Style panel.
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MAPINFO TABLE (*.TAB)

TAB is a proprietary geospatial vector data format for geographic information systems software used by Maplinfo
mapping products. A minimum of two files are required for the tab format. The .DAT file which stores the attribute
data and the .TAB ASCII file which is the link between all other files and holds information about the type of data
file. The Maplnfo TAB importer is closely patterned after the MaplInfo MIF/MID reader and writer. This commonality
makes it easy to support both MIF and Maplnfo native formats in the same mapping file.

A single logical TAB file consists of a number of physical files, having the following file name extensions:

*tab: The main file for a Maplnfo table, it is associated with the appropriate dat, map, id and ind files.
*dat: Tabular data for a table in MaplInfo native format

*id: An index to a Maplnfo graphical objects (MAP) file.

*map : Contains geographic information describing map objects

*ind: An index to a MaplInfo tabular (DAT) file

These extensions are added to the base name of the TAB file, creating separate physical files that must all reside in
the same directory. You must select the *.tab file for import.

Supported Elements Supported Geometry
Typical File Extensions *tab (*.dat, *.id, *.map, *.ind)  Aggregate Yes
Automated Translation Yes Circles Yes
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support Yes Elliptical Arc Yes
Generic Colour Support Yes Ellipses Yes
Spatial Index Always Polygon Yes
Schema Required Yes Donut Polygon Yes
Geometry Type Attribute mapinfo_type Point Yes
Line Yes
Text Yes

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The
following parameters can be applied to the import:

- Import as Visible Attributes - Enable this option to view the pen and brush pattern values in the imported attribute
table

The MAPublisher TAB importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded
rectangle, region (polygon), and text geometric data in .tab files. Each geometric entity present in a *.tab file
has display properties such as pen and brush width, pattern, and colour. Supported TAB properties match those
described for MID MIF files on the previous page.

Raster TAB files cannot be imported in MAPublisher.
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MICROSTATION DESIGN (*.DGN)

DGN are the native files created for Bentley Systems Inc. MicroStation product. These files consist of a header,
followed by a series of elements. The header contains global information including the transformation equation
from design units to user coordinates, as well as the dimension of the elements in the file. Each element contains
standard display information, such as its colour, level, class, and style, as well as a number of attributes specific to
its element type. For example, a text element has fields for font, size, and the text string in addition to the standard
display attributes.

Supported Elements Supported Geometry
Typical File Extensions *.dgn Aggregate No
Automated Translation Yes Circles Yes
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support No Elliptical Arc Yes
Generic Colour Support Yes Ellipses Yes
Spatial Index Never Polygon Yes
Schema Required Yes Donut Polygon Yes
Geometry Type Attribute igds_type Point Yes
3D Support Yes Line Yes
Text Yes

Supported Versions
Windows: V7, V8. Mac OS X:V7,V8

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The
following parameters can be applied to the import. Note: versions V7 and V8 are supported for import, attached raster
files are ignored.

« Group Elements - Choose how you want to group the elements of the file on import. If you group the elements by
level, it may result in a large number of output files. By Level is the default.

« Coordinate Units - Choose Master or UOR (Unit of Resolution) as the coordinate units. Master is the default.

« White Lines and Fills - Enabling the Import as is option will instruct MAPublisher to import the data true to the
original colour settings contained in the file. Check the Change white lines and fills to black box to import black
lines instead of the files native white lines. Check the Create black background option to incorporate a layer
containing a black background to mimic the AutoCAD environment.

« Other - Check Drop complex chains if you want each component of a complex chain to be returned as its own
feature, otherwise all elements of the complex chain will be merged into a single linear feature.

Note: Line weightin Microstation are integer number only, as such, the Microstation export will round the Adobe
Illustrator stroke width. 0 is a valid line weight in Microstation.
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INTERNATIONAL HYDROGRAPHIC OFFICE S-57 FORMAT (*000)

S-57format is intended for the exchange of digital hydrographic data between national hydrographic offices and
for its distribution to manufacturers, mariners and other data users. It is used for the supply of ENC cells (Electronic

Navigational Charts) to ECDIS (Electronic Chart Display and Information System).

The format is public, developed and maintained by the IHO (International Hydrographic Office) CHRIS working
committee (Committee on Hydrographic Requirements for Information Systems). The objects spatial geometry can
be of Point, Line or Area geometry, while object descriptions are categorized in object classes, organized in specific
attributes schemas. For a full format description, please visit http://www.iho.shom.fr/PUBLICATIONS/IHO_Download.
htm#S-57 (Appendix A in particular). An online object catalog is also available on www.s-57.com

An S-57 base file has the extension *.000, while the update files have extensions like .001,.002 and so on. It can also

be accompanied by other files:

*,000: main file

*,001: update file 1

*,002: update file 2

*,00n: update file n

files. TXT and files.JPG: ancillary text and picture files indicated in attribute definition

Update files contains only the changed (new/deleted/modified) objects and are only used as a complement
of a.000 file. Only the *.000 file is required for the import into MAPublisher. The update files will be applied at

conversion, when present. However, text and image files linked to attributes will be ignored.

Supported Elements Supported Geometry
Typical File Extensions *,000 (*.001 *.002...) Aggregate
Automated Translation Yes Circles
User-Defined Attributes No Circular Arc
Coordinate System Support Yes Elliptical Arc
Generic Colour Support No Ellipses
3D Support Yes Polygon
Schema Required N/A Donut Polygon
Transaction Support No Point
Geometry Type Attribute s57_type Line

Text

Note: Most ENC producers (private and public) publish their .000 files in encrypted formats. Only non-encrypted

files can be imported in MAPublisher (from NOAA or USACE for example).
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TIGER/LINE (*.RT1, *.BW1)

Topologically Integrated Geographic Encoding and Referencing (TIGER). TIGER is the United States Census Bureau
format for its digital database of geographic features. TIGER includes both land attributes such as roads, buildings,
rivers, and lakes, as well as areas such as counties, ZIP codes, census tracts, and census blocks. Some of the
geographic areas represented in TIGER are political areas, including counties, congressional districts, school districts,
and ZIP codes. Others are statistical areas, including Metropolitan Statistical Areas (MSA), census tracts, census block
groups, and census block. The database contains information about these features such as their location in latitude
and longitude, the name, the type of feature, address ranges for most streets, the geographic relationship to other
features, and other related information. More information on the TIGER/Line file format and data product can be
found on the U.S. Census web page at: http.//www.census.gov/geo/www/tiger/

This web site contains a detailed description of the current TIGER/Line format, with an explanation of field meaning
for each feature type. A detailed description of the TIGER/Line 1998 format, with an explanation of field meaning for
each feature type, is available at: http://www.census.gov/geo/www/tiger/tiger98.pdf

Supported Elements Supported Geometry
Typical File Extensions *rt1, *bw1 Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes Yes Circular Arc No
Coordinate System Support Yes Elliptical Arc No
Generic Colour Support Yes Ellipses No
Spatial Index Never Polygon Yes
Schema Required Yes Donut Polygon Yes
Transaction Support No Point Yes
Geometry Type Attribute tiger_type Line Yes
Text No

Supported Versions: 1992, 1995, 1997, 1998, 1999, 2000, 2002

USGS SDTS (*CATD.DDF)

SDTS is the USGS robust way of transferring Earth-referenced spatial data between dissimilar computer systems with
the potential for no information loss. It is a transfer standard that embraces the philosophy of self-contained transfers,
i.e. spatial data, attribute, georeferencing, data quality report, data dictionary, and other supporting metadata all
included in the transfer. More info can be found at http://mcmcweb.er.usgs.gov/sdts/. Files in the SDTS format will
have the extension *.ddf. More information on this format can be found at: http.//mcmcweb.er.usgs.gov/sdts/

A group of *.ddf files is normally identified by the catalog file, or *CATD.DDF file, which relates the files of a single
SDTS transfer, and binds together all the files with a common prefix. Always select the SDTS file which ends in CATD,
i.e. HPO1CATD.DDF.

Supported Elements Supported Geometry
Typical File Extensions *ddf Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes No Circular Arc No
Coordinate System Support Yes Elliptical Arc No
Generic Colour Support No Ellipses No
Spatial Index Yes Polygon Yes
Schema Required N/A Donut Polygon Yes
Transaction Support No Point Yes
Geometry Type Attribute sdts_type Line Yes
Text No
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USGS DIGITAL LINE GRAPH (*.DLG) (*.OPT)

DLG is a fixed field record that may or may not have end of line markers. The DLG file structure was designed to
accommodate all categories of spatial data represented on a conventional line map. DLG is a published ASCII format
developed by the United States Geological Survey (USGS) Federal Agency and is intended to assist in data exchange
with the National Digital Cartographic Data Base (NDCDB).

The DLG reader supports all three distinct types of DLG data:
« Large-scale DLG data (1:24,000-scale)
« Intermediate-scale DLG (1:100,000-scale)
+ Small-scale DLG data (1:2,000,000-scale)

The three scales of DLG data are physically formatted into files in one of these ways: standard, optional, and graphics
formats. MAPublisher supports both the standard and the optional DLG distribution formats; however the graphics
format is not supported. Most DLG data is distributed in the optional format. The DLG file structure was designed to
accommodate all categories of spatial data represented on a conventional line map. Node, line, and area data types
are present within the DLG format, along with linkages and attribute codes. Linkages are references to other features
within the same DLG data set, used in a variety of contexts. DLG files do not explicitly store attribute values but use a
feature coding approach in which unique feature codes are assigned to the different types of features stored within
the data set. MAPublisher will look for the extension .dlg or .opt for the input DLG files.

Supported Elements Supported Geometry
Typical File Extensions *.dlg, *.opt Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes No Circular Arc No
Coordinate System Support Yes Elliptical Arc No
Generic Colour Support No Ellipses No
Spatial Index Never Polygon Yes
Schema Required No Donut Polygon Yes
Geometry Type Attribute dlg_type Point Yes
Line Yes
Text No
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MAPublisher Unicode Support

This section contains information regarding Unicode character encoding in MAPublisher. MAPublisher supports
Unicode character encoding in MAP Views, MAP Attributes, MAP Themes, and MAP Selections. MAPublisher can also
reference Adobe lllustrator layers, graphic styles and character styles using Unicode encoding.

To use Unicode character encoding you require a Unicode compliant font. Mac OS X users will have Unicode
compliant fonts installed with OS X. Windows users will require Unicode compliant fonts to render Unicode. For
more information on Unicode visit http://www.unicode.org.

The following tables display Unicode—UTF8 support in MAPublisher, for GIS data formats that are Unicode—UTF8
compliant. Unicode support for importing and exporting data is different, so for each platform two tables have
been created. For each data format there are four areas where Unicode character encoding can be used:

1. File Directory - when Unicode encoding is used in the path to where the file is located.

2. Filename - when Unicode encoding is used in the filename.

3. Attribute column name - when Unicode encoding is used in a column name for attributes.
4. Attribute value - when an attribute value contains Unicode encoding.

Windows Unicode Support (Importing) Windows Unicode Support (Exporting)

- Attribute . n Attribute q
Data Format A it Filename Column uibute Data Format N s Filename Column grgbuts
Directory Value Directory Value
Name Name
Delimited Delimited
- v v v v - v v v v
FORMAT HAS NO FORMAT HAS NO
CADDIG ‘/ ‘/ ATTRIBUTES CADDIG ‘/ ‘/ ATTRIBUTES
FORMAT HAS NO FORMAT HAS NO
CAD-DXF v 4 ATTRIBUTES CAD-DXF 4 v ATTRIBUTES
Esri Arcinfo FORMAT HAS NO Esri Inter-
Generate \/ \/ ATTRIBUTES change File \/ \/ \/ \/
Esri ArcSDE Esri Arcinfo FORMAT HAS NO
Geodatabase \/ \/ \/ \/ Generate \/ \/ ATTRIBUTES
Esri File Esri
Geodatabase \/ \/ \/ \/ Shapefile \/ \/ \/ \/
Esri Inter- GML (Simple
change File \/ \/ \/ \/ Features) ‘/ \/ \/ \/
Esri Personal Maplinfo
Geodatabase v v v v MIF/MID v v x v
Esri
Maplinfo TAI
e v v v v apinfo TAB v v X v
GML (Simple MicroStation FORMAT HAS NO
Features) 4 4 4 v Design X X ATTRIBUTES
Maplnfo KML
MIF/MID v v X v v v v v
Maplinfo TAB \/ \/ X \/
MicroStation X X FORMAT HAS NO
Design ATTRIBUTES
KML/KMZ v v v v
FORMAT USES SIMPLE
=7 \/ \/ ASCII TEXT FOR ATTRIBUTE
NAMES AND MOST VALUES
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Mac OS X Unicode Support (Importing)

Data Format

File

File-

Directory name

Attribute | Attribute
Column Value
Name

Delimited Text

v

v

v v

FORMAT HAS NO

CAD-DWG \/ \/ ATTRIBUTES
wor | v | v | o
e ||| e
GE:orid:::iI:fe NOT SUPPORTED ON MAC OS X
Gei;:tFaiLease NOT SUPPORTED ON MAC OS X
v [ v [V

Esri Personal
Geodatabase

NOT SUPPORTED ON MAC OS X

Esri Shapefile

v

v

v v
GML (Simple
Features) \/ \/ \/ \/
Maplnfo
MID/MIF \/ \/ X \/
Maplinfo TAB \/ / X \/
MicroStation FORMAT HAS NO
Design X X ATTRIBUTES
KML/KMZ \/ \/ \/ \/
FORMAT USES SIMPLE
S57 \/ \/ ASCII TEXT FOR ATTRIBUTE

NAMES AND MOST
VALUES
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Mac OS X Unicode Support (Exporting)

File File- Attribute | Attribute
Data Format A Column Value
Directory name
Name
Delimited Text \/ \/ \/ \/
FORMAT HAS NO
CADDWE ATTRIBUTES
FORMAT HAS NO
CADDXE ATTRIBUTES
Esri Inter-
change File \/ ‘/
Esri Arcinfo FORMAT HAS NO
Generate ATTRIBUTES

Esri Shapefile

v | v

GML (Simple
Features) \/ \/
Maplnfo
MID/MIF X \/
Maplnfo TAB X \/

MicroStation
Design

FORMAT HAS NO
ATTRIBUTES

KML

NEINA RSN AAE

AN R N N NN N NN

v v




Windows Unicode Support
(Working with Images)

Data Format File Directory Filename File Directory Filename
(Register Image) (Register Image) (Export Image) (Export Image)

World File (.tfw) viv' ViV vV vk
Image Report (.irp) \/*/ \/‘ \/*/ \/’ ‘/*/ X. \/*/ X’
MapinfoTAB (tab) | v/ v* Vivt | vTx® vix®
ListGeo (.Igo) \/*/ v \/*/ v \/*/ x* \/*/ x*
GeoTIFF (.tif) iV vt vV x! V!

Mac OS X Unicode Support
(Working with Images)

Data Format File.Directory Fi_lename File Directory Filename
(Register Image) (Register Image) (Export Image) (Export Image)
World File (.tfw) v'° v'° v'° Ve
Image Report (.irp) \/G \/G \/Q \/O
Maplnfo TAB (.tab) Ve Ve v Ve
ListGeo (.Igo) ‘/o ‘/o \/G \/O
GeoTIFF (.tif) Ve v Ve Ve

*When using system encoding
on Windows XP

(for example, using the default
Japanese encoding on Japanese
Windows XP)

*When using non-system
encoding on Windows XP
(for example, using Japanese
encoding on English Windows XP)

°Limited support
(not all combinations of Unicode
characters are supported)
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Technical Support Options / FAQ

MAPublisher support is provided free of charge to customers with a current MAPublisher Maintenance Program
(MMP) subscription. All new license and upgrade purchases include a one year MMP subscription. Customers
without a current MMP subscription may obtain support from a qualified MAPublisher technical specialist at the
rate of US$49 per incident.

TECHNICAL SUPPORT

Please consult the FAQs, the additional how-to's on the following pages as well as the following online options
before contacting Avenza technical support as your situation may be easily addressed by one of the answers
contained therein.

MAPublisher Online Resources

The Avenza Systems Inc. Website provides additional source of information to assist you in the use of MAPublisher.
The Avenza Resources are located at http://www.avenza.com/resources

Avenza Resources Blog: tips, how-tos and news on MAPublisher and Geographic Imager software.
Map Gallery: examples of maps created with MAPublisher.

Styles and Symbols: a collection of styles and symbols to help make your maps look better.

User Forums and Frequently Asked Questions: answers to common technical questions may be
found in the Common Support Issues and FAQs category. All users with a MAPublisher license (evaluation or
permanent) can post and read topics under the General Questions for Evaluation and Licensed Users category.
Additionally, users with maintenance have access to the Maintenance Users category. There, users can find
additional information relative to software updates, etc.

MAP Web Author API and CSS: find advanced information on MAP Web Author API functions and CSS
support - see chapter 15 for more details.

Contacting Avenza Technical Support

Avenza offers a number of methods for direct communication with our qualified and experienced technical experts.
Please have your MAPublisher registration details handy to get prompt attention and include it in any email
correspondence. Support issues are handled on a first come, first-served basis. For non-maintenance users, Avenza
does not guarantee a response within any specified time. MAPublisher Maintenance Program subscribers receive
free and unlimited support. All others are eligible for support at the rate of US$49 per incident.
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Hours: 9:00am to 4:00pm Eastern Standard Time

Email: support@avenza.com

Online request form: http://www.avenza.com/support/form
Phone: +1 (416) 487-6442



MAPUBLISHER MAINTENANCE PROGRAM (MMP)

The MAPublisher Maintenance Program is a subscription-based service plan that guarantees its members:
« unlimited priority technical support—guaranteed same business day or next business day response
« unlimited telephone support
«  free MAPublisher updates
«  free MAPublisher version upgrades
«  additional discounts and offers available to MMP members only

Your MAPublisher purchase includes a one-year membership in the MAPublisher Maintenance Program so you are
well on the way to worry-free use of MAPublisher for the first year and will be able to enjoy all the benefits of the
MMP immediately. All MAPublisher Maintenance Program subscriptions begin on the date of purchase and run for
one calendar year.

Your email address has been automatically entered in the mp-maintenance-l online email list for MMP subscribers
so that you are assured of receiving all the latest MMP news and access to all the update and upgrade files. If you
purchased your MAPublisher license from a reseller or are the end user but not the person who purchased the
software, please contact us at sales@avenza.com to ensure that we receive your email address and add you to the
MMP notification group.

Renewal

You will be notified regarding renewal options approximately six to eight weeks prior to the expiration of your
annual MMP subscription. You will be contacted a minimum of five times prior to expiration in order to ensure that
you have ample opportunity to renew or not at your discretion. You will have the option of renewing your MMP for
an additional year at the then prevailing price or canceling without penalty. Of course, if you cancel or let your MMP
lapse you will no longer be entitled to the benefits of the program as outlined above and will thus have to purchase
future upgrades at the upgrade price.

There is a grace period of approximately 30 days from the time of the MMP expiry during which you may still renew
without penalty. All post-expiration renewals will be backdated to the actual expiry date.

Lapsed Subscriptions

Failure to renew your MMP within 30 days from the expiry date will result in a lapsed MMP subscription. Lapsed
subscriptions may not be renewed and the licensee will be required to purchase support and upgrades accordingly.

Please direct all MMP questions and purchase inquiries to info@avenza.com.

WISHLIST

As either a new or experienced MAPublisher user we value your opinions on how we can improve our product.
Please let us know what functions you would like to see incorporated into future upgrades of MAPublisher.
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Memory Considerations

RAM RECOMMENDATIONS

Occasional User: 2 GB of RAM is recommended.
A graphics or GIS user who uses MAPublisher with medium sized data sets with up to 20 layers, minimal text labels,
and some low-resolution or small coverage raster images.

Power User: 4 GB or more of RAM is recommended.

A professional cartographer who uses MAPublisher daily and works with large urban data sets (including large
transportation layers) with 20 or more layers, raster based air photographs, large numbers of text labels, complex fill
patterns, etc.

RAM USAGE HINTS

Users often ask us why is so much RAM needed to operate MAPublisher. First of all, Adobe lllustrator requires a
significant amount of RAM itself in order to run smoothly. Secondly, map data sets are often large which increases
the need for RAM even further. Map data sets contain both vector and attribute data which must be stored in
memory. Since we are adding a database to Adobe lllustrator this increases the file size, which increases the

RAM requirements. MAPublisher builds a mini-GIS application inside Adobe Illustrator so that it can geo-code
information and attach data to objects. This also has some overhead.

GIS users also often ask why so much more memory is needed with MAPublisher than is with GIS software. The
graphics environment software of Adobe Illustrator loads the entire file into memory rather than just reading it
from disk, thus more RAM memory is required.

When you are importing a large number of files into Adobe Illustrator using MAPublisher, you'll notice that the
amount of available memory will decrease rapidly and your computer loses speed. This is due to the memory
management. MAPublisher reserves a fairly large amount of memory for each import-action, which is not properly
returned when the import is done or even when it is cancelled. The solution is simple: save your file, close it and
open it again. It's not even necessary to close Adobe lllustrator itself. By closing the file, the reserved memory is
properly returned.

RAM SAVING TIPS

Since a percentage of the memory is taken for attribute storage, remove any redundant or otherwise unnecessary
attribute fields from the MAP Attributes table of a layer.

Many sources of street data include paths/vectors that are segmented based on street addressing information. You
can use the MAPublisher Join Lines function to join these into single linear features based on a selected attribute
field. Reducing the number of objects (and data records) in the map file will free up memory.

Many GIS data files are large and when a series of such files is imported, you may find that the import function

starts to run more slowly. This is because scratch and memory allocations are being used up. The best solution is to
periodically save your work, quit Adobe lllustrator and then restart. This will free up the available scratch memory.
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Reduce the minimum number of Undo commands (since they all reside in memory).
Use polylined or pre-joined linear feature data sets where available.

In your GIS application, strip out the attributes you won't be using for queries or labeling before importing the data
into Adobe Illustrator.

You can set a primary and secondary scratch disk under the Adobe lllustrator preferences option in order to draw
additional storage from a partitioned or multi-drive environment.

Turn off the layer preview icon that appears to the left of each layer name in the Adobe Illustrator layers panel.

This can be done by clicking the options menu in the layers panel and then selecting small panel rows in the panel
option dialog box.
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Online Sources

For geographic information system (GIS) users, the appeal of graphics is strong and the increasing ability to discover
and share GIS across the Internet is fascinating. The Internet offers a large number of free-access GIS-related web
sites from which you can access map and information data sets. To find some information on the source listed it, use
any internet search browser such as Google to get access to the websites.

For the general public, there's general information about countries, states, and places; simple maps of areas (e.g.,
GIF, PS format); lists and maps of Internet resources in an area. For cartographers and geography researchers, there
are cartographic/ GIS base map files (e.g., USGS Demos, DLGs, TIGER); thematic data of a geographic nature (e.g.,
census data); and complete GIS data sets (e.g., Esri Interchange Files).

FREE MAP DATA

Many sites on the Internet offer GIS data free of charge. Data is available from these and other Internet sites in a
wide variety of formats. Please consult the sections in this manual on file formats (chapter 2) to ensure that you
download usable data. Some popular sites:

«  (ASTdata: Center of Advanced Spatial Technologies, University of Arkansas.

- EROS Data Center: access to USGS digital datasets.

«  Geocommunity and GIS Data Depot: very good source of free GIS data.

«  Geoconnections/Geoconnexions: Canada Ministry of Natural Resources site.

«  Geography Network: world-wide geographic contents.

«  Geogratis: maps offered by Natural Resources Canada.

«  Geoscience Australia: Australian National Mapping Agency.

«  National Atlas of the United States: excellent data source for the United States.

. NOAA ENC Download: free download of electronic nautical charts in S-57 format (USA).

+  RobertE. Kennedy Library @ California Polytechnic State University: US based map inventory.

. United State Geological Survey: various data formats available (DLG, GeoTIFF, etc.) from the USGS website.

«  United States Fish and Wildlife Service: variety of map data in USGS DLG format.

« USACE IENCdownload: US Army Corps of Engineers, S-57 and Esri Shapefile of US waterways.

OTHER VALUABLE GEOSPATIAL RESOURCES

In some additional places on the Internet where you can find news, reviews, tips and general GIS, cartographic and
geographic information. Some popular sites:

. Directions Magazine

+  Geospatial World

«  GISCafe

+  GIS Dictionary

+  GISLounge

+  GIS Development
+  GlSuser

«  University of Edinburgh
+  University of Florida - Geoplan Center
. US Census Bureau
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General Tips and Hints

CREATING DELIMITED XY TEXT FILES

There may be times when you wish to add a point or a series of points to your map but you do not have a GIS or
ASClI file containing these points ready for import. Provided you have the real-world coordinates for the locations
you wish to plot*, you can manually create a delimited ASCI file using a text editor (e.g. Notepad) or a spreadsheet
program (e.g. Microsoft Excel). This file can then be imported using either Simple or Advanced Import using the
Delimited XY Text Data format.

In a text editor, one column in the file must contain the X coordinate and another must contain the Y coordinate.
Add as many additional columns as you wish containing additional information to be imported as attribute data.

If you are using a text editor, you can simply type in your data in the following format:

“Column 1 Header”,”Column 2 Header”,”Column 3 Header”...etc
“Column 1 Value 1”,”Column 2 Value 1”,”Column 3 Value 1”...etc
“Column 1 Value 2”,”Column 2 Value 2”,”Column 3 Value 2”...etc

Note that negative values for the X and Y coordinates denote west longitude and south latitude, respectively. Also
make sure to enter a carriage return using the Enter key on your keyboard after the last line of data otherwise the
last line may be ignored by MAPublisher Simple or Advanced Import.

In a spreadsheet application, enter your point information as a table and save the file in a text format, preferably
.csv or .txt, choosing either comma or tab delimiting. The spreadsheet application will format the text automatically.

= PointsOfinterest.csv - OpenOffice.org Calc (=] E s
Eile Edit View Insert Format Tools Data Window Help x
- a8 R ¥ Kbk - D- siEZ
A20 ] hE =]
B [ c ] D E I B =
| 1 |ID Longitude Latitude PlaceName CATEGORY I
| 2 | 2 -123.13 49.3 Vancouver Aguarium aquarium
| 3| 4 -123.11 49.29 MAX Theatre at Canada Place theatre
| 4 | 5 -12312 49.28 Vancouver Art Gallery gallery =
| 5 | B -123.15 49.28 Vancouver Museum museum
| 6 | 7 -123.11 49.29/Coastal Peoples Fine Arts Gallery gallery
| 7| 8 -1231 49.27 Science World British Columbia  |science
| 8| 9 -123.15 49 28 Vancouver Maritime Museum museum
| 9 | 10 -123.12 49.29 Tourism Information Centre information
|10 11 -123.11 49.28Inuit Art Gallery Vancouver gallery
| 11| 12 -123.11 49 28 BC Sport Hall of Fame & Museum museum
|12 |
Il
|
15 -
Sheetl 1« i vl
Sheet1/1 Default STD | [* CountA=0 ||©@— & @|[100%
&

* The MAP Location Tool can be used to generate the X and Y coordinate values suitable for building ASCII Point
Files. See chapter 4 for more information.
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JOINING SDTS TABLES

The following information should be used in conjunction with the MAPublisher Join Table function.

When working with United States Geological Survey SDTS files it is necessary to join tables frequently in order

to obtain the map attribute table you require to make the map you want. This is due to the fact that SDTS data is
constructed such that the primary vector data is held separately from the various attribute tables that one might
want to use for a particular mapping purpose. The attribute table that comes as part of the vector file usually
contains a unique identifier (RCID) for each map element that is used to join it with the other data tables. For
example, a particular vector file containing the geography of rivers would contain a data column called RCID.
Various data tables containing information such as vegetation, fish counts or flow rates might be available each also
with an RCID column. The desired tables are then joined to the initial map attribute table by RCID value using the
techniques described in the previous pages.

To find the SDTS tables to join with the vector map file look for the files which have names that start with the same
character string as the name of the vector file. MAPublisher imports SDTS files that have the characters “CATD"” at the
end of the file name. A typical table to import and join with this file might be called HY01CATD.ddf.

Use the MAPublisher table importer with SDTS file type chosen to import these files. When you join layer and table,
you do the join based on the column from the layer matched to the RCID column of the table. Note that the CATD
catalog file found amongst the SDTS files explains what each table is.

ROTATING OBJECTS INDIVIDUALLY IN ADOBE ILLUSTRATOR

On some occasions you may wish to rotate selected objects about their own centres rather than as a group about

a common origin. This can be accomplished using the Adobe Illustrator Transform Each function. To use this function,
first select the objects you wish to rotate. Then go to Object > Transform > Transform Each. In the Rotate box enter a
desired rotation value and click OK. Each of the selected objects will be rotated individually about their own centres.

You may also use the #Rotation property column to individually rotate point symbols or text items based on a
specified value. See chapter 5 for guidelines on how to use this function.

GEOREFERENCING AN ADOBE ILLUSTRATOR FILE

If you are using an existing Adobe lllustrator file that was created without the use of MAPublisher and as such does
not contain any geographic parameters or attribute data, the following steps will enable you to georeference your
Adobe lllustrator file and ultimately create an attribute-rich and accurate scale and world grid structure for your
map. Please note that the steps that follow refer to functions that are outlined in more detail in the body of this user
guide. Please familiarize yourself with the main MAPublisher functions and in particular those under the MAP Views
section (see chapter 4) before proceeding.

Before beginning to georeference an Adobe lllustrator file you must be in possession of the following information:
1. The real-world scale of your data

2. Details of the coordinate system the data is in (i.e. Projection, Datum etc)

3. The X-Y coordinates of one tie-in point in the coordinate system of your data
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To determine the real-world scale of your data, use the scale bar drawn on the map for reference (measure the
page size using the Adobe lllustrator Measure tool and divide by the scale size indicated - make sure to correct for
the measurement units). If no scale bar is available, try measuring distances in page units in Adobe lllustrator and
compare with the same distance measured in real unit with a mapping or GIS software, beware that differences in
coordinate systems may affect the distance measurements.

Determining the coordinate system of the map may be difficult. If no information is provided as meta data or in the
map legend, try to compare with other maps of the same area or with traditional coordinate systems used in the
area (e.g. US State Plane zone matching a county name in the USA...).

To determine the real-world tie point, find a specific location in your document for which a real-world coordinate
location is known or can be easily determined (such as known feature or grid or graticule crossing positions).
Record the location of this point in real world coordinates on a piece of paper.

When you have this information please use the following guidelines in order to georeferencing data with

MAPublisher in Adobe lllustrator.

1. Identify the registration or tie-in point in your document for which you know the X,Y or Lat,Long coordinates.

2. Determine the page position of the same point on the Adobe lllustrator page using the Info panel (Window >
Info).

You should now have the location of your tie-in point in both map and page units (e.g. -79.5, 43.5 in Lat/Long is located

at 4cm, 2cm in the document).

3. In the MAP Views panel, choose New MAP View in the panel options menu.

4. Enter a name for the MAP View.

5. Click the Specify button in the Source Coordinate System section. Choose the coordinate system that matches that
of your vector data and click OK.

6. Set the Scale to the proper scale of the map. It is important to set the scale after the coordinate system but
before you enter the map anchors.

7. Click OKin the MAP View Editor to apply the information to the new MAP View.

In the MAP Views panel, choose Specify Anchors in the panel options menu.

9. Set the Map Anchors to the value of the tie-in location in map units using the values determined earlier
(e.g. Longitude= -79.5°, 43.5°).

10. Set the Page Anchors to the value of the tie-in location in Page Units using the values determined in step 2
(e.g. X=4cm, Y=2cm). Then click OK.

11. If you have not previously done so, ensure that each layer in your Adobe Illustrator file contains only one feature
type (Point, Area, Line, Text, Legend).

12. In the MAP Views panel drag each of the layers which contain your data in to your new MAP View, ensuring that
you set the appropriate Feature Type in the Define Layer dialog box.

13. Repeat steps 1-13 for any other coordinate systems which exist in your document (such as inset maps for
example).

14. Your document is now a georeferenced MAPublisher file wherein each feature is also georeferenced and
capable of accepting attributes using MAP Attributes (see chapter 5). You can also use the MAPublisher Export
function to create a GIS file from this newly georeferenced Adobe Illustrator map.

©
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TIPS ON EXPORTING TO OTHER GIS SOFTWARE WITH MAPUBLISHER

These strategies do not focus on how to do the procedures, as these are discussed in the Export section of the MAP
Views chapter, but more on what you need to know and understand for successful export results.

First and most importantly you need to understand that the MAPublisher export was designed to export MP
imported or created data one layer and one feature at a time. Why is it important to know this? MAPublisher only
recognizes objects that have been imported by or created with its functions. If a layer was not imported with
MAPublisher or is not hosted by a designated MAP View, then MAPublisher will not allow you to export the layer.

If you have an entire layer that was not created by MAPublisher then:

1. Ensure that your layer contains only a single feature type (Point, Area, Line or Text).

2. Inthe MAP Views panel, check that you have a designated MAP View with a matching coordinate system. If you
do not, create a new MAP Views.

3. Select the layer in the MAP Views panel.

4. Drag the layer to the MAP View containing the matching coordinate system to georeference the layer.

There are also a couple of additional considerations to be aware of when exporting:

Since the current exported vector formats are GIS formats that do not support the concept of Bezier curves you
need to compensate for this. If you have Bezier curves in your Adobe lllustrator file they will not be recognized in
the GIS software. In order for these features may be represented correctly you will need to add points to these lines
in Adobe lllustrator first. Simply identify and select any objects that use Bezier curves and then select Object > Path
> Add Anchor Points. Repeat this command until the line has a sufficient number of anchor points that the shape of
your curves will not be lost on export.

Adobe lllustrator stores the origin of text that has been applied along paths differently from other text objects. We
have found the following steps to be the most successful way to get such Text exported to GIS files:

1. Create a new Adobe lllustrator layer

Select any text that has been created along paths.

Drag this text to the new Adobe Illustrator layer

Select Type > Create Outlines. The text will be converted to vector objects.

In the MAP Views panel, drag this layer back into your MAP View, specifying Area as the feature type

You can now export your Text as Area objects. Since the text is no longer text, you can no longer modify the fonts.
We recommend that you make a copy of the original text objects before you do this process. These hints on how to
transfer Adobe lllustrator files are necessary because the graphics environment handles text and curves differently
and they need some modification in order for the GIS software to represent these accurately.

VAW

DOUGLAS-PEUCKER LINE SIMPLIFICATION

The Douglas-Peucker algorithm was primarily designed to reduce the number of points required to represent a
vector line. A common problem in digital cartography and geographic information systems can occur when lines
are generated automatically from a mathematical function, which records points at a fixed interval regardless if
they are all lying along a straight line. A reduction of the number of points makes for a cleaner and more readable
cartographic line. As well in cartographic work within Adobe lllustrator the removal of points along a path can
significantly improve the speed of file redraws and reduce the overall file size.

The Douglas-Peucker Algorithm was created in Fortran 66 by David H. Douglas and Thomas K. Peucker at the
University of Ottawa in 1970-71. It was extensively tested in 1972 and was publicly communicated in the following
article: Algorithms for the Reduction of the Number of Points Required to Represent a Digitized Line or Its Caricature,
Canadian Cartographer, Vol. 10, No. 2, December 1973.
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BEZIER CURVES AND OTHER MAPUBLISHER OPERATIONS

Bezier curves are defined using four control points. Two of these are the end points of the curve, while the other
two effectively define the gradient at the end points. These two points control the shape of the curve. The curve is
actually a blend of the control points. This is a recurring theme of approximation curves; defining a curve as a blend
of the values of several control points.

Most GIS formats do not support Bezier curves when used in graphics software such as Adobe lllustrator. Typically,
curved sections of GIS data will be composed of a series of small line segments rather than an actual curve. This is
also how features imported by MAPublisher will first appear in Adobe lllustrator. Use Adobe lllustrator Object > Path
> Simplify to convert this type of feature into a Bezier curve (see chapter 8). Furthermore, Bezier curves cannot be
simplified using the MAPublisher Simplify Lines tool.

If Bezier curves are exported from Adobe lllustrator using any of the MAPublisher Export functions they will be

converted to link and node topology (i.e. the end points of the curve will simply be joined as straight lines). It is
therefore necessary to create additional points to curves to retain their true shape. This can be done globally by
using the Adobe lIllustrator Object > Path > Add Anchor Points function.

This version of MAPublisher supports Bezier curve features during the following operations:
«  Scale and Projection transformations via the MAP View Editor
«  Areaand length calculations

CREATING SYMBOLS FOR USE IN POINT STYLESHEETS

A MAPublisher Symbol Library and a National Parks Symbol Library are supplied in the Helpful Styles & Symbols
folder. You may also find that a search on the internet may be useful for finding additional libraries. If you are
required to create new symbols, the steps below will help you to quickly create symbols manually in Adobe
lllustrator.

1. Use Adobe Illustrator Tools for the manual creation of artwork that will comprise the new symbol. If you wish to
use a character that are contained in a font library, select the text character instance and click the menu
Type > Create Outlines to convert the text to vector art.

2. Open the Adobe lllustrator Symbols panel (Window > Symbols).

3. Select the artwork that will comprise the new symbol and drag it into the Adobe Illustrator Symbols panel
double-click the symbol in this panel to assign a name.

4. When Edit Stylesheet Theme is accessed for Point stylesheets, this symbol will be available in the Style column.

CREATING A MAP THEMES TEMPLATE

You can create template files with legends to automate the production of a series of similar maps. The procedure

when using MAP Themes is as follows:

1. Create a prototype map using MAP Themes to create the desired look.

2. Make a copy of your prototype map file. Delete all the layers from the file so that only the designated MAP
Themes exist.

3. Saveittoanew Adobe lllustrator template file (*.ait).
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4. Use this template file as a base for future maps as follows:
a) Make a copy of the template file.
b) Import all map layers into the template file and do any needed processing.
¢) Inthe MAP Themes panel, assign your MAP Layers into the desired MAP Themes type.
d) Apply the MAP Themes and your new layers will be symbolized.

CREATING A MULTI-CONDITIONAL IF EXPRESSION

In Edit Expression it is possible to assign symbology to map objects by assigning an expression to the #Style
column. In the following example this is achieved by creating a multi-conditional IF statement.

In the following example, a point layer represents cities. Each point has the value “Y”, “N” or “C" in the CAPITAL
attribute column, describing whether the city is a state capital (Y), is not a state capital (N) or is a country capital (C).
There are three point symbols to assign to the type of point. In this example the following expressions can be
assigned to the #Style column of the point layer (both expressions have the same result):

Expression 1:

IF(CAPITAL ="Y", “MAP Symbol 01, IF(CAPITAL =“C", “MAP Symbol 02", “MAP Symbol 03"))

Expression 2:

IF_CASE("MAP Symbol 01", CAPITAL="C", "MAP Symbol 02", CAPITAL="N", "MAP Symbol 03")

Therefore: If the capital is “Y”, assign the symbol “MAP Symbol 01", If the capital is “C" assign the symbol “MAP Symbol
02" All other symbols assign “MAP Symbol 03".

NOTES FOR EXPORTING IMAGES

If the document colour mode is CMYK, exporting an embedded image may result in increased file size compared to
RGB mode.

If the image is linked consider the following:

1. The image will be exported in the original colour mode of the image irrespective of the current colour mode of
the document (i.e. a linked grayscale image in a CMYK document will be exported as a grayscale image, whereas
a linked RGB image in an CMYK document will be exported as a RGB image).

2. Alinked image with Alpha channels may be exported in a different colour model. For example a grayscale with
two alphas will export as an RGB or an RGB with an alpha channel will export as CMYK.

3. Linked images in CMYK mode (regardless of the color mode of the document) will export with an incorrect
result and should therefore be avoided (see chapter 12).

If the image is embedded consider the following:

1. The image will be exported in the colour mode of document (i.e. an embedded grayscale image in a CMYK
document will be exported as a CMYK image, whereas an embedded CMYK image in an RGB document will be
exported as an RGB image).

2. Embedded grayscales do not pick up the document colour model (i.e. an embedded grayscale image will be
exported as grayscale).

3. The export of embedded Bitmap images is not supported.
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Appendix 2: Coordinate Systems
Overview

In the MAPublisher application, the coordinate system option must be entered at two levels: coordinate system of
the source data (when importing GIS data) and coordinate system of the final map.

SOURCE DATA COORDINATE SYSTEM

The Source coordinate system is usually detected when the coordinate system information is available with the
GIS data being imported and when supported in the native GIS format (such as Shapefile , e00). However, in some
cases, this information is not imported because it is not supported in the original GIS format (e.g. DWG, DXF) or
when using a non-referenced Adobe lllustrator files. In that case, the coordinate system must be specified by the
user. It generally can be found from an attached metadata document, by contacting the data provider or in textual
information on the original data itself (e.g. title or legend of a scanned map).

In all cases, the source coordinate system must be known with certainty. Then only can the proper parameter
be specified in the MAPublisher interface. A wrongly specified source coordinate system would make the map data
unusable for transformations and merging with other datasets.

FINAL MAP COORDINATE SYSTEM

Most of cartographic projects are restricted in the choice of coordinate system for the final map. This parameter

is usually part of the project requirement. It is the task of the professional cartographer to analyze carefully the
situation to make the wise decision. For general purpose mapping projects (interpretive or marketing maps for
example), a more approximative selection of the coordinate systems might be acceptable. Following the request
from some of our users, who may not have a cartographic expertise, here are a list of simple considerations to take
into account before making a choice:

- Use of a Geodetic Coordinate system (angular coordinates, Lat/Long): Fnldia-aeudeﬁc i
« Appropriate for overlay with GPS data recorded in Lat/Long format. L s
- WGS84 system is required to export vector data to KML format (for display N
in Google Earth, Google Maps). iy

- Use of a Projected coordinate system:
« Appropriate for printed map (so that users can use a ruler to measure

Example Systems-NOT FOR USE
orth America

|a

distances on the map). & Canada
« Required to add a scale bar. E:;Eb??:gm Systems s
« Use of a particular system (within the list of projected and geodetic systems): 5oy
- Maps that are part of a portfolio or Atlas have to comply to the same |
system to be consistent. s
- When a geo-referenced image (geotiff or world tiff) is to be used together | i
with the data, it is easier to use the same coordinate system for the vector .
data as of the raster.  Mmnesom
« Most countries or geographic areas have published standards or usual | I North Dakota
way for representing the land (e.g. for road maps or meteorological maps). I ST
In this case, the user should make some test with the systems listed in I e e |

MAPublisher. For a convenient use, coordinate systems are sorted by
continent>country>sub-division (state or county for example).
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In doubt, it is recommended to test different coordinate systems and visualize the results.

For more information on the supported coordinate systems and projections in MAPublisher, please refer to the
Avenza Projections Guide installed with MAPublisher.

Examples of appearance of the USA depending of the chosen coordinate system

.u n -

Geodetic > World > WGS84 (unprojected)
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The Geodetic Datasource

MAPublisher includes an extensive geodetic parameter database called the Geodetic Datasource. It contains all the
latest updates from the widely used EPSG Geodetic Parameter Dataset maintained by the Geodesy Subcommittee
of OGP (International Association of Oil and Gas producers) as well as custom systems maintained by Avenza.

In addition, the MAPublisher Geodetic Datasource supports user's custom definitions and allows for importing
external WKT (Well-Know Text) and PRJ (Esri projection file) parameter files.

Over 3500 pre-defined coordinates systems are readily available for use in most cartographic projects. Even though
the current list of systems is comprehensive, there may be instances where the end users may wish to add a brand
new coordinate system to meet their particular needs, or perhaps to duplicate and modify an existing definition to
change the units for example. A complementary Avenza Projections Guide is installed with MAPublisher. It describes
all the projections and datum shifts methods supported by MAPublisher, to assist users in the process of creating or
editing a coordinate system.

The default parameters installed with MAPublisher are stored within read-only XML database files referred to
as the Geodetic Datasource (files named geodata.xml and avenza.xsp). The base datasource files shipped with
MAPublisher are installed in the Data Source Files folder at the following location:

Windows: C:\Program Files\Avenza\MAPublisher 8\Data Source Files
Mac OS X: /Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/Data Source Files

Custom definitions and parameters are saved or loaded from separate XML files that must always accompanied
with a file named geocalc.xsd (when not present, this file can be copied from the Data Source Files folder).

The custom and read-only entries are organized into categories and sub-folders — users may create new folders,
move entries or create short-cuts. That folder structure is saved in a view file (* xvw).

When MAPublisher is uninstalled or a newer release is installed, an option will be given to backup the custom
coordinates systems and view file (Windows only). The backup files can be found:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8
Mac OS X: /Applications/Avenza/MAPublisher 8/Data Source Backup

LOAD CUSTOM COORDINATE SYSTEMS

A geodetic datasource or coordinate system database can be loaded into MAPublisher, greatly extending the
coordinate systems available for use. To load a geodetic database within MAPublisher, choose Load Custom Coordinate
Systems from the MAP Views panel options menu.

The directory containing the XML file must also contain the file geocalc.xsd. This file can be found in the directory

of the default geodata.xml file (see above). So the custom XML file can either be copied to the Data Source File

directory prior to loading, or geocalc.xsd should be copied from there to the custom XML directory.

Any additional change will be saved into the loaded xml file.
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Note: Coordinate systems may also be extracted from the input data formats (during import process).

EDIT CUSTOM COORDINATE SYSTEMS

MAPublisher includes an extensive geodetic parameter database. The contents of the Geodetic Datasource can be
browsed or searched by using a search frame. Users can extend MAPublisher Geodetic Datasource to support an
unlimited number of custom linear and angular units, ellipsoids, datums, datum shifts, and coordinate systems.

MAPublisher Custom Coordinate Systems Editor is accessed from the MAP Views panel options menu Edit Custom
Coordinate Systems. Coordinate systems may also be edited/created from the Specify Destination Coordinate System
dialog box (opened using the Specify button in MAP Views panel and import dialog boxes), but the other geodetic
objects are only accessible through Edit Custom Coordinate Systems.

Individual entries in the geodetic data source are known as Data Source Objects. There are different types of objects
for different types of definition. Objects contained in the geodetic data source are:

- *All*: used to define the orientation of axes used and the type of units used in the system.

- Angular Units: type of units for measuring rotation.

- Coordinate Systems: a complete definition needed to express the context of a set of map data.
- Datum Transformations: parameters to transform coordinates from one datum to another.

«  Ellipsoids: an ellipsoid gives a horizontal datum its size and shape. An ellipsoid does not have an origin
and cannot be used as a base model for coordinates on its own.

- Envelopes: defines a geographic area of use for a particular object.

- Horizontal Datums: more commonly referred to as just "datum" is the base model maps are built
on. All coordinate systems must have a datum associated with them to be related to any other map.
Without a known datum, coordinates are meaningless.

- Linear Units: units for measuring straight line, Cartesian distances.

- Prime Meridians: defines longitude values of meridians.
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You can define new coordinate systems, make copy and modify existing objects. The custom objects are stored
in a separate xml file saved by the user. Users can also re-organize the Geodetic Datasource (default and custom
parameters) into categories and sub-folders. These changes are saved to a view file (.xvw). The view file may be
deleted to reset the Edit Custom Coordinate Systems dialog box to its default state.

& Edit Custom Coordinate Systems =)
Datasource - File contains the ——|HeDatasource:  C:\Program Files (x36)\Avenza\MAPublisher &\Data Source Files'geodata.xml
default geodetic parameter e Custom Data:  C:\ProgramD: -
(geodata.xml). = -
Folder © & Display Name Name Units per Degree  Abbrev EPSGCode  *[[  c...
_Ei . s I B ArcMinute ArcMinute 60 9103 o— Save/SaveAs - Save
Custom Data - File contains » Angular Units £ ArcSecond ArcSecond 3600 ac o104 changes to a custom
custom geodetic : . 9
! - Coordinate Systems B4 Centesimal Minute Centesimal Minute 1111111111111 9112 2 file (data to XML and
parameters. It is loaded or > Datum Transformations {4 Centesimal Second  Centesimal Second 1111111111111 9113 N
saved by the user. . Ellipsoids £ Degree Degree 1 deg o102 view to XVW).
+ Envelopes £ Degree Degree 1 deg 912 B
. > Horizontal Datums @ Gon Gon 11111311111111 9106
Data Source Object Folders - See ——te| . Linear nits £ Grad Grad 1111111 grads 9105
list on previous page > Prime Meridians & Microradian Microradian 17453.292519943 9109 i
Add/Remove - Add and —e ] Edit Object Buttons -
remove folders and e Add, remove, edit,
. ar . .
categories. information or copy
Search - Search for —fe Toer: Anguiar ns objects.
geodetic objects. Search Foxh n
in categories such as EPSG

Code, Envelope, Source
Datum, Class Type, etc.

At the top of the Edit Custom Coordinate Systems dialog box, two directory paths are listed: the geodetic data source
path and the custom data path.

Note: The geodetic data source file is protected (read-only). Any additions or modifications to coordinate systems
are stored in a separate XML file called customsystems.xml.

On the left-hand side of the dialog box is the data source object folders. To expand a folder to see its subfolders,
click the plus sign (Windows) or arrow (Mac) to the left of the category name. To see the entries at any particular
level of category, click the category itself. When an object, folder or subfolder is selected, the data source objects
list box to the right displays the information stored within each one. User defined coordinate system objects can

be organized using drag-and-drop between folders. Columns can be resized and sorted alphabetically/numerically.
Right-click on a column header to show or hide it. Entries loaded from the main geodetic data source will be shown
in black text, while entries from the custom data file will be shown in blue.

To create a new folder, click the New Folder button. A new folder will be titled "New Folder" by default and can be
renamed. Subfolders can also be created using the same method. Only user-defined categories can be deleted
using the Delete Folder button.

Changes are saved to customsystems.xml located in:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8

Mac OS Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/Data Source Files

The default XVW file (folder structure) is saved to customview.xvw, located in:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 8
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 8

Mac OS X: Applications/Avenza/MAPublisher 8/MAPublisher Plug-In/
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CREATE NEW DATA SOURCE OBJECTS

In the Edit Custom Coordinate Systems dialog box, click the New Object button [*] to create a new data source
object. When creating new data source objects, the identification information and definition parameters need to be
completed. Complete this information in the respective Identification and Definition tabs.

The Identification tab is used to name the object and associate identification codes with it (if applicable). It is
important to enter an appropriate name for the object. The Remarks field can be used to add notes on a definition
and is optional. The Identifiers list may be used to add identifying codes for an object that may come from other
databases. The GC code is a unique identifier assigned by Geographic Imager and should not be altered. To enter
additional codes use the space below it.

The Definition tab is used to define the parameters of an object. Each object has parameters unique to it. Refer to the
list below when creating new objects.

Note: Refer to the Avenza Projections Guide for more information on supported projections and their parameters
as well as supported datum transformations methods.

*All*

For coordinate points, specify the coordinate point dimensions in either 2D or 3D. For Geodetic and Projected
Coordinate Points, the Longitude and Latitude style of units must be entered for all 2D Dimensional Points. The
Longitude, Latitude and Ellipsoid Height style of units must be entered for 3D Dimensional Points.
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Labal % o & 0 o L
| o || Lo || eas
¥ Label Longitude Label Eastrg
Label v Ly 1) Lt L1
el L1 Latds i
] Label Lataue Label rawshung
Label 1 Unts (T} Units ()
\rfa| On). 1| [= S—rh— Heght
iklcts ksl
s o | s L
| | |
| o carcel || | o carcel || | o carcel ||
tr - .
e Angular Units
I For angular units, enter a conversion for the new unit in terms of the scientific
s e standard Degrees. The Abbreviation is used to identify the unit within the
@ ol ihete L

application interface (Example: The abbreviation for degrees is "deg").

tershcanen | Deinnon

Piame turw Al Lt
Remariy

Lo [ Code

G0 | S0 E900- L o Recki-1 0 o

A2/6



& Geodsetic Coantinate System Editer ===

| Mﬁahm Defrinon
Ervveloe | warkd [oee] 8
Pont Style
Datm

Vertical Rederence [ &

& Projected Coordinate System Ednoe ===
| [bsenstiaton | Defranen
Errvekope |werkd o] i
| | Pont Style
|
| | Geodet:
|
1 Prosustion Tanmveme MpEsRr =
Parsmneter Vot Units
o unspacified
° unspeoteed
" undpecifued
v urapoted
(]
|
|
| o* Cancel
& Datum Transiormation Edene ===
| [bsensticaton | Detrumen
Ermveloe | werkd o]
Source
Target
Mathad Mokedendcy =
Parametes Vot Units
o unspacified
° unspeoteed
L) undpecifued
|
|
| o* Cangel
& Eipsaid Edor ===
| [bsensticaton | Defranen
Sermi Majer A
e g
Units e | W
Sem-Minor s
Vooe 0
[ress )
e Farienrg
Srromrun Fatterwg Oefratve
|
|
| o* Cancel

Coordinate Systems

For Coordinate Systems, select an Envelope defining the appropriate area

of use. If you are unsure of the appropriate envelope, you can leave it set to
the default World envelope. The Point Style is how you will select the style
of linear units for your system. For most projected systems, you will want to
select "Projected point in (units)". Then select the Geodetic model that using
the appropriate datum for your system. When you select the appropriate
projection for your system, the parameters needed to define the system will
appear in the table below. Enter the needed parameters and define the units
each parameter is specified in.

Datum Transformations

For Datum Shifts, select an Envelope (appropriate geographic area of use),
Source, Target and Method. If you are unsure of a more specific envelope, leave
it set to the default "World" Envelope. The Source and Target fields are used

to specify the two geodetic models the Transformation is valid for. The Method
specifies the necessary parameters to define a particular datum transformation.
With the proper method selected, enter the appropriate parameters for

your datum transformation. Be sure to define the appropriate units for each
parameter by clicking the Units button.

Ellipsoids

For Ellipsoids you must enter the parameters for the Semi-Major Axis and Semi-
Minor Axis (often noted as "a" and "b" respectively) define the linear units the
axes are specified in by selecting a predefined unit in the appropriate fields.
The Inverse Flattening (often noted as "1/f") will automatically calculate in

the field below. Alternately, you can make the Inverse Flattening definitive by
enabling the check box at the bottom. You can then manually enter the Inverse
Flattening rather than the Semi-Minor Axis parameter.
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Envelopes

For Envelopes, specify the extents of the envelope (it is not required but
recommended). If the Specify Extents Points check box is checked, it is required to
enter the minimum and maximum points of the envelope and the point style the
value represent.

Horizontal Datums
For Horizontal datums you must select the Ellipsoid the datum is based on, as well
as the prime meridian used.

Linear Units

For Linear units, enter a conversion for the new unit in terms of the scientific
standard Meters. The Abbreviation is used to identify the unit within the
application interface (Example: The Abbreviation for Meters is "'m")

Prime Meridians
For Prime Meridians you must enter the longitude value of the Prime Meridian
and the angular unit that value is in.



EDIT OBJECTS

To edit a custom or user-defined object, click the Edit Object button [Z]. Edits may be made in the respective object
editor dialog box. Alternatively, double-click an object to open the editor dialog box. When a data source object
belonging to the master data set is selected, the Edit Object button |#] is disabled (because these objects are read-
only). To modify an original object, create a copy of the object first then edit it.

DELETE OBJECTS

When a data source object belonging to the master data set is selected, the Delete Object button @ is disabled.
Only user-defined objects can be deleted.

COPY OBJECTS

Any object can be copied. To create a copy of an object, select an object and click the Copy Object button [&]. A
dialog box will appear with "Copy of:" preceding the object name in the Name box.

MOVE OBJECTS

Any user defined object can be moved. Drag-and-drop an object from the Data Source Objects List to a Data Source
Object Folder. A dialog box will prompt you to move the object or to create a shortcut to it.

LOAD CUSTOM COORDINATE SYSTEM DEFINITIONS

In some instances, the coordinate system of an image is not listed in the geodetic data source or the reference file
format does not support the coordinate system. In such cases, it may be useful to load custom coordinate system
definitions. In the Geographic Imager panel options menu, click Load Custom Coordinate System. MAPublisher can use
the following coordinate system file formats: WKT definitions (.wkt), MapInfo MAP files (.map), MapInfo TAB files
(.tab) and ESRI projection files (.prj).

When a new coordinate system definition is loaded, it automatically replaces the source coordinate system of the
currently selected image. To transform the image to the loaded coordinate system, open another referenced file
and then load the coordinate system to that file. In the Transform dialog box, choose the Same As option to make
the destination coordinate system identical to the image of the loaded coordinate system.

When a coordinate system definition is loaded, it is added to the geodetic data source but not saved. If the loaded
file matches an existing definition, the original definition will be used and the loaded definition will not be added.
All new definitions are located at the top level of the appropriate category in the Coordinate Systems folder list (in
either Geodetic or Projected). Before exiting Adobe Photoshop, be sure to save your geodetic data source if you
wish to use the coordinate system definition again.
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Appendix 3: MAPublisher 8 How-To’s For Legacy Users

Legend Functionality in MAP Themes

A number of functions have been redesigned in MAPublisher 8.4. Users of MAPublisher 6 or earlier should consult
the following pages for information on how to perform common legacy MAPublisher tasks in MAPublisher 8.4.

BUILDING COLOUR RAMPS TO CREATE STYLES

You can enhance the look of your maps by using colour ramps, rather than random colours, for your area and line

styles. A possible use for this would be in the creation of relief maps.

Determine the number of new graduated styles you wish to create.

Create two rectangles with the Rectangle Tool aligned vertically, one at the top of the page, the other at the base.

Colour the first (top) and last (bottom) elements with two end colours for the ramp.

Choose Object > Blend > Blend Options.

Choose Specified Steps from the list. Enter the value you determined in the first step minus two. Click OK.

Select the two rectangles. Choose Object > Blend > Make. The legend elements will be blended between the two

end colours.

7. Choose Object > Expand, then choose Object > Ungroup. This ungroups the art so that the new styles can be
added to the Graphic Styles panel and be used in the MAP Themes.

ounpkwnN=

ASSIGNING INCREMENTAL VALUES TO STYLES

It is very straightforward to assign styles to values for stylesheets based on Equal to expressions. The following
examples can be used as a basis for new stylesheets, providing the functionality which was previously available in
the Unique Occurrences option in Auto Assign Legend Info.

Example 1 (Rule 1 assigned first listed value and first style):

1. Create the first Equal to rule, using the first listed style, and an expression based on the first listed value in a
specified attribute column, i.e. Style A assigned to Column X = "Value 1”.

2. Click the Add button. The second rule will be automatically assigned an incremental expression, i.e. Style B
assigned to Column X = "Value 2.

3. Keep clicking the Add button until all the values or styles have been used.

Example 2 (Rule 1 assigned first listed value and third style):

1. Create the first Equal to rule, using the first listed style, and an expression based on the third listed value in a
specified attribute column, i.e. Style C assigned to Column X ="Value 1”.

2. Click the Add button. The second rule will be automatically assigned the first unused style, i.e. Style A assigned
to Column X = "Value 2”.

3. Keep clicking the Add button. Assignments will be incremental, but will not include the third style again, i.e.
Style B assigned to Column X ="Value 3”; Style D assigned to Column X = "Value 4”; etc
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CREATING STYLE RULES BASED ON MULTIBLE ATTRIBUTE COLUMNS

Assign Legend Info previously provided options to assign legend criteria to legend elements based on values in
multiple attribute columns. This functionality can be achieved in the Edit Stylesheet Theme dialog box. Toggle to
the Advanced mode to compose advanced expressions.

The following are some examples of multi-column expressions in a world countries stylesheet (using a string type
column named CONTINENT and an integer type column named POPULATION).

CONTINENT="Africa” AND POPULATION<1000000
Result: only African countries with populations less than one million are assigned the selected style.

CONTINENT="Africa” OR POPULATION<1000000
Result: all African countries and all countries with populations less than one million are assigned the selected style.

CONTAINS(CONTINENT,“America” AND POPULATION>1000000
Result: only countries in North and South America with populations more than one million are assigned the selected style.

CONTINENT="Europe” AND POPULATION>1000000 OR CONTINENT="Asia” AND POPULATION>10000000
Result: countries in Europe with populations more than one million and countries in Asia with populations more than ten
million are assigned the selected style.

Copy and Paste

The MAP Copy/Paste function was removed in MAPublisher version 7. You can now achieve the same functionality
via Adobe lllustrator native Copy/Paste tools.

Use Edit > Copy or Edit > Cut to copy art.

Deselect the art.

Select the destination layer in the Layers panel

Use Edit > Paste in Front or Edit > Paste in Back to paste the art into the new layer at its previous location.

HWN -

« When pasting to layers which already contain an attribute structure, the destination layer must have an attribute
schema which matches the source layer (only attributes in common will be transferred).

+ When pasting to layers which contain no attribute structure, the destination layer will be assigned the same
attribute schema as the source layer.

« The destination layer can be contained in any MAP View as required.

- The destination layer must be of a matching feature type as the source layer.

- Pasted data will always maintain its attributes. If you paste into a non-map layer, drag this layer into a MAP View,
then recreate the schema, attributes will be populated appropriately.
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Grid and Scalebar Operations

EDITING CUSTOM ART

Manually editing type (position, font, colour, etc) is not possible on Grids and Scale Bars in their default grouped
state. Manual editing is possible but objects must be first expanded (choose Object > Expand). Note that this will
negate any opportunity to subsequently edit the art using MAPublisher editing tools.

If you require a different design to be used for your Grid or Scale Bar, or wish to change any parameter without
generating a new version, simply select the Grid or Scale Bar and choose Object > Edit Grid or Scale Bar. This will
re-open the Grids and Graticules or Scale Bar dialog box with the current parameters of the object for subsequent
editing. Editing the style of text (text colour, font, alignment, etc) used in the Grid or Scale Bar can be achieved by
modifying the properties of the style in the Character Styles panel.

Use the bounding box of the generated grid or scale bar (choose View > Show Bounding Box) to resize. Resizing scale
bars horizontally will add or remove intervals from the bar(s). Resizing scale bars vertically will adjust the width of
the bar(s). Resizing grids horizontally or vertically will add or remove component cells in the grid.

EXPORTING GRIDS

To export a grid you must first expand the object (choose Object > Expand), then move it to an Area layer.
Alternatively expand your grid, move the legend layer to the [Non-MAP layers] category, then move it back into the
MAP View specifying the feature type as Area.

MISSING DATA IN GRIDS ON PROJECTED MAP VIEWS

Certain projections may cause incomplete grids and graticules to be drawn. Such issues may occur if the MAP View
is in a polar projection or the extents of the data cross the 180 degree west/east meridian.

If the generation of a grid/graticule causes blank or incomplete results, the following workflow should be used:
Reproject the MAP View to a standard Lat/Long projection (e.g. NAD27 Lat/Long, Degrees).

Generate your grid or graticules on this MAP View.

Expand the object (choose Object > Expand).

Create a new Area layer in the MAP View. Drag the expanded grid to this new layer.

Reproject the MAP View back to the original projection.

nhwnN =
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Legacy Text Conversion
Opening legacy files, you may be prompted to update text (legacy text conversion).

Only text objects that are associated to attributes are required to be updated. For other text with no attributes, you
do not necessarily need to update.

Legacy Text Conversion

MAPublisher has detected that this document contains legacy Hlustrator text art.
Tllustrator will not recognize such text as true text art until that art is converted,
and MAPublisher will not display attributes for legacy text art.

If you decide not to convert the text at this time and instead opt to convert it
manually at a later time, be aware that Iustrator's legacy text conversion process
does NOT preserve attributes for converted text art.

. . Update
All text art - Choose this option to convert all text—l
to the Adobe lllustrator current version. @ Al textart
MAPublisher text art only - Choose this option to (7) MAPublisher text art only
convert only the MAPublisher text (on MAP )
() Nothing

layers)
Nothing - Choose this option if no conversion is J
necessary
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Appendix 4: Helpful Styles and Symbols Files

The Helpful Styles & Symbols folder is found in the following locations:

Windows XP: C:\Documents and Settings\All Users\Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols
Windows Vista/7: C:\Users\Public\Public Documents\Avenza\MAPublisher 8\Helpful Styles & Symbols

Mac OS X: Applications/Avenza/MAPublisher 8/Helpful Styles & Symbols

Helpful Styles & Symbols > MAP Graphic Styles

This folder contains eight sets of graphic styles for areas and lines:

MAP - Area Effects.ai A set of area gradients

MAP - Area Patterns.ai A set of black and patterns for areas

MAP - Area Solid Colors.ai A set of solid colors for areas

MAP - Line Styles.ai A set of line styles

Format specific styles

DGN - Line Styles.ai A set of MicroStation DGN line styles 1-7

MIF - Area Styles.ai A set of MapInfo MIF/MID area styles 1-71
MIF - Line Styles.ai A set of MapInfo MIF/MID line styles 1-77
S57 - Line and Area Styles.ai A set of S-57 specific styles for lines and areas

Helpful Styles & Symbols > MAP Swatches
This folder contains two sets of swatches:
MAP - Color Groups and Gradients.ai A set color groups and gradient swatches

MAP - Patterns.ai A set of various swatch patterns

Helpful Styles & Symbols > Symbols

This folder contains nine symbol sets of categorized symbols:

MAP - Symbols.ai A set of useful map symbols

KML - Symbols.ai A set of Google Earth symbols used with KML points
S57 - Symbols.ai A set of S-57 specific symbols

LabelPro Arrowheads.ai A set of arrowheads used with MAP LabelPro
Aeronautical Symbols.ai A set of aeronautical point symbols

Bank Symbols.ai A set of symbols from major world banks
North Arrows.ai A set of north arrow symbols

Park Symbols.ai A set of U.S. National Parks Service symbols
Subway Symbols.ai A set of symbols from major subway lines
Transit Symbols.ai A set of symbols from major transit systems
Weather Symbols.ai A set of weather-related point symbols
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Helpful Styles & Symbols > S-57 Symbolization

The S-57 Symbolization folder contains two templates with a series of MAP Theme stylesheets linking S-57
imported features to appropriate nautical symbols and graphic styles inspired from the International Hydrographic
Office S-4 publication (previously M-4) (Regulations of the IHO for international (INT) charts and charts specifications
of the IHO). Graphic styles and symbol names are mostly based on the S-57 naming conventions. The basic template
allow users to quickly apply styles to the imported data. The advanced template is more detailed to help users learn
the format and make use of the data.

Subway Symbols.ai Adobe lllustrator template with detailed MAP Themes for use with S-57 data
S57_Basic_Template.ait  Adobe lllustrator template with simplified MAP Themes for use with S-57data
US5FL12M Sample ENC file in S-57 format (chart of Tampa Bay, courtesy of NOAA®)

How to use S-57 templates:
«  Open S-57_Basic_Template.ait or S-57_Basic_Template.ait and import S-57 data.
«  Inthe MAP Themes panel, double-click a stylesheet theme to see its settings.
«  For depth sounding labels, use attribute values with the Label Features - Use sounding style option for
points labels. To round the depth values according to hydrographic standards, use the expression
provided in the Expression Library (see chapter 5 on MAP Attributes and chapter 10 on Labeling)

Note: This representation is non-exhaustive and meant to assist users with limited knowledge of the S-57 format

to interpret the data contents more easily. The created map must not be used for navigation, unless further
processing is supervised by a trained hydrographer.

More Helpful Styles & Symbols on Avenza.com

For even more styles and symbols, visit http://www.avenza.com/resources/styles-symbols.
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